]> git.pld-linux.org Git - packages/syslog-ng.git/blob - syslog-ng.spec
- updated to 1.6.7
[packages/syslog-ng.git] / syslog-ng.spec
1 %define         mainver         1.6
2 %define         minorver        7
3
4 Summary:        Syslog-ng - new generation of the system logger
5 Summary(pl):    Syslog-ng - zamiennik syskloga
6 Summary(pt_BR): Daemon de log nova geração
7 Name:           syslog-ng
8 Version:        %{mainver}.%{minorver}
9 Release:        1
10 License:        GPL
11 Group:          Daemons
12 Source0:        http://www.balabit.hu/downloads/syslog-ng/%{mainver}/src/%{name}-%{version}.tar.gz
13 # Source0-md5:  dc4d7cdbc5792e7ba0fd836bbdd4c62d
14 Source1:        %{name}.init
15 Source2:        %{name}.conf
16 Source3:        %{name}.logrotate
17 Patch0:         %{name}-link.patch
18 URL:            http://www.balabit.com/products/syslog_ng/
19 BuildRequires:  autoconf >= 2.53
20 BuildRequires:  automake
21 BuildRequires:  flex
22 BuildRequires:  libol-static >= 0.3.15
23 BuildRequires:  libwrap-devel
24 PreReq:         rc-scripts >= 0.2.0
25 Requires(post,preun):   /sbin/chkconfig
26 Requires(post): fileutils
27 Requires:       logrotate
28 Requires:       psmisc >= 20.1
29 Provides:       syslogdaemon
30 Obsoletes:      syslog
31 Obsoletes:      msyslog
32 Obsoletes:      klogd
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 syslog-ng is a syslogd replacement for unix and unix-like systems. It
37 has been tested on Solaris, BSDi and Linux, and were found to run
38 reliably. syslog-ng gives you a much enhanced configuration scheme,
39 which lets you filter messages based on not only priority/facility
40 pairs, but also on message content. You can use regexps to direct log
41 stream to different destinations. A destination can be anything from a
42 simple file to a network connection. syslog-ng supports TCP
43 logforwarding, together with hashing to prevent unauthorized
44 modification on the line.
45
46 %description -l pl
47 Syslog-ng jest zamiennikiem dla standardowo u¿ywanych programów typu
48 sysklog. Dzia³a w systemie SunOS, BSD, Linux. Daje znacznie wiêksze
49 mo¿liwo¶ci logowania i kontrolowania zbieranych informacji.
50
51 %description -l pt_BR
52 Syslog-ng é um substituto para o syslog tradicional, mas com diversas
53 melhorias, como, por exemplo, a habilidade de filtrar mensagens de log
54 por seu conteúdo (usando expressões regulares) e não apenas pelo par
55 facility/prioridade como o syslog original.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60
61 %build
62 %{__aclocal}
63 %{__autoconf}
64 %{__automake}
65 %configure \
66         --enable-tcp-wrapper
67 %{__make}
68
69 tar zxvf doc/sgml/syslog-ng.html.tar.gz
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT{/etc/{logrotate.d,rc.d/init.d},%{_sysconfdir}/syslog-ng} \
74         $RPM_BUILD_ROOT/var/log/{mail,archiv/mail}
75
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/syslog-ng
80 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/syslog-ng/syslog-ng.conf
81 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/syslog-ng
82
83 > $RPM_BUILD_ROOT/var/log/syslog
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post
89 for n in /var/log/{cron,daemon,debug,kernel,lpr,maillog,messages,ppp,secure,spooler,syslog,user,mail/{info,warn,err}}
90 do
91         [ -f $n ] && continue
92         touch $n
93         chmod 640 $n
94 done
95
96 /sbin/chkconfig --add syslog-ng
97 if [ -f /var/lock/subsys/syslog-ng ]; then
98         /etc/rc.d/init.d/syslog-ng restart >&2
99 else
100         echo "Run \"/etc/rc.d/init.d/syslog-ng start\" to start syslog-ng daemon."
101 fi
102
103 %preun
104 if [ "$1" = "0" ]; then
105         if [ -f /var/lock/subsys/syslog-ng ]; then
106                 /etc/rc.d/init.d/syslog-ng stop >&2
107         fi
108         /sbin/chkconfig --del syslog-ng
109 fi
110
111 %files
112 %defattr(644,root,root,755)
113 %doc doc/syslog-ng.conf.{demo,sample} doc/sgml/syslog-ng.txt* contrib/syslog-ng.conf.{doc,RedHat}
114 %doc syslog-ng.html/*
115 %attr(750,root,root) %dir %{_sysconfdir}/syslog-ng
116 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/syslog-ng/syslog-ng.conf
117 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/syslog-ng
118 %attr(754,root,root) /etc/rc.d/init.d/syslog-ng
119 %attr(755,root,root) %{_sbindir}/syslog-ng
120 %{_mandir}/man[58]/*
121
122 %attr(640,root,root) %ghost /var/log/syslog
123 %dir /var/log/mail
124 %dir /var/log/archiv/mail
This page took 0.10271 seconds and 4 git commands to generate.