]> git.pld-linux.org Git - packages/sword.git/blob - sword.spec
8e32ac775aa998517b1dcc80959f183d09280eeb
[packages/sword.git] / sword.spec
1 #
2 # TODO:
3 # - Split out subpackages for tests, examples
4 # - Fix debug package. Patch Makefile so debugfiles.list is generated?
5 # - Package icu-sword and add bcond for it here
6 #
7 %define debug_package 0
8
9 %bcond_with             examples
10 #%bcond_with    icusword
11 %bcond_with             tests
12 %bcond_without  clucene
13 %bcond_without  curl
14 %bcond_without  icu
15 %bcond_without  utilities
16
17 Summary:        The SWORD Project framework for manipulating Bible texts
18 Name:           sword
19 Version:        1.6.1
20 Release:        0.1
21 License:        GPL
22 Group:          Libraries
23 Source0:        http://www.crosswire.org/ftpmirror/pub/sword/source/v1.6/%{name}-%{version}.tar.gz
24 # Source0-md5:  347e72f73313ff3ba700368db76a5d50
25 Patch0:         %{name}-curl.patch
26 URL:            http://www.crosswire.org/sword
27 %{?with_clucene:BuildRequires:  clucene-core-devel}
28 %{?with_clucene:Requires:       clucene-core}
29 %{?with_curl:BuildRequires:     curl-devel}
30 %{?with_curl:Requires:  curl}
31 %{?with_icu:BuildRequires:      icu}
32 %{?with_icu:Requires:   icu}
33 #%{?with_icusword:BuildRequires:        icu-sword}
34 #%{?with_icusword:Requires:     icu-sword}
35 Requires:       zlib
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 The SWORD Project is an effort to create an ever expanding software
40 package for research and study of God and His Word. The SWORD Bible
41 Framework allows easy manipulation of Bible texts, commentaries,
42 lexicons, dictionaries, etc. Many frontends are build using this
43 framework. An installed module set may be shared between any frontend
44 using the framework.
45
46 %package utilities
47 Summary:        Utility programes using the sword libraries.
48 Group:          Applications
49 Provides:       diatheke
50 Requires:       %{name} = %{version}-%{release}
51
52 %description utilities
53 Utility programes using the sword libraries.
54
55 %package devel
56 Summary:        Include files and static libraries for developing sword applications
57 Group:          Development/Libraries
58 Requires:       curl-devel >= 7.10.5
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       zlib-devel
61
62 %description devel
63 Include files and static libraries for developing sword applications.
64 This package is required to compile Sword frontends, too.
65
66 %prep
67 %setup -q
68 %if %{with_curl}
69 %patch0 -p0
70 %endif
71
72 %build
73 %{configure} \
74         --with%{!?with_clucene:out}-clucene \
75         --with%{!?with_curl:out}-curl \
76         --with%{!?with_icu:out}-icu \
77         --%{?with_utilities:en}%{!?with_utilities:dis}able-utilities \
78         --%{?with_tests:en}%{!?with_tests:dis}able-tests \
79         --with-conf \
80         --disable-debug \
81         --disable-dependency-tracking
82         #--with%{!?with_icusword:out}-icusword \
83
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install-strip \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %{__make} install_config \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 install -d $RPM_BUILD_ROOT%{_libdir}/sword
96 exit 0
97
98 %post devel -p /sbin/ldconfig
99
100 %postun devel -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %config %{_sysconfdir}/sword.conf
105 %dir %{_datadir}/sword
106 %dir %{_datadir}/sword/mods.d
107 %dir %{_datadir}/sword/locales.d
108 %config %{_datadir}/sword/mods.d/globals.conf
109 %config %{_datadir}/sword/locales.d/*.conf
110 %doc README AUTHORS NEWS INSTALL
111 %attr(755,root,root) %{_libdir}/libsword*.so*
112 %dir %{_libdir}/sword
113 %dir %{_libdir}/sword/*icu*
114 %{_libdir}/sword/*/*.res
115
116 %files utilities
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_bindir}/*
119
120 %files devel
121 %defattr(644,root,root,755)
122 %doc doc/*
123 %{_pkgconfigdir}/sword.pc
124 %{_includedir}/sword
125 %{_libdir}/libsword*.*a
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
This page took 0.088227 seconds and 3 git commands to generate.