]> git.pld-linux.org Git - packages/swig.git/blob - swig.spec
- split libs into subpackages; rel 2
[packages/swig.git] / swig.spec
1 Summary:        Interface generator for Perl, Tcl, Guile and Python
2 Summary(pl):    Generator interfejsu do Perl'a, Tcl'a, Guile'a i Python'a
3 Name:           swig
4 Version:        1.3.11
5 Release:        2
6 License:        distributable
7 Group:          Development/Languages
8 Source0:        http://prdownloads.sourceforge.net/swig/%{name}-%{version}.tar.gz
9 Patch0:         %{name}-configure.patch
10 URL:            http://www.swig.org/
11 BuildRequires:  autoconf
12 BuildRequires:  guile-devel
13 BuildRequires:  libstdc++-devel
14 BuildRequires:  perl-devel >= 5.6.1
15 BuildRequires:  php-devel >= 4.1.0
16 BuildRequires:  python >= 2.2
17 BuildRequires:  ruby >= 1.6.3
18 BuildRequires:  tcl >= 8.3.3
19 Icon:           swig.gif
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 SWIG is a compiler that attempts to make it easy to integrate C, C++,
24 or Objective-C code with scripting languages including Perl, Tcl, and
25 Python. In a nutshell, you give it a bunch of ANSI C/C++ declarations
26 and it generates an interface between C and your favorite scripting
27 language. However, this is only scratching the surface of what SWIG
28 can do--some of its more advanced features include automatic
29 documentation generation, module and library management, extensive
30 customization options, and more.
31
32 SWIG is entirely the product of users who have used the system and
33 suggested new idea. There are far too many people to thank
34 individually, but without this support, SWIG would be not be nearly as
35 powerful or fun to use as it is now. Many thanks!
36
37 %description -l pl
38 SWIG jesk kompilatorem, który próbuje ulatwic integrowanie kodu
39 napisanego w C, C++ lub Objective-C z jêzykami skryptowymitakimi jak
40 Perl, Tcl i Python. Mówi±c najpro¶ciej, jesli dostarczysz mu zestaw
41 zdeklarowanych w ANSI C/C++ funkcji, SWIG wygeneruje Ci interfejs
42 pomiedzy C a Twoim ulubionym jêzykiem skryptowym. To tylko drobna
43 czê¶æ tego co SWIG potrafi robiæ, bardziej zaawansowane zastosowania
44 to automatyczne generowanie dokumentacji, zarzadzanie bibliotekami i
45 modu³ami i wiele innych.
46
47 SWIG jest w ca³o¶ci dzi³em ludzi, którzy go u¿ywali i wprowadzali nowe
48 pomys³y. Zbyt wielu ich jest, aby dziêkowaæ ka¿demu z nich osobno, ale
49 bez ich wsparcia, SWIG nie by³by anie tak pote¿nym na¿edziem, ani tak
50 fajnym w u¿yciu jak jest teraz. Wiekie dziêki!
51
52 %package guile
53 Summary:        SWIG library: guile
54 Summary(pl):    Biblioteka SWIG: guile
55 Group:          Libraries
56
57 %description guile
58 SWIG library: guile
59
60 %description guile -l pl
61 Biblioteka SWIG: guile
62
63 %package perl
64 Summary:        SWIG library: Perl
65 Summary(pl):    Biblioteka SWIG: Perl
66 Group:          Libraries
67
68 %description perl
69 SWIG library: perl
70
71 %description perl -l pl
72 Biblioteka SWIG: perl
73
74 %package python
75 Summary:        SWIG library: python
76 Summary(pl):    Biblioteka SWIG: python
77 Group:          Libraries
78
79 %description python
80 SWIG library: python
81
82 %description python -l pl
83 Biblioteka SWIG: python
84
85 %package ruby
86 Summary:        SWIG library: ruby
87 Summary(pl):    Biblioteka SWIG: ruby
88 Group:          Libraries
89
90 %description ruby
91 SWIG library: ruby
92
93 %description ruby -l pl
94 Biblioteka SWIG: ruby
95
96 %package tcl
97 Summary:        SWIG library: tcl
98 Summary(pl):    Biblioteka SWIG: tcl
99 Group:          Libraries
100
101 %description tcl
102 SWIG library: tcl
103
104 %description tcl -l pl
105 Biblioteka SWIG: tcl
106
107 %prep
108 %setup -q -n SWIG-%{version}
109 %patch0 -p1
110
111 %build
112 oldpwd=$PWD
113 for i in . Source/DOH Tools Examples/GIFPlot; do
114   cd $i
115   aclocal
116   autoconf
117   cd $oldpwd
118 done
119 %configure
120 %{__make} OPT="%{rpmcflags}"
121
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 install -d $RPM_BUILD_ROOT/{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
131
132 gzip -9nf CHANGES NEW README ANNOUNCE TODO LICENSE
133
134 %post -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %files
141 %defattr(644,root,root,755)
142 %doc Doc *.gz
143 %{_libdir}/%{name}*
144 %attr(755,root,root) %{_bindir}/swig
145 %{_examplesdir}/%{name}-%{version}
146
147 %files guile
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/lib*guile.so
150 %attr(755,root,root) %{_libdir}/lib*guile.la
151
152 %files perl
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/lib*pl.so
155 %attr(755,root,root) %{_libdir}/lib*pl.la
156
157 %files python
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/lib*py.so
160 %attr(755,root,root) %{_libdir}/lib*py.la
161
162 %files ruby
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/lib*rb.so
165 %attr(755,root,root) %{_libdir}/lib*rb.la
166
167 %files tcl
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_libdir}/lib*tcl*.so
170 %attr(755,root,root) %{_libdir}/lib*tcl*.la
This page took 0.071069 seconds and 4 git commands to generate.