]> git.pld-linux.org Git - packages/swig.git/blob - swig.spec
- 1.3.17
[packages/swig.git] / swig.spec
1 Summary:        Interface generator for Perl, Tcl, Guile and Python
2 Summary(pl):    Generator interfejsów do Perla, Tcl-a, Guile'a i Pythona
3 Summary(pt_BR): Gerador de Interfaces e "Wrappers" Simplificado (SWIG)
4 Name:           swig
5 Version:        1.3.17
6 Release:        1
7 License:        distributable
8 Group:          Development/Languages
9 Source0:        ftp://ftp.sourceforge.net/pub/sourceforge/swig/%{name}-%{version}.tar.gz
10 URL:            http://www.swig.org/
11 Icon:           swig.gif
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  guile-devel
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  perl-devel >= 5.6.1
17 BuildRequires:  php-devel >= 4.1.0
18 BuildRequires:  python >= 2.2
19 BuildRequires:  ruby >= 1.6.3
20 BuildRequires:  tcl >= 8.3.3
21 BuildRequires:  ocaml-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 SWIG is a compiler that attempts to make it easy to integrate C, C++,
26 or Objective-C code with scripting languages including Perl, Tcl, and
27 Python. In a nutshell, you give it a bunch of ANSI C/C++ declarations
28 and it generates an interface between C and your favorite scripting
29 language. However, this is only scratching the surface of what SWIG
30 can do--some of its more advanced features include automatic
31 documentation generation, module and library management, extensive
32 customization options, and more.
33
34 SWIG is entirely the product of users who have used the system and
35 suggested new idea. There are far too many people to thank
36 individually, but without this support, SWIG would be not be nearly as
37 powerful or fun to use as it is now. Many thanks!
38
39 %description -l pl
40 SWIG jesk kompilatorem, który próbuje u³atwiæ integrowanie kodu
41 napisanego w C, C++ lub Objective-C z jêzykami skryptowymi, takimi jak
42 Perl, Tcl i Python. Mówi±c najpro¶ciej, je¶li dostarczysz mu zestaw
43 zadeklarowanych w ANSI C/C++ funkcji, SWIG wygeneruje Ci interfejs
44 pomiêdzy C a Twoim ulubionym jêzykiem skryptowym. To tylko drobna
45 czê¶æ tego co SWIG potrafi robiæ, bardziej zaawansowane zastosowania
46 to automatyczne generowanie dokumentacji, zarz±dzanie bibliotekami i
47 modu³ami i wiele innych.
48
49 SWIG jest w ca³o¶ci dzie³em ludzi, którzy go u¿ywali i wprowadzali
50 nowe pomys³y. Zbyt wielu ich jest, aby dziêkowaæ ka¿demu z nich
51 osobno, ale bez ich wsparcia SWIG nie by³by ani tak potê¿nym
52 narzêdziem, ani tak fajnym w u¿yciu jak jest teraz. Wiekie dziêki!
53
54 %description -l pt_BR
55 O SWIG gera interfaces para perl, python e tcl a partir de uma arquivo 
56 com uma interface de descrição que consiste de uma combinação de C/C++
57 e diretivas especiais. Permite que linguagens tipo script usem C/C++
58 com um mínimo de esforço.
59
60 %package guile
61 Summary:        SWIG library: guile
62 Summary(pl):    Biblioteka SWIG: guile
63 Group:          Libraries
64
65 %description guile
66 SWIG library: guile.
67
68 %description guile -l pl
69 Biblioteka SWIG: guile.
70
71 %package perl
72 Summary:        SWIG library: Perl
73 Summary(pl):    Biblioteka SWIG: Perl
74 Group:          Libraries
75
76 %description perl
77 SWIG library: perl.
78
79 %description perl -l pl
80 Biblioteka SWIG: perl.
81
82 %package python
83 Summary:        SWIG library: python
84 Summary(pl):    Biblioteka SWIG: python
85 Group:          Libraries
86
87 %description python
88 SWIG library: python.
89
90 %description python -l pl
91 Biblioteka SWIG: python.
92
93 %package ruby
94 Summary:        SWIG library: ruby
95 Summary(pl):    Biblioteka SWIG: ruby
96 Group:          Libraries
97
98 %description ruby
99 SWIG library: ruby.
100
101 %description ruby -l pl
102 Biblioteka SWIG: ruby.
103
104 %package tcl
105 Summary:        SWIG library: tcl
106 Summary(pl):    Biblioteka SWIG: tcl
107 Group:          Libraries
108
109 %description tcl
110 SWIG library: tcl.
111
112 %description tcl -l pl
113 Biblioteka SWIG: tcl.
114
115 %package ocaml
116 Summary:        SWIG library: ocaml
117 Summary(pl):    Biblioteka SWIG: ocaml
118 Group:          Libraries
119
120 %description ocaml
121 SWIG library: ocaml.
122
123 %description ocaml -l pl
124 Biblioteka SWIG: ocaml.
125
126 %prep
127 %setup -q -n SWIG-%{version}
128
129 %build
130 oldpwd=$PWD
131 for i in . Source/DOH Tools Examples/GIFPlot; do
132   cd $i
133   %{__aclocal}
134   %{__autoconf}
135   cd $oldpwd
136 done
137 %configure
138
139 %{__make} OPT="%{rpmcflags}"
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post   -p /sbin/ldconfig
154 %postun -p /sbin/ldconfig
155
156 %files
157 %defattr(644,root,root,755)
158 %doc Doc CHANGES NEW README ANNOUNCE TODO LICENSE
159 %{_libdir}/%{name}*
160 %attr(755,root,root) %{_bindir}/swig
161 %{_examplesdir}/%{name}-%{version}
162
163 %files guile
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_libdir}/lib*guile.so
166 %{_libdir}/lib*guile.la
167
168 %files perl
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libdir}/lib*pl.so
171 %{_libdir}/lib*pl.la
172
173 %files python
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_libdir}/lib*py.so
176 %{_libdir}/lib*py.la
177
178 %files ruby
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/lib*rb.so
181 %{_libdir}/lib*rb.la
182
183 %files tcl
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_libdir}/lib*tcl*.so
186 %{_libdir}/lib*tcl*.la
187
188 %files ocaml
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/lib*ocaml*.so*
191 %{_libdir}/lib*ocaml*.la
This page took 0.082828 seconds and 4 git commands to generate.