]> git.pld-linux.org Git - packages/swig.git/blob - swig.spec
- BR: python-modules, rpm-pythonprov
[packages/swig.git] / swig.spec
1 #
2 # Conditional build:
3 %bcond_without  guile   # disable guile support
4 %bcond_without  ocaml   # disable ocaml support
5 %bcond_without  octave  # disable octave support
6 %bcond_without  perl    # disable perl support
7 %bcond_without  php     # disable php support
8 %bcond_without  ruby    # disable ruby support
9 %bcond_without  tcl     # disable tcl support
10 #
11 Summary:        Interface generator for Perl, Tcl, Guile and Python
12 Summary(pl.UTF-8):      Generator interfejsów do Perla, Tcl-a, Guile'a i Pythona
13 Summary(pt_BR.UTF-8):   Gerador de Interfaces e "Wrappers" Simplificado (SWIG)
14 Name:           swig
15 Version:        1.3.40
16 Release:        1
17 License:        distributable
18 Group:          Development/Languages
19 Source0:        http://dl.sourceforge.net/swig/%{name}-%{version}.tar.gz
20 # Source0-md5:  2df766c9e03e02811b1ab4bba1c7b9cc
21 Patch0:         %{name}-php-freearg.patch
22 URL:            http://www.swig.org/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 %{?with_guile:BuildRequires:    guile-devel}
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtool
28 %{?with_ocaml:BuildRequires:    ocaml}
29 %{?with_octave:BuildRequires:   octave-devel}
30 %{?with_perl:BuildRequires:     perl-devel >= 1:5.6.1}
31 %{?with_php:BuildRequires:      php-cli}
32 %{?with_php:BuildRequires:      php-devel >= 4.1.0}
33 BuildRequires:  python-devel >= 1:2.3.2
34 BuildRequires:  python-modules
35 BuildRequires:  rpm-pythonprov
36 %if %{with ruby}
37 BuildRequires:  rpmbuild(macros) >= 1.277
38 BuildRequires:  ruby-devel >= 1:1.6.3
39 %endif
40 %{?with_tcl:BuildRequires:      tcl-devel >= 8.3.3}
41 Obsoletes:      swig-ocaml
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 SWIG is a compiler that attempts to make it easy to integrate C, C++,
46 or Objective-C code with scripting languages including Perl, Tcl, and
47 Python. In a nutshell, you give it a bunch of ANSI C/C++ declarations
48 and it generates an interface between C and your favorite scripting
49 language. However, this is only scratching the surface of what SWIG
50 can do--some of its more advanced features include automatic
51 documentation generation, module and library management, extensive
52 customization options, and more.
53
54 SWIG is entirely the product of users who have used the system and
55 suggested new idea. There are far too many people to thank
56 individually, but without this support, SWIG would be not be nearly as
57 powerful or fun to use as it is now. Many thanks!
58
59 %description -l pl.UTF-8
60 SWIG jesk kompilatorem, który próbuje ułatwić integrowanie kodu
61 napisanego w C, C++ lub Objective-C z językami skryptowymi, takimi jak
62 Perl, Tcl i Python. Mówiąc najprościej, jeśli dostarczysz mu zestaw
63 zadeklarowanych w ANSI C/C++ funkcji, SWIG wygeneruje Ci interfejs
64 pomiędzy C a Twoim ulubionym językiem skryptowym. To tylko drobna
65 część tego co SWIG potrafi robić, bardziej zaawansowane zastosowania
66 to automatyczne generowanie dokumentacji, zarządzanie bibliotekami i
67 modułami i wiele innych.
68
69 SWIG jest w całości dziełem ludzi, którzy go używali i wprowadzali
70 nowe pomysły. Zbyt wielu ich jest, aby dziękować każdemu z nich
71 osobno, ale bez ich wsparcia SWIG nie byłby ani tak potężnym
72 narzędziem, ani tak fajnym w użyciu jak jest teraz. Wiekie dzięki!
73
74 %description -l pt_BR.UTF-8
75 O SWIG gera interfaces para perl, python e Tcl a partir de uma arquivo
76 com uma interface de descrição que consiste de uma combinação de C/C++
77 e diretivas especiais. Permite que linguagens tipo script usem C/C++
78 com um mínimo de esforço.
79
80 %package guile
81 Summary:        SWIG library: guile
82 Summary(pl.UTF-8):      Biblioteka SWIG: guile
83 Group:          Libraries
84 Requires:       %{name} = %{version}-%{release}
85
86 %description guile
87 SWIG library: guile.
88
89 %description guile -l pl.UTF-8
90 Biblioteka SWIG: guile.
91
92 %package perl
93 Summary:        SWIG library: Perl
94 Summary(pl.UTF-8):      Biblioteka SWIG: Perl
95 Group:          Libraries
96 Requires:       %{name} = %{version}-%{release}
97
98 %description perl
99 SWIG library: perl.
100
101 %description perl -l pl.UTF-8
102 Biblioteka SWIG: perl.
103
104 %package php
105 Summary:        SWIG library: php
106 Summary(pl.UTF-8):      Biblioteka SWIG: php
107 Group:          Libraries
108 Requires:       %{name} = %{version}-%{release}
109
110 %description php
111 SWIG library: php.
112
113 %description php -l pl.UTF-8
114 Biblioteka SWIG: php.
115
116 %package python
117 Summary:        SWIG library: python
118 Summary(pl.UTF-8):      Biblioteka SWIG: python
119 Group:          Libraries
120 Requires:       %{name} = %{version}-%{release}
121
122 %description python
123 SWIG library: python.
124
125 %description python -l pl.UTF-8
126 Biblioteka SWIG: python.
127
128 %package ruby
129 Summary:        SWIG library: ruby
130 Summary(pl.UTF-8):      Biblioteka SWIG: ruby
131 Group:          Libraries
132 Requires:       %{name} = %{version}-%{release}
133 %{?ruby_mod_ver_requires_eq}
134
135 %description ruby
136 SWIG library: ruby.
137
138 %description ruby -l pl.UTF-8
139 Biblioteka SWIG: ruby.
140
141 %package tcl
142 Summary:        SWIG library: tcl
143 Summary(pl.UTF-8):      Biblioteka SWIG: tcl
144 Group:          Libraries
145 Requires:       %{name} = %{version}-%{release}
146
147 %description tcl
148 SWIG library: tcl.
149
150 %description tcl -l pl.UTF-8
151 Biblioteka SWIG: tcl.
152
153 %prep
154 %setup -q
155 %patch0 -p1
156
157 %build
158 %{__libtoolize}
159 %{__aclocal} -I Tools/config
160 %{__autoconf}
161 %{__automake}
162 %configure
163
164 %{__make} \
165         OPT="%{rpmcflags}"
166
167 %install
168 rm -rf $RPM_BUILD_ROOT
169 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
170
171 %{__make} install \
172         DESTDIR=$RPM_BUILD_ROOT \
173         M4_INSTALL_DIR=$RPM_BUILD_ROOT%{_aclocaldir}
174
175 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %files
181 %defattr(644,root,root,755)
182 %doc Doc CHANGES CHANGES.current NEW README ANNOUNCE TODO LICENSE
183 %attr(755,root,root) %{_bindir}/ccache-swig
184 %attr(755,root,root) %{_bindir}/swig
185 %{_datadir}/%{name}
186 %{?with_guile:%exclude %{_datadir}/%{name}/%{version}/guile}
187 %{?with_perl:%exclude %{_datadir}/%{name}/%{version}/perl5}
188 %{?with_php:%exclude %{_datadir}/%{name}/%{version}/php}
189 %exclude %{_datadir}/%{name}/%{version}/python
190 %{?with_ruby:%exclude %{_datadir}/%{name}/%{version}/ruby}
191 %{?with_tcl:%exclude %{_datadir}/%{name}/%{version}/tcl}
192 %{_mandir}/man1/ccache-swig.1*
193 %{_examplesdir}/%{name}-%{version}
194
195 %if %{with guile}
196 %files guile
197 %defattr(644,root,root,755)
198 %{_datadir}/%{name}/%{version}/guile
199 %endif
200
201 %if %{with perl}
202 %files perl
203 %defattr(644,root,root,755)
204 %{_datadir}/%{name}/%{version}/perl5
205 %endif
206
207 %if %{with php}
208 %files php
209 %defattr(644,root,root,755)
210 %{_datadir}/%{name}/%{version}/php
211 %endif
212
213 %files python
214 %defattr(644,root,root,755)
215 %{_datadir}/%{name}/%{version}/python
216
217 %if %{with ruby}
218 %files ruby
219 %defattr(644,root,root,755)
220 %{_datadir}/%{name}/%{version}/ruby
221 %endif
222
223 %if %{with tcl}
224 %files tcl
225 %defattr(644,root,root,755)
226 %{_datadir}/%{name}/%{version}/tcl
227 %endif
This page took 0.111773 seconds and 4 git commands to generate.