]> git.pld-linux.org Git - packages/swig.git/blob - swig.spec
- rel 3
[packages/swig.git] / swig.spec
1 #
2 # Conditional build:
3 %bcond_without  guile   # disable guile support
4 %bcond_without  ocaml   # disable ocaml support
5 %bcond_without  octave  # disable octave support
6 %bcond_without  perl    # disable perl support
7 %bcond_without  php     # disable php support
8 %bcond_without  ruby    # disable ruby support
9 %bcond_without  tcl     # disable tcl support
10 #
11 Summary:        Interface generator for Perl, Tcl, Guile and Python
12 Summary(pl.UTF-8):      Generator interfejsów do Perla, Tcl-a, Guile'a i Pythona
13 Summary(pt_BR.UTF-8):   Gerador de Interfaces e "Wrappers" Simplificado (SWIG)
14 Name:           swig
15 Version:        1.3.40
16 Release:        3
17 License:        distributable
18 Group:          Development/Languages
19 Source0:        http://dl.sourceforge.net/swig/%{name}-%{version}.tar.gz
20 # Source0-md5:  2df766c9e03e02811b1ab4bba1c7b9cc
21 Patch0:         %{name}-php-freearg.patch
22 Patch1:         %{name}-ruby1.9.patch
23 URL:            http://www.swig.org/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 %{?with_guile:BuildRequires:    guile-devel}
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtool
29 %{?with_ocaml:BuildRequires:    ocaml}
30 %{?with_octave:BuildRequires:   octave-devel}
31 %{?with_perl:BuildRequires:     perl-devel >= 1:5.6.1}
32 %{?with_php:BuildRequires:      php-cli}
33 %{?with_php:BuildRequires:      php-devel >= 4.1.0}
34 BuildRequires:  python-devel >= 1:2.3.2
35 BuildRequires:  python-modules
36 BuildRequires:  rpm-pythonprov
37 %if %{with ruby}
38 BuildRequires:  rpmbuild(macros) >= 1.277
39 BuildRequires:  ruby-devel >= 1:1.6.3
40 %endif
41 %{?with_tcl:BuildRequires:      tcl-devel >= 8.3.3}
42 Obsoletes:      swig-ocaml
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 SWIG is a compiler that attempts to make it easy to integrate C, C++,
47 or Objective-C code with scripting languages including Perl, Tcl, and
48 Python. In a nutshell, you give it a bunch of ANSI C/C++ declarations
49 and it generates an interface between C and your favorite scripting
50 language. However, this is only scratching the surface of what SWIG
51 can do--some of its more advanced features include automatic
52 documentation generation, module and library management, extensive
53 customization options, and more.
54
55 SWIG is entirely the product of users who have used the system and
56 suggested new idea. There are far too many people to thank
57 individually, but without this support, SWIG would be not be nearly as
58 powerful or fun to use as it is now. Many thanks!
59
60 %description -l pl.UTF-8
61 SWIG jesk kompilatorem, który próbuje ułatwić integrowanie kodu
62 napisanego w C, C++ lub Objective-C z językami skryptowymi, takimi jak
63 Perl, Tcl i Python. Mówiąc najprościej, jeśli dostarczysz mu zestaw
64 zadeklarowanych w ANSI C/C++ funkcji, SWIG wygeneruje Ci interfejs
65 pomiędzy C a Twoim ulubionym językiem skryptowym. To tylko drobna
66 część tego co SWIG potrafi robić, bardziej zaawansowane zastosowania
67 to automatyczne generowanie dokumentacji, zarządzanie bibliotekami i
68 modułami i wiele innych.
69
70 SWIG jest w całości dziełem ludzi, którzy go używali i wprowadzali
71 nowe pomysły. Zbyt wielu ich jest, aby dziękować każdemu z nich
72 osobno, ale bez ich wsparcia SWIG nie byłby ani tak potężnym
73 narzędziem, ani tak fajnym w użyciu jak jest teraz. Wiekie dzięki!
74
75 %description -l pt_BR.UTF-8
76 O SWIG gera interfaces para perl, python e Tcl a partir de uma arquivo
77 com uma interface de descrição que consiste de uma combinação de C/C++
78 e diretivas especiais. Permite que linguagens tipo script usem C/C++
79 com um mínimo de esforço.
80
81 %package guile
82 Summary:        SWIG library: guile
83 Summary(pl.UTF-8):      Biblioteka SWIG: guile
84 Group:          Libraries
85 Requires:       %{name} = %{version}-%{release}
86
87 %description guile
88 SWIG library: guile.
89
90 %description guile -l pl.UTF-8
91 Biblioteka SWIG: guile.
92
93 %package perl
94 Summary:        SWIG library: Perl
95 Summary(pl.UTF-8):      Biblioteka SWIG: Perl
96 Group:          Libraries
97 Requires:       %{name} = %{version}-%{release}
98
99 %description perl
100 SWIG library: perl.
101
102 %description perl -l pl.UTF-8
103 Biblioteka SWIG: perl.
104
105 %package php
106 Summary:        SWIG library: php
107 Summary(pl.UTF-8):      Biblioteka SWIG: php
108 Group:          Libraries
109 Requires:       %{name} = %{version}-%{release}
110
111 %description php
112 SWIG library: php.
113
114 %description php -l pl.UTF-8
115 Biblioteka SWIG: php.
116
117 %package python
118 Summary:        SWIG library: python
119 Summary(pl.UTF-8):      Biblioteka SWIG: python
120 Group:          Libraries
121 Requires:       %{name} = %{version}-%{release}
122
123 %description python
124 SWIG library: python.
125
126 %description python -l pl.UTF-8
127 Biblioteka SWIG: python.
128
129 %package ruby
130 Summary:        SWIG library: ruby
131 Summary(pl.UTF-8):      Biblioteka SWIG: ruby
132 Group:          Libraries
133 Requires:       %{name} = %{version}-%{release}
134 %{?ruby_mod_ver_requires_eq}
135
136 %description ruby
137 SWIG library: ruby.
138
139 %description ruby -l pl.UTF-8
140 Biblioteka SWIG: ruby.
141
142 %package tcl
143 Summary:        SWIG library: tcl
144 Summary(pl.UTF-8):      Biblioteka SWIG: tcl
145 Group:          Libraries
146 Requires:       %{name} = %{version}-%{release}
147
148 %description tcl
149 SWIG library: tcl.
150
151 %description tcl -l pl.UTF-8
152 Biblioteka SWIG: tcl.
153
154 %prep
155 %setup -q
156 %patch0 -p1
157 %patch1 -p1
158
159 %build
160 %{__libtoolize}
161 %{__aclocal} -I Tools/config
162 %{__autoconf}
163 %{__automake}
164 %configure
165
166 %{__make} \
167         OPT="%{rpmcflags}"
168
169 %install
170 rm -rf $RPM_BUILD_ROOT
171 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
172
173 %{__make} install \
174         DESTDIR=$RPM_BUILD_ROOT \
175         M4_INSTALL_DIR=$RPM_BUILD_ROOT%{_aclocaldir}
176
177 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %files
183 %defattr(644,root,root,755)
184 %doc Doc CHANGES CHANGES.current NEW README ANNOUNCE TODO LICENSE
185 %attr(755,root,root) %{_bindir}/ccache-swig
186 %attr(755,root,root) %{_bindir}/swig
187 %{_datadir}/%{name}
188 %{?with_guile:%exclude %{_datadir}/%{name}/%{version}/guile}
189 %{?with_perl:%exclude %{_datadir}/%{name}/%{version}/perl5}
190 %{?with_php:%exclude %{_datadir}/%{name}/%{version}/php}
191 %exclude %{_datadir}/%{name}/%{version}/python
192 %{?with_ruby:%exclude %{_datadir}/%{name}/%{version}/ruby}
193 %{?with_tcl:%exclude %{_datadir}/%{name}/%{version}/tcl}
194 %{_mandir}/man1/ccache-swig.1*
195 %{_examplesdir}/%{name}-%{version}
196
197 %if %{with guile}
198 %files guile
199 %defattr(644,root,root,755)
200 %{_datadir}/%{name}/%{version}/guile
201 %endif
202
203 %if %{with perl}
204 %files perl
205 %defattr(644,root,root,755)
206 %{_datadir}/%{name}/%{version}/perl5
207 %endif
208
209 %if %{with php}
210 %files php
211 %defattr(644,root,root,755)
212 %{_datadir}/%{name}/%{version}/php
213 %endif
214
215 %files python
216 %defattr(644,root,root,755)
217 %{_datadir}/%{name}/%{version}/python
218
219 %if %{with ruby}
220 %files ruby
221 %defattr(644,root,root,755)
222 %{_datadir}/%{name}/%{version}/ruby
223 %endif
224
225 %if %{with tcl}
226 %files tcl
227 %defattr(644,root,root,755)
228 %{_datadir}/%{name}/%{version}/tcl
229 %endif
This page took 0.071363 seconds and 4 git commands to generate.