]> git.pld-linux.org Git - packages/swig.git/blob - swig.spec
- cosmetics only (not compiles).
[packages/swig.git] / swig.spec
1 Summary:        Interface generator for Perl, Tcl, Guile and Python
2 Summary(pl):    Generator interfejsu do Perl'a, Tcl'a, Guile'a i Python'a
3 Name:           swig
4 Version:        1.1p5
5 Release:        1
6 Copyright:      distributable
7 Group:          Development/Languages
8 Group(pl):      Programowanie/Jêzyki
9 Source0:        %{name}%{version}.tar.gz
10 Patch:          swig1.1p2-fixed-paths.patch
11 Icon:           swig.gif
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 SWIG is a compiler that attempts to make it easy to integrate C, C++,
16 or Objective-C code with scripting languages including Perl, Tcl, and
17 Python.  In a nutshell, you give it a bunch of ANSI C/C++ declarations
18 and it generates an interface between C and your favorite scripting
19 language.  However, this is only scratching the surface of what SWIG
20 can do--some of its more advanced features include automatic
21 documentation generation, module and library management, extensive
22 customization options, and more.
23
24 SWIG is entirely the product of users who have used the system and
25 suggested new idea.  There are far too many people to thank
26 individually, but without this support, SWIG would be not be nearly as
27 powerful or fun to use as it is now. Many thanks!
28
29 %description -l pl
30 SWIG jesk kompilatorem, który próbuje ulatwic integrowanie kodu napisanego
31 w C, C++ lub Objective-C z jêzykami skryptowymitakimi jak Perl, Tcl i Python.
32 Mówi±c najpro¶ciej, jesli dostarczysz mu zestaw zdeklarowanych w ANSI C/C++
33 funkcji, SWIG wygeneruje Ci interfejs pomiedzy C a Twoim ulubionym jêzykiem
34 skryptowym. To tylko drobna czê¶æ tego co SWIG potrafi robiæ, bardziej 
35 zaawansowane zastosowania to automatyczne generowanie dokumentacji,
36 zarzadzanie bibliotekami i modu³ami i wiele innych.
37
38 SWIG jest w ca³o¶ci dzi³em ludzi, którzy go u¿ywali i wprowadzali nowe 
39 pomys³y. Zbyt wielu ich jest, aby dziêkowaæ ka¿demu z nich osobno, 
40 ale bez ich wsparcia, SWIG nie by³by anie tak pote¿nym na¿edziem, ani tak
41 fajnym w u¿yciu jak jest teraz. Wiekie dziêki!
42
43 %prep
44 %setup -q -n SWIG1.1p5
45 find Examples/ -type l -exec rm -v {} \;
46 %patch -p1
47
48 %build
49 %configure
50 make OPT="$RPM_OPT_FLAGS"
51 make test
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT/{%{_libdir}/swig_lib,%{_mandir}/man1,%{_prefix}/src/examples/swig}
56
57 make install \
58         prefix=$RPM_BUILD_ROOT/%{_prefix} \
59         exec_prefix=$RPM_BUILD_ROOT/%{_prefix} \
60         MAN_DIR=$RPM_BUILD_ROOT/%{_mandir}/man1
61
62 cp -a Examples/* $RPM_BUILD_ROOT/%{_prefix}/src/examples/swig/
63
64 gzip -9nf CHANGES NEW README TROUBLESHOOTING ToDo \
65         $RPM_BUILD_ROOT/%{_mandir}/man1/*
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(-,root,root,755)
72 %doc Doc *.gz
73 %dir %{_libdir}/swig_lib
74 %{_libdir}/swig_lib/*
75 %{_libdir}/libswig.a
76 %{_includedir}/swig.h
77 %attr(755,root,root) %{_bindir}/swig
78 %{_mandir}/man1/*
79 %{_prefix}/src/examples/swig
This page took 0.029386 seconds and 4 git commands to generate.