]> git.pld-linux.org Git - packages/swig.git/blob - swig.spec
- added format patch to fix funny messages (what is "Successodule"?)
[packages/swig.git] / swig.spec
1 Summary:        Interface generator for Perl, Tcl, Guile and Python
2 Summary(pl):    Generator interfejsów do Perla, Tcl-a, Guile'a i Pythona
3 Summary(pt_BR): Gerador de Interfaces e "Wrappers" Simplificado (SWIG)
4 Name:           swig
5 Version:        1.3.19
6 Release:        1
7 License:        distributable
8 Group:          Development/Languages
9 Source0:        http://dl.sourceforge.net/swig/%{name}-%{version}.tar.gz
10 Patch0:         %{name}-format.patch
11 URL:            http://www.swig.org/
12 Icon:           swig.gif
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  guile-devel
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libtool
18 BuildRequires:  perl-devel >= 5.6.1
19 BuildRequires:  php-devel >= 4.1.0
20 BuildRequires:  python >= 2.2
21 BuildRequires:  ruby >= 1.6.3
22 BuildRequires:  tcl-devel >= 8.3.3
23 BuildRequires:  ocaml
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 SWIG is a compiler that attempts to make it easy to integrate C, C++,
28 or Objective-C code with scripting languages including Perl, Tcl, and
29 Python. In a nutshell, you give it a bunch of ANSI C/C++ declarations
30 and it generates an interface between C and your favorite scripting
31 language. However, this is only scratching the surface of what SWIG
32 can do--some of its more advanced features include automatic
33 documentation generation, module and library management, extensive
34 customization options, and more.
35
36 SWIG is entirely the product of users who have used the system and
37 suggested new idea. There are far too many people to thank
38 individually, but without this support, SWIG would be not be nearly as
39 powerful or fun to use as it is now. Many thanks!
40
41 %description -l pl
42 SWIG jesk kompilatorem, który próbuje u³atwiæ integrowanie kodu
43 napisanego w C, C++ lub Objective-C z jêzykami skryptowymi, takimi jak
44 Perl, Tcl i Python. Mówi±c najpro¶ciej, je¶li dostarczysz mu zestaw
45 zadeklarowanych w ANSI C/C++ funkcji, SWIG wygeneruje Ci interfejs
46 pomiêdzy C a Twoim ulubionym jêzykiem skryptowym. To tylko drobna
47 czê¶æ tego co SWIG potrafi robiæ, bardziej zaawansowane zastosowania
48 to automatyczne generowanie dokumentacji, zarz±dzanie bibliotekami i
49 modu³ami i wiele innych.
50
51 SWIG jest w ca³o¶ci dzie³em ludzi, którzy go u¿ywali i wprowadzali
52 nowe pomys³y. Zbyt wielu ich jest, aby dziêkowaæ ka¿demu z nich
53 osobno, ale bez ich wsparcia SWIG nie by³by ani tak potê¿nym
54 narzêdziem, ani tak fajnym w u¿yciu jak jest teraz. Wiekie dziêki!
55
56 %description -l pt_BR
57 O SWIG gera interfaces para perl, python e tcl a partir de uma arquivo
58 com uma interface de descrição que consiste de uma combinação de C/C++
59 e diretivas especiais. Permite que linguagens tipo script usem C/C++
60 com um mínimo de esforço.
61
62 %package guile
63 Summary:        SWIG library: guile
64 Summary(pl):    Biblioteka SWIG: guile
65 Group:          Libraries
66
67 %description guile
68 SWIG library: guile.
69
70 %description guile -l pl
71 Biblioteka SWIG: guile.
72
73 %package perl
74 Summary:        SWIG library: Perl
75 Summary(pl):    Biblioteka SWIG: Perl
76 Group:          Libraries
77
78 %description perl
79 SWIG library: perl.
80
81 %description perl -l pl
82 Biblioteka SWIG: perl.
83
84 %package python
85 Summary:        SWIG library: python
86 Summary(pl):    Biblioteka SWIG: python
87 Group:          Libraries
88
89 %description python
90 SWIG library: python.
91
92 %description python -l pl
93 Biblioteka SWIG: python.
94
95 %package ruby
96 Summary:        SWIG library: ruby
97 Summary(pl):    Biblioteka SWIG: ruby
98 Group:          Libraries
99
100 %description ruby
101 SWIG library: ruby.
102
103 %description ruby -l pl
104 Biblioteka SWIG: ruby.
105
106 %package tcl
107 Summary:        SWIG library: tcl
108 Summary(pl):    Biblioteka SWIG: tcl
109 Group:          Libraries
110
111 %description tcl
112 SWIG library: tcl.
113
114 %description tcl -l pl
115 Biblioteka SWIG: tcl.
116
117 %package ocaml
118 Summary:        SWIG library: ocaml
119 Summary(pl):    Biblioteka SWIG: ocaml
120 Group:          Libraries
121
122 %description ocaml
123 SWIG library: ocaml.
124
125 %description ocaml -l pl
126 Biblioteka SWIG: ocaml.
127
128 %prep
129 %setup -q -n SWIG-%{version}
130 %patch -p1
131
132 %build
133 oldpwd=$PWD
134 for i in . Tools; do
135   cd $i
136   %{__libtoolize}
137   %{__aclocal}
138   %{__autoconf}
139   cd $oldpwd
140 done
141 %configure
142
143 %{__make} OPT="%{rpmcflags}"
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
148
149 %{__make} install \
150         DESTDIR=$RPM_BUILD_ROOT
151
152 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post   -p /sbin/ldconfig
158 %postun -p /sbin/ldconfig
159
160 %files
161 %defattr(644,root,root,755)
162 %doc Doc CHANGES NEW README ANNOUNCE TODO LICENSE
163 %{_libdir}/%{name}*
164 %attr(755,root,root) %{_bindir}/swig
165 %{_examplesdir}/%{name}-%{version}
166
167 %files guile
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_libdir}/lib*guile.so
170 %{_libdir}/lib*guile.la
171
172 %files perl
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_libdir}/lib*pl.so
175 %{_libdir}/lib*pl.la
176
177 %files python
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/lib*py.so
180 %{_libdir}/lib*py.la
181
182 %files ruby
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/lib*rb.so
185 %{_libdir}/lib*rb.la
186
187 %files tcl
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_libdir}/lib*tcl*.so
190 %{_libdir}/lib*tcl*.la
191
192 %files ocaml
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/lib*ocaml*.so*
195 %{_libdir}/lib*ocaml*.la
This page took 0.084492 seconds and 4 git commands to generate.