]> git.pld-linux.org Git - packages/swig.git/blob - swig.spec
- release 2
[packages/swig.git] / swig.spec
1 #
2 # Conditional build:
3 %bcond_without  guile   # disable guile support
4 %bcond_without  ocaml   # disable ocaml support
5 %bcond_without  octave  # disable octave support
6 %bcond_without  perl    # disable perl support
7 %bcond_without  php     # disable php support
8 %bcond_without  ruby    # disable ruby support
9 %bcond_without  tcl     # disable tcl support
10 #
11 Summary:        Interface generator for Perl, Tcl, Guile and Python
12 Summary(pl.UTF-8):      Generator interfejsów do Perla, Tcl-a, Guile'a i Pythona
13 Summary(pt_BR.UTF-8):   Gerador de Interfaces e "Wrappers" Simplificado (SWIG)
14 Name:           swig
15 Version:        2.0.4
16 Release:        2
17 License:        GPL v3+ (utility), free (library)
18 Group:          Development/Languages
19 Source0:        http://downloads.sourceforge.net/swig/%{name}-%{version}.tar.gz
20 # Source0-md5:  4319c503ee3a13d2a53be9d828c3adc0
21 Patch0:         %{name}-php-freearg.patch
22 Patch1:         %{name}-guile2.patch
23 URL:            http://www.swig.org/
24 BuildRequires:  autoconf >= 2.58
25 BuildRequires:  automake >= 1:1.7.2
26 %{?with_guile:BuildRequires:    guile-devel}
27 BuildRequires:  libstdc++-devel
28 %{?with_ocaml:BuildRequires:    ocaml}
29 %{?with_octave:BuildRequires:   octave-devel}
30 %{?with_perl:BuildRequires:     perl-devel >= 1:5.6.1}
31 %{?with_php:BuildRequires:      php-cli}
32 %{?with_php:BuildRequires:      php-devel >= 4.1.0}
33 BuildRequires:  python-devel >= 1:2.3.2
34 BuildRequires:  python-modules
35 BuildRequires:  rpm-pythonprov
36 %if %{with ruby}
37 BuildRequires:  rpmbuild(macros) >= 1.277
38 BuildRequires:  ruby-devel >= 1:1.6.3
39 %endif
40 %{?with_tcl:BuildRequires:      tcl-devel >= 8.3.3}
41 Obsoletes:      swig-ocaml
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 SWIG is a compiler that attempts to make it easy to integrate C, C++,
46 or Objective-C code with scripting languages including Perl, Tcl, and
47 Python. In a nutshell, you give it a bunch of ANSI C/C++ declarations
48 and it generates an interface between C and your favorite scripting
49 language. However, this is only scratching the surface of what SWIG
50 can do--some of its more advanced features include automatic
51 documentation generation, module and library management, extensive
52 customization options, and more.
53
54 SWIG is entirely the product of users who have used the system and
55 suggested new idea. There are far too many people to thank
56 individually, but without this support, SWIG would be not be nearly as
57 powerful or fun to use as it is now. Many thanks!
58
59 %description -l pl.UTF-8
60 SWIG jesk kompilatorem, który próbuje ułatwić integrowanie kodu
61 napisanego w C, C++ lub Objective-C z językami skryptowymi, takimi jak
62 Perl, Tcl i Python. Mówiąc najprościej, jeśli dostarczysz mu zestaw
63 zadeklarowanych w ANSI C/C++ funkcji, SWIG wygeneruje Ci interfejs
64 pomiędzy C a Twoim ulubionym językiem skryptowym. To tylko drobna
65 część tego co SWIG potrafi robić, bardziej zaawansowane zastosowania
66 to automatyczne generowanie dokumentacji, zarządzanie bibliotekami i
67 modułami i wiele innych.
68
69 SWIG jest w całości dziełem ludzi, którzy go używali i wprowadzali
70 nowe pomysły. Zbyt wielu ich jest, aby dziękować każdemu z nich
71 osobno, ale bez ich wsparcia SWIG nie byłby ani tak potężnym
72 narzędziem, ani tak fajnym w użyciu jak jest teraz. Wiekie dzięki!
73
74 %description -l pt_BR.UTF-8
75 O SWIG gera interfaces para perl, python e Tcl a partir de uma arquivo
76 com uma interface de descrição que consiste de uma combinação de C/C++
77 e diretivas especiais. Permite que linguagens tipo script usem C/C++
78 com um mínimo de esforço.
79
80 %package guile
81 Summary:        SWIG library: guile
82 Summary(pl.UTF-8):      Biblioteka SWIG: guile
83 License:        free
84 Group:          Libraries
85 Requires:       %{name} = %{version}-%{release}
86
87 %description guile
88 SWIG library: guile.
89
90 %description guile -l pl.UTF-8
91 Biblioteka SWIG: guile.
92
93 %package perl
94 Summary:        SWIG library: Perl
95 Summary(pl.UTF-8):      Biblioteka SWIG: Perl
96 License:        free
97 Group:          Libraries
98 Requires:       %{name} = %{version}-%{release}
99
100 %description perl
101 SWIG library: perl.
102
103 %description perl -l pl.UTF-8
104 Biblioteka SWIG: perl.
105
106 %package php
107 Summary:        SWIG library: php
108 Summary(pl.UTF-8):      Biblioteka SWIG: php
109 License:        free
110 Group:          Libraries
111 Requires:       %{name} = %{version}-%{release}
112
113 %description php
114 SWIG library: php.
115
116 %description php -l pl.UTF-8
117 Biblioteka SWIG: php.
118
119 %package python
120 Summary:        SWIG library: python
121 Summary(pl.UTF-8):      Biblioteka SWIG: python
122 License:        free
123 Group:          Libraries
124 Requires:       %{name} = %{version}-%{release}
125
126 %description python
127 SWIG library: python.
128
129 %description python -l pl.UTF-8
130 Biblioteka SWIG: python.
131
132 %package ruby
133 Summary:        SWIG library: ruby
134 Summary(pl.UTF-8):      Biblioteka SWIG: ruby
135 License:        free
136 Group:          Libraries
137 Requires:       %{name} = %{version}-%{release}
138 %{?ruby_mod_ver_requires_eq}
139
140 %description ruby
141 SWIG library: ruby.
142
143 %description ruby -l pl.UTF-8
144 Biblioteka SWIG: ruby.
145
146 %package tcl
147 Summary:        SWIG library: tcl
148 Summary(pl.UTF-8):      Biblioteka SWIG: tcl
149 License:        free
150 Group:          Libraries
151 Requires:       %{name} = %{version}-%{release}
152
153 %description tcl
154 SWIG library: tcl.
155
156 %description tcl -l pl.UTF-8
157 Biblioteka SWIG: tcl.
158
159 %prep
160 %setup -q
161 %patch0 -p1
162 %patch1 -p1
163
164 %build
165 %{__aclocal} -I Tools/config
166 %{__autoconf}
167 %{__automake}
168 %configure
169
170 %{__make} \
171         OPT="%{rpmcflags}"
172
173 %install
174 rm -rf $RPM_BUILD_ROOT
175 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
176
177 %{__make} install \
178         DESTDIR=$RPM_BUILD_ROOT \
179         M4_INSTALL_DIR=$RPM_BUILD_ROOT%{_aclocaldir}
180
181 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
182
183 %clean
184 rm -rf $RPM_BUILD_ROOT
185
186 %files
187 %defattr(644,root,root,755)
188 %doc ANNOUNCE CHANGES CHANGES.current COPYRIGHT LICENSE LICENSE-UNIVERSITIES README RELEASENOTES TODO Doc
189 %attr(755,root,root) %{_bindir}/ccache-swig
190 %attr(755,root,root) %{_bindir}/swig
191 %{_datadir}/%{name}
192 %{?with_guile:%exclude %{_datadir}/%{name}/%{version}/guile}
193 %{?with_perl:%exclude %{_datadir}/%{name}/%{version}/perl5}
194 %{?with_php:%exclude %{_datadir}/%{name}/%{version}/php}
195 %exclude %{_datadir}/%{name}/%{version}/python
196 %{?with_ruby:%exclude %{_datadir}/%{name}/%{version}/ruby}
197 %{?with_tcl:%exclude %{_datadir}/%{name}/%{version}/tcl}
198 %{_mandir}/man1/ccache-swig.1*
199 %{_examplesdir}/%{name}-%{version}
200
201 %if %{with guile}
202 %files guile
203 %defattr(644,root,root,755)
204 %{_datadir}/%{name}/%{version}/guile
205 %endif
206
207 %if %{with perl}
208 %files perl
209 %defattr(644,root,root,755)
210 %{_datadir}/%{name}/%{version}/perl5
211 %endif
212
213 %if %{with php}
214 %files php
215 %defattr(644,root,root,755)
216 %{_datadir}/%{name}/%{version}/php
217 %endif
218
219 %files python
220 %defattr(644,root,root,755)
221 %{_datadir}/%{name}/%{version}/python
222
223 %if %{with ruby}
224 %files ruby
225 %defattr(644,root,root,755)
226 %{_datadir}/%{name}/%{version}/ruby
227 %endif
228
229 %if %{with tcl}
230 %files tcl
231 %defattr(644,root,root,755)
232 %{_datadir}/%{name}/%{version}/tcl
233 %endif
This page took 0.059436 seconds and 4 git commands to generate.