]> git.pld-linux.org Git - packages/swig.git/blob - swig.spec
- dropped obsolete ldconfig calls
[packages/swig.git] / swig.spec
1 #
2 # Conditional build:
3 %bcond_without  guile   # disable guile support
4 %bcond_without  ocaml   # disable ocaml support
5 %bcond_without  perl    # disable perl support
6 %bcond_without  php     # disable php support
7 %bcond_without  ruby    # disable ruby support
8 %bcond_without  tcl     # disable tcl support
9 #
10 Summary:        Interface generator for Perl, Tcl, Guile and Python
11 Summary(pl.UTF-8):      Generator interfejsów do Perla, Tcl-a, Guile'a i Pythona
12 Summary(pt_BR.UTF-8):   Gerador de Interfaces e "Wrappers" Simplificado (SWIG)
13 Name:           swig
14 Version:        1.3.33
15 Release:        1
16 License:        distributable
17 Group:          Development/Languages
18 Source0:        http://dl.sourceforge.net/swig/%{name}-%{version}.tar.gz
19 # Source0-md5:  98798707c72ca65c572cad6870148cdd
20 Patch0:         %{name}-format.patch
21 Patch1:         %{name}-php.patch
22 Patch2:         %{name}-php-freearg.patch
23 Patch3:         %{name}-php-vdecl.patch
24 URL:            http://www.swig.org/
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 %{?with_guile:BuildRequires:    guile-devel}
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libtool
30 %{?with_ocaml:BuildRequires:    ocaml}
31 %{?with_perl:BuildRequires:     perl-devel >= 1:5.6.1}
32 %{?with_php:BuildRequires:      php-cli}
33 %{?with_php:BuildRequires:      php-devel >= 4.1.0}
34 BuildRequires:  python-devel >= 1:2.3.2
35 %if %{with ruby}
36 BuildRequires:  rpmbuild(macros) >= 1.277
37 BuildRequires:  ruby-devel >= 1:1.6.3
38 %endif
39 %{?with_tcl:BuildRequires:      tcl-devel >= 8.3.3}
40 Obsoletes:      swig-ocaml
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 SWIG is a compiler that attempts to make it easy to integrate C, C++,
45 or Objective-C code with scripting languages including Perl, Tcl, and
46 Python. In a nutshell, you give it a bunch of ANSI C/C++ declarations
47 and it generates an interface between C and your favorite scripting
48 language. However, this is only scratching the surface of what SWIG
49 can do--some of its more advanced features include automatic
50 documentation generation, module and library management, extensive
51 customization options, and more.
52
53 SWIG is entirely the product of users who have used the system and
54 suggested new idea. There are far too many people to thank
55 individually, but without this support, SWIG would be not be nearly as
56 powerful or fun to use as it is now. Many thanks!
57
58 %description -l pl.UTF-8
59 SWIG jesk kompilatorem, który próbuje ułatwić integrowanie kodu
60 napisanego w C, C++ lub Objective-C z językami skryptowymi, takimi jak
61 Perl, Tcl i Python. Mówiąc najprościej, jeśli dostarczysz mu zestaw
62 zadeklarowanych w ANSI C/C++ funkcji, SWIG wygeneruje Ci interfejs
63 pomiędzy C a Twoim ulubionym językiem skryptowym. To tylko drobna
64 część tego co SWIG potrafi robić, bardziej zaawansowane zastosowania
65 to automatyczne generowanie dokumentacji, zarządzanie bibliotekami i
66 modułami i wiele innych.
67
68 SWIG jest w całości dziełem ludzi, którzy go używali i wprowadzali
69 nowe pomysły. Zbyt wielu ich jest, aby dziękować każdemu z nich
70 osobno, ale bez ich wsparcia SWIG nie byłby ani tak potężnym
71 narzędziem, ani tak fajnym w użyciu jak jest teraz. Wiekie dzięki!
72
73 %description -l pt_BR.UTF-8
74 O SWIG gera interfaces para perl, python e Tcl a partir de uma arquivo
75 com uma interface de descrição que consiste de uma combinação de C/C++
76 e diretivas especiais. Permite que linguagens tipo script usem C/C++
77 com um mínimo de esforço.
78
79 %package guile
80 Summary:        SWIG library: guile
81 Summary(pl.UTF-8):      Biblioteka SWIG: guile
82 Group:          Libraries
83 Requires:       %{name} = %{version}-%{release}
84
85 %description guile
86 SWIG library: guile.
87
88 %description guile -l pl.UTF-8
89 Biblioteka SWIG: guile.
90
91 %package perl
92 Summary:        SWIG library: Perl
93 Summary(pl.UTF-8):      Biblioteka SWIG: Perl
94 Group:          Libraries
95 Requires:       %{name} = %{version}-%{release}
96
97 %description perl
98 SWIG library: perl.
99
100 %description perl -l pl.UTF-8
101 Biblioteka SWIG: perl.
102
103 %package php
104 Summary:        SWIG library: php
105 Summary(pl.UTF-8):      Biblioteka SWIG: php
106 Group:          Libraries
107 Requires:       %{name} = %{version}-%{release}
108
109 %description php
110 SWIG library: php.
111
112 %description php -l pl.UTF-8
113 Biblioteka SWIG: php.
114
115 %package python
116 Summary:        SWIG library: python
117 Summary(pl.UTF-8):      Biblioteka SWIG: python
118 Group:          Libraries
119 Requires:       %{name} = %{version}-%{release}
120
121 %description python
122 SWIG library: python.
123
124 %description python -l pl.UTF-8
125 Biblioteka SWIG: python.
126
127 %package ruby
128 Summary:        SWIG library: ruby
129 Summary(pl.UTF-8):      Biblioteka SWIG: ruby
130 Group:          Libraries
131 Requires:       %{name} = %{version}-%{release}
132 %{?ruby_mod_ver_requires_eq}
133
134 %description ruby
135 SWIG library: ruby.
136
137 %description ruby -l pl.UTF-8
138 Biblioteka SWIG: ruby.
139
140 %package tcl
141 Summary:        SWIG library: tcl
142 Summary(pl.UTF-8):      Biblioteka SWIG: tcl
143 Group:          Libraries
144 Requires:       %{name} = %{version}-%{release}
145
146 %description tcl
147 SWIG library: tcl.
148
149 %description tcl -l pl.UTF-8
150 Biblioteka SWIG: tcl.
151
152 %prep
153 %setup -q
154 %patch0 -p1
155 %patch1 -p1
156 %patch2 -p1
157 %patch3 -p1
158
159 %build
160 %{__libtoolize}
161 %{__aclocal} -I Tools/config
162 %{__autoconf}
163 %{__automake}
164 %configure
165
166 %{__make} \
167         OPT="%{rpmcflags}"
168
169 %install
170 rm -rf $RPM_BUILD_ROOT
171 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
172
173 %{__make} install \
174         DESTDIR=$RPM_BUILD_ROOT \
175         M4_INSTALL_DIR=$RPM_BUILD_ROOT%{_aclocaldir}
176
177 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %files
183 %defattr(644,root,root,755)
184 %doc Doc CHANGES CHANGES.current NEW README ANNOUNCE TODO LICENSE
185 %attr(755,root,root) %{_bindir}/swig
186 %{_datadir}/%{name}
187 %{?with_guile:%exclude %{_datadir}/%{name}/%{version}/guile}
188 %{?with_perl:%exclude %{_datadir}/%{name}/%{version}/perl5}
189 %{?with_php:%exclude %{_datadir}/%{name}/%{version}/php4}
190 %exclude %{_datadir}/%{name}/%{version}/python
191 %{?with_ruby:%exclude %{_datadir}/%{name}/%{version}/ruby}
192 %{?with_tcl:%exclude %{_datadir}/%{name}/%{version}/tcl}
193 %{_examplesdir}/%{name}-%{version}
194
195 %if %{with guile}
196 %files guile
197 %defattr(644,root,root,755)
198 %{_datadir}/%{name}/%{version}/guile
199 %endif
200
201 %if %{with perl}
202 %files perl
203 %defattr(644,root,root,755)
204 %{_datadir}/%{name}/%{version}/perl5
205 %endif
206
207 %if %{with php}
208 %files php
209 %defattr(644,root,root,755)
210 %{_datadir}/%{name}/%{version}/php4
211 %endif
212
213 %files python
214 %defattr(644,root,root,755)
215 %{_datadir}/%{name}/%{version}/python
216
217 %if %{with ruby}
218 %files ruby
219 %defattr(644,root,root,755)
220 %{_datadir}/%{name}/%{version}/ruby
221 %endif
222
223 %if %{with tcl}
224 %files tcl
225 %defattr(644,root,root,755)
226 %{_datadir}/%{name}/%{version}/tcl
227 %endif
This page took 0.039931 seconds and 4 git commands to generate.