]> git.pld-linux.org Git - packages/swig.git/blob - swig.spec
d00aef47f45e7154e61338c291d4b9e5c6d606a8
[packages/swig.git] / swig.spec
1
2 Summary:        Interface generator for Perl, Tcl, Guile and Python
3 Summary(pl):    Generator interfejsów do Perla, Tcl-a, Guile'a i Pythona
4 Summary(pt_BR): Gerador de Interfaces e "Wrappers" Simplificado (SWIG)
5 Name:           swig
6 Version:        1.3.19
7 Release:        6
8 License:        distributable
9 Group:          Development/Languages
10 Source0:        http://dl.sourceforge.net/swig/%{name}-%{version}.tar.gz
11 # Source0-md5:  a733455544426b31868dd87fc162e750
12 Patch0:         %{name}-format.patch
13 Patch1:         %{name}-php.patch
14 Patch2:         %{name}-php-tsrm.patch
15 Patch3:         %{name}-php-freearg.patch
16 Patch4:         %{name}-php-vdecl.patch
17 URL:            http://www.swig.org/
18 Icon:           swig.gif
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  guile-devel
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtool
24 BuildRequires:  perl-devel >= 5.6.1
25 BuildRequires:  php-devel >= 4.1.0
26 BuildRequires:  php-cgi
27 BuildRequires:  python-devel >= 2.2
28 BuildRequires:  ruby >= 1.6.3
29 BuildRequires:  tcl-devel >= 8.3.3
30 BuildRequires:  ocaml
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 SWIG is a compiler that attempts to make it easy to integrate C, C++,
35 or Objective-C code with scripting languages including Perl, Tcl, and
36 Python. In a nutshell, you give it a bunch of ANSI C/C++ declarations
37 and it generates an interface between C and your favorite scripting
38 language. However, this is only scratching the surface of what SWIG
39 can do--some of its more advanced features include automatic
40 documentation generation, module and library management, extensive
41 customization options, and more.
42
43 SWIG is entirely the product of users who have used the system and
44 suggested new idea. There are far too many people to thank
45 individually, but without this support, SWIG would be not be nearly as
46 powerful or fun to use as it is now. Many thanks!
47
48 %description -l pl
49 SWIG jesk kompilatorem, który próbuje u³atwiæ integrowanie kodu
50 napisanego w C, C++ lub Objective-C z jêzykami skryptowymi, takimi jak
51 Perl, Tcl i Python. Mówi±c najpro¶ciej, je¶li dostarczysz mu zestaw
52 zadeklarowanych w ANSI C/C++ funkcji, SWIG wygeneruje Ci interfejs
53 pomiêdzy C a Twoim ulubionym jêzykiem skryptowym. To tylko drobna
54 czê¶æ tego co SWIG potrafi robiæ, bardziej zaawansowane zastosowania
55 to automatyczne generowanie dokumentacji, zarz±dzanie bibliotekami i
56 modu³ami i wiele innych.
57
58 SWIG jest w ca³o¶ci dzie³em ludzi, którzy go u¿ywali i wprowadzali
59 nowe pomys³y. Zbyt wielu ich jest, aby dziêkowaæ ka¿demu z nich
60 osobno, ale bez ich wsparcia SWIG nie by³by ani tak potê¿nym
61 narzêdziem, ani tak fajnym w u¿yciu jak jest teraz. Wiekie dziêki!
62
63 %description -l pt_BR
64 O SWIG gera interfaces para perl, python e tcl a partir de uma arquivo
65 com uma interface de descrição que consiste de uma combinação de C/C++
66 e diretivas especiais. Permite que linguagens tipo script usem C/C++
67 com um mínimo de esforço.
68
69 %package guile
70 Summary:        SWIG library: guile
71 Summary(pl):    Biblioteka SWIG: guile
72 Group:          Libraries
73
74 %description guile
75 SWIG library: guile.
76
77 %description guile -l pl
78 Biblioteka SWIG: guile.
79
80 %package perl
81 Summary:        SWIG library: Perl
82 Summary(pl):    Biblioteka SWIG: Perl
83 Group:          Libraries
84
85 %description perl
86 SWIG library: perl.
87
88 %description perl -l pl
89 Biblioteka SWIG: perl.
90
91 %package php
92 Summary:        SWIG library: php
93 Summary(pl):    Biblioteka SWIG: php
94 Group:          Libraries
95
96 %description php
97 SWIG library: php.
98
99 %description php -l pl
100 Biblioteka SWIG: php.
101
102 %package python
103 Summary:        SWIG library: python
104 Summary(pl):    Biblioteka SWIG: python
105 Group:          Libraries
106
107 %description python
108 SWIG library: python.
109
110 %description python -l pl
111 Biblioteka SWIG: python.
112
113 %package ruby
114 Summary:        SWIG library: ruby
115 Summary(pl):    Biblioteka SWIG: ruby
116 Group:          Libraries
117
118 %description ruby
119 SWIG library: ruby.
120
121 %description ruby -l pl
122 Biblioteka SWIG: ruby.
123
124 %package tcl
125 Summary:        SWIG library: tcl
126 Summary(pl):    Biblioteka SWIG: tcl
127 Group:          Libraries
128
129 %description tcl
130 SWIG library: tcl.
131
132 %description tcl -l pl
133 Biblioteka SWIG: tcl.
134
135 %package ocaml
136 Summary:        SWIG library: ocaml
137 Summary(pl):    Biblioteka SWIG: ocaml
138 Group:          Libraries
139
140 %description ocaml
141 SWIG library: ocaml.
142
143 %description ocaml -l pl
144 Biblioteka SWIG: ocaml.
145
146 %prep
147 %setup -q -n SWIG-%{version}
148 %patch0 -p1
149 %patch1 -p1
150 %patch2 -p1
151 %patch3 -p1
152 %patch4 -p1
153
154 %build
155 oldpwd=$PWD
156 for i in . Tools; do
157   cd $i
158   %{__libtoolize}
159   %{__aclocal}
160   %{__autoconf}
161   cd $oldpwd
162 done
163 %configure
164
165 %{__make} OPT="%{rpmcflags}"
166
167 %install
168 rm -rf $RPM_BUILD_ROOT
169 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
170
171 %{__make} install \
172         DESTDIR=$RPM_BUILD_ROOT
173
174 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %post   -p /sbin/ldconfig
180 %postun -p /sbin/ldconfig
181
182 %files
183 %defattr(644,root,root,755)
184 %doc Doc CHANGES NEW README ANNOUNCE TODO LICENSE
185 %{_libdir}/%{name}*
186 %attr(755,root,root) %{_bindir}/swig
187 %{_examplesdir}/%{name}-%{version}
188
189 %files guile
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libdir}/lib*guile.so
192 %{_libdir}/lib*guile.la
193
194 %files perl
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_libdir}/lib*pl.so
197 %{_libdir}/lib*pl.la
198
199 %files php
200 %defattr(644,root,root,755)
201 %attr(755,root,root) %{_libdir}/lib*php4.so
202 %{_libdir}/lib*php4.la
203
204 %files python
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_libdir}/lib*py.so
207 %{_libdir}/lib*py.la
208
209 %files ruby
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{_libdir}/lib*rb.so
212 %{_libdir}/lib*rb.la
213
214 %files tcl
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_libdir}/lib*tcl*.so
217 %{_libdir}/lib*tcl*.la
218
219 %files ocaml
220 %defattr(644,root,root,755)
221 %attr(755,root,root) %{_libdir}/lib*ocaml*.so*
222 %{_libdir}/lib*ocaml*.la
This page took 0.039387 seconds and 3 git commands to generate.