]> git.pld-linux.org Git - packages/suil.git/blob - suil.spec
ca264dc5583a54728fdf2106d53adcce78479f2e
[packages/suil.git] / suil.spec
1 #
2 # Conditional build:
3 %bcond_with    qt4                     # Qt4 support
4
5 Summary:        Lightweight C library for loading and wrapping LV2 plugin UIs
6 Summary(pl.UTF-8):      Lekka biblioteka C do ładowania i obudowywania UI wtyczek LV2
7 Name:           suil
8 Version:        0.8.4
9 Release:        1
10 License:        ISC
11 Group:          Libraries
12 Source0:        http://download.drobilla.net/%{name}-%{version}.tar.bz2
13 # Source0-md5:  50598cc44f419f60805862272abe881c
14 URL:            http://drobilla.net/software/suil/
15 %{?with_qt4:BuildRequires:      QtGui-devel >= 4.4.0}
16 BuildRequires:  Qt5Widgets-devel >= 5.1.0
17 BuildRequires:  gtk+2-devel >= 2:2.18.0
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  lv2-devel >= 1.12.0
20 BuildRequires:  python
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Suil is a lightweight C library for loading and wrapping LV2 plugin
25 UIs.
26
27 Suil makes it possible to load a UI of any toolkit in a host using any
28 other toolkit (assuming the toolkits are both supported by Suil).
29 Hosts do not need to build against or link to foreign toolkit
30 libraries to use UIs written with that toolkit (Suil performs its
31 magic at runtime using dynamically loaded modules). The API is
32 designed such that hosts do not need to explicitly support particular
33 toolkits whatsoever - if Suil supports a particular toolkit, then all
34 hosts that use Suil will support that toolkit "for free".
35
36 %description -l pl.UTF-8
37 Suil to lekka biblioteka C do ładowania i obudowywania interfejsów
38 użytkownika (UI) wtyczek LV2.
39
40 Suil umożliwia wczytanie UI dowolnego toolkitu do hosta
41 wykorzystującego dowolny inny toolkit (zakładając, że oba toolkity są
42 obsługiwane prez Suil). Hosty nie muszą być budowane z obsługą obcych
43 bibliotek toolkitów, aby można było używać UI napisanego z użyciem
44 danego toolkitu (Suil wykonuje całą potrzebną magię w czasie działania
45 przy użyciu modułów ładowanych dynamicznie). API jest zaprojektowane
46 tak, że hosty nie muszą jawnie obsługiwać konkretnego toolkitu - jeśli
47 Suil obsługuje ten toolkit, to wszystkie hosty wykorzystujące Suil
48 będą obsługiwały ten toolkit za darmo.
49
50 %package modules
51 Summary:        UI wrapper modules for suil library
52 Summary(pl.UTF-8):      Moduły obudowujące UI dla biblioteki suil
53 Group:          Libraries
54 Requires:       %{name} = %{version}-%{release}
55 %{?with_qt4:Requires:   QtGui >= 4.0.0}
56 Requires:       gtk+2 >= 2:2.18.0
57
58 %description modules
59 Dynamically loaded modules for suil library, allowing to use X11
60 UIs in GTK+ or Qt host, GTK+ UI in Qt host, Qt UI in GTK+ host.
61
62 %description modules -l pl.UTF-8
63 Dynamicznie wczytywane moduły dla biblioteki suil, pozwalające na
64 używanie interfejsów użytkownika X11 w hostach GTK+ lub Qt,
65 interfejsów GTK+ w hostach Qt oraz  interfejsów Qt w hostach GTK+.
66
67 %package devel
68 Summary:        Header files for suil library
69 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki suil
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       lv2-devel >= 1.12.0
73
74 %description devel
75 Header files for suil library.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe biblioteki suil.
79
80 %prep
81 %setup -q
82
83 %build
84 CC="%{__cc}" \
85 CFLAGS="%{rpmcflags}" \
86 ./waf configure \
87         --prefix=%{_prefix} \
88         --libdir=%{_libdir} \
89         --gtk2-lib-name=libgtk-x11-2.0.so.0
90
91 ./waf -v
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 ./waf install \
97         --destdir=$RPM_BUILD_ROOT
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %doc AUTHORS COPYING NEWS README
108 %attr(755,root,root) %{_libdir}/libsuil-0.so.*.*.*
109 %attr(755,root,root) %ghost %{_libdir}/libsuil-0.so.0
110 %dir %{_libdir}/suil-0
111
112 %files modules
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_libdir}/suil-0/libsuil_x11_in_gtk2.so
115 %attr(755,root,root) %{_libdir}/suil-0/libsuil_x11_in_qt5.so
116 %attr(755,root,root) %{_libdir}/suil-0/libsuil_gtk2_in_qt5.so
117 %if %{with qt4}
118 %attr(755,root,root) %{_libdir}/suil-0/libsuil_gtk2_in_qt4.so
119 %attr(755,root,root) %{_libdir}/suil-0/libsuil_x11_in_qt4.so
120 %attr(755,root,root) %{_libdir}/suil-0/libsuil_qt4_in_gtk2.so
121 %endif
122
123 %files devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/libsuil-0.so
126 %{_includedir}/suil-0
127 %{_pkgconfigdir}/suil-0.pc
This page took 0.046607 seconds and 2 git commands to generate.