]> git.pld-linux.org Git - packages/sudo.git/blob - sudo.spec
- changed all BuildRoot definitons
[packages/sudo.git] / sudo.spec
1 Summary:        Allows command execution as root for specified users
2 Summary(pl):    Umo¿liwia wykonywaniew poleceñ jako root dla konkretnych u¿ytkowników
3 Name:           sudo
4 Version:        1.6.3
5 Release:        1
6 License:        GPL
7 Group:          Utilities/System
8 Group(pl):      Narzêdzia/Systemowe
9 Source0:        ftp://ftp.cs.colorado.edu/pub/sudo/%{name}-%{version}.tar.gz
10 Source1:        sudo.pamd
11 Patch:          sudo-DESTDIR.patch
12 URL:            http://www.courtesan.com/sudo/
13 BuildRequires:  pam-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15 Obsoletes:      cu-sudo
16
17 %define         _sysconfdir     /etc
18
19 %description
20 Sudo (superuser do) allows a permitted user to execute a command as the
21 superuser (real and effective uid and gid are set to 0 and root's group as
22 set in the passwd file respectively).
23
24 Sudo determines who is an authorized user by consulting the file
25 /etc/sudoers. By giving sudo the -v flag a user can update the time stamp
26 without running a command. The password prompt itself will also time out
27 if the password is not entered with N minutes (again, this is defined at
28 installation time and defaults to 5 minutes).
29
30 %description -l pl
31 Sudo (superuser do) umo¿liwia wykonywanie konkretnych poleceñ jako root dla
32 wyspecyfikowanych u¿ytkowników (rzeczywiste i efektywne uid/gid podczas
33 wykonywania tych programów jest 0). To kto mo¿e wykonywaæ konkretne
34 polecenia i w jaki sposób ma byæ autoryzowany jest opisane w pliku
35 /etc/sudoers.
36
37 %prep
38 %setup -q
39 %patch -p1
40
41 %build
42 autoconf
43 LDFLAGS="-s"; export LDFLAGS
44 %configure \
45         --with-timedir=/var/run/sudo \
46         --with-C2 \
47         --with-pam \
48         --with-logging=both \
49         --with-logfac=auth \
50         --with-logpath=/var/log/sudo.log \
51         --with-message=full \
52         --with-ignore-dot \
53         --with-env-editor \
54         --with-insults \
55         --with-all-insults \
56         --with-classic-insults \
57         --with-csops-insults \
58         --with-hal-insults \
59         --with-goons-insults \
60         --with-secure-path="/bin:/sbin:%{_bindir}:%{_sbindir}" \
61         --with-loglen=320 \
62
63 make CFLAGS="$RPM_OPT_FLAGS"
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/pam.d,/var/{log,run/sudo}}
68
69 make install \
70         DESTDIR=$RPM_BUILD_ROOT \
71         install_uid=`id -u` \
72         install_gid=`id -g` \
73         sudoers_uid=`id -u` \
74         sudoers_gid=`id -g`
75
76 install %{SOURCE1}  $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/sudo
77 touch $RPM_BUILD_ROOT/var/log/sudo.log
78
79 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man{5,8}/* \
80         BUGS CHANGES HISTORY README TODO TROUBLESHOOTING
81
82 chmod -R +r $RPM_BUILD_ROOT%{_prefix}
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc *.gz sample.sudoers
90 %attr(0400,root,root) %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/sudoers
91 %attr(0600,root,root) %config %verify(not size mtime md5) %{_sysconfdir}/pam.d/sudo
92 %attr(4555,root,root) %{_bindir}/sudo
93 %attr(0555,root,root) %{_sbindir}/visudo
94 %{_mandir}/man*/*
95 %attr(0600,root,root) %ghost /var/log/sudo.log
96 %attr(0700,root,root) %dir /var/run/sudo
This page took 0.057542 seconds and 4 git commands to generate.