]> git.pld-linux.org Git - packages/sudo.git/blob - sudo.spec
40a340cbba7d7f719a1c3bf215806aa269876476
[packages/sudo.git] / sudo.spec
1 Summary:     Allows command execution as root for specified users
2 Summary(pl): Umo¿liwia wykonywaniew poleceñ jako root dla konkretnych u¿ytkowników
3 Name:        sudo
4 Version:     1.5.7p2
5 Release:     1
6 Copyright:   GPL
7 Group:       Utilities/System
8 Group(pl):   Narzêdzia/Systemowe
9 Source:      ftp://ftp.cs.colorado.edu/pub/sudo/cu-sudo.v%{version}.tar.Z
10 URL:         http://www.courtesan.com/courtesan/products/sudo/
11 BuildRoot:   /tmp/%{name}-%{version}-root
12
13 %description
14 Sudo (superuser do) allows a permitted user to execute a command as the
15 superuser (real and effective uid and gid are set to 0 and root's group as
16 set in the passwd file respectively).
17                                                                                                               
18 Sudo determines who is an authorized user by consulting the file
19 /etc/sudoers.  By giving sudo the -v flag a user can update the time stamp
20 without running a command.  The password prompt itself will also time out if
21 the password is not entered with N minutes (again, this is defined at
22 installation time and defaults to 5 minutes).
23
24 %description -l pl
25 Sudo (superuser do) umo¿liwia wykonywanie konkretnych poleceñ jako root dla
26 wyspecyfikowanych u¿ytkowników (rzeczywiste i efektywne uid/gid podczas
27 wykonywania tych programów jest 0).
28
29 To kto mo¿e wykonywaæ konkretne polecenia i w jaki sposób ma byæ
30 autoryzowany jest opisane w pliku /etc/sudoers.
31
32 %prep
33 %setup -q -n %{name}.v%{version}
34
35 %build
36 CFLAGS="$RPM_OPT_FLAGS" ./configure \
37         --prefix=/usr \
38         --sbindir=/usr/sbin \
39         --with-timedir=/var/run \
40         --with-C2 \
41         --with-pam \
42         --with-logging=both \
43         --with-logfac=LOG_AUTH \
44         --with-logpath=/var/log/sudo.log \
45         --with-message=full \
46         --with-ignore-dot \
47         --with-env-editor \
48         --with-insults \
49         --with-all-insults \
50         --with-classic-insults \
51         --with-csops-insults \
52         --with-hal-insults \
53         --with-goons-insults \
54         --with-secure-path="/bin:/sbin:/usr/bin:/usr/sbin" \
55         --with-loglen=320 \
56
57 make CFLAGS="$RPM_OPT_FLAGS"
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT/{etc/pam.d,var/log}
62
63 make install \
64         prefix=$RPM_BUILD_ROOT/usr \
65         visudodir=$RPM_BUILD_ROOT/usr/sbin \
66         sysconfdir=$RPM_BUILD_ROOT/etc \
67         install_uid=`id -u` \
68         install_gid=`id -g` \
69         sudoers_uid=`id -u` \
70         sudoers_gid=`id -g`
71
72 install sample.pam $RPM_BUILD_ROOT/etc/pam.d/sudo
73 touch $RPM_BUILD_ROOT/var/log/sudo.log
74
75 gzip -9nf $RPM_BUILD_ROOT/usr/man/man{5,8}/*
76
77 chmod -R +r $RPM_BUILD_ROOT/usr
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644, root, root, 755)
84 %doc BUGS CHANGES HISTORY README TODO TROUBLESHOOTING sample.sudoers
85 %attr(0400, root, root) %verify(not md5 size mtime) %config(noreplace) /etc/sudoers
86 %attr(0600, root, root) %config /etc/pam.d/sudo
87 %attr(4111, root, root) /usr/bin/sudo
88 %attr(0111, root, root) /usr/sbin/visudo
89 %attr(0644, root,  man) /usr/man/man[58]/*
90 %attr(0600, root, root) %ghost /var/log/sudo.log
91
92 %changelog
93 * Sun Nov 29 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
94   [1.5.7p2-1]
95 - added gziping man pages,
96 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
97 - added "not size mtime" to %verify rule for /etc/sudoers,
98 - changed way passing $RPM_OPT_FLAGS,
99 - rewrited %description,
100 - rewrited %build and %install using new autoconf sheme,
101 - added pl translation.
102
103 * Tue Sep 21 1998 Ian Macdonald <ianmacd@xs4all.nl>
104 - upgraded to 1.5.6p2
105 - built with PAM support
106 - removed SUDO_LDFLAGS="-static" from make: would no longer build with it
107
108 * Wed May  6 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
109 - %%{version} macro instead %%{PACKAGE_VERSION},
110 - added -q %setup parameter,
111 - added using %%{name} macro in Buildroot.
112
113 * Mon Apr 27 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
114   [1.5.4-3]
115 - Buildroot changed to /tmp/sudo-%%{PACKAGE_VERSION}-root,
116 - added %%{PACKAGE_VERSION} to Source url and %setup macro,
117 - removed sudo-1.5.4-buildroot.patch and instead this added few parameters
118   to "make install",
119 - SUDO_LDFLAGS="-static" and CFLAGS="$RPM_OPT_FLAGS" is passed as make 
120   arguments,
121 - removed COPYING from %doc (Copyright statement is in Copyright field),
122 - removed from %doc *.pod and options.h and added sample.sudoers,
123 - added /var/log/sudo.log as %ghost file,
124 - added %verify(not md5) for /etc/sudoers (allow modify this file without
125   display warning on verify with using rpm),
126 - added noreplace parameter for /etc/sudoers %config file,
127 - removed sudo.v1.5.4-glibc.diff because sudo compiles on glibc 2.0.7,
128 - added %defattr and %attr macros in %files (allows building package from
129   non-root account); %defattr requires rpm >= 2.4.99.
130
131 * Fri Jan 23 1998 Ian Macdonald <ianmacd@xs4all.nl>
132   [1.5.4-2]
133 - glibc build was broken; added patch to fix it
134
135 * Tue Nov 18 1997 Otto Hammersmith <otto@redhat.com>
136 - built for glibc, no problems
137
138 * Fri Apr 25 1997 Michael Fulbright <msf@redhat.com>
139 - Fixed for 4.2 PowerTools 
140 - Still need to be pamified
141 - Still need to move stmp file to /var/log
142
143 * Mon Feb 17 1997 Michael Fulbright <msf@redhat.com>
144 - First version for PowerCD.
This page took 0.063278 seconds and 3 git commands to generate.