]> git.pld-linux.org Git - packages/sudo.git/blob - sudo.spec
3c7a00b8d3ec134e758f8eeb5a75f9db91479050
[packages/sudo.git] / sudo.spec
1 Summary:        Allows command execution as root for specified users
2 Summary(es):    Permite que usuarios específicos ejecuten comandos como se fueran el root
3 Summary(pl):    Umo¿liwia wykonywaniew poleceñ jako root dla konkretnych u¿ytkowników
4 Summary(pt_BR): Permite que usuários específicos executem comandos como se fossem o root
5 Name:           sudo
6 Version:        1.6.5p1
7 Release:        2
8 License:        BSD
9 Group:          Applications/System
10 Source0:        ftp://ftp.courtesan.com/pub/sudo/%{name}-%{version}.tar.gz
11 Source1:        %{name}.pamd
12 Source2:        %{name}.logrotate
13 URL:            http://www.courtesan.com/sudo/
14 BuildRequires:  autoconf
15 BuildRequires:  pam-devel
16 BuildRequires:  /bin/vi
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18 Obsoletes:      cu-sudo
19
20 %define         _sysconfdir     /etc
21
22 %description
23 Sudo (superuser do) allows a permitted user to execute a command as
24 the superuser (real and effective uid and gid are set to 0 and root's
25 group as set in the passwd file respectively).
26
27 Sudo determines who is an authorized user by consulting the file
28 /etc/sudoers. By giving sudo the -v flag a user can update the time
29 stamp without running a command. The password prompt itself will also
30 time out if the password is not entered with N minutes (again, this is
31 defined at installation time and defaults to 5 minutes).
32
33 %description -l es
34 Sudo (superuser do) permite que el administrador del sistema otorga a
35 ciertos usuarios (o grupos de usuarios) la habilidad para ejecutar
36 algunos (o todos) comandos como root, registrando todos los comandos y
37 argumentos. Sudo opera en una base por comando, no siendo un
38 substituto para la shell.
39
40 %description -l pl
41 Sudo (superuser do) umo¿liwia wykonywanie konkretnych poleceñ jako
42 root dla wyspecyfikowanych u¿ytkowników (rzeczywiste i efektywne
43 uid/gid podczas wykonywania tych programów jest 0). To kto mo¿e
44 wykonywaæ konkretne polecenia i w jaki sposób ma byæ autoryzowany jest
45 opisane w pliku /etc/sudoers.
46
47 %description -l pt_BR
48 Sudo (superuser do) permite que o administrador do sistema dê a certos
49 usuários (ou grupos de usuários) a habilidade para rodar alguns (ou
50 todos) comandos como root, registrando todos os comandos e argumentos.
51 Sudo opera numa base por comando, não sendo um substituto para a
52 shell.
53
54 %prep
55 %setup -q
56
57 %build
58 %configure2_13 \
59         --with-timedir=/var/run/sudo \
60         --with-C2 \
61         --with-pam \
62         --with-logging=both \
63         --with-logfac=auth \
64         --with-logpath=/var/log/sudo \
65         --with-message=full \
66         --with-ignore-dot \
67         --with-env-editor \
68         --with-insults \
69         --with-all-insults \
70         --with-classic-insults \
71         --with-csops-insults \
72         --with-hal-insults \
73         --with-goons-insults \
74         --with-secure-path="/bin:/sbin:%{_bindir}:%{_sbindir}" \
75         --with-loglen=320 \
76         --disable-saved-ids 
77
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/{pam.d,logrotate.d},/var/{log,run/sudo}}
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT \
86         install_uid=`id -u` \
87         install_gid=`id -g` \
88         sudoers_uid=`id -u` \
89         sudoers_gid=`id -g`
90
91 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/sudo
92 touch $RPM_BUILD_ROOT/var/log/sudo
93 install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/sudo
94
95 gzip -9nf BUGS CHANGES HISTORY README TODO TROUBLESHOOTING
96
97 chmod -R +r $RPM_BUILD_ROOT%{_prefix}
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %files
103 %defattr(644,root,root,755)
104 %doc *.gz sample.sudoers
105 %attr(0440,root,root) %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/sudoers
106 %attr(0600,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/pam.d/sudo
107 %attr(4555,root,root) %{_bindir}/sudo
108 %attr(0555,root,root) %{_sbindir}/visudo
109 %{_mandir}/man*/*
110 %attr(0600,root,root) %ghost /var/log/sudo
111 %attr(0640,root,root) /etc/logrotate.d/*
112 %attr(0700,root,root) %dir /var/run/sudo
This page took 0.027165 seconds and 3 git commands to generate.