]> git.pld-linux.org Git - packages/sudo.git/blob - sudo.spec
29df20e9be9a7937f45117d2bf1ed6f1a132de32
[packages/sudo.git] / sudo.spec
1 Summary:        Allows command execution as root for specified users
2 Summary(es):    Permite que usuarios específicos ejecuten comandos como se fueran el root
3 Summary(pl):    Umo¿liwia wykonywaniew poleceñ jako root dla konkretnych u¿ytkowników
4 Summary(pt_BR): Permite que usuários específicos executem comandos como se fossem o root
5 Name:           sudo
6 Version:        1.6.3p7
7 Release:        5
8 License:        BSD
9 Group:          Applications/System
10 Group(de):      Applikationen/System
11 Group(pl):      Aplikacje/System
12 Source0:        ftp://ftp.courtesan.com/pub/sudo/%{name}-%{version}.tar.gz
13 Source1:        %{name}.pamd
14 Source2:        %{name}.logrotate
15 Patch0:         %{name}-DESTDIR.patch
16 URL:            http://www.courtesan.com/sudo/
17 BuildRequires:  autoconf
18 BuildRequires:  pam-devel
19 BuildRequires:  /bin/vi
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21 Obsoletes:      cu-sudo
22
23 %define         _sysconfdir     /etc
24
25 %description
26 Sudo (superuser do) allows a permitted user to execute a command as
27 the superuser (real and effective uid and gid are set to 0 and root's
28 group as set in the passwd file respectively).
29
30 Sudo determines who is an authorized user by consulting the file
31 /etc/sudoers. By giving sudo the -v flag a user can update the time
32 stamp without running a command. The password prompt itself will also
33 time out if the password is not entered with N minutes (again, this is
34 defined at installation time and defaults to 5 minutes).
35
36 %description -l es
37 Sudo (superuser do) permite que el administrador del sistema otorga a
38 ciertos usuarios (o grupos de usuarios) la habilidad para ejecutar
39 algunos (o todos) comandos como root, registrando todos los comandos y
40 argumentos. Sudo opera en una base por comando, no siendo un
41 substituto para la shell.
42
43 %description -l pl
44 Sudo (superuser do) umo¿liwia wykonywanie konkretnych poleceñ jako
45 root dla wyspecyfikowanych u¿ytkowników (rzeczywiste i efektywne
46 uid/gid podczas wykonywania tych programów jest 0). To kto mo¿e
47 wykonywaæ konkretne polecenia i w jaki sposób ma byæ autoryzowany jest
48 opisane w pliku /etc/sudoers.
49
50 %description -l pt_BR
51 Sudo (superuser do) permite que o administrador do sistema dê a certos
52 usuários (ou grupos de usuários) a habilidade para rodar alguns (ou
53 todos) comandos como root, registrando todos os comandos e argumentos.
54 Sudo opera numa base por comando, não sendo um substituto para a
55 shell.
56
57 %prep
58 %setup -q
59 %patch -p1
60
61 %build
62 %configure2_13 \
63         --with-timedir=/var/run/sudo \
64         --with-C2 \
65         --with-pam \
66         --with-logging=both \
67         --with-logfac=auth \
68         --with-logpath=/var/log/sudo \
69         --with-message=full \
70         --with-ignore-dot \
71         --with-env-editor \
72         --with-insults \
73         --with-all-insults \
74         --with-classic-insults \
75         --with-csops-insults \
76         --with-hal-insults \
77         --with-goons-insults \
78         --with-secure-path="/bin:/sbin:%{_bindir}:%{_sbindir}" \
79         --with-loglen=320 \
80
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/{pam.d,logrotate.d},/var/{log,run/sudo}}
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT \
89         install_uid=`id -u` \
90         install_gid=`id -g` \
91         sudoers_uid=`id -u` \
92         sudoers_gid=`id -g`
93
94 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/sudo
95 touch $RPM_BUILD_ROOT/var/log/sudo
96 install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/sudo
97
98 gzip -9nf BUGS CHANGES HISTORY README TODO TROUBLESHOOTING
99
100 chmod -R +r $RPM_BUILD_ROOT%{_prefix}
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %files
106 %defattr(644,root,root,755)
107 %doc *.gz sample.sudoers
108 %attr(0440,root,root) %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/sudoers
109 %attr(0600,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/pam.d/sudo
110 %attr(4555,root,root) %{_bindir}/sudo
111 %attr(0555,root,root) %{_sbindir}/visudo
112 %{_mandir}/man*/*
113 %attr(0600,root,root) %ghost /var/log/sudo
114 %attr(0640,root,root) /etc/logrotate.d/*
115 %attr(0700,root,root) %dir /var/run/sudo
This page took 0.072084 seconds and 3 git commands to generate.