]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- release 2
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - serf as default: https://subversion.apache.org/docs/release-notes/1.7.html#serf
3 #
4 # Conditional build:
5 %bcond_with     net_client_only         # build only net client
6 %bcond_without  neon                    # use serf instead of neon
7 %bcond_without  swig                    # disable bindings generation with Swig
8 %bcond_without  python                  # build without Python bindings (broken)
9 %bcond_without  csvn                    # build Python csvn bindings
10 %bcond_without  perl                    # build without Perl bindings
11 %bcond_with     ruby                    # build with Ruby bindings (only 1.8.x is supported)
12 %bcond_without  apache                  # build without Apache support (webdav, etc)
13 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
14 %bcond_without  tests                   # don't perform "make check"
15 %bcond_without  kwallet                 # build without kde4 wallet support
16 %bcond_without  kde                     # build without kde4 support (alias for kwallet)
17 %bcond_without  gnome                   # build without gnome keyring support
18 %bcond_without  db                      # disable Subversion Berkeley DB based filesystem library
19
20 %if %{with net_client_only}
21 %undefine       with_apache
22 %undefine       with_db
23 %undefine       with_swig
24 %undefine       with_javahl
25 %endif
26
27 %if %{without swig}
28 %undefine       with_perl
29 %undefine       with_python
30 %undefine       with_ruby
31 %endif
32
33 %if %{without kde}
34 %undefine       with_kwallet
35 %endif
36
37 %if %{without python} && %{without perl} && %{without ruby}
38 %undefine       with_swig
39 %endif
40
41 %define apxs    /usr/sbin/apxs
42 %define pdir    SVN
43 %define pnam    _Core
44
45 %if %{with neon}
46 %define webdavlib       neon
47 %else
48 %define webdavlib       serf
49 %endif
50 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
51 Summary:        A Concurrent Versioning system similar to but better than CVS
52 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
53 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
54 Name:           subversion
55 Version:        1.7.2
56 Release:        2
57 License:        Apache v2.0
58 Group:          Development/Version Control
59 Source0:        http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
60 # Source0-md5:  1e5dfffd27be080672e5a042564368a8
61 Source1:        %{name}-dav_svn.conf
62 Source2:        %{name}-authz_svn.conf
63 Source3:        %{name}-svnserve.init
64 Source4:        %{name}-svnserve.sysconfig
65 # current subversion tarball has correct *.swg files
66 # but after regeneration these are broken again, so
67 # we still need this script
68 Source5:        %{name}-convert-typemaps-to-ifdef.py
69 Patch0:         %{name}-home_etc.patch
70 Patch1:         %{name}-DESTDIR.patch
71 Patch2:         %{name}-ruby-datadir-path.patch
72 Patch3:         %{name}-tests.patch
73 URL:            http://subversion.apache.org/
74 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
75 BuildRequires:  apr-devel >= 1:1.0.0
76 BuildRequires:  apr-util-devel >= 1:1.2.8-3
77 BuildRequires:  autoconf >= 2.59
78 BuildRequires:  automake
79 BuildRequires:  bison
80 BuildRequires:  cyrus-sasl-devel
81 %if %{with kwallet} || %{with gnome}
82 BuildRequires:  dbus-devel
83 %endif
84 BuildRequires:  db-devel >= 4.1.25
85 BuildRequires:  expat-devel
86 BuildRequires:  gettext-devel
87 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
88 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
89 BuildRequires:  libmagic-devel
90 BuildRequires:  libtool >= 1.4-9
91 BuildRequires:  pkgconfig
92 %{?with_csvn:BuildRequires:     python-ctypesgen}
93 BuildRequires:  rpm-pythonprov
94 BuildRequires:  rpmbuild(macros) >= 1.583
95 BuildRequires:  sed >= 4.0
96 BuildRequires:  sqlite3-devel >= 3.6.18
97 BuildRequires:  texinfo
98 BuildRequires:  which
99 %if %{with neon}
100 BuildRequires:  neon-devel >= 0.26.0
101 %else
102 BuildRequires:  serf-devel >= 0.7.1
103 %endif
104 %if %{with javahl}
105 BuildRequires:  jdk >= 1.5
106 BuildRequires:  libstdc++-devel
107 %endif
108 %if %{with perl}
109 BuildRequires:  perl-devel >= 1:5.8.0
110 BuildRequires:  rpm-perlprov >= 4.1-13
111 BuildRequires:  swig-perl >= 1.3.24
112 %endif
113 %if %{with python}
114 BuildRequires:  python-devel >= 1:2.4
115 BuildRequires:  swig-python >= 1.3.24
116 %endif
117 %if %{with ruby}
118 BuildRequires:  ruby-devel < 1:1.9
119 BuildRequires:  ruby-devel >= 1:1.8.2
120 BuildRequires:  ruby-rubygems
121 BuildRequires:  swig-ruby >= 1.3.24
122 %endif
123 Requires:       %{name}-libs = %{version}-%{release}
124 %requires_ge    sqlite3
125 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
126
127 %define         _libexecdir             %{_libdir}/svn
128 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
129 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
130
131 %define         skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
132
133 %description
134 The goal of the Subversion project is to build a version control
135 system that is a compelling replacement for CVS in the open source
136 community.
137
138 Our goals are:
139 - All current CVS features.
140 - Directories, renames, and file meta-data are versioned.
141 - Symbolic links, etc, are supported
142 - Commits are truly atomic.
143 - Branching and tagging are cheap (constant time) operations
144 - Repeated merges are handled gracefully
145 - Support for plug-in client side diff programs
146 - Natively client/server
147 - Client/server protocol sends diffs in both directions
148 - Costs are proportional to change size, not project size
149 - Internationalization
150 - Progressive multi-lingual support
151
152 %description -l pl.UTF-8
153 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
154 zamiennika dla CVS.
155
156 Cele projektu to:
157 - Wszystkie aktualne możliwości CVS.
158 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
159 - Obsługa dowiązań symbolicznych itp.
160 - Commity są w pełni atomowe.
161 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
162 - Dobra obsługa powtarzanego łączenia (merge).
163 - Obsługa wtyczek diff po stronie klienta.
164 - Natywny klient/serwer.
165 - Klient/Serwer przesyłają diffy w obu kierunkach.
166 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
167 - Internacjonalizacja.
168 - Postępujące wsparcie dla wielu języków.
169
170 %description -l pt_BR.UTF-8
171 O objetivo do projeto Subversion é construir um sistema de controle de
172 versões que seja um substituto para o CVS (Concurrent Versioning
173 System) na comunidade opensource, fornecendo grandes melhorias.
174
175 %package libs
176 Summary:        Subversion libraries and modules
177 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
178 Group:          Libraries
179 %if %{with neon}
180 Requires:       neon >= 0.26.0
181 %else
182 Requires:       serf >= 0.7.1
183 %endif
184 Obsoletes:      libsubversion0
185
186 %description libs
187 Subversion libraries and modules.
188
189 %description libs -l pl.UTF-8
190 Biblioteka subversion oraz ładowalne moduły.
191
192 %package devel
193 Summary:        Header files and develpment documentation for subversion
194 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
195 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
196 Group:          Development/Libraries
197 Requires:       %{name}-libs = %{version}-%{release}
198 Requires:       apr-util-devel >= 1:1.0.0
199 %{?with_neon:Requires:  neon-devel >= 0.26.0}
200 Obsoletes:      libsubversion0-devel
201
202 %description devel
203 Header files and develpment documentation for subversion.
204
205 %description devel -l pl.UTF-8
206 Pliki nagłówkowe i dokumetacja do subversion.
207
208 %description devel -l pt_BR.UTF-8
209 Este pacote provê os arquivos necessários para desenvolvedores
210 interagirem com o Subversion.
211
212 %package static
213 Summary:        Static subversion library
214 Summary(pl.UTF-8):      Biblioteka statyczna subversion
215 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
216 Group:          Development/Libraries
217 Requires:       %{name}-devel = %{version}
218 Obsoletes:      libsubversion0-static-devel
219
220 %description static
221 Static subversion library.
222
223 %description static -l pl.UTF-8
224 Biblioteka statyczna subversion.
225
226 %description static -l pt_BR.UTF-8
227 Este pacote provê um cliente estático do subversion.
228
229 %package svnserve
230 Summary:        Subversion svnserve
231 Summary(pl.UTF-8):      Subversion svnserve
232 Group:          Networking/Daemons
233 Requires(post,preun):   /sbin/chkconfig
234 Requires(postun):       /usr/sbin/groupdel
235 Requires(postun):       /usr/sbin/userdel
236 Requires(pre):  /bin/id
237 Requires(pre):  /usr/bin/getgid
238 Requires(pre):  /usr/lib/rpm/user_group.sh
239 Requires(pre):  /usr/sbin/groupadd
240 Requires(pre):  /usr/sbin/useradd
241 Requires(pre):  /usr/sbin/usermod
242 Requires:       %{name} = %{version}-%{release}
243 Requires:       rc-scripts
244 Provides:       group(svn)
245 Provides:       user(svn)
246
247 %description svnserve
248 Subversion svnserve server.
249
250 %description svnserve -l pl.UTF-8
251 Serwer subversion svnserve.
252
253 %package tools
254 Summary:        Subversion tools and scripts
255 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
256 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
257 Group:          Applications
258 %pyrequires_eq  python
259 Requires:       %{name} = %{version}-%{release}
260 Requires:       python-subversion = %{version}
261
262 %description tools
263 Subversion tools and scripts.
264
265 %description tools -l pl.UTF-8
266 Narzędzia oraz skrypty dla subversion.
267
268 %package -n bash-completion-subversion
269 Summary:        bash completion for subversion
270 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
271 Group:          Applications/Shells
272 Requires:       %{name} = %{version}-%{release}
273 Requires:       bash-completion
274 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
275
276 %description -n bash-completion-subversion
277 Bash completion for subversion.
278
279 %description -n bash-completion-subversion -l pl.UTF-8
280 Dopełnienia basha dla subversion.
281
282 %package -n java-subversion
283 Summary:        Subversion Java bindings
284 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
285 Group:          Development/Languages/Java
286 Requires:       %{name}-libs = %{version}-%{release}
287
288 %description -n java-subversion
289 This is a set of Java classes which provide the functionality of
290 subversion-libs, the Subversion libraries. It is useful if you want
291 to, for example, write a Java class that manipulates a Subversion
292 repository or working copy. See the 'subversion' package for more
293 information.
294
295 %description -n java-subversion -l pl.UTF-8
296 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
297 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
298 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
299 roboczą. Więcej informacji w pakiecie subversion.
300
301 %package -n python-subversion
302 Summary:        Subversion Python bindings
303 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
304 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
305 Group:          Development/Languages/Python
306 %pyrequires_eq  python
307 Requires:       %{name}-libs = %{version}-%{release}
308 Obsoletes:      subversion-python
309
310 %description -n python-subversion
311 Subversion Python bindings.
312
313 %description -n python-subversion -l pl.UTF-8
314 Dowiązania do Subversion dla Pythona.
315
316 %description -n python-subversion -l pt_BR.UTF-8
317 Módulos Python para acessar os recursos do Subversion.
318
319 %package -n python-csvn
320 Summary:        CTypes Subversion Python bindings
321 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
322 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
323 Group:          Development/Languages/Python
324 %pyrequires_eq  python
325 Requires:       %{name}-libs = %{version}-%{release}
326
327 %description -n python-csvn
328 Subversion CTypes Python bindings.
329
330 %description -n python-csvn -l pl.UTF-8
331 Dowiązania do Subversion dla Pythona używające CTypes.
332
333 %description -n python-csvn -l pt_BR.UTF-8
334 Módulos Python para acessar os recursos do Subversion.
335
336 %package -n perl-subversion
337 Summary:        Subversion Perl bindings
338 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
339 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
340 Group:          Development/Languages/Perl
341 Requires:       %{name}-libs = %{version}-%{release}
342 Obsoletes:      subversion-perl
343
344 %description -n perl-subversion
345 Subversion Perl bindings.
346
347 %description -n perl-subversion -l pl.UTF-8
348 Dowiązania do Subversion dla Perla.
349
350 %description -n perl-subversion -l pt_BR.UTF-8
351 Módulos Perl para acessar os recursos do Subversion.
352
353 %package -n ruby-subversion
354 Summary:        Subversion Ruby bindings
355 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
356 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
357 Group:          Development/Languages
358 Requires:       %{name}-libs = %{version}-%{release}
359 Obsoletes:      subversion-ruby
360
361 %description -n ruby-subversion
362 Subversion Ruby bindings.
363
364 %description -n ruby-subversion -l pl.UTF-8
365 Dowiązania do Subversion dla języka Ruby.
366
367 %description -n ruby-subversion -l pt_BR.UTF-8
368 Módulos Ruby para acessar os recursos do Subversion.
369
370 %package -n apache-mod_dav_svn
371 Summary:        Apache module: Subversion Server
372 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
373 Group:          Networking/Daemons
374 Requires:       %{name} = %{version}-%{release}
375 Requires:       apache(modules-api) = %apache_modules_api
376 Requires:       apache-mod_dav
377
378 %description -n apache-mod_dav_svn
379 Apache module: Subversion Server.
380
381 %description -n apache-mod_dav_svn -l pl.UTF-8
382 Moduł apache: Serwer Subversion.
383
384 %package -n apache-mod_authz_svn
385 Summary:        Apache module: Subversion Server - path-based authorization
386 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
387 Group:          Networking/Daemons
388 Requires:       %{name}-libs = %{version}-%{release}
389 Requires:       apache(modules-api) = %apache_modules_api
390 Requires:       apache-mod_dav_svn = %{version}-%{release}
391
392 %description -n apache-mod_authz_svn
393 Apache module: Subversion Server - path-based authorization.
394
395 %description -n apache-mod_authz_svn -l pl.UTF-8
396 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
397
398 %package -n gnome-keyring-subversion
399 Summary:        GNOME Keyring authentication provider for Subversion
400 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Subversion
401 Group:          X11/Applications
402 Requires:       %{name}-libs = %{version}-%{release}
403
404 %description -n gnome-keyring-subversion
405 Authentication provider module for Subversion which allows SVN client
406 to authenticate using GNOME Keyring.
407
408 %description -n gnome-keyring-subversion -l pl.UTF-8
409 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
410 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
411
412 %package -n kde4-kwallet-subversion
413 Summary:        KDE Wallet authentication provider for Subversion
414 Summary(pl.UTF-8):      Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
415 Group:          X11/Applications
416 Requires:       %{name}-libs = %{version}-%{release}
417
418 %description -n kde4-kwallet-subversion
419 Authentication provider module for Subversion which allows SVN client
420 to authenticate using KDE Wallet.
421
422 %description -n kde4-kwallet-subversion -l pl.UTF-8
423 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
424 uwierzytelniać się przy użyciu Portfela KDE.
425
426 %prep
427 %setup -q
428 %patch0 -p0
429 %patch1 -p1
430 %patch2 -p0
431 %patch3 -p1
432
433 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
434
435 # serf.m4 macro is broken and ignores --without serf
436 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
437
438 %build
439 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
440 #%{__rm} subversion/bindings/swig/proxy/*.swg
441 #cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
442 chmod +x ./autogen.sh && ./autogen.sh
443 %{__libtoolize}
444 %configure \
445         --with-editor=vi \
446         --with-zlib=%{_libdir} \
447         --disable-runtime-module-search \
448         --disable-mod-activation \
449 %if %{with db}
450         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
451 %else
452         --without-berkeley-db \
453 %endif
454 %if %{with apache}
455         --with-apxs=%{_sbindir}/apxs \
456 %else
457         --without-apxs \
458 %endif
459 %if %{without swig}
460         --without-swig \
461 %endif
462 %if %{without ruby}
463         ac_cv_path_RUBY=none \
464 %endif
465 %if %{with csvn}
466         --with-ctypesgen=%{_bindir}/ctypesgen.py \
467 %endif
468 %if %{with javahl}
469         --enable-javahl \
470         --with-jdk="%{java_home}" \
471         --without-jikes \
472 %else
473         --disable-javahl \
474 %endif
475 %if %{with neon}
476         --without-serf \
477         --with-neon=%{_prefix} \
478         --disable-neon-version-check \
479 %else
480         --with-serf=%{_prefix} \
481         --without-neon \
482 %endif
483         --with-apr=%{_bindir}/apr-1-config \
484         --with-apr-util=%{_bindir}/apu-1-config \
485 %if %{with kwallet}
486         --with-kwallet \
487 %endif
488 %if %{with gnome}
489         --with-gnome-keyring
490 %endif
491
492 %{__make} -j1
493
494 %{__make} tools
495
496 %if %{with csvn}
497 # Python ctypes bindings
498 %{__make} ctypes-python
499 %endif
500 %if %{with python}
501 # Python swig bindings
502 %{__make} swig-py \
503         swig_pydir=%{py_sitedir}/libsvn \
504         swig_pydir_extra=%{py_sitedir}/svn
505 %endif
506 %if %{with perl}
507 # Perl swig bindings
508 %{__make} -j1 swig-pl-lib
509 cd subversion/bindings/swig/perl/native
510 %{__perl} Makefile.PL INSTALLDIRS=vendor
511 %{__make} -j1
512 cd -
513 %endif
514 %if %{with javahl}
515 %{__make} -j1 javahl \
516         javahl_javadir="%{_javadir}"
517 %endif
518 # ruby
519 %if %{with ruby}
520 %{__make} swig-rb
521 %endif
522
523 %if %{with tests}
524 %{__make} -j1 check
525 %if %{with csvn}
526 %{__make} -j1 check-ctypes-python
527 %endif
528 %if %{with python}
529 %{__make} -j1 check-swig-py
530 %endif
531 %if %{with perl}
532 %{__make} -j1 check-swig-pl
533 %endif
534 %if %{with ruby}
535 # disabled, see https://bugs.launchpad.net/pld-linux/+bug/734340
536 #%{__make} check-swig-rb
537 %endif
538 %endif
539
540 %install
541 rm -rf $RPM_BUILD_ROOT
542 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
543         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
544         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
545         $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
546         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
547
548 %{__make} install -j1 \
549         toolsdir=%{_bindir} \
550         DESTDIR=$RPM_BUILD_ROOT \
551         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
552 %if %{with javahl}
553         install-javahl \
554         javahl_javadir="%{_javadir}" \
555 %endif
556 %if %{with python}
557         install-swig-py \
558         swig_pydir=%{py_sitedir}/libsvn \
559         swig_pydir_extra=%{py_sitedir}/svn \
560 %endif
561 %if %{with csvn}
562         install-ctypes-python \
563 %endif
564         install-tools
565
566 %if %{with ruby}
567 %{__make} install -j1 \
568         DESTDIR=$RPM_BUILD_ROOT \
569         install-swig-rb install-swig-rb-doc \
570
571 # not our package
572 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Kernel
573 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
574 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
575 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Uconv
576 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
577 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
578 %endif
579
580 %if %{with perl}
581 %{__make} install-swig-pl-lib \
582         DESTDIR=$RPM_BUILD_ROOT
583 %{__make} -C subversion/bindings/swig/perl/native install \
584         DESTDIR=$RPM_BUILD_ROOT \
585         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
586         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
587 %endif
588
589 %if %{with apache}
590 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
591 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
592 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
593 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
594 %endif
595
596 %if %{without net_client_only}
597 install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
598 %endif
599
600 # rename not to conflict with standard packages. (are these needed at all?)
601 mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff
602 mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff3
603 mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff4
604
605 %if %{with python} || %{with csvn}
606 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
607 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
608 %py_postclean
609 %endif
610 %if %{with python}
611 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
612 # .a created on ac only
613 %{__rm} -f $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.a
614 cp -p tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
615 %endif
616
617 cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
618 cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
619
620 %if %{with javahl}
621 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}
622 %endif
623 %if %{with swig}
624 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
625 %if %{with ruby}
626 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
627 %endif
628 %endif
629 %if %{with gnome} || %{with kwallet}
630 # dlopened by soname (libsvn_auth_*-1.so.0)
631 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
632 %endif
633
634 %find_lang %{name}
635
636 %clean
637 rm -rf $RPM_BUILD_ROOT
638
639 %pre svnserve
640 %groupadd -g 86 svn
641 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
642
643 %post   libs -p /sbin/ldconfig
644 %postun libs -p /sbin/ldconfig
645
646 %post   devel -p /sbin/postshell
647 -/usr/sbin/fix-info-dir -c %{_infodir}
648
649 %postun devel -p /sbin/postshell
650 -/usr/sbin/fix-info-dir -c %{_infodir}
651
652 %post   -n java-subversion -p /sbin/ldconfig
653 %postun -n java-subversion -p /sbin/ldconfig
654
655 %post   -n perl-subversion -p /sbin/ldconfig
656 %postun -n perl-subversion -p /sbin/ldconfig
657
658 %post   -n python-subversion -p /sbin/ldconfig
659 %postun -n python-subversion -p /sbin/ldconfig
660
661 %post   -n ruby-subversion -p /sbin/ldconfig
662 %postun -n ruby-subversion -p /sbin/ldconfig
663
664 %post   -n gnome-keyring-subversion -p /sbin/ldconfig
665 %postun -n gnome-keyring-subversion -p /sbin/ldconfig
666
667 %post   -n kde4-kwallet-subversion -p /sbin/ldconfig
668 %postun -n kde4-kwallet-subversion -p /sbin/ldconfig
669
670 %post svnserve
671 /sbin/chkconfig --add svnserve
672 %service svnserve restart "svnserve daemon"
673
674 %preun svnserve
675 if [ "$1" = "0" ]; then
676         %service svnserve stop
677         /sbin/chkconfig --del svnserve
678 fi
679
680 %postun svnserve
681 if [ "$1" = "0" ]; then
682         %userremove svn
683         %groupremove svn
684 fi
685
686 %post -n apache-mod_dav_svn
687 %service -q httpd restart
688
689 %postun -n apache-mod_dav_svn
690 if [ "$1" = "0" ]; then
691         %service -q httpd restart
692 fi
693
694 %post -n apache-mod_authz_svn
695 %service -q httpd restart
696
697 %postun -n apache-mod_authz_svn
698 if [ "$1" = "0" ]; then
699         %service -q httpd restart
700 fi
701
702 %files
703 %defattr(644,root,root,755)
704 %doc BUGS CHANGES INSTALL README
705 %doc doc/*/*.html
706 %doc tools/hook-scripts/*.{pl,py,example}
707 %doc tools/hook-scripts/mailer/*.{py,example}
708 %doc tools/xslt/*
709 %attr(755,root,root) %{_bindir}/svn
710 %attr(755,root,root) %{_bindir}/svnadmin
711 %attr(755,root,root) %{_bindir}/svndumpfilter
712 %attr(755,root,root) %{_bindir}/svnrdump
713 %attr(755,root,root) %{_bindir}/svnlook
714 %attr(755,root,root) %{_bindir}/svnsync
715 %attr(755,root,root) %{_bindir}/svnversion
716 %{_mandir}/man1/svn.1*
717 %{_mandir}/man1/svnadmin.1*
718 %{_mandir}/man1/svndumpfilter.1*
719 %{_mandir}/man1/svnrdump.1*
720 %{_mandir}/man1/svnlook.1*
721 %{_mandir}/man1/svnsync.1*
722 %{_mandir}/man1/svnversion.1*
723
724 %files libs -f %{name}.lang
725 %defattr(644,root,root,755)
726 %dir %{_sysconfdir}/%{name}
727 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
728 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
729 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
730 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
731 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
732 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
733 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
734 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
735 %if %{without net_client_only}
736 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
737 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
738 %endif
739 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
740 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
741 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
742 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
743 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
744 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
745 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
746 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
747 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
748 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
749 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
750 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
751 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
752 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
753 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
754 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
755 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
756 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
757
758 %files devel
759 %defattr(644,root,root,755)
760 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
761 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
762 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
763 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
764 %if %{without net_client_only}
765 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
766 %endif
767 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
768 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
769 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
770 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
771 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
772 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
773 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
774 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
775 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
776 %{_libdir}/libsvn_client-1.la
777 %{_libdir}/libsvn_delta-1.la
778 %{_libdir}/libsvn_diff-1.la
779 %{_libdir}/libsvn_fs-1.la
780 %if %{without net_client_only}
781 %{_libdir}/libsvn_fs_base-1.la
782 %endif
783 %{_libdir}/libsvn_fs_fs-1.la
784 %{_libdir}/libsvn_fs_util-1.la
785 %{_libdir}/libsvn_ra-1.la
786 %{_libdir}/libsvn_ra_local-1.la
787 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
788 %{_libdir}/libsvn_ra_svn-1.la
789 %{_libdir}/libsvn_repos-1.la
790 %{_libdir}/libsvn_subr-1.la
791 %{_libdir}/libsvn_wc-1.la
792 %{_includedir}/%{name}-1
793 %{_examplesdir}/%{name}-%{version}
794
795 %files static
796 %defattr(644,root,root,755)
797 %{_libdir}/libsvn_client-1.a
798 %{_libdir}/libsvn_delta-1.a
799 %{_libdir}/libsvn_diff-1.a
800 %{_libdir}/libsvn_fs-1.a
801 %if %{without net_client_only}
802 %{_libdir}/libsvn_fs_base-1.a
803 %endif
804 %{_libdir}/libsvn_fs_fs-1.a
805 %{_libdir}/libsvn_fs_util-1.a
806 %{_libdir}/libsvn_ra-1.a
807 %{_libdir}/libsvn_ra_local-1.a
808 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
809 %{_libdir}/libsvn_ra_svn-1.a
810 %{_libdir}/libsvn_repos-1.a
811 %{_libdir}/libsvn_subr-1.a
812 %{_libdir}/libsvn_wc-1.a
813
814 %if %{with gnome}
815 %files -n gnome-keyring-subversion
816 %defattr(644,root,root,755)
817 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
818 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
819 %endif
820
821 %if %{with kwallet}
822 %files -n kde4-kwallet-subversion
823 %defattr(644,root,root,755)
824 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
825 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
826 %endif
827
828 %if %{without net_client_only}
829 %files svnserve
830 %defattr(644,root,root,755)
831 %attr(755,root,root) %{_bindir}/svnserve
832 %{_mandir}/man5/svnserve.conf.5*
833 %{_mandir}/man8/svnserve.8*
834 %dir %attr(750,svn,svn) /home/services/subversion
835 %dir %attr(750,svn,svn) /home/services/subversion/repos
836 %if %{with apache}
837 %attr(754,root,root) /etc/rc.d/init.d/svnserve
838 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
839 %endif
840
841 %files tools
842 %defattr(644,root,root,755)
843 # tools/backup/hot-backup.py
844 %attr(755,root,root) %{_bindir}/svn-hot-backup
845
846 # tools/diff
847 %attr(755,root,root) %{_bindir}/svndiff
848 %attr(755,root,root) %{_bindir}/svndiff3
849 %attr(755,root,root) %{_bindir}/svndiff4
850
851 # tools/server-side
852 %attr(755,root,root) %{_bindir}/svn-populate-node-origins-index
853 %attr(755,root,root) %{_bindir}/svn-rep-sharing-stats
854 %attr(755,root,root) %{_bindir}/svnauthz-validate
855
856 # tools/client-side/svnmucc
857 %attr(755,root,root) %{_bindir}/svnmucc
858 # tools/dev/svnraisetreeconflict
859 %attr(755,root,root) %{_bindir}/svnraisetreeconflict
860
861 %files -n bash-completion-subversion
862 %defattr(644,root,root,755)
863 /etc/bash_completion.d/%{name}
864
865 %endif # net_client_only
866
867 %if %{with javahl}
868 %files -n java-subversion
869 %defattr(644,root,root,755)
870 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
871 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
872 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
873 %{_javadir}/svn-javahl.jar
874 %endif
875
876 %if %{with python}
877 %files -n python-subversion
878 %defattr(644,root,root,755)
879 %doc tools/backup/*.py
880 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
881 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
882 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
883 %dir %{py_sitedir}/libsvn
884 %attr(755,root,root) %{py_sitedir}/libsvn/_*.so
885 %{py_sitedir}/libsvn/*.py[co]
886 %dir %{py_sitedir}/svn
887 %{py_sitedir}/svn/*.py[co]
888 %{_examplesdir}/python-%{name}-%{version}
889 %endif
890
891 %if %{with csvn}
892 %files -n python-csvn
893 %defattr(644,root,root,755)
894 %doc subversion/bindings/ctypes-python/{README,TODO}
895 %doc subversion/bindings/ctypes-python/examples/*.py
896 %dir %{py_sitescriptdir}/csvn
897 %{py_sitescriptdir}/csvn/*.py[co]
898 %dir %{py_sitescriptdir}/csvn/core
899 %{py_sitescriptdir}/csvn/core/*.py[co]
900 %dir %{py_sitescriptdir}/csvn/ext
901 %{py_sitescriptdir}/csvn/ext/*.py[co]
902 %{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
903 %endif
904
905 %if %{with perl}
906 %files -n perl-subversion
907 %defattr(644,root,root,755)
908 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
909 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
910 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
911 %{perl_vendorarch}/SVN
912 %dir %{perl_vendorarch}/auto/SVN
913 %dir %{perl_vendorarch}/auto/SVN/*
914 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
915 %{perl_vendorarch}/auto/SVN/*/*.bs
916 %{_mandir}/man3/*.3pm*
917 %endif
918
919 %if %{with ruby}
920 %files -n ruby-subversion
921 %defattr(644,root,root,755)
922 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
923 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
924 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
925 %dir %{ruby_sitelibdir}/svn
926 %{ruby_sitelibdir}/svn/*.rb
927 %dir %{ruby_sitearchdir}/svn
928 %dir %{ruby_sitearchdir}/svn/ext
929 %attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
930 %{ruby_ridir}/Svn
931 %endif
932
933 %if %{with apache}
934 %files -n apache-mod_dav_svn
935 %defattr(644,root,root,755)
936 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
937 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
938
939 %files -n apache-mod_authz_svn
940 %defattr(644,root,root,755)
941 %doc subversion/mod_authz_svn/INSTALL
942 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
943 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
944 %endif
This page took 0.136819 seconds and 4 git commands to generate.