]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- updated to 1.5.0-rc9
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - remove net_client_only and add db bcond (then without apache and
3 #   without db => net_client_only - spec will be more simpler, I think)
4 # - finish ruby
5 #
6 # Conditional build:
7 %bcond_with     net_client_only         # build only net client
8 %bcond_without  python                  # build without python bindings (broken)
9 %bcond_without  perl                    # build without perl bindings
10 %bcond_without  ruby                    # build without ruby bindings
11 %bcond_without  apache                  # build without apache support (webdav, etc)
12 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
13 %bcond_without  tests                   # don't perform "make check"
14 #
15 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
16 %define apxs    /usr/sbin/apxs
17 %define pdir    SVN
18 %define pnam    _Core
19 #
20 %define snap    rc9
21 Summary:        A Concurrent Versioning system similar to but better than CVS
22 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
23 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
24 Name:           subversion
25 Version:        1.5.0
26 Release:        0.%{snap}.1
27 License:        Apache/BSD-like
28 Group:          Development/Version Control
29 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}-%{snap}.tar.bz2
30 # Source0-md5:  9b16d352ffabfd070f2e3e9d8e5fcffd
31 Source1:        %{name}-dav_svn.conf
32 Source2:        %{name}-authz_svn.conf
33 Source3:        %{name}-svnserve.init
34 Source4:        %{name}-svnserve.sysconfig
35 Source5:        %{name}-convert-typemaps-to-ifdef.py
36 Patch0:         %{name}-home_etc.patch
37 Patch1:         %{name}-DESTDIR.patch
38 URL:            http://subversion.tigris.org/
39 %if %{with net_client_only}
40 %global apache_modules_api 0
41 %else
42 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
43 BuildRequires:  automake
44 BuildRequires:  db-devel >= 4.1.25
45 BuildRequires:  rpmbuild(macros) >= 1.268
46 %if %{with perl}
47 BuildRequires:  perl-devel >= 1:5.8.0
48 BuildRequires:  rpm-perlprov >= 4.1-13
49 BuildRequires:  swig-perl >= 1.3.24
50 %endif
51 %{?with_javahl:BuildRequires:   jdk}
52 %endif
53 BuildRequires:  apr-devel >= 1:1.0.0
54 BuildRequires:  apr-util-devel >= 1:1.2.8-3
55 BuildRequires:  autoconf >= 2.59
56 BuildRequires:  bison
57 BuildRequires:  cyrus-sasl-devel
58 BuildRequires:  expat-devel
59 BuildRequires:  gettext-devel
60 BuildRequires:  libtool >= 1.4-9
61 BuildRequires:  neon-devel >= 0.26.0
62 BuildRequires:  python >= 2.2
63 BuildRequires:  python-modules >= 2.2
64 %if %{with python}
65 BuildRequires:  python-devel >= 2.2
66 BuildRequires:  sed >= 4.0
67 BuildRequires:  swig-python >= 1.3.24
68 %endif
69 %{?with_ruby:BuildRequires:     swig-ruby >= 1.3.24}
70 BuildRequires:  texinfo
71 BuildRequires:  which
72 Requires:       %{name}-libs = %{version}-%{release}
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         _libexecdir             %{_libdir}/svn
76 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
77 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
78
79 %description
80 The goal of the Subversion project is to build a version control
81 system that is a compelling replacement for CVS in the open source
82 community.
83
84 Our goals are:
85 - All current CVS features.
86 - Directories, renames, and file meta-data are versioned.
87 - Symbolic links, etc, are supported
88 - Commits are truly atomic.
89 - Branching and tagging are cheap (constant time) operations
90 - Repeated merges are handled gracefully
91 - Support for plug-in client side diff programs
92 - Natively client/server
93 - Client/server protocol sends diffs in both directions
94 - Costs are proportional to change size, not project size
95 - Internationalization
96 - Progressive multi-lingual support
97
98 %description -l pl.UTF-8
99 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
100 zamiennika dla CVS.
101
102 Cele projektu to:
103 - Wszystkie aktualne możliwości CVS.
104 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
105 - Obsługa dowiązań symbolicznych itp.
106 - Commity są w pełni atomowe.
107 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
108 - Dobra obsługa powtarzanego łączenia (merge).
109 - Obsługa wtyczek diff po stronie klienta.
110 - Natywny klient/serwer.
111 - Klient/Serwer przesyłają diffy w obu kierunkach.
112 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
113 - Internacjonalizacja.
114 - Postępujące wsparcie dla wielu języków.
115
116 %description -l pt_BR.UTF-8
117 O objetivo do projeto Subversion é construir um sistema de controle de
118 versões que seja um substituto para o CVS (Concurrent Versioning
119 System) na comunidade opensource, fornecendo grandes melhorias.
120
121 %package libs
122 Summary:        Subversion libraries and modules
123 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
124 Group:          Libraries
125 Requires:       neon >= 0.26.0
126 Obsoletes:      libsubversion0
127
128 %description libs
129 Subversion libraries and modules.
130
131 %description libs -l pl.UTF-8
132 Biblioteka subversion oraz ładowalne moduły.
133
134 %package devel
135 Summary:        Header files and develpment documentation for subversion
136 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
137 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
138 Group:          Development/Libraries
139 Requires:       %{name}-libs = %{version}-%{release}
140 Requires:       apr-util-devel >= 1:1.0.0
141 Requires:       neon-devel >= 0.26.0
142 Obsoletes:      libsubversion0-devel
143
144 %description devel
145 Header files and develpment documentation for subversion.
146
147 %description devel -l pl.UTF-8
148 Pliki nagłówkowe i dokumetacja do subversion.
149
150 %description devel -l pt_BR.UTF-8
151 Este pacote provê os arquivos necessários para desenvolvedores
152 interagirem com o Subversion.
153
154 %package static
155 Summary:        Static subversion library
156 Summary(pl.UTF-8):      Biblioteka statyczna subversion
157 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
158 Group:          Development/Libraries
159 Requires:       %{name}-devel = %{version}
160 Obsoletes:      libsubversion0-static-devel
161
162 %description static
163 Static subversion library.
164
165 %description static -l pl.UTF-8
166 Biblioteka statyczna subversion.
167
168 %description static -l pt_BR.UTF-8
169 Este pacote provê um cliente estático do subversion.
170
171 %package svnserve
172 Summary:        Subversion svnserve
173 Summary(pl.UTF-8):      Subversion svnserve
174 Group:          Networking/Daemons
175 Requires(post,preun):   /sbin/chkconfig
176 Requires(postun):       /usr/sbin/groupdel
177 Requires(postun):       /usr/sbin/userdel
178 Requires(pre):  /bin/id
179 Requires(pre):  /usr/bin/getgid
180 Requires(pre):  /usr/lib/rpm/user_group.sh
181 Requires(pre):  /usr/sbin/groupadd
182 Requires(pre):  /usr/sbin/useradd
183 Requires(pre):  /usr/sbin/usermod
184 Requires:       %{name} = %{version}-%{release}
185 Requires:       rc-scripts
186 Provides:       group(svn)
187 Provides:       user(svn)
188
189 %description svnserve
190 Subversion svnserve server.
191
192 %description svnserve -l pl.UTF-8
193 Serwer subversion svnserve.
194
195 %package tools
196 Summary:        Subversion tools and scripts
197 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
198 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
199 Group:          Applications
200 %pyrequires_eq  python
201 Requires:       %{name} = %{version}-%{release}
202 Requires:       python-rcsparse >= 0.1-0.20031026.0
203 Requires:       python-subversion = %{version}
204
205 %description tools
206 Subversion tools and scripts.
207
208 %description tools -l pl.UTF-8
209 Narzędzia oraz skrypty dla subversion.
210
211 %package -n bash-completion-subversion
212 Summary:        bash completion for subversion
213 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
214 Group:          Applications/Shells
215 Requires:       %{name} = %{version}-%{release}
216 Requires:       bash-completion
217 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
218
219 %description -n bash-completion-subversion
220 Bash completion for subversion.
221
222 %description -n bash-completion-subversion -l pl.UTF-8
223 Dopełnienia basha dla subversion.
224
225 %package -n java-subversion
226 Summary:        Subversion Java bindings
227 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
228 Group:          Development/Languages/Java
229 Requires:       %{name}-libs = %{version}-%{release}
230
231 %description -n java-subversion
232 This is a set of Java classes which provide the functionality of
233 subversion-libs, the Subversion libraries. It is useful if you want
234 to, for example, write a Java class that manipulates a Subversion
235 repository or working copy. See the 'subversion' package for more
236 information.
237
238 %description -n java-subversion -l pl.UTF-8
239 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
240 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
241 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
242 roboczą. Więcej informacji w pakiecie subversion.
243
244 %package -n python-subversion
245 Summary:        Subversion Python bindings
246 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
247 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
248 Group:          Development/Languages/Python
249 %pyrequires_eq  python
250 Requires:       %{name}-libs = %{version}-%{release}
251 Obsoletes:      subversion-python
252
253 %description -n python-subversion
254 Subversion Python bindings.
255
256 %description -n python-subversion -l pl.UTF-8
257 Dowiązania do Subversion dla Pythona.
258
259 %description -n python-subversion -l pt_BR.UTF-8
260 Módulos Python para acessar os recursos do Subversion.
261
262 %package -n perl-subversion
263 Summary:        Subversion Perl bindings
264 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
265 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
266 Group:          Development/Languages/Perl
267 Requires:       %{name}-libs = %{version}-%{release}
268 Obsoletes:      subversion-perl
269
270 %description -n perl-subversion
271 Subversion Perl bindings.
272
273 %description -n perl-subversion -l pl.UTF-8
274 Dowiązania do Subversion dla Perla.
275
276 %description -n perl-subversion -l pt_BR.UTF-8
277 Módulos Perl para acessar os recursos do Subversion.
278
279 %package -n ruby-subversion
280 Summary:        Subversion Ruby bindings
281 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
282 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
283 Group:          Development/Languages
284 Requires:       %{name}-libs = %{version}-%{release}
285 Obsoletes:      subversion-ruby
286
287 %description -n ruby-subversion
288 Subversion Ruby bindings.
289
290 %description -n ruby-subversion -l pl.UTF-8
291 Dowiązania do Subversion dla języka Ruby.
292
293 %description -n ruby-subversion -l pt_BR.UTF-8
294 Módulos Ruby para acessar os recursos do Subversion.
295
296 %package -n apache-mod_dav_svn
297 Summary:        Apache module: Subversion Server
298 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
299 Group:          Networking/Daemons
300 Requires:       %{name} = %{version}-%{release}
301 Requires:       apache(modules-api) = %apache_modules_api
302 Requires:       apache-mod_dav
303
304 %description -n apache-mod_dav_svn
305 Apache module: Subversion Server.
306
307 %description -n apache-mod_dav_svn -l pl.UTF-8
308 Moduł apache: Serwer Subversion.
309
310 %package -n apache-mod_authz_svn
311 Summary:        Apache module: Subversion Server - path-based authorization
312 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
313 Group:          Networking/Daemons
314 Requires:       apache(modules-api) = %apache_modules_api
315 Requires:       apache-mod_dav_svn = %{version}-%{release}
316
317 %description -n apache-mod_authz_svn
318 Apache module: Subversion Server - path-based authorization.
319
320 %description -n apache-mod_authz_svn -l pl.UTF-8
321 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
322
323 %prep
324 %setup -q -n %{name}-%{version}-%{snap}
325 rm -rf apr apr-util neon
326 %patch0 -p0
327 %patch1 -p1
328
329 %build
330 rm subversion/bindings/swig/proxy/*.swg
331 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
332 cp -f /usr/share/automake/config.sub ac-helpers
333 chmod +x ./autogen.sh && ./autogen.sh
334
335 # don't enable dso - currently it's broken
336 %configure \
337         --with-editor=vi \
338         --with-zlib=%{_libdir} \
339         --with-python=%{__python} \
340         --with-perl5=%{__perl} \
341 %if %{with net_client_only}
342         --without-apache \
343         --without-swig \
344         --without-apxs \
345         --without-berkeley-db \
346 %else
347         --disable-dso \
348         --disable-mod-activation \
349 %if %{with apache}
350         --with-apxs=%{_sbindir}/apxs \
351 %else
352         --without-apache \
353         --without-apxs \
354         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
355 %endif
356 %if !%{with python} && !%{with perl} && !%{with ruby}
357         --without-swig \
358 %endif
359         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
360 %endif
361         --with-jdk="%{java_home}" \
362         --with-neon=%{_prefix} \
363         --disable-neon-version-check \
364         --with-apr=%{_bindir}/apr-1-config \
365         --with-apr-util=%{_bindir}/apu-1-config
366
367 %{__make} -j1
368
369 %if !%{with net_client_only}
370 # python
371 %if %{with python}
372 %{__make} swig-py \
373         swig_pydir=%{py_sitedir}/libsvn \
374         swig_pydir_extra=%{py_sitedir}/svn
375 %endif
376 # perl
377 %if %{with perl}
378 %{__make} swig-pl-lib
379 odir=$(pwd)
380 cd subversion/bindings/swig/perl/native
381 %{__perl} Makefile.PL INSTALLDIRS=vendor
382 %{__make} -j1
383 cd $odir
384 %endif
385 %if %{with javahl}
386 %{__make} -j1 javahl \
387         javahl_javadir="%{_javadir}"
388 %endif
389 # ruby
390 %if %{with ruby}
391 %{__make} swig-rb
392 %endif
393 %endif
394
395 %if %{with tests}
396 %{__make} check
397 %if %{with python}
398 %{__make} check-swig-py
399 %endif
400 %if %{with perl}
401 %{__make} check-swig-pl
402 %endif
403 %if %{with ruby}
404 %{__make} check-swig-rb
405 %endif
406 %endif
407
408 %install
409 rm -rf $RPM_BUILD_ROOT
410 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
411         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
412         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
413         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
414
415 %{__make} install -j1 \
416 %if %{with javahl}
417         install-javahl \
418         javahl_javadir="%{_javadir}" \
419 %endif
420 %if !%{with net_client_only}
421 %if %{with python}
422         install-swig-py \
423 %endif
424 %if %{with ruby}
425         install-swig-rb install-swig-rb-doc \
426 %endif
427 %endif
428         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
429         DESTDIR=$RPM_BUILD_ROOT \
430         swig_pydir=%{py_sitedir}/libsvn \
431         swig_pydir_extra=%{py_sitedir}/svn
432
433 %if !%{with net_client_only} && %{with perl}
434 %{__make} install-swig-pl-lib \
435         DESTDIR=$RPM_BUILD_ROOT
436 %{__make} -C subversion/bindings/swig/perl/native install \
437         DESTDIR=$RPM_BUILD_ROOT \
438         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
439         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
440 %endif
441
442 %if %{with apache}
443 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
444 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
445 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
446 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
447 %endif
448
449 %if !%{with net_client_only}
450 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
451 %if %{with python}
452 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
453 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
454 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
455 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
456 %endif
457 %endif
458
459 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
460 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
461
462 %find_lang %{name}
463
464 rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn{javahl,_swig}*.{la,a}
465 rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/svn/ext/*.la
466
467 %clean
468 rm -rf $RPM_BUILD_ROOT
469
470 %pre svnserve
471 %groupadd -g 86 svn
472 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
473
474 %post   libs -p /sbin/ldconfig
475 %postun libs -p /sbin/ldconfig
476
477 %post   devel -p /sbin/postshell
478 -/usr/sbin/fix-info-dir -c %{_infodir}
479
480 %postun devel -p /sbin/postshell
481 -/usr/sbin/fix-info-dir -c %{_infodir}
482
483 %post   -n perl-subversion -p /sbin/ldconfig
484 %postun -n perl-subversion -p /sbin/ldconfig
485
486 %post   -n python-subversion -p /sbin/ldconfig
487 %postun -n python-subversion -p /sbin/ldconfig
488
489 %post svnserve
490 /sbin/chkconfig --add svnserve
491 %service svnserve restart "svnserve daemon"
492
493 %preun svnserve
494 if [ "$1" = "0" ]; then
495         %service svnserve stop
496         /sbin/chkconfig --del svnserve
497 fi
498
499 %postun svnserve
500 if [ "$1" = "0" ]; then
501         %userremove svn
502         %groupremove svn
503 fi
504
505 %post -n apache-mod_dav_svn
506 %service -q httpd restart
507
508 %preun -n apache-mod_dav_svn
509 if [ "$1" = "0" ]; then
510         %service -q httpd restart
511 fi
512
513 %files
514 %defattr(644,root,root,755)
515 %doc BUGS CHANGES COPYING INSTALL README
516 %doc doc/*/*.html
517 %doc tools/hook-scripts/*.{pl,py,example}
518 %doc tools/hook-scripts/mailer/*.{py,example}
519 %doc tools/xslt/*
520 %attr(755,root,root) %{_bindir}/svn
521 %attr(755,root,root) %{_bindir}/svnadmin
522 %attr(755,root,root) %{_bindir}/svndumpfilter
523 %attr(755,root,root) %{_bindir}/svnlook
524 %attr(755,root,root) %{_bindir}/svnsync
525 %attr(755,root,root) %{_bindir}/svnversion
526 %{_mandir}/man1/svn.1*
527 %{_mandir}/man1/svnadmin.1*
528 %{_mandir}/man1/svndumpfilter.1*
529 %{_mandir}/man1/svnlook.1*
530 %{_mandir}/man1/svnsync.1*
531 %{_mandir}/man1/svnversion.1*
532
533 %files libs -f %{name}.lang
534 %defattr(644,root,root,755)
535 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
536 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
537 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
538 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
539 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
540 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
541 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
542 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
543 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
544 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
545 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
546 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
547 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
548 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
549 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
550 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
551 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
552 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
553 %attr(755,root,root) %{_libdir}/libsvn_ra_neon-1.so.*.*.*
554 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_neon-1.so.0
555 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
556 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
557 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
558 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
559 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
560 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
561 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
562 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
563
564 %files devel
565 %defattr(644,root,root,755)
566 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
567 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
568 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
569 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
570 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
571 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
572 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
573 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
574 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
575 %attr(755,root,root) %{_libdir}/libsvn_ra_neon-1.so
576 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
577 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
578 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
579 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
580 %{_libdir}/libsvn_client-1.la
581 %{_libdir}/libsvn_delta-1.la
582 %{_libdir}/libsvn_diff-1.la
583 %{_libdir}/libsvn_fs-1.la
584 %{_libdir}/libsvn_fs_base-1.la
585 %{_libdir}/libsvn_fs_fs-1.la
586 %{_libdir}/libsvn_fs_util-1.la
587 %{_libdir}/libsvn_ra-1.la
588 %{_libdir}/libsvn_ra_local-1.la
589 %{_libdir}/libsvn_ra_neon-1.la
590 %{_libdir}/libsvn_ra_svn-1.la
591 %{_libdir}/libsvn_repos-1.la
592 %{_libdir}/libsvn_subr-1.la
593 %{_libdir}/libsvn_wc-1.la
594 %{_includedir}/%{name}-1
595 %{_examplesdir}/%{name}-%{version}
596
597 %files static
598 %defattr(644,root,root,755)
599 %{_libdir}/libsvn_client-1.a
600 %{_libdir}/libsvn_delta-1.a
601 %{_libdir}/libsvn_diff-1.a
602 %{_libdir}/libsvn_fs-1.a
603 %{_libdir}/libsvn_fs_base-1.a
604 %{_libdir}/libsvn_fs_fs-1.a
605 %{_libdir}/libsvn_fs_util-1.a
606 %{_libdir}/libsvn_ra-1.a
607 %{_libdir}/libsvn_ra_local-1.a
608 %{_libdir}/libsvn_ra_neon-1.a
609 %{_libdir}/libsvn_ra_svn-1.a
610 %{_libdir}/libsvn_repos-1.a
611 %{_libdir}/libsvn_subr-1.a
612 %{_libdir}/libsvn_wc-1.a
613
614 %if !%{with net_client_only}
615 %files svnserve
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_bindir}/svnserve
618 %{_mandir}/man5/svnserve.conf.5*
619 %{_mandir}/man8/svnserve.8*
620 %dir %attr(750,svn,svn) /home/services/subversion
621 %dir %attr(750,svn,svn) /home/services/subversion/repos
622 %if %{with apache}
623 %attr(754,root,root) /etc/rc.d/init.d/svnserve
624 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
625 %endif
626
627 %files tools
628 %defattr(644,root,root,755)
629 %attr(755,root,root) %{_bindir}/svn-hot-backup
630
631 %files -n bash-completion-subversion
632 %defattr(644,root,root,755)
633 /etc/bash_completion.d/%{name}
634
635 %if %{with javahl}
636 %files -n java-subversion
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
639 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
640 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
641 %{_javadir}/svn-javahl.jar
642 %endif
643
644 %if %{with python}
645 %files -n python-subversion
646 %defattr(644,root,root,755)
647 %doc tools/backup/*.py tools/examples/*.py
648 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
649 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
650 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
651 %dir %{py_sitedir}/libsvn
652 %{py_sitedir}/libsvn/*.py[co]
653 %dir %{py_sitedir}/svn
654 %{py_sitedir}/svn/*.py[co]
655 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
656 %{_examplesdir}/python-%{name}-%{version}
657 %endif
658
659 %if %{with perl}
660 %files -n perl-subversion
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
663 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
664 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
665 %{perl_vendorarch}/SVN
666 %dir %{perl_vendorarch}/auto/SVN
667 %dir %{perl_vendorarch}/auto/SVN/*
668 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
669 %{perl_vendorarch}/auto/SVN/*/*.bs
670 %{_mandir}/man3/*.3pm*
671 %endif
672
673 %if %{with ruby}
674 %files -n ruby-subversion
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
677 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
678 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
679 %dir %{_libdir}/ruby/site_ruby/svn
680 %{_libdir}/ruby/site_ruby/svn/*.rb
681 %dir %{_libdir}/ruby/site_ruby/svn/ext
682 %attr(755,root,root) %{_libdir}/ruby/site_ruby/svn/ext/*.so
683 %{_datadir}/ri/*.*/site/Svn
684 %{_datadir}/ri/*.*/site/Time
685 %{_datadir}/ri/*.*/site/Uconv
686 %{_datadir}/ri/*.*/site/*.rid
687 %{_datadir}/ri/*.*/site/Kernel/*
688 %{_datadir}/ri/*.*/site/OptionParser/*
689 %endif
690
691 %if %{with apache}
692 %files -n apache-mod_dav_svn
693 %defattr(644,root,root,755)
694 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
695 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
696
697 %files -n apache-mod_authz_svn
698 %defattr(644,root,root,755)
699 %doc subversion/mod_authz_svn/INSTALL
700 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
701 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
702 %endif
703
704 %endif # net_client_only
This page took 2.251765 seconds and 4 git commands to generate.