]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- up to 1.2.0
[packages/subversion.git] / subversion.spec
1 #
2 # todo:
3 # - remove net_client_only and add db bcond (then without apache and
4 #   without db => net_client_only - spec will be more simpler, I think)
5 #
6 # Conditional build:
7 %bcond_with     internal_neon                   # build with internal neon
8 %bcond_with     net_client_only                 # build only net client
9 %bcond_without  python                          # build without python bindings
10 %bcond_without  perl                            # build without perl bindings
11 %bcond_without  apache                          # build without apache support (webdav, etc)
12 #       
13 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
14 Summary:        A Concurrent Versioning system similar to but better than CVS
15 Summary(pl):    System kontroli wersji podobny, ale lepszy, ni¿ CVS
16 Summary(pt_BR): Sistema de versionamento concorrente
17 Name:           subversion
18 Version:        1.2.0
19 Release:        1
20 License:        Apache/BSD Style
21 Group:          Development/Version Control
22 Source0:        http://subversion.tigris.org/tarballs/%{name}-%{version}.tar.bz2
23 # Source0-md5:  f25c0c884201f411e99a6cb6c25529ff
24 Source1:        %{name}-dav_svn.conf
25 Source2:        %{name}-authz_svn.conf
26 Source3:        %{name}-svnserve.init
27 Source4:        %{name}-svnserve.sysconfig
28 URL:            http://subversion.tigris.org/
29 %if %{with net_client_only}
30 %global apache_modules_api 0
31 %else
32 BuildRequires:  automake
33 %{?with_apache:BuildRequires:   apache-devel >= 2.0.47-0.6}
34 BuildRequires:  db-devel >= 4.1.25
35 BuildRequires:  rpmbuild(macros) >= 1.120
36 %if %{with python} || %{with perl}
37 BuildRequires:  swig >= 1.3.19
38 %endif
39 %{?with_python:BuildRequires:   swig-python >= 1.3.21}
40 %if %{with perl}
41 BuildRequires:  swig-perl >= 1.3.21
42 BuildRequires:  perl-devel >= 1:5.8.0
43 BuildRequires:  rpm-perlprov >= 4.1-13
44 %endif
45 %endif
46 BuildRequires:  apr-devel >= 1:1.0.0
47 BuildRequires:  apr-util-devel >= 1:1.0.0
48 BuildRequires:  autoconf >= 2.59
49 BuildRequires:  bison
50 BuildRequires:  expat-devel
51 BuildRequires:  libtool >= 1.4-9
52 %{!?with_internal_neon:BuildRequires:   neon-devel >= 0.24.7}
53 %if %{with python}
54 BuildRequires:  python >= 2.2
55 BuildRequires:  python-devel >= 2.2
56 %endif
57 BuildRequires:  texinfo
58 BuildRequires:  which
59 Requires:       %{name}-libs = %{version}-%{release}
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %define         _apachelibdir   /usr/%{_lib}/apache
63 %define         _libexecdir     %{_libdir}/svn
64
65 %description
66 The goal of the Subversion project is to build a version control
67 system that is a compelling replacement for CVS in the open source
68 community.
69
70 Our goals are:
71 - All current CVS features.
72 - Directories, renames, and file meta-data are versioned.
73 - Symbolic links, etc, are supported
74 - Commits are truly atomic.
75 - Branching and tagging are cheap (constant time) operations
76 - Repeated merges are handled gracefully
77 - Support for plug-in client side diff programs
78 - Natively client/server
79 - Client/server protocol sends diffs in both directions
80 - Costs are proportional to change size, not project size
81 - Internationalization
82 - Progressive multi-lingual support
83
84 %description -l pl
85 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
86 zamiennika dla CVS.
87
88 Cele projektu to:
89 - Wszystkie aktualne mo¿liwo¶ci CVS.
90 - Katalogi, zmiany nazw oraz meta-dane plików s± wersjonowane.
91 - Wsparcie dla linków symbolicznych itp.
92 - Commity s± w pe³ni atomowe.
93 - Branchowanie oraz tagowanie s± tanimi (sta³ymi w czasie) operacjami.
94 - Powtarzaj±ce merge.
95 - Wsparcie dla pluginów diff'a po stronie klienta.
96 - Natywny klient/serwer.
97 - Klient/Serwer przesy³aj± diffy w obu kierunkach.
98 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
99 - Internacjonalizacja.
100 - Postêpuj±ce wsparcie dla wielu jêzyków.
101
102 %description -l pt_BR
103 O objetivo do projeto Subversion é construir um sistema de controle de
104 versões que seja um substituto para o CVS (Concurrent Versioning
105 System) na comunidade opensource, fornecendo grandes melhorias.
106
107 %package libs
108 Summary:        Subversion libraries and modules
109 Summary(pl):    Biblioteka subversion oraz ³adowalne modu³y
110 Group:          Libraries
111 Obsoletes:      libsubversion0
112 %{!?with_internal_neon:Requires:        neon >= 0.24.6}
113
114 %description libs
115 Subversion libraries and modules.
116
117 %description libs -l pl
118 Biblioteka subversion oraz ³adowalne modu³y.
119
120 %package devel
121 Summary:        Header files and develpment documentation for subversion
122 Summary(pl):    Pliki nag³ówkowe i dokumetacja do subversion
123 Summary(pt_BR): Arquivos de desenvolvimento para o Subversion
124 Group:          Development/Libraries
125 Requires:       %{name}-libs = %{version}-%{release}
126 Requires:       apr-util-devel >= 1:1.0.0
127 %{!?with_internal_neon:Requires:        neon-devel >= 0.24.6}
128 Obsoletes:      libsubversion0-devel
129
130 %description devel
131 Header files and develpment documentation for subversion.
132
133 %description devel -l pl
134 Pliki nag³ówkowe i dokumetacja do subversion.
135
136 %description devel -l pt_BR
137 Este pacote provê os arquivos necessários para desenvolvedores
138 interagirem com o Subversion.
139
140 %package static
141 Summary:        Static subversion library
142 Summary(pl):    Biblioteka statyczna subversion
143 Summary(pt_BR): Sistema de versionamento concorrente
144 Group:          Development/Libraries
145 Requires:       %{name}-devel = %{version}
146 Obsoletes:      libsubversion0-static-devel
147
148 %description static
149 Static subversion library.
150
151 %description static -l pl
152 Biblioteka statyczna subversion.
153
154 %description static -l pt_BR
155 Este pacote provê um cliente estático do subversion.
156
157 %package svnserve
158 Summary:        Subversion svnserve
159 Summary(pl):    Subversion svnserve
160 Group:          Networking/Daemons
161 PreReq:         rc-scripts
162 Requires(post,preun):   /sbin/chkconfig
163 Requires:       %{name} = %{version}-%{release}
164
165 %description svnserve
166 Subversion svnserve server.
167
168 %description svnserve -l pl
169 Serwer subversion svnserve.
170
171 %package tools
172 Summary:        Subversion tools and scripts
173 Summary(pl):    Narzêdzia oraz skrypty dla subversion
174 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
175 Group:          Applications
176 %pyrequires_eq  python
177 Requires:       python-rcsparse >= 0.1-0.20031026.0
178 Requires:       python-subversion = %{version}
179 Requires:       %{name} = %{version}-%{release}
180
181 %description tools
182 Subversion tools and scripts.
183
184 %description tools -l pl
185 Narzêdzia oraz skrypty dla subversion.
186
187 %package -n bash-completion-subversion
188 Summary:        bash completion for subversion
189 Summary(pl):    Dope³nienia basha dla subversion
190 Group:          Applications/Shells
191 Requires:       bash-completion
192 Requires:       %{name} = %{version}-%{release}
193 Conflicts:      %{name}-tools <= 1.1.0-0.rc2.1
194
195 %description -n bash-completion-subversion
196 Bash completion for subversion.
197
198 %description -n bash-completion-subversion -l pl
199 Dope³nienia basha dla subversion.
200
201 %package -n python-subversion
202 Summary:        Subversion python bindings
203 Summary(pl):    Dowi±zania do subversion dla pythona
204 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
205 Group:          Development/Languages/Python
206 %pyrequires_eq  python
207 Obsoletes:      subversion-python
208 Requires:       %{name}-libs = %{version}-%{release}
209
210 %description -n python-subversion
211 Subversion python bindings.
212
213 %description -n python-subversion -l pl
214 Dowi±zania do subversion dla pythona.
215
216 %description -n python-subversion -l pt_BR
217 Módulos python para acessar os recursos do Subversion.
218
219 %package -n perl-subversion
220 Summary:        Subversion perl bindings
221 Summary(pl):    Dowi±zania do subversion dla perla
222 Summary(pt_BR): Módulos perl para acessar os recursos do Subversion
223 Group:          Development/Languages/Perl
224 Obsoletes:      subversion-perl
225 Requires:       %{name}-libs = %{version}-%{release}
226
227 %description -n perl-subversion
228 Subversion perl bindings.
229
230 %description -n perl-subversion -l pl
231 Dowi±zania do subversion dla perl.
232
233 %description -n perl-subversion -l pt_BR
234 Módulos perl para acessar os recursos do Subversion.
235
236 %package -n apache-mod_dav_svn
237 Summary:        Apache module: Subversion Server
238 Summary(pl):    Modu³ apache: Serwer Subversion
239 Group:          Networking/Daemons
240 Requires:       apache >= 2.0.47
241 Requires:       apache(modules-api) = %{apache_modules_api}
242 Requires:       apache-mod_dav
243 Requires:       %{name} = %{version}-%{release}
244
245 %description -n apache-mod_dav_svn
246 Apache module: Subversion Server.
247
248 %description -n apache-mod_dav_svn -l pl
249 Modu³ apache: Serwer Subversion.
250
251 %package -n apache-mod_authz_svn
252 Summary:        Apache module: Subversion Server - path-based authorization
253 Summary(pl):    Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion
254 Group:          Networking/Daemons
255 Requires:       apache-mod_dav_svn = %{version}-%{release}
256 Requires:       apache >= 2.0.47
257 Requires:       apache(modules-api) = %{apache_modules_api}
258
259 %description -n apache-mod_authz_svn
260 Apache module: Subversion Server - path-based authorization.
261
262 %description -n apache-mod_authz_svn -l pl
263 Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion.
264
265 %prep
266 %setup -q
267
268 rm -rf apr-util{,/xml/expat}/autom4te.cache
269
270 %build
271 cp -f /usr/share/automake/config.sub ac-helpers
272 chmod +x ./autogen.sh && ./autogen.sh
273
274 # don't enable dso - currently it's broken
275 %configure \
276         --with-editor=vi \
277         --with-zlib \
278         --with-python=%{_bindir}/python \
279         --with-perl5=%{_bindir}/perl \
280 %if %{with net_client_only}
281         --without-apache \
282         --without-swig \
283         --without-apxs \
284         --without-berkeley-db \
285 %else
286         --disable-dso \
287         --disable-mod-activation \
288 %if %{with apache}
289         --with-apxs=%{_sbindir}/apxs \
290 %else
291         --without-apache \
292         --without-apxs \
293         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
294 %endif
295 %if !%{with python} && !%{with perl}
296         --without-swig \
297 %endif
298 %endif
299         %{!?with_internal_neon:--with-neon=%{_prefix}} \
300         --with-apr=%{_bindir}/apr-1-config \
301         --with-apr-util=%{_bindir}/apu-1-config
302
303 %{__make}
304
305 %if !%{with net_client_only}
306 # python
307 %if %{with python}
308 %{__make} swig-py \
309         swig_pydir=%{py_sitedir}/libsvn \
310         swig_pydir_extra=%{py_sitedir}/svn
311 %endif
312 # perl
313 %if %{with perl}
314 %{__make} swig-pl-lib
315 odir=$(pwd)
316 cd subversion/bindings/swig/perl/native
317 %{__perl} Makefile.PL INSTALLDIRS=vendor
318 %{__make}
319 cd $odir
320 %endif
321 %endif
322
323 %install
324 rm -rf $RPM_BUILD_ROOT
325 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
326         $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}} \
327         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
328         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
329
330 %{__make} install \
331 %if !%{with net_client_only} && %{with python}
332         install-swig-py \
333 %endif
334         DESTDIR=$RPM_BUILD_ROOT \
335         swig_pydir=%{py_sitedir}/libsvn \
336         swig_pydir_extra=%{py_sitedir}/svn
337
338 %if !%{with net_client_only} && %{with perl}
339 %{__make} install-swig-pl-lib \
340         DESTDIR=$RPM_BUILD_ROOT
341 odir=$(pwd)
342 cd subversion/bindings/swig/perl/native
343 %{__make} install \
344         DESTDIR=$RPM_BUILD_ROOT \
345         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
346         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
347 cd $odir
348 %endif
349
350 %if %{with apache}
351 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
352 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
353 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
354 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
355 %endif
356
357 %if !%{with net_client_only}
358 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
359 %if %{with python}
360 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
361 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
362 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
363 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
364 %endif
365 %endif
366
367 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
368 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
369
370 %find_lang %{name}
371
372 %clean
373 rm -rf $RPM_BUILD_ROOT
374
375 %post devel
376 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
377
378 %postun devel
379 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
380
381 %post   libs -p /sbin/ldconfig
382 %postun libs -p /sbin/ldconfig
383 %post   -n python-subversion -p /sbin/ldconfig
384 %postun -n perl-subversion -p /sbin/ldconfig
385
386 %post svnserve
387 if [ -f /var/lock/subsys/svnserve ]; then
388         /etc/rc.d/init.d/svnserve restart 1>&2
389 else
390         echo "Run \"/etc/rc.d/init.d/svnserve start\" to start subversion svnserve daemon."
391 fi
392 %preun svnserve
393 if [ "$1" = "0" ]; then
394         if [ -f /var/lock/subsys/svnserve ]; then
395                 /etc/rc.d/init.d/svnserve restart 1>&2
396         fi
397 fi
398
399
400 %post -n apache-mod_dav_svn
401 if [ -f /var/lock/subsys/httpd ]; then
402         /etc/rc.d/init.d/httpd restart 1>&2
403 else
404         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache HTTP daemon."
405 fi
406
407 %preun -n apache-mod_dav_svn
408 if [ "$1" = "0" ]; then
409         if [ -f /var/lock/subsys/httpd ]; then
410                 /etc/rc.d/init.d/httpd restart 1>&2
411         fi
412 fi
413
414 %files
415 %defattr(644,root,root,755)
416 %doc BUGS CHANGES COPYING INSTALL README
417 %doc doc/*/*.html
418 %doc tools/hook-scripts/*.{pl,py,example}
419 %doc tools/hook-scripts/mailer/*.{py,example}
420 %doc tools/xslt/*
421 %attr(755,root,root) %{_bindir}/svn*
422 %exclude %{_bindir}/svnserve
423 %exclude %{_bindir}/svn-hot-backup
424 %{_mandir}/man1/*
425 %{_mandir}/man5/*
426 %{_mandir}/man8/*
427 %exclude %{_mandir}/man?/svnserve*
428 %{?with_internal_neon:%exclude %{_mandir}/man1/neon*}
429
430 %files libs -f %{name}.lang
431 %defattr(644,root,root,755)
432 %attr(755,root,root) %{_libdir}/lib*.so.*
433 %if %{with perl} || %{with python}
434 %exclude %{_libdir}/lib*_swig_*.so.*
435 %endif
436
437 %files devel
438 %defattr(644,root,root,755)
439 %{_includedir}/%{name}*
440 %attr(755,root,root) %{_libdir}/lib*.so
441 %{_libdir}/lib*.la
442 %{_examplesdir}/%{name}-%{version}
443
444 %files static
445 %defattr(644,root,root,755)
446 %{_libdir}/lib*.a
447
448 %if !%{with net_client_only}
449 %files svnserve
450 %defattr(644,root,root,755)
451 %attr(755,root,root) %{_bindir}/svnserve
452 %{_mandir}/man?/svnserve*
453 %dir /home/services/subversion
454 %dir /home/services/subversion/repos
455 %if %{with apache}
456 %attr(754,root,root) /etc/rc.d/init.d/svnserve
457 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/svnserve
458 %endif
459
460 %files tools
461 %defattr(644,root,root,755)
462 %attr(755,root,root) %{_bindir}/svn-hot-backup
463
464 %files -n bash-completion-subversion
465 %defattr(644,root,root,755)
466 /etc/bash_completion.d/%{name}
467
468 %if %{with python}
469 %files -n python-subversion
470 %defattr(644,root,root,755)
471 %doc tools/backup/*.py tools/examples/*.py
472 %dir %{py_sitedir}/svn
473 %dir %{py_sitedir}/libsvn
474 %{py_sitedir}/svn/*.py[co]
475 %{py_sitedir}/libsvn/*.py[co]
476 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
477 %{_examplesdir}/python-%{name}-%{version}
478 %attr(755,root,root) %{_libdir}/lib*_swig_py*.so.*
479 %endif
480
481 %if %{with perl}
482 %files -n perl-subversion
483 %defattr(644,root,root,755)
484 %{perl_vendorarch}/SVN
485 %dir %{perl_vendorarch}/auto/SVN
486 %dir %{perl_vendorarch}/auto/SVN/*
487 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
488 %{perl_vendorarch}/auto/SVN/*/*.bs
489 %{_mandir}/man3/*.3pm*
490 %attr(755,root,root) %{_libdir}/lib*_swig_perl*.so.*
491 %endif
492
493 %if %{with apache}
494 %files -n apache-mod_dav_svn
495 %defattr(644,root,root,755)
496 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
497 %attr(755,root,root) %{_apachelibdir}/mod_dav_svn.so
498
499 %files -n apache-mod_authz_svn
500 %defattr(644,root,root,755)
501 %doc subversion/mod_authz_svn/INSTALL
502 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
503 %attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
504 %endif
505 %endif
This page took 0.059208 seconds and 4 git commands to generate.