]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- rel 2; disable jikes usage (we prefer regular java* to be used)
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - remove net_client_only and add db bcond (then without apache and
3 #   without db => net_client_only - spec will be more simpler, I think)
4 # - finish ruby
5 # - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
6 #
7 # Conditional build:
8 %bcond_with     net_client_only         # build only net client
9 %bcond_without  neon                    # use serf instead of neon
10 %bcond_without  python                  # build without python bindings (broken)
11 %bcond_without  perl                    # build without perl bindings
12 %bcond_without  ruby                    # build without ruby bindings
13 %bcond_without  apache                  # build without apache support (webdav, etc)
14 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
15 %bcond_without  tests                   # don't perform "make check"
16 %bcond_without  kwallet                 # build without kde4 wallet support
17 %bcond_without  gnome                   # build without gnome keyring support
18 #
19 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
20 %define apxs    /usr/sbin/apxs
21 %define pdir    SVN
22 %define pnam    _Core
23 #
24 %if %{with neon}
25 %define webdavlib       neon
26 %else
27 %define webdavlib       serf
28 %endif
29 #
30 Summary:        A Concurrent Versioning system similar to but better than CVS
31 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
32 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
33 Name:           subversion
34 Version:        1.6.11
35 Release:        2
36 License:        Apache/BSD-like
37 Group:          Development/Version Control
38 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
39 # Source0-md5:  75419159b50661092c4137449940b5cc
40 Source1:        %{name}-dav_svn.conf
41 Source2:        %{name}-authz_svn.conf
42 Source3:        %{name}-svnserve.init
43 Source4:        %{name}-svnserve.sysconfig
44 # current subversion tarball has correct *.swg files
45 # but after regeneration these are broken again, so
46 # we still need this script
47 Source5:        %{name}-convert-typemaps-to-ifdef.py
48 Patch0:         %{name}-home_etc.patch
49 Patch1:         %{name}-DESTDIR.patch
50 Patch2:         %{name}-ruby-datadir-path.patch
51 URL:            http://subversion.apache.org/
52 %if %{with net_client_only}
53 %global apache_modules_api 0
54 %else
55 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
56 BuildRequires:  automake
57 BuildRequires:  db-devel >= 4.1.25
58 BuildRequires:  rpmbuild(macros) >= 1.268
59 %if %{with perl}
60 BuildRequires:  perl-devel >= 1:5.8.0
61 BuildRequires:  rpm-perlprov >= 4.1-13
62 BuildRequires:  swig-perl >= 1.3.24
63 %endif
64 %if %{with python}
65 BuildRequires:  python-ctypesgen
66 BuildRequires:  python-devel >= 2.2
67 BuildRequires:  swig-python >= 1.3.24
68 %endif
69 %if %{with ruby}
70 BuildRequires:  ruby-devel
71 BuildRequires:  swig-ruby >= 1.3.24
72 %endif
73 %if %{with javahl}
74 BuildRequires:  jdk
75 %endif
76 BuildRequires:  cyrus-sasl-devel
77 %endif
78 BuildRequires:  apr-devel >= 1:1.0.0
79 BuildRequires:  apr-util-devel >= 1:1.2.8-3
80 BuildRequires:  autoconf >= 2.59
81 BuildRequires:  bison
82 BuildRequires:  expat-devel
83 BuildRequires:  gettext-devel
84 %{?with_gnome:BuildRequires:    gnome-keyring-devel}
85 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
86 BuildRequires:  libtool >= 1.4-9
87 BuildRequires:  pkgconfig
88 BuildRequires:  sed >= 4.0
89 BuildRequires:  sqlite3-devel >= 3.6.11
90 BuildRequires:  texinfo
91 BuildRequires:  which
92 %if %{with neon}
93 BuildRequires:  neon-devel >= 0.26.0
94 %else
95 BuildRequires:  serf-devel
96 %endif
97 BuildRequires:  python >= 2.2
98 BuildRequires:  python-modules >= 2.2
99 Requires:       %{name}-libs = %{version}-%{release}
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %define         _libexecdir             %{_libdir}/svn
103 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
104 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
105
106 %description
107 The goal of the Subversion project is to build a version control
108 system that is a compelling replacement for CVS in the open source
109 community.
110
111 Our goals are:
112 - All current CVS features.
113 - Directories, renames, and file meta-data are versioned.
114 - Symbolic links, etc, are supported
115 - Commits are truly atomic.
116 - Branching and tagging are cheap (constant time) operations
117 - Repeated merges are handled gracefully
118 - Support for plug-in client side diff programs
119 - Natively client/server
120 - Client/server protocol sends diffs in both directions
121 - Costs are proportional to change size, not project size
122 - Internationalization
123 - Progressive multi-lingual support
124
125 %description -l pl.UTF-8
126 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
127 zamiennika dla CVS.
128
129 Cele projektu to:
130 - Wszystkie aktualne możliwości CVS.
131 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
132 - Obsługa dowiązań symbolicznych itp.
133 - Commity są w pełni atomowe.
134 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
135 - Dobra obsługa powtarzanego łączenia (merge).
136 - Obsługa wtyczek diff po stronie klienta.
137 - Natywny klient/serwer.
138 - Klient/Serwer przesyłają diffy w obu kierunkach.
139 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
140 - Internacjonalizacja.
141 - Postępujące wsparcie dla wielu języków.
142
143 %description -l pt_BR.UTF-8
144 O objetivo do projeto Subversion é construir um sistema de controle de
145 versões que seja um substituto para o CVS (Concurrent Versioning
146 System) na comunidade opensource, fornecendo grandes melhorias.
147
148 %package libs
149 Summary:        Subversion libraries and modules
150 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
151 Group:          Libraries
152 %{?with_neon:Requires:  neon >= 0.26.0}
153 Obsoletes:      libsubversion0
154
155 %description libs
156 Subversion libraries and modules.
157
158 %description libs -l pl.UTF-8
159 Biblioteka subversion oraz ładowalne moduły.
160
161 %package devel
162 Summary:        Header files and develpment documentation for subversion
163 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
164 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
165 Group:          Development/Libraries
166 Requires:       %{name}-libs = %{version}-%{release}
167 Requires:       apr-util-devel >= 1:1.0.0
168 %{?with_neon:Requires:  neon-devel >= 0.26.0}
169 Obsoletes:      libsubversion0-devel
170
171 %description devel
172 Header files and develpment documentation for subversion.
173
174 %description devel -l pl.UTF-8
175 Pliki nagłówkowe i dokumetacja do subversion.
176
177 %description devel -l pt_BR.UTF-8
178 Este pacote provê os arquivos necessários para desenvolvedores
179 interagirem com o Subversion.
180
181 %package static
182 Summary:        Static subversion library
183 Summary(pl.UTF-8):      Biblioteka statyczna subversion
184 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
185 Group:          Development/Libraries
186 Requires:       %{name}-devel = %{version}
187 Obsoletes:      libsubversion0-static-devel
188
189 %description static
190 Static subversion library.
191
192 %description static -l pl.UTF-8
193 Biblioteka statyczna subversion.
194
195 %description static -l pt_BR.UTF-8
196 Este pacote provê um cliente estático do subversion.
197
198 %package svnserve
199 Summary:        Subversion svnserve
200 Summary(pl.UTF-8):      Subversion svnserve
201 Group:          Networking/Daemons
202 Requires(post,preun):   /sbin/chkconfig
203 Requires(postun):       /usr/sbin/groupdel
204 Requires(postun):       /usr/sbin/userdel
205 Requires(pre):  /bin/id
206 Requires(pre):  /usr/bin/getgid
207 Requires(pre):  /usr/lib/rpm/user_group.sh
208 Requires(pre):  /usr/sbin/groupadd
209 Requires(pre):  /usr/sbin/useradd
210 Requires(pre):  /usr/sbin/usermod
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       rc-scripts
213 Provides:       group(svn)
214 Provides:       user(svn)
215
216 %description svnserve
217 Subversion svnserve server.
218
219 %description svnserve -l pl.UTF-8
220 Serwer subversion svnserve.
221
222 %package tools
223 Summary:        Subversion tools and scripts
224 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
225 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
226 Group:          Applications
227 %pyrequires_eq  python
228 Requires:       %{name} = %{version}-%{release}
229 Requires:       python-subversion = %{version}
230
231 %description tools
232 Subversion tools and scripts.
233
234 %description tools -l pl.UTF-8
235 Narzędzia oraz skrypty dla subversion.
236
237 %package -n bash-completion-subversion
238 Summary:        bash completion for subversion
239 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
240 Group:          Applications/Shells
241 Requires:       %{name} = %{version}-%{release}
242 Requires:       bash-completion
243 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
244
245 %description -n bash-completion-subversion
246 Bash completion for subversion.
247
248 %description -n bash-completion-subversion -l pl.UTF-8
249 Dopełnienia basha dla subversion.
250
251 %package -n java-subversion
252 Summary:        Subversion Java bindings
253 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
254 Group:          Development/Languages/Java
255 Requires:       %{name}-libs = %{version}-%{release}
256
257 %description -n java-subversion
258 This is a set of Java classes which provide the functionality of
259 subversion-libs, the Subversion libraries. It is useful if you want
260 to, for example, write a Java class that manipulates a Subversion
261 repository or working copy. See the 'subversion' package for more
262 information.
263
264 %description -n java-subversion -l pl.UTF-8
265 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
266 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
267 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
268 roboczą. Więcej informacji w pakiecie subversion.
269
270 %package -n python-subversion
271 Summary:        Subversion Python bindings
272 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
273 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
274 Group:          Development/Languages/Python
275 %pyrequires_eq  python
276 Requires:       %{name}-libs = %{version}-%{release}
277 Obsoletes:      subversion-python
278
279 %description -n python-subversion
280 Subversion Python bindings.
281
282 %description -n python-subversion -l pl.UTF-8
283 Dowiązania do Subversion dla Pythona.
284
285 %description -n python-subversion -l pt_BR.UTF-8
286 Módulos Python para acessar os recursos do Subversion.
287
288 %package -n python-csvn
289 Summary:        CTypes Subversion Python bindings
290 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
291 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
292 Group:          Development/Languages/Python
293 %pyrequires_eq  python
294 Requires:       %{name}-libs = %{version}-%{release}
295
296 %description -n python-csvn
297 Subversion CTypes Python bindings.
298
299 %description -n python-csvn -l pl.UTF-8
300 Dowiązania do Subversion dla Pythona używające CTypes.
301
302 %description -n python-csvn -l pt_BR.UTF-8
303 Módulos Python para acessar os recursos do Subversion.
304
305 %package -n perl-subversion
306 Summary:        Subversion Perl bindings
307 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
308 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
309 Group:          Development/Languages/Perl
310 Requires:       %{name}-libs = %{version}-%{release}
311 Obsoletes:      subversion-perl
312
313 %description -n perl-subversion
314 Subversion Perl bindings.
315
316 %description -n perl-subversion -l pl.UTF-8
317 Dowiązania do Subversion dla Perla.
318
319 %description -n perl-subversion -l pt_BR.UTF-8
320 Módulos Perl para acessar os recursos do Subversion.
321
322 %package -n ruby-subversion
323 Summary:        Subversion Ruby bindings
324 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
325 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
326 Group:          Development/Languages
327 Requires:       %{name}-libs = %{version}-%{release}
328 Obsoletes:      subversion-ruby
329
330 %description -n ruby-subversion
331 Subversion Ruby bindings.
332
333 %description -n ruby-subversion -l pl.UTF-8
334 Dowiązania do Subversion dla języka Ruby.
335
336 %description -n ruby-subversion -l pt_BR.UTF-8
337 Módulos Ruby para acessar os recursos do Subversion.
338
339 %package -n apache-mod_dav_svn
340 Summary:        Apache module: Subversion Server
341 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
342 Group:          Networking/Daemons
343 Requires:       %{name} = %{version}-%{release}
344 Requires:       apache(modules-api) = %apache_modules_api
345 Requires:       apache-mod_dav
346
347 %description -n apache-mod_dav_svn
348 Apache module: Subversion Server.
349
350 %description -n apache-mod_dav_svn -l pl.UTF-8
351 Moduł apache: Serwer Subversion.
352
353 %package -n apache-mod_authz_svn
354 Summary:        Apache module: Subversion Server - path-based authorization
355 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
356 Group:          Networking/Daemons
357 Requires:       apache(modules-api) = %apache_modules_api
358 Requires:       apache-mod_dav_svn = %{version}-%{release}
359
360 %description -n apache-mod_authz_svn
361 Apache module: Subversion Server - path-based authorization.
362
363 %description -n apache-mod_authz_svn -l pl.UTF-8
364 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
365
366 %package -n gnome-keyring-subversion
367 Summary:        Subversion module for Gnome Keyring
368 Summary(pl.UTF-8):      Moduł subversion dla zarządcy kluczy Gnome
369 Group:          X11/Applications
370
371 %description -n gnome-keyring-subversion
372 Subversion module for Gnome Keyring.
373
374 %description -n gnome-keyring-subversion -l pl.UTF-8
375 Moduł subversion dla zarządcy kluczy Gnome.
376
377 %package -n kde4-kwallet-subversion
378 Summary:        Subversion module for KDE Wallet
379 Summary(pl.UTF-8):      Moduł subversion dla Portfela KDE
380 Group:          X11/Applications
381
382 %description -n kde4-kwallet-subversion
383 Subversion module for KDE Wallet.
384
385 %description -n kde4-kwallet-subversion -l pl.UTF-8
386 Moduł subversion dla Portfela KDE.
387
388 %prep
389 %setup -q
390 rm -rf apr apr-util neon
391 %patch0 -p0
392 %patch1 -p1
393 %patch2 -p0
394
395 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
396
397 # serf.m4 macro is broken and ignores --without serf
398 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
399
400 %build
401 rm subversion/bindings/swig/proxy/*.swg
402 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
403 cp -f /usr/share/automake/config.sub ac-helpers
404 chmod +x ./autogen.sh && ./autogen.sh
405
406 %configure \
407         --with-editor=vi \
408         --with-zlib=%{_libdir} \
409 %if %{with net_client_only}
410         --without-apache \
411         --without-swig \
412         --without-apxs \
413         --without-berkeley-db \
414 %else
415         --disable-runtime-module-search \
416         --disable-mod-activation \
417         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
418 %if %{with apache}
419         --with-apxs=%{_sbindir}/apxs \
420 %else
421         --without-apache \
422         --without-apxs \
423 %endif
424 %if !%{with python} && !%{with perl} && !%{with ruby}
425         --without-swig \
426 %endif
427         %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
428         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
429 %endif
430         --with-jdk="%{java_home}" \
431         --without-jikes \
432 %if %{with neon}
433         --without-serf \
434         --with-neon=%{_prefix} \
435         --disable-neon-version-check \
436 %else
437         --with-serf=%{_prefix} \
438         --without-neon \
439 %endif
440         --with-apr=%{_bindir}/apr-1-config \
441         --with-apr-util=%{_bindir}/apu-1-config \
442 %if %{with kwallet}
443         --with-kwallet \
444 %endif
445 %if %{with gnome}
446         --with-gnome-keyring
447 %endif
448
449 %{__make} -j1
450
451 %if !%{with net_client_only}
452 # python
453 %if %{with python}
454 # ctypes bindings
455 %{__make} ctypes-python
456 # swig bindings
457 %{__make} swig-py \
458         swig_pydir=%{py_sitedir}/libsvn \
459         swig_pydir_extra=%{py_sitedir}/svn
460 %endif
461 # perl
462 %if %{with perl}
463 %{__make} -j1 swig-pl-lib
464 odir=$(pwd)
465 cd subversion/bindings/swig/perl/native
466 %{__perl} Makefile.PL INSTALLDIRS=vendor
467 %{__make} -j1
468 cd $odir
469 %endif
470 %if %{with javahl}
471 %{__make} -j1 javahl \
472         javahl_javadir="%{_javadir}"
473 %endif
474 # ruby
475 %if %{with ruby}
476 %{__make} swig-rb
477 %endif
478 %endif
479
480 %if %{with tests}
481 %{__make} check
482 %if %{with python}
483 %{__make} check-ctypes-python
484 %{__make} check-swig-py
485 %endif
486 %if %{with perl}
487 %{__make} check-swig-pl
488 %endif
489 %if %{with ruby}
490 %{__make} check-swig-rb
491 %endif
492 %endif
493
494 %install
495 rm -rf $RPM_BUILD_ROOT
496 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
497         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
498         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
499         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
500
501 %{__make} install -j1 \
502 %if %{with javahl}
503         install-javahl \
504         javahl_javadir="%{_javadir}" \
505 %endif
506 %if !%{with net_client_only}
507 %if %{with python}
508         install-swig-py \
509         install-ctypes-python \
510 %endif
511 %if %{with ruby}
512         install-swig-rb install-swig-rb-doc \
513 %endif
514 %endif
515         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
516         DESTDIR=$RPM_BUILD_ROOT \
517         swig_pydir=%{py_sitedir}/libsvn \
518         swig_pydir_extra=%{py_sitedir}/svn
519
520 %if !%{with net_client_only} && %{with perl}
521 %{__make} install-swig-pl-lib \
522         DESTDIR=$RPM_BUILD_ROOT
523 %{__make} -C subversion/bindings/swig/perl/native install \
524         DESTDIR=$RPM_BUILD_ROOT \
525         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
526         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
527 %endif
528
529 %if %{with apache}
530 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
531 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
532 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
533 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
534 %endif
535
536 %if !%{with net_client_only}
537 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
538 %if %{with python}
539 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
540 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
541 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
542 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
543 %endif
544 %endif
545
546 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
547 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
548
549 %find_lang %{name}
550
551 %{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
552 rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
553 rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
554
555 %clean
556 rm -rf $RPM_BUILD_ROOT
557
558 %pre svnserve
559 %groupadd -g 86 svn
560 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
561
562 %post   libs -p /sbin/ldconfig
563 %postun libs -p /sbin/ldconfig
564
565 %post   devel -p /sbin/postshell
566 -/usr/sbin/fix-info-dir -c %{_infodir}
567
568 %postun devel -p /sbin/postshell
569 -/usr/sbin/fix-info-dir -c %{_infodir}
570
571 %post   -n perl-subversion -p /sbin/ldconfig
572 %postun -n perl-subversion -p /sbin/ldconfig
573
574 %post   -n python-subversion -p /sbin/ldconfig
575 %postun -n python-subversion -p /sbin/ldconfig
576
577 %post svnserve
578 /sbin/chkconfig --add svnserve
579 %service svnserve restart "svnserve daemon"
580
581 %preun svnserve
582 if [ "$1" = "0" ]; then
583         %service svnserve stop
584         /sbin/chkconfig --del svnserve
585 fi
586
587 %postun svnserve
588 if [ "$1" = "0" ]; then
589         %userremove svn
590         %groupremove svn
591 fi
592
593 %post -n apache-mod_dav_svn
594 %service -q httpd restart
595
596 %postun -n apache-mod_dav_svn
597 if [ "$1" = "0" ]; then
598         %service -q httpd restart
599 fi
600
601 %post -n apache-mod_authz_svn
602 %service -q httpd restart
603
604 %postun -n apache-mod_authz_svn
605 if [ "$1" = "0" ]; then
606         %service -q httpd restart
607 fi
608
609 %files
610 %defattr(644,root,root,755)
611 %doc BUGS CHANGES COPYING INSTALL README
612 %doc doc/*/*.html
613 %doc tools/hook-scripts/*.{pl,py,example}
614 %doc tools/hook-scripts/mailer/*.{py,example}
615 %doc tools/xslt/*
616 %attr(755,root,root) %{_bindir}/svn
617 %attr(755,root,root) %{_bindir}/svnadmin
618 %attr(755,root,root) %{_bindir}/svndumpfilter
619 %attr(755,root,root) %{_bindir}/svnlook
620 %attr(755,root,root) %{_bindir}/svnsync
621 %attr(755,root,root) %{_bindir}/svnversion
622 %{_mandir}/man1/svn.1*
623 %{_mandir}/man1/svnadmin.1*
624 %{_mandir}/man1/svndumpfilter.1*
625 %{_mandir}/man1/svnlook.1*
626 %{_mandir}/man1/svnsync.1*
627 %{_mandir}/man1/svnversion.1*
628
629 %files libs -f %{name}.lang
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
632 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
633 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
634 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
635 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
636 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
637 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
638 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
639 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
640 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
641 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
642 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
643 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
644 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
645 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
646 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
647 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
648 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
649 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
650 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
651 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
652 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
653 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
654 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
655 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
656 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
657 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
658 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
659
660 %files devel
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
663 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
664 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
665 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
666 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
667 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
668 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
669 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
670 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
671 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
672 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
673 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
674 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
675 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
676 %{_libdir}/libsvn_client-1.la
677 %{_libdir}/libsvn_delta-1.la
678 %{_libdir}/libsvn_diff-1.la
679 %{_libdir}/libsvn_fs-1.la
680 %{_libdir}/libsvn_fs_base-1.la
681 %{_libdir}/libsvn_fs_fs-1.la
682 %{_libdir}/libsvn_fs_util-1.la
683 %{_libdir}/libsvn_ra-1.la
684 %{_libdir}/libsvn_ra_local-1.la
685 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
686 %{_libdir}/libsvn_ra_svn-1.la
687 %{_libdir}/libsvn_repos-1.la
688 %{_libdir}/libsvn_subr-1.la
689 %{_libdir}/libsvn_wc-1.la
690 %{_includedir}/%{name}-1
691 %{_examplesdir}/%{name}-%{version}
692
693 %files static
694 %defattr(644,root,root,755)
695 %{_libdir}/libsvn_client-1.a
696 %{_libdir}/libsvn_delta-1.a
697 %{_libdir}/libsvn_diff-1.a
698 %{_libdir}/libsvn_fs-1.a
699 %{_libdir}/libsvn_fs_base-1.a
700 %{_libdir}/libsvn_fs_fs-1.a
701 %{_libdir}/libsvn_fs_util-1.a
702 %{_libdir}/libsvn_ra-1.a
703 %{_libdir}/libsvn_ra_local-1.a
704 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
705 %{_libdir}/libsvn_ra_svn-1.a
706 %{_libdir}/libsvn_repos-1.a
707 %{_libdir}/libsvn_subr-1.a
708 %{_libdir}/libsvn_wc-1.a
709
710 %if %{with gnome}
711 %files -n gnome-keyring-subversion
712 %defattr(644,root,root,755)
713 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
714 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
715 %endif
716
717 %if %{with kwallet}
718 %files -n kde4-kwallet-subversion
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
721 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
722 %endif
723
724 %if !%{with net_client_only}
725 %files svnserve
726 %defattr(644,root,root,755)
727 %attr(755,root,root) %{_bindir}/svnserve
728 %{_mandir}/man5/svnserve.conf.5*
729 %{_mandir}/man8/svnserve.8*
730 %dir %attr(750,svn,svn) /home/services/subversion
731 %dir %attr(750,svn,svn) /home/services/subversion/repos
732 %if %{with apache}
733 %attr(754,root,root) /etc/rc.d/init.d/svnserve
734 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
735 %endif
736
737 %files tools
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_bindir}/svn-hot-backup
740
741 %files -n bash-completion-subversion
742 %defattr(644,root,root,755)
743 /etc/bash_completion.d/%{name}
744
745 %if %{with javahl}
746 %files -n java-subversion
747 %defattr(644,root,root,755)
748 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
749 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
750 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
751 %{_javadir}/svn-javahl.jar
752 %endif
753
754 %if %{with python}
755 %files -n python-subversion
756 %defattr(644,root,root,755)
757 %doc tools/backup/*.py tools/examples/*.py
758 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
759 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
760 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
761 %dir %{py_sitedir}/libsvn
762 %{py_sitedir}/libsvn/*.py[co]
763 %dir %{py_sitedir}/svn
764 %{py_sitedir}/svn/*.py[co]
765 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
766 %{_examplesdir}/python-%{name}-%{version}
767
768 %files -n python-csvn
769 %defattr(644,root,root,755)
770 %doc subversion/bindings/ctypes-python/{README,TODO}
771 %doc subversion/bindings/ctypes-python/examples/*.py
772 %dir %{py_sitescriptdir}/csvn
773 %{py_sitescriptdir}/csvn/*.py[co]
774 %dir %{py_sitescriptdir}/csvn/core
775 %{py_sitescriptdir}/csvn/core/*.py[co]
776 %dir %{py_sitescriptdir}/csvn/ext
777 %{py_sitescriptdir}/csvn/ext/*.py[co]
778 %{py_sitescriptdir}/*.egg-info
779 %endif
780
781 %if %{with perl}
782 %files -n perl-subversion
783 %defattr(644,root,root,755)
784 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
785 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
786 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
787 %{perl_vendorarch}/SVN
788 %dir %{perl_vendorarch}/auto/SVN
789 %dir %{perl_vendorarch}/auto/SVN/*
790 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
791 %{perl_vendorarch}/auto/SVN/*/*.bs
792 %{_mandir}/man3/*.3pm*
793 %endif
794
795 %if %{with ruby}
796 %files -n ruby-subversion
797 %defattr(644,root,root,755)
798 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
799 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
800 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
801 %dir %{ruby_sitelibdir}/svn
802 %{ruby_sitelibdir}/svn/*.rb
803 %dir %{ruby_sitearchdir}/svn
804 %dir %{ruby_sitearchdir}/svn/ext
805 %attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
806 %{ruby_ridir}/Svn
807 %endif
808
809 %if %{with apache}
810 %files -n apache-mod_dav_svn
811 %defattr(644,root,root,755)
812 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
813 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
814
815 %files -n apache-mod_authz_svn
816 %defattr(644,root,root,755)
817 %doc subversion/mod_authz_svn/INSTALL
818 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
819 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
820 %endif
821
822 %endif # net_client_only
This page took 0.090222 seconds and 4 git commands to generate.