]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- up to 1.3.1
[packages/subversion.git] / subversion.spec
1 #
2 # todo:
3 # - remove net_client_only and add db bcond (then without apache and
4 #   without db => net_client_only - spec will be more simpler, I think)
5 #
6 # Conditional build:
7 %bcond_with     net_client_only                 # build only net client
8 %bcond_without  python                          # build without python bindings
9 %bcond_without  perl                            # build without perl bindings
10 %bcond_without  apache                          # build without apache support (webdav, etc)
11 #
12 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
13 %define apxs    /usr/sbin/apxs
14 Summary:        A Concurrent Versioning system similar to but better than CVS
15 Summary(pl):    System kontroli wersji podobny, ale lepszy, ni¿ CVS
16 Summary(pt_BR): Sistema de versionamento concorrente
17 Name:           subversion
18 Version:        1.3.1
19 Release:        1
20 License:        Apache/BSD Style
21 Group:          Development/Version Control
22 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.gz
23 # Source0-md5:  6d650e918255596ef8b74255b3938547
24 Source1:        %{name}-dav_svn.conf
25 Source2:        %{name}-authz_svn.conf
26 Source3:        %{name}-svnserve.init
27 Source4:        %{name}-svnserve.sysconfig
28 Patch0:         %{name}-home_etc.patch
29 Patch1:         %{name}-DESTDIR.patch
30 Patch2:         %{name}-neon.patch
31 URL:            http://subversion.tigris.org/
32 %if %{with net_client_only}
33 %global apache_modules_api 0
34 %else
35 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
36 BuildRequires:  automake
37 BuildRequires:  db-devel >= 4.1.25
38 BuildRequires:  rpmbuild(macros) >= 1.268
39 %if %{with perl}
40 BuildRequires:  perl-devel >= 1:5.8.0
41 BuildRequires:  rpm-perlprov >= 4.1-13
42 BuildRequires:  swig-perl >= 1.3.24
43 %endif
44 %endif
45 BuildRequires:  apr-devel >= 1:1.0.0
46 BuildRequires:  apr-util-devel >= 1:1.0.0
47 BuildRequires:  autoconf >= 2.59
48 BuildRequires:  bison
49 BuildRequires:  expat-devel
50 BuildRequires:  gettext-devel
51 BuildRequires:  libtool >= 1.4-9
52 BuildRequires:  neon-devel >= 0.26.0
53 %if %{with python}
54 BuildRequires:  python >= 2.2
55 BuildRequires:  python-devel >= 2.2
56 BuildRequires:  python-modules >= 2.2
57 BuildRequires:  sed >= 4.0
58 BuildRequires:  swig-python >= 1.3.24
59 %endif
60 BuildRequires:  texinfo
61 BuildRequires:  which
62 Requires:       %{name}-libs = %{version}-%{release}
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %define         _apachelibdir   %(%{apxs} -q LIBEXECDIR 2>/dev/null)
66 %define         _libexecdir             %{_libdir}/svn
67
68 %description
69 The goal of the Subversion project is to build a version control
70 system that is a compelling replacement for CVS in the open source
71 community.
72
73 Our goals are:
74 - All current CVS features.
75 - Directories, renames, and file meta-data are versioned.
76 - Symbolic links, etc, are supported
77 - Commits are truly atomic.
78 - Branching and tagging are cheap (constant time) operations
79 - Repeated merges are handled gracefully
80 - Support for plug-in client side diff programs
81 - Natively client/server
82 - Client/server protocol sends diffs in both directions
83 - Costs are proportional to change size, not project size
84 - Internationalization
85 - Progressive multi-lingual support
86
87 %description -l pl
88 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
89 zamiennika dla CVS.
90
91 Cele projektu to:
92 - Wszystkie aktualne mo¿liwo¶ci CVS.
93 - Katalogi, zmiany nazw oraz meta-dane plików s± wersjonowane.
94 - Wsparcie dla linków symbolicznych itp.
95 - Commity s± w pe³ni atomowe.
96 - Branchowanie oraz tagowanie s± tanimi (sta³ymi w czasie) operacjami.
97 - Powtarzaj±ce merge.
98 - Wsparcie dla pluginów diff'a po stronie klienta.
99 - Natywny klient/serwer.
100 - Klient/Serwer przesy³aj± diffy w obu kierunkach.
101 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
102 - Internacjonalizacja.
103 - Postêpuj±ce wsparcie dla wielu jêzyków.
104
105 %description -l pt_BR
106 O objetivo do projeto Subversion é construir um sistema de controle de
107 versões que seja um substituto para o CVS (Concurrent Versioning
108 System) na comunidade opensource, fornecendo grandes melhorias.
109
110 %package libs
111 Summary:        Subversion libraries and modules
112 Summary(pl):    Biblioteka subversion oraz ³adowalne modu³y
113 Group:          Libraries
114 Requires:       neon >= 0.24.7
115 Obsoletes:      libsubversion0
116
117 %description libs
118 Subversion libraries and modules.
119
120 %description libs -l pl
121 Biblioteka subversion oraz ³adowalne modu³y.
122
123 %package devel
124 Summary:        Header files and develpment documentation for subversion
125 Summary(pl):    Pliki nag³ówkowe i dokumetacja do subversion
126 Summary(pt_BR): Arquivos de desenvolvimento para o Subversion
127 Group:          Development/Libraries
128 Requires:       %{name}-libs = %{version}-%{release}
129 Requires:       apr-util-devel >= 1:1.0.0
130 Requires:       neon-devel >= 0.24.7
131 Obsoletes:      libsubversion0-devel
132
133 %description devel
134 Header files and develpment documentation for subversion.
135
136 %description devel -l pl
137 Pliki nag³ówkowe i dokumetacja do subversion.
138
139 %description devel -l pt_BR
140 Este pacote provê os arquivos necessários para desenvolvedores
141 interagirem com o Subversion.
142
143 %package static
144 Summary:        Static subversion library
145 Summary(pl):    Biblioteka statyczna subversion
146 Summary(pt_BR): Sistema de versionamento concorrente
147 Group:          Development/Libraries
148 Requires:       %{name}-devel = %{version}
149 Obsoletes:      libsubversion0-static-devel
150
151 %description static
152 Static subversion library.
153
154 %description static -l pl
155 Biblioteka statyczna subversion.
156
157 %description static -l pt_BR
158 Este pacote provê um cliente estático do subversion.
159
160 %package svnserve
161 Summary:        Subversion svnserve
162 Summary(pl):    Subversion svnserve
163 Group:          Networking/Daemons
164 Requires(post,preun):   /sbin/chkconfig
165 Requires:       %{name} = %{version}-%{release}
166 Requires:       rc-scripts
167
168 %description svnserve
169 Subversion svnserve server.
170
171 %description svnserve -l pl
172 Serwer subversion svnserve.
173
174 %package tools
175 Summary:        Subversion tools and scripts
176 Summary(pl):    Narzêdzia oraz skrypty dla subversion
177 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
178 Group:          Applications
179 %pyrequires_eq  python
180 Requires:       %{name} = %{version}-%{release}
181 Requires:       python-rcsparse >= 0.1-0.20031026.0
182 Requires:       python-subversion = %{version}
183
184 %description tools
185 Subversion tools and scripts.
186
187 %description tools -l pl
188 Narzêdzia oraz skrypty dla subversion.
189
190 %package -n bash-completion-subversion
191 Summary:        bash completion for subversion
192 Summary(pl):    Dope³nienia basha dla subversion
193 Group:          Applications/Shells
194 Requires:       %{name} = %{version}-%{release}
195 Requires:       bash-completion
196 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
197
198 %description -n bash-completion-subversion
199 Bash completion for subversion.
200
201 %description -n bash-completion-subversion -l pl
202 Dope³nienia basha dla subversion.
203
204 %package -n python-subversion
205 Summary:        Subversion python bindings
206 Summary(pl):    Dowi±zania do subversion dla pythona
207 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
208 Group:          Development/Languages/Python
209 %pyrequires_eq  python
210 Requires:       %{name}-libs = %{version}-%{release}
211 Obsoletes:      subversion-python
212
213 %description -n python-subversion
214 Subversion python bindings.
215
216 %description -n python-subversion -l pl
217 Dowi±zania do subversion dla pythona.
218
219 %description -n python-subversion -l pt_BR
220 Módulos python para acessar os recursos do Subversion.
221
222 %package -n perl-subversion
223 Summary:        Subversion perl bindings
224 Summary(pl):    Dowi±zania do subversion dla perla
225 Summary(pt_BR): Módulos perl para acessar os recursos do Subversion
226 Group:          Development/Languages/Perl
227 Requires:       %{name}-libs = %{version}-%{release}
228 Obsoletes:      subversion-perl
229
230 %description -n perl-subversion
231 Subversion perl bindings.
232
233 %description -n perl-subversion -l pl
234 Dowi±zania do subversion dla perl.
235
236 %description -n perl-subversion -l pt_BR
237 Módulos perl para acessar os recursos do Subversion.
238
239 %package -n apache-mod_dav_svn
240 Summary:        Apache module: Subversion Server
241 Summary(pl):    Modu³ apache: Serwer Subversion
242 Group:          Networking/Daemons
243 Requires:       %{name} = %{version}-%{release}
244 Requires:       apache(modules-api) = %apache_modules_api
245 Requires:       apache-mod_dav
246
247 %description -n apache-mod_dav_svn
248 Apache module: Subversion Server.
249
250 %description -n apache-mod_dav_svn -l pl
251 Modu³ apache: Serwer Subversion.
252
253 %package -n apache-mod_authz_svn
254 Summary:        Apache module: Subversion Server - path-based authorization
255 Summary(pl):    Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion
256 Group:          Networking/Daemons
257 Requires:       apache(modules-api) = %apache_modules_api
258 Requires:       apache-mod_dav_svn = %{version}-%{release}
259
260 %description -n apache-mod_authz_svn
261 Apache module: Subversion Server - path-based authorization.
262
263 %description -n apache-mod_authz_svn -l pl
264 Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion.
265
266 %prep
267 %setup -q
268 rm -rf apr apr-util neon
269 %patch0 -p0
270 %patch1 -p1
271 %patch2 -p1
272
273 %build
274 cp -f /usr/share/automake/config.sub ac-helpers
275 chmod +x ./autogen.sh && ./autogen.sh
276
277 # don't enable dso - currently it's broken
278 %configure \
279         --with-editor=vi \
280         --with-zlib \
281         --with-python=%{_bindir}/python \
282         --with-perl5=%{_bindir}/perl \
283 %if %{with net_client_only}
284         --without-apache \
285         --without-swig \
286         --without-apxs \
287         --without-berkeley-db \
288 %else
289         --disable-dso \
290         --disable-mod-activation \
291 %if %{with apache}
292         --with-apxs=%{_sbindir}/apxs \
293 %else
294         --without-apache \
295         --without-apxs \
296         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
297 %endif
298 %if !%{with python} && !%{with perl}
299         --without-swig \
300 %endif
301 %endif
302         --with-neon=%{_prefix} \
303         --disable-neon-version-check \
304         --with-apr=%{_bindir}/apr-1-config \
305         --with-apr-util=%{_bindir}/apu-1-config
306
307 %{__make}
308
309 %if !%{with net_client_only}
310 # python
311 %if %{with python}
312 %{__make} swig-py \
313         swig_pydir=%{py_sitedir}/libsvn \
314         swig_pydir_extra=%{py_sitedir}/svn
315 %endif
316 # perl
317 %if %{with perl}
318 %{__make} swig-pl-lib
319 odir=$(pwd)
320 cd subversion/bindings/swig/perl/native
321 %{__perl} Makefile.PL INSTALLDIRS=vendor
322 %{__make}
323 cd $odir
324 %endif
325 %endif
326
327 %{__sed} -i -e 's/@SVN_DB_INCLUDES@//g' -e 's/@SVN_DB_LIBS@//g' svn-config
328
329 %install
330 rm -rf $RPM_BUILD_ROOT
331 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
332         $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}} \
333         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
334         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
335
336 %{__make} install \
337 %if !%{with net_client_only} && %{with python}
338         install-swig-py \
339 %endif
340         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
341         DESTDIR=$RPM_BUILD_ROOT \
342         swig_pydir=%{py_sitedir}/libsvn \
343         swig_pydir_extra=%{py_sitedir}/svn
344
345 %if !%{with net_client_only} && %{with perl}
346 %{__make} install-swig-pl-lib \
347         DESTDIR=$RPM_BUILD_ROOT
348 odir=$(pwd)
349 cd subversion/bindings/swig/perl/native
350 %{__make} install \
351         DESTDIR=$RPM_BUILD_ROOT \
352         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
353         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
354 cd $odir
355 %endif
356
357 install svn-config $RPM_BUILD_ROOT%{_bindir}
358
359 %if %{with apache}
360 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
361 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
362 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
363 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
364 %endif
365
366 %if !%{with net_client_only}
367 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
368 %if %{with python}
369 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
370 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
371 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
372 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
373 %endif
374 %endif
375
376 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
377 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
378
379 %find_lang %{name}
380
381 %clean
382 rm -rf $RPM_BUILD_ROOT
383
384 %post devel
385 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
386
387 %postun devel
388 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
389
390 %post   libs -p /sbin/ldconfig
391 %postun libs -p /sbin/ldconfig
392 %post   -n python-subversion -p /sbin/ldconfig
393 %postun -n perl-subversion -p /sbin/ldconfig
394
395 %post svnserve
396 /sbin/chkconfig --add svnserve
397 %service svnserve restart "svnserve daemon"
398
399 %preun svnserve
400 if [ "$1" = "0" ]; then
401         %service svnserve stop
402         /sbin/chkconfig --del svnserve
403 fi
404
405 %post -n apache-mod_dav_svn
406 %service -q httpd restart
407
408 %preun -n apache-mod_dav_svn
409 if [ "$1" = "0" ]; then
410         %service -q httpd restart
411 fi
412
413 %files
414 %defattr(644,root,root,755)
415 %doc BUGS CHANGES COPYING INSTALL README
416 %doc doc/*/*.html
417 %doc tools/hook-scripts/*.{pl,py,example}
418 %doc tools/hook-scripts/mailer/*.{py,example}
419 %doc tools/xslt/*
420 %attr(755,root,root) %{_bindir}/svn*
421 %exclude %{_bindir}/svnserve
422 %exclude %{_bindir}/svn-config
423 %exclude %{_bindir}/svn-hot-backup
424 %{_mandir}/man1/*
425 %{_mandir}/man5/*
426 %{_mandir}/man8/*
427 %exclude %{_mandir}/man?/svnserve*
428
429 %files libs -f %{name}.lang
430 %defattr(644,root,root,755)
431 %attr(755,root,root) %{_libdir}/lib*.so.*
432 %if %{with perl} || %{with python}
433 %exclude %{_libdir}/lib*_swig_*.so.*
434 %endif
435
436 %files devel
437 %defattr(644,root,root,755)
438 %attr(755,root,root) %{_bindir}/svn-config
439 %{_includedir}/%{name}*
440 %attr(755,root,root) %{_libdir}/lib*.so
441 %{_libdir}/lib*.la
442 %if %{with perl} || %{with python}
443 %exclude %{_libdir}/lib*_swig_*.so
444 %exclude %{_libdir}/lib*swig*.la
445 %endif
446 %{_examplesdir}/%{name}-%{version}
447
448 %files static
449 %defattr(644,root,root,755)
450 %{_libdir}/lib*.a
451
452 %if %{without net_client_only}
453 %files svnserve
454 %defattr(644,root,root,755)
455 %attr(755,root,root) %{_bindir}/svnserve
456 %{_mandir}/man?/svnserve*
457 %dir /home/services/subversion
458 %dir /home/services/subversion/repos
459 %if %{with apache}
460 %attr(754,root,root) /etc/rc.d/init.d/svnserve
461 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
462 %endif
463
464 %files tools
465 %defattr(644,root,root,755)
466 %attr(755,root,root) %{_bindir}/svn-hot-backup
467
468 %files -n bash-completion-subversion
469 %defattr(644,root,root,755)
470 /etc/bash_completion.d/%{name}
471
472 %if %{with python}
473 %files -n python-subversion
474 %defattr(644,root,root,755)
475 %doc tools/backup/*.py tools/examples/*.py
476 %dir %{py_sitedir}/svn
477 %dir %{py_sitedir}/libsvn
478 %{py_sitedir}/svn/*.py[co]
479 %{py_sitedir}/libsvn/*.py[co]
480 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
481 %{_examplesdir}/python-%{name}-%{version}
482 %attr(755,root,root) %{_libdir}/lib*_swig_py*.so*
483 %{_libdir}/lib*_swig_py*.la
484 %endif
485
486 %if %{with perl}
487 %files -n perl-subversion
488 %defattr(644,root,root,755)
489 %{perl_vendorarch}/SVN
490 %dir %{perl_vendorarch}/auto/SVN
491 %dir %{perl_vendorarch}/auto/SVN/*
492 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
493 %{perl_vendorarch}/auto/SVN/*/*.bs
494 %{_mandir}/man3/*.3pm*
495 %attr(755,root,root) %{_libdir}/lib*_swig_perl*.so*
496 %{_libdir}/lib*_swig_perl*.la
497 %endif
498
499 %if %{with apache}
500 %files -n apache-mod_dav_svn
501 %defattr(644,root,root,755)
502 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
503 %attr(755,root,root) %{_apachelibdir}/mod_dav_svn.so
504
505 %files -n apache-mod_authz_svn
506 %defattr(644,root,root,755)
507 %doc subversion/mod_authz_svn/INSTALL
508 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
509 %attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
510 %endif
511
512 %endif # net_client_only
This page took 0.195593 seconds and 4 git commands to generate.