]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- updated to 1.5.0
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - remove net_client_only and add db bcond (then without apache and
3 #   without db => net_client_only - spec will be more simpler, I think)
4 # - finish ruby
5 #
6 # Conditional build:
7 %bcond_with     net_client_only         # build only net client
8 %bcond_without  python                  # build without python bindings (broken)
9 %bcond_without  perl                    # build without perl bindings
10 %bcond_without  ruby                    # build without ruby bindings
11 %bcond_without  apache                  # build without apache support (webdav, etc)
12 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
13 %bcond_without  tests                   # don't perform "make check"
14 #
15 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
16 %define apxs    /usr/sbin/apxs
17 %define pdir    SVN
18 %define pnam    _Core
19 #
20 Summary:        A Concurrent Versioning system similar to but better than CVS
21 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
22 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
23 Name:           subversion
24 Version:        1.5.0
25 Release:        0.1
26 License:        Apache/BSD-like
27 Group:          Development/Version Control
28 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
29 # Source0-md5:  004b57643406dd10957ec87955702189
30 Source1:        %{name}-dav_svn.conf
31 Source2:        %{name}-authz_svn.conf
32 Source3:        %{name}-svnserve.init
33 Source4:        %{name}-svnserve.sysconfig
34 Source5:        %{name}-convert-typemaps-to-ifdef.py
35 Patch0:         %{name}-home_etc.patch
36 Patch1:         %{name}-DESTDIR.patch
37 URL:            http://subversion.tigris.org/
38 %if %{with net_client_only}
39 %global apache_modules_api 0
40 %else
41 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
42 BuildRequires:  automake
43 BuildRequires:  db-devel >= 4.1.25
44 BuildRequires:  rpmbuild(macros) >= 1.268
45 %if %{with perl}
46 BuildRequires:  perl-devel >= 1:5.8.0
47 BuildRequires:  rpm-perlprov >= 4.1-13
48 BuildRequires:  swig-perl >= 1.3.24
49 %endif
50 %{?with_javahl:BuildRequires:   jdk}
51 %endif
52 BuildRequires:  apr-devel >= 1:1.0.0
53 BuildRequires:  apr-util-devel >= 1:1.2.8-3
54 BuildRequires:  autoconf >= 2.59
55 BuildRequires:  bison
56 BuildRequires:  cyrus-sasl-devel
57 BuildRequires:  expat-devel
58 BuildRequires:  gettext-devel
59 BuildRequires:  libtool >= 1.4-9
60 BuildRequires:  neon-devel >= 0.26.0
61 BuildRequires:  python >= 2.2
62 BuildRequires:  python-modules >= 2.2
63 %if %{with python}
64 BuildRequires:  python-devel >= 2.2
65 BuildRequires:  sed >= 4.0
66 BuildRequires:  swig-python >= 1.3.24
67 %endif
68 %{?with_ruby:BuildRequires:     swig-ruby >= 1.3.24}
69 BuildRequires:  texinfo
70 BuildRequires:  which
71 Requires:       %{name}-libs = %{version}-%{release}
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         _libexecdir             %{_libdir}/svn
75 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
76 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
77
78 %description
79 The goal of the Subversion project is to build a version control
80 system that is a compelling replacement for CVS in the open source
81 community.
82
83 Our goals are:
84 - All current CVS features.
85 - Directories, renames, and file meta-data are versioned.
86 - Symbolic links, etc, are supported
87 - Commits are truly atomic.
88 - Branching and tagging are cheap (constant time) operations
89 - Repeated merges are handled gracefully
90 - Support for plug-in client side diff programs
91 - Natively client/server
92 - Client/server protocol sends diffs in both directions
93 - Costs are proportional to change size, not project size
94 - Internationalization
95 - Progressive multi-lingual support
96
97 %description -l pl.UTF-8
98 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
99 zamiennika dla CVS.
100
101 Cele projektu to:
102 - Wszystkie aktualne możliwości CVS.
103 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
104 - Obsługa dowiązań symbolicznych itp.
105 - Commity są w pełni atomowe.
106 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
107 - Dobra obsługa powtarzanego łączenia (merge).
108 - Obsługa wtyczek diff po stronie klienta.
109 - Natywny klient/serwer.
110 - Klient/Serwer przesyłają diffy w obu kierunkach.
111 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
112 - Internacjonalizacja.
113 - Postępujące wsparcie dla wielu języków.
114
115 %description -l pt_BR.UTF-8
116 O objetivo do projeto Subversion é construir um sistema de controle de
117 versões que seja um substituto para o CVS (Concurrent Versioning
118 System) na comunidade opensource, fornecendo grandes melhorias.
119
120 %package libs
121 Summary:        Subversion libraries and modules
122 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
123 Group:          Libraries
124 Requires:       neon >= 0.26.0
125 Obsoletes:      libsubversion0
126
127 %description libs
128 Subversion libraries and modules.
129
130 %description libs -l pl.UTF-8
131 Biblioteka subversion oraz ładowalne moduły.
132
133 %package devel
134 Summary:        Header files and develpment documentation for subversion
135 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
136 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
137 Group:          Development/Libraries
138 Requires:       %{name}-libs = %{version}-%{release}
139 Requires:       apr-util-devel >= 1:1.0.0
140 Requires:       neon-devel >= 0.26.0
141 Obsoletes:      libsubversion0-devel
142
143 %description devel
144 Header files and develpment documentation for subversion.
145
146 %description devel -l pl.UTF-8
147 Pliki nagłówkowe i dokumetacja do subversion.
148
149 %description devel -l pt_BR.UTF-8
150 Este pacote provê os arquivos necessários para desenvolvedores
151 interagirem com o Subversion.
152
153 %package static
154 Summary:        Static subversion library
155 Summary(pl.UTF-8):      Biblioteka statyczna subversion
156 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
157 Group:          Development/Libraries
158 Requires:       %{name}-devel = %{version}
159 Obsoletes:      libsubversion0-static-devel
160
161 %description static
162 Static subversion library.
163
164 %description static -l pl.UTF-8
165 Biblioteka statyczna subversion.
166
167 %description static -l pt_BR.UTF-8
168 Este pacote provê um cliente estático do subversion.
169
170 %package svnserve
171 Summary:        Subversion svnserve
172 Summary(pl.UTF-8):      Subversion svnserve
173 Group:          Networking/Daemons
174 Requires(post,preun):   /sbin/chkconfig
175 Requires(postun):       /usr/sbin/groupdel
176 Requires(postun):       /usr/sbin/userdel
177 Requires(pre):  /bin/id
178 Requires(pre):  /usr/bin/getgid
179 Requires(pre):  /usr/lib/rpm/user_group.sh
180 Requires(pre):  /usr/sbin/groupadd
181 Requires(pre):  /usr/sbin/useradd
182 Requires(pre):  /usr/sbin/usermod
183 Requires:       %{name} = %{version}-%{release}
184 Requires:       rc-scripts
185 Provides:       group(svn)
186 Provides:       user(svn)
187
188 %description svnserve
189 Subversion svnserve server.
190
191 %description svnserve -l pl.UTF-8
192 Serwer subversion svnserve.
193
194 %package tools
195 Summary:        Subversion tools and scripts
196 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
197 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
198 Group:          Applications
199 %pyrequires_eq  python
200 Requires:       %{name} = %{version}-%{release}
201 Requires:       python-rcsparse >= 0.1-0.20031026.0
202 Requires:       python-subversion = %{version}
203
204 %description tools
205 Subversion tools and scripts.
206
207 %description tools -l pl.UTF-8
208 Narzędzia oraz skrypty dla subversion.
209
210 %package -n bash-completion-subversion
211 Summary:        bash completion for subversion
212 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
213 Group:          Applications/Shells
214 Requires:       %{name} = %{version}-%{release}
215 Requires:       bash-completion
216 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
217
218 %description -n bash-completion-subversion
219 Bash completion for subversion.
220
221 %description -n bash-completion-subversion -l pl.UTF-8
222 Dopełnienia basha dla subversion.
223
224 %package -n java-subversion
225 Summary:        Subversion Java bindings
226 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
227 Group:          Development/Languages/Java
228 Requires:       %{name}-libs = %{version}-%{release}
229
230 %description -n java-subversion
231 This is a set of Java classes which provide the functionality of
232 subversion-libs, the Subversion libraries. It is useful if you want
233 to, for example, write a Java class that manipulates a Subversion
234 repository or working copy. See the 'subversion' package for more
235 information.
236
237 %description -n java-subversion -l pl.UTF-8
238 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
239 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
240 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
241 roboczą. Więcej informacji w pakiecie subversion.
242
243 %package -n python-subversion
244 Summary:        Subversion Python bindings
245 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
246 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
247 Group:          Development/Languages/Python
248 %pyrequires_eq  python
249 Requires:       %{name}-libs = %{version}-%{release}
250 Obsoletes:      subversion-python
251
252 %description -n python-subversion
253 Subversion Python bindings.
254
255 %description -n python-subversion -l pl.UTF-8
256 Dowiązania do Subversion dla Pythona.
257
258 %description -n python-subversion -l pt_BR.UTF-8
259 Módulos Python para acessar os recursos do Subversion.
260
261 %package -n perl-subversion
262 Summary:        Subversion Perl bindings
263 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
264 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
265 Group:          Development/Languages/Perl
266 Requires:       %{name}-libs = %{version}-%{release}
267 Obsoletes:      subversion-perl
268
269 %description -n perl-subversion
270 Subversion Perl bindings.
271
272 %description -n perl-subversion -l pl.UTF-8
273 Dowiązania do Subversion dla Perla.
274
275 %description -n perl-subversion -l pt_BR.UTF-8
276 Módulos Perl para acessar os recursos do Subversion.
277
278 %package -n ruby-subversion
279 Summary:        Subversion Ruby bindings
280 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
281 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
282 Group:          Development/Languages
283 Requires:       %{name}-libs = %{version}-%{release}
284 Obsoletes:      subversion-ruby
285
286 %description -n ruby-subversion
287 Subversion Ruby bindings.
288
289 %description -n ruby-subversion -l pl.UTF-8
290 Dowiązania do Subversion dla języka Ruby.
291
292 %description -n ruby-subversion -l pt_BR.UTF-8
293 Módulos Ruby para acessar os recursos do Subversion.
294
295 %package -n apache-mod_dav_svn
296 Summary:        Apache module: Subversion Server
297 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
298 Group:          Networking/Daemons
299 Requires:       %{name} = %{version}-%{release}
300 Requires:       apache(modules-api) = %apache_modules_api
301 Requires:       apache-mod_dav
302
303 %description -n apache-mod_dav_svn
304 Apache module: Subversion Server.
305
306 %description -n apache-mod_dav_svn -l pl.UTF-8
307 Moduł apache: Serwer Subversion.
308
309 %package -n apache-mod_authz_svn
310 Summary:        Apache module: Subversion Server - path-based authorization
311 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
312 Group:          Networking/Daemons
313 Requires:       apache(modules-api) = %apache_modules_api
314 Requires:       apache-mod_dav_svn = %{version}-%{release}
315
316 %description -n apache-mod_authz_svn
317 Apache module: Subversion Server - path-based authorization.
318
319 %description -n apache-mod_authz_svn -l pl.UTF-8
320 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
321
322 %prep
323 %setup -q
324 rm -rf apr apr-util neon
325 %patch0 -p0
326 %patch1 -p1
327
328 %build
329 rm subversion/bindings/swig/proxy/*.swg
330 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
331 cp -f /usr/share/automake/config.sub ac-helpers
332 chmod +x ./autogen.sh && ./autogen.sh
333
334 # don't enable dso - currently it's broken
335 %configure \
336         --with-editor=vi \
337         --with-zlib=%{_libdir} \
338         --with-python=%{__python} \
339         --with-perl5=%{__perl} \
340 %if %{with net_client_only}
341         --without-apache \
342         --without-swig \
343         --without-apxs \
344         --without-berkeley-db \
345 %else
346         --disable-dso \
347         --disable-mod-activation \
348 %if %{with apache}
349         --with-apxs=%{_sbindir}/apxs \
350 %else
351         --without-apache \
352         --without-apxs \
353         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
354 %endif
355 %if !%{with python} && !%{with perl} && !%{with ruby}
356         --without-swig \
357 %endif
358         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
359 %endif
360         --with-jdk="%{java_home}" \
361         --with-neon=%{_prefix} \
362         --disable-neon-version-check \
363         --with-apr=%{_bindir}/apr-1-config \
364         --with-apr-util=%{_bindir}/apu-1-config
365
366 %{__make} -j1
367
368 %if !%{with net_client_only}
369 # python
370 %if %{with python}
371 %{__make} swig-py \
372         swig_pydir=%{py_sitedir}/libsvn \
373         swig_pydir_extra=%{py_sitedir}/svn
374 %endif
375 # perl
376 %if %{with perl}
377 %{__make} swig-pl-lib
378 odir=$(pwd)
379 cd subversion/bindings/swig/perl/native
380 %{__perl} Makefile.PL INSTALLDIRS=vendor
381 %{__make} -j1
382 cd $odir
383 %endif
384 %if %{with javahl}
385 %{__make} -j1 javahl \
386         javahl_javadir="%{_javadir}"
387 %endif
388 # ruby
389 %if %{with ruby}
390 %{__make} swig-rb
391 %endif
392 %endif
393
394 %if %{with tests}
395 %{__make} check
396 %if %{with python}
397 %{__make} check-swig-py
398 %endif
399 %if %{with perl}
400 %{__make} check-swig-pl
401 %endif
402 %if %{with ruby}
403 %{__make} check-swig-rb
404 %endif
405 %endif
406
407 %install
408 rm -rf $RPM_BUILD_ROOT
409 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
410         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
411         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
412         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
413
414 %{__make} install -j1 \
415 %if %{with javahl}
416         install-javahl \
417         javahl_javadir="%{_javadir}" \
418 %endif
419 %if !%{with net_client_only}
420 %if %{with python}
421         install-swig-py \
422 %endif
423 %if %{with ruby}
424         install-swig-rb install-swig-rb-doc \
425 %endif
426 %endif
427         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
428         DESTDIR=$RPM_BUILD_ROOT \
429         swig_pydir=%{py_sitedir}/libsvn \
430         swig_pydir_extra=%{py_sitedir}/svn
431
432 %if !%{with net_client_only} && %{with perl}
433 %{__make} install-swig-pl-lib \
434         DESTDIR=$RPM_BUILD_ROOT
435 %{__make} -C subversion/bindings/swig/perl/native install \
436         DESTDIR=$RPM_BUILD_ROOT \
437         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
438         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
439 %endif
440
441 %if %{with apache}
442 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
443 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
444 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
445 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
446 %endif
447
448 %if !%{with net_client_only}
449 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
450 %if %{with python}
451 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
452 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
453 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
454 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
455 %endif
456 %endif
457
458 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
459 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
460
461 %find_lang %{name}
462
463 rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn{javahl,_swig}*.{la,a}
464 rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/svn/ext/*.la
465
466 %clean
467 rm -rf $RPM_BUILD_ROOT
468
469 %pre svnserve
470 %groupadd -g 86 svn
471 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
472
473 %post   libs -p /sbin/ldconfig
474 %postun libs -p /sbin/ldconfig
475
476 %post   devel -p /sbin/postshell
477 -/usr/sbin/fix-info-dir -c %{_infodir}
478
479 %postun devel -p /sbin/postshell
480 -/usr/sbin/fix-info-dir -c %{_infodir}
481
482 %post   -n perl-subversion -p /sbin/ldconfig
483 %postun -n perl-subversion -p /sbin/ldconfig
484
485 %post   -n python-subversion -p /sbin/ldconfig
486 %postun -n python-subversion -p /sbin/ldconfig
487
488 %post svnserve
489 /sbin/chkconfig --add svnserve
490 %service svnserve restart "svnserve daemon"
491
492 %preun svnserve
493 if [ "$1" = "0" ]; then
494         %service svnserve stop
495         /sbin/chkconfig --del svnserve
496 fi
497
498 %postun svnserve
499 if [ "$1" = "0" ]; then
500         %userremove svn
501         %groupremove svn
502 fi
503
504 %post -n apache-mod_dav_svn
505 %service -q httpd restart
506
507 %preun -n apache-mod_dav_svn
508 if [ "$1" = "0" ]; then
509         %service -q httpd restart
510 fi
511
512 %files
513 %defattr(644,root,root,755)
514 %doc BUGS CHANGES COPYING INSTALL README
515 %doc doc/*/*.html
516 %doc tools/hook-scripts/*.{pl,py,example}
517 %doc tools/hook-scripts/mailer/*.{py,example}
518 %doc tools/xslt/*
519 %attr(755,root,root) %{_bindir}/svn
520 %attr(755,root,root) %{_bindir}/svnadmin
521 %attr(755,root,root) %{_bindir}/svndumpfilter
522 %attr(755,root,root) %{_bindir}/svnlook
523 %attr(755,root,root) %{_bindir}/svnsync
524 %attr(755,root,root) %{_bindir}/svnversion
525 %{_mandir}/man1/svn.1*
526 %{_mandir}/man1/svnadmin.1*
527 %{_mandir}/man1/svndumpfilter.1*
528 %{_mandir}/man1/svnlook.1*
529 %{_mandir}/man1/svnsync.1*
530 %{_mandir}/man1/svnversion.1*
531
532 %files libs -f %{name}.lang
533 %defattr(644,root,root,755)
534 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
535 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
536 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
537 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
538 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
539 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
540 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
541 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
542 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
543 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
544 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
545 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
546 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
547 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
548 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
549 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
550 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
551 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
552 %attr(755,root,root) %{_libdir}/libsvn_ra_neon-1.so.*.*.*
553 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_neon-1.so.0
554 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
555 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
556 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
557 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
558 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
559 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
560 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
561 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
562
563 %files devel
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
566 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
567 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
568 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
569 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
570 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
571 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
572 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
573 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
574 %attr(755,root,root) %{_libdir}/libsvn_ra_neon-1.so
575 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
576 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
577 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
578 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
579 %{_libdir}/libsvn_client-1.la
580 %{_libdir}/libsvn_delta-1.la
581 %{_libdir}/libsvn_diff-1.la
582 %{_libdir}/libsvn_fs-1.la
583 %{_libdir}/libsvn_fs_base-1.la
584 %{_libdir}/libsvn_fs_fs-1.la
585 %{_libdir}/libsvn_fs_util-1.la
586 %{_libdir}/libsvn_ra-1.la
587 %{_libdir}/libsvn_ra_local-1.la
588 %{_libdir}/libsvn_ra_neon-1.la
589 %{_libdir}/libsvn_ra_svn-1.la
590 %{_libdir}/libsvn_repos-1.la
591 %{_libdir}/libsvn_subr-1.la
592 %{_libdir}/libsvn_wc-1.la
593 %{_includedir}/%{name}-1
594 %{_examplesdir}/%{name}-%{version}
595
596 %files static
597 %defattr(644,root,root,755)
598 %{_libdir}/libsvn_client-1.a
599 %{_libdir}/libsvn_delta-1.a
600 %{_libdir}/libsvn_diff-1.a
601 %{_libdir}/libsvn_fs-1.a
602 %{_libdir}/libsvn_fs_base-1.a
603 %{_libdir}/libsvn_fs_fs-1.a
604 %{_libdir}/libsvn_fs_util-1.a
605 %{_libdir}/libsvn_ra-1.a
606 %{_libdir}/libsvn_ra_local-1.a
607 %{_libdir}/libsvn_ra_neon-1.a
608 %{_libdir}/libsvn_ra_svn-1.a
609 %{_libdir}/libsvn_repos-1.a
610 %{_libdir}/libsvn_subr-1.a
611 %{_libdir}/libsvn_wc-1.a
612
613 %if !%{with net_client_only}
614 %files svnserve
615 %defattr(644,root,root,755)
616 %attr(755,root,root) %{_bindir}/svnserve
617 %{_mandir}/man5/svnserve.conf.5*
618 %{_mandir}/man8/svnserve.8*
619 %dir %attr(750,svn,svn) /home/services/subversion
620 %dir %attr(750,svn,svn) /home/services/subversion/repos
621 %if %{with apache}
622 %attr(754,root,root) /etc/rc.d/init.d/svnserve
623 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
624 %endif
625
626 %files tools
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_bindir}/svn-hot-backup
629
630 %files -n bash-completion-subversion
631 %defattr(644,root,root,755)
632 /etc/bash_completion.d/%{name}
633
634 %if %{with javahl}
635 %files -n java-subversion
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
638 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
639 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
640 %{_javadir}/svn-javahl.jar
641 %endif
642
643 %if %{with python}
644 %files -n python-subversion
645 %defattr(644,root,root,755)
646 %doc tools/backup/*.py tools/examples/*.py
647 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
648 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
649 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
650 %dir %{py_sitedir}/libsvn
651 %{py_sitedir}/libsvn/*.py[co]
652 %dir %{py_sitedir}/svn
653 %{py_sitedir}/svn/*.py[co]
654 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
655 %{_examplesdir}/python-%{name}-%{version}
656 %endif
657
658 %if %{with perl}
659 %files -n perl-subversion
660 %defattr(644,root,root,755)
661 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
662 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
663 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
664 %{perl_vendorarch}/SVN
665 %dir %{perl_vendorarch}/auto/SVN
666 %dir %{perl_vendorarch}/auto/SVN/*
667 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
668 %{perl_vendorarch}/auto/SVN/*/*.bs
669 %{_mandir}/man3/*.3pm*
670 %endif
671
672 %if %{with ruby}
673 %files -n ruby-subversion
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
676 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
677 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
678 %dir %{_libdir}/ruby/site_ruby/svn
679 %{_libdir}/ruby/site_ruby/svn/*.rb
680 %dir %{_libdir}/ruby/site_ruby/svn/ext
681 %attr(755,root,root) %{_libdir}/ruby/site_ruby/svn/ext/*.so
682 %{_datadir}/ri/*.*/site/Svn
683 %{_datadir}/ri/*.*/site/Time
684 %{_datadir}/ri/*.*/site/Uconv
685 %{_datadir}/ri/*.*/site/*.rid
686 %{_datadir}/ri/*.*/site/Kernel/*
687 %{_datadir}/ri/*.*/site/OptionParser/*
688 %endif
689
690 %if %{with apache}
691 %files -n apache-mod_dav_svn
692 %defattr(644,root,root,755)
693 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
694 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
695
696 %files -n apache-mod_authz_svn
697 %defattr(644,root,root,755)
698 %doc subversion/mod_authz_svn/INSTALL
699 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
700 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
701 %endif
702
703 %endif # net_client_only
This page took 0.089869 seconds and 4 git commands to generate.