]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- rel 2; br java-sun-tools
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - fix java build with java-gcj-compat and s/java-sun/jdk/
3 # - remove net_client_only and add db bcond (then without apache and
4 #   without db => net_client_only - spec will be more simpler, I think)
5 # - finish ruby
6 #
7 # Conditional build:
8 %bcond_with     net_client_only         # build only net client
9 %bcond_without  neon                    # use serf instead of neon
10 %bcond_without  python                  # build without python bindings (broken)
11 %bcond_without  perl                    # build without perl bindings
12 %bcond_without  ruby                    # build without ruby bindings
13 %bcond_without  apache                  # build without apache support (webdav, etc)
14 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
15 %bcond_without  tests                   # don't perform "make check"
16 %bcond_without  kwallet                 # build without kde4 wallet support
17 #
18 %ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
19 %undefine       with_javahl
20 %endif
21 #
22 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
23 %define apxs    /usr/sbin/apxs
24 %define pdir    SVN
25 %define pnam    _Core
26 #
27 %if %{with neon}
28 %define webdavlib       neon
29 %else
30 %define webdavlib       serf
31 %endif
32 #
33 Summary:        A Concurrent Versioning system similar to but better than CVS
34 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
35 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
36 Name:           subversion
37 Version:        1.6.3
38 Release:        2
39 License:        Apache/BSD-like
40 Group:          Development/Version Control
41 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
42 # Source0-md5:  8bf7637ac99368db0890e3f085fa690d
43 Source1:        %{name}-dav_svn.conf
44 Source2:        %{name}-authz_svn.conf
45 Source3:        %{name}-svnserve.init
46 Source4:        %{name}-svnserve.sysconfig
47 # current subversion tarball has correct *.swg files
48 # but after regeneration these are broken again, so
49 # we still need this script
50 Source5:        %{name}-convert-typemaps-to-ifdef.py
51 Patch0:         %{name}-home_etc.patch
52 Patch1:         %{name}-DESTDIR.patch
53 Patch2:         %{name}-ruby-datadir-path.patch
54 URL:            http://subversion.tigris.org/
55 %if %{with net_client_only}
56 %global apache_modules_api 0
57 %else
58 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
59 BuildRequires:  automake
60 BuildRequires:  db-devel >= 4.1.25
61 BuildRequires:  rpmbuild(macros) >= 1.268
62 %if %{with perl}
63 BuildRequires:  perl-devel >= 1:5.8.0
64 BuildRequires:  rpm-perlprov >= 4.1-13
65 BuildRequires:  swig-perl >= 1.3.24
66 %endif
67 %if %{with python}
68 BuildRequires:  python-ctypesgen
69 BuildRequires:  python-devel >= 2.2
70 BuildRequires:  swig-python >= 1.3.24
71 %endif
72 %if %{with ruby}
73 BuildRequires:  ruby-devel
74 BuildRequires:  swig-ruby >= 1.3.24
75 %endif
76 %if %{with javahl}
77 BuildRequires:  java-sun
78 BuildRequires:  java-sun-tools
79 %endif
80 BuildRequires:  cyrus-sasl-devel
81 %endif
82 BuildRequires:  apr-devel >= 1:1.0.0
83 BuildRequires:  apr-util-devel >= 1:1.2.8-3
84 BuildRequires:  autoconf >= 2.59
85 BuildRequires:  bison
86 BuildRequires:  expat-devel
87 BuildRequires:  gettext-devel
88 BuildRequires:  gnome-keyring-devel
89 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
90 BuildRequires:  libtool >= 1.4-9
91 BuildRequires:  sed >= 4.0
92 BuildRequires:  sqlite3-devel >= 3.6.11
93 BuildRequires:  texinfo
94 BuildRequires:  which
95 %if %{with neon}
96 BuildRequires:  neon-devel >= 0.26.0
97 %else
98 BuildRequires:  serf-devel
99 %endif
100 BuildRequires:  python >= 2.2
101 BuildRequires:  python-modules >= 2.2
102 Requires:       %{name}-libs = %{version}-%{release}
103 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
104
105 %define         _libexecdir             %{_libdir}/svn
106 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
107 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
108
109 %description
110 The goal of the Subversion project is to build a version control
111 system that is a compelling replacement for CVS in the open source
112 community.
113
114 Our goals are:
115 - All current CVS features.
116 - Directories, renames, and file meta-data are versioned.
117 - Symbolic links, etc, are supported
118 - Commits are truly atomic.
119 - Branching and tagging are cheap (constant time) operations
120 - Repeated merges are handled gracefully
121 - Support for plug-in client side diff programs
122 - Natively client/server
123 - Client/server protocol sends diffs in both directions
124 - Costs are proportional to change size, not project size
125 - Internationalization
126 - Progressive multi-lingual support
127
128 %description -l pl.UTF-8
129 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
130 zamiennika dla CVS.
131
132 Cele projektu to:
133 - Wszystkie aktualne możliwości CVS.
134 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
135 - Obsługa dowiązań symbolicznych itp.
136 - Commity są w pełni atomowe.
137 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
138 - Dobra obsługa powtarzanego łączenia (merge).
139 - Obsługa wtyczek diff po stronie klienta.
140 - Natywny klient/serwer.
141 - Klient/Serwer przesyłają diffy w obu kierunkach.
142 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
143 - Internacjonalizacja.
144 - Postępujące wsparcie dla wielu języków.
145
146 %description -l pt_BR.UTF-8
147 O objetivo do projeto Subversion é construir um sistema de controle de
148 versões que seja um substituto para o CVS (Concurrent Versioning
149 System) na comunidade opensource, fornecendo grandes melhorias.
150
151 %package libs
152 Summary:        Subversion libraries and modules
153 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
154 Group:          Libraries
155 %{?with_neon:Requires:  neon >= 0.26.0}
156 Obsoletes:      libsubversion0
157
158 %description libs
159 Subversion libraries and modules.
160
161 %description libs -l pl.UTF-8
162 Biblioteka subversion oraz ładowalne moduły.
163
164 %package devel
165 Summary:        Header files and develpment documentation for subversion
166 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
167 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
168 Group:          Development/Libraries
169 Requires:       %{name}-libs = %{version}-%{release}
170 Requires:       apr-util-devel >= 1:1.0.0
171 %{?with_neon:Requires:  neon-devel >= 0.26.0}
172 Obsoletes:      libsubversion0-devel
173
174 %description devel
175 Header files and develpment documentation for subversion.
176
177 %description devel -l pl.UTF-8
178 Pliki nagłówkowe i dokumetacja do subversion.
179
180 %description devel -l pt_BR.UTF-8
181 Este pacote provê os arquivos necessários para desenvolvedores
182 interagirem com o Subversion.
183
184 %package static
185 Summary:        Static subversion library
186 Summary(pl.UTF-8):      Biblioteka statyczna subversion
187 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
188 Group:          Development/Libraries
189 Requires:       %{name}-devel = %{version}
190 Obsoletes:      libsubversion0-static-devel
191
192 %description static
193 Static subversion library.
194
195 %description static -l pl.UTF-8
196 Biblioteka statyczna subversion.
197
198 %description static -l pt_BR.UTF-8
199 Este pacote provê um cliente estático do subversion.
200
201 %package svnserve
202 Summary:        Subversion svnserve
203 Summary(pl.UTF-8):      Subversion svnserve
204 Group:          Networking/Daemons
205 Requires(post,preun):   /sbin/chkconfig
206 Requires(postun):       /usr/sbin/groupdel
207 Requires(postun):       /usr/sbin/userdel
208 Requires(pre):  /bin/id
209 Requires(pre):  /usr/bin/getgid
210 Requires(pre):  /usr/lib/rpm/user_group.sh
211 Requires(pre):  /usr/sbin/groupadd
212 Requires(pre):  /usr/sbin/useradd
213 Requires(pre):  /usr/sbin/usermod
214 Requires:       %{name} = %{version}-%{release}
215 Requires:       rc-scripts
216 Provides:       group(svn)
217 Provides:       user(svn)
218
219 %description svnserve
220 Subversion svnserve server.
221
222 %description svnserve -l pl.UTF-8
223 Serwer subversion svnserve.
224
225 %package tools
226 Summary:        Subversion tools and scripts
227 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
228 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
229 Group:          Applications
230 %pyrequires_eq  python
231 Requires:       %{name} = %{version}-%{release}
232 Requires:       python-subversion = %{version}
233
234 %description tools
235 Subversion tools and scripts.
236
237 %description tools -l pl.UTF-8
238 Narzędzia oraz skrypty dla subversion.
239
240 %package -n bash-completion-subversion
241 Summary:        bash completion for subversion
242 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
243 Group:          Applications/Shells
244 Requires:       %{name} = %{version}-%{release}
245 Requires:       bash-completion
246 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
247
248 %description -n bash-completion-subversion
249 Bash completion for subversion.
250
251 %description -n bash-completion-subversion -l pl.UTF-8
252 Dopełnienia basha dla subversion.
253
254 %package -n java-subversion
255 Summary:        Subversion Java bindings
256 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
257 Group:          Development/Languages/Java
258 Requires:       %{name}-libs = %{version}-%{release}
259
260 %description -n java-subversion
261 This is a set of Java classes which provide the functionality of
262 subversion-libs, the Subversion libraries. It is useful if you want
263 to, for example, write a Java class that manipulates a Subversion
264 repository or working copy. See the 'subversion' package for more
265 information.
266
267 %description -n java-subversion -l pl.UTF-8
268 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
269 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
270 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
271 roboczą. Więcej informacji w pakiecie subversion.
272
273 %package -n python-subversion
274 Summary:        Subversion Python bindings
275 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
276 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
277 Group:          Development/Languages/Python
278 %pyrequires_eq  python
279 Requires:       %{name}-libs = %{version}-%{release}
280 Obsoletes:      subversion-python
281
282 %description -n python-subversion
283 Subversion Python bindings.
284
285 %description -n python-subversion -l pl.UTF-8
286 Dowiązania do Subversion dla Pythona.
287
288 %description -n python-subversion -l pt_BR.UTF-8
289 Módulos Python para acessar os recursos do Subversion.
290
291 %package -n python-csvn
292 Summary:        CTypes Subversion Python bindings
293 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
294 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
295 Group:          Development/Languages/Python
296 %pyrequires_eq  python
297 Requires:       %{name}-libs = %{version}-%{release}
298
299 %description -n python-csvn
300 Subversion CTypes Python bindings.
301
302 %description -n python-csvn -l pl.UTF-8
303 Dowiązania do Subversion dla Pythona używające CTypes.
304
305 %description -n python-csvn -l pt_BR.UTF-8
306 Módulos Python para acessar os recursos do Subversion.
307
308 %package -n perl-subversion
309 Summary:        Subversion Perl bindings
310 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
311 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
312 Group:          Development/Languages/Perl
313 Requires:       %{name}-libs = %{version}-%{release}
314 Obsoletes:      subversion-perl
315
316 %description -n perl-subversion
317 Subversion Perl bindings.
318
319 %description -n perl-subversion -l pl.UTF-8
320 Dowiązania do Subversion dla Perla.
321
322 %description -n perl-subversion -l pt_BR.UTF-8
323 Módulos Perl para acessar os recursos do Subversion.
324
325 %package -n ruby-subversion
326 Summary:        Subversion Ruby bindings
327 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
328 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
329 Group:          Development/Languages
330 Requires:       %{name}-libs = %{version}-%{release}
331 Obsoletes:      subversion-ruby
332
333 %description -n ruby-subversion
334 Subversion Ruby bindings.
335
336 %description -n ruby-subversion -l pl.UTF-8
337 Dowiązania do Subversion dla języka Ruby.
338
339 %description -n ruby-subversion -l pt_BR.UTF-8
340 Módulos Ruby para acessar os recursos do Subversion.
341
342 %package -n apache-mod_dav_svn
343 Summary:        Apache module: Subversion Server
344 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
345 Group:          Networking/Daemons
346 Requires:       %{name} = %{version}-%{release}
347 Requires:       apache(modules-api) = %apache_modules_api
348 Requires:       apache-mod_dav
349
350 %description -n apache-mod_dav_svn
351 Apache module: Subversion Server.
352
353 %description -n apache-mod_dav_svn -l pl.UTF-8
354 Moduł apache: Serwer Subversion.
355
356 %package -n apache-mod_authz_svn
357 Summary:        Apache module: Subversion Server - path-based authorization
358 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
359 Group:          Networking/Daemons
360 Requires:       apache(modules-api) = %apache_modules_api
361 Requires:       apache-mod_dav_svn = %{version}-%{release}
362
363 %description -n apache-mod_authz_svn
364 Apache module: Subversion Server - path-based authorization.
365
366 %description -n apache-mod_authz_svn -l pl.UTF-8
367 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
368
369 %package -n gnome-keyring-subversion
370 Summary:        Subversion module for Gnome Keyring
371 Summary(pl.UTF-8):      Moduł subversion dla zarządcy kluczy Gnome
372 Group:          X11/Applications
373
374 %description -n gnome-keyring-subversion
375 Subversion module for Gnome Keyring.
376
377 %description -n gnome-keyring-subversion -l pl.UTF-8
378 Moduł subversion dla zarządcy kluczy Gnome.
379
380 %package -n kde4-kwallet-subversion
381 Summary:        Subversion module for KDE Wallet
382 Summary(pl.UTF-8):      Moduł subversion dla Portfela KDE
383 Group:          X11/Applications
384
385 %description -n kde4-kwallet-subversion
386 Subversion module for KDE Wallet.
387
388 %description -n kde4-kwallet-subversion -l pl.UTF-8
389 Moduł subversion dla Portfela KDE.
390
391 %prep
392 %setup -q
393 rm -rf apr apr-util neon
394 %patch0 -p0
395 %patch1 -p1
396 %patch2 -p0
397
398 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
399
400 # serf.m4 macro is broken and ignores --without serf
401 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
402
403 %build
404 rm subversion/bindings/swig/proxy/*.swg
405 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
406 cp -f /usr/share/automake/config.sub ac-helpers
407 chmod +x ./autogen.sh && ./autogen.sh
408
409 %configure \
410         --with-editor=vi \
411         --with-zlib=%{_libdir} \
412 %if %{with net_client_only}
413         --without-apache \
414         --without-swig \
415         --without-apxs \
416         --without-berkeley-db \
417 %else
418         --disable-runtime-module-search \
419         --disable-mod-activation \
420 %if %{with apache}
421         --with-apxs=%{_sbindir}/apxs \
422 %else
423         --without-apache \
424         --without-apxs \
425         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
426 %endif
427 %if !%{with python} && !%{with perl} && !%{with ruby}
428         --without-swig \
429 %endif
430         %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
431         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
432 %endif
433         --with-jdk="%{java_home}" \
434 %if %{with neon}
435         --without-serf \
436         --with-neon=%{_prefix} \
437         --disable-neon-version-check \
438 %else
439         --with-serf=%{_prefix} \
440         --without-neon \
441 %endif
442         --with-apr=%{_bindir}/apr-1-config \
443         --with-apr-util=%{_bindir}/apu-1-config \
444 %if %{with kwallet}
445         --with-kwallet \
446 %endif
447         --with-gnome-keyring
448
449 %{__make} -j1
450
451 %if !%{with net_client_only}
452 # python
453 %if %{with python}
454 # ctypes bindings
455 %{__make} ctypes-python
456 # swig bindings
457 %{__make} swig-py \
458         swig_pydir=%{py_sitedir}/libsvn \
459         swig_pydir_extra=%{py_sitedir}/svn
460 %endif
461 # perl
462 %if %{with perl}
463 %{__make} -j1 swig-pl-lib
464 odir=$(pwd)
465 cd subversion/bindings/swig/perl/native
466 %{__perl} Makefile.PL INSTALLDIRS=vendor
467 %{__make} -j1
468 cd $odir
469 %endif
470 %if %{with javahl}
471 %{__make} -j1 javahl \
472         javahl_javadir="%{_javadir}"
473 %endif
474 # ruby
475 %if %{with ruby}
476 %{__make} swig-rb
477 %endif
478 %endif
479
480 %if %{with tests}
481 %{__make} check
482 %if %{with python}
483 %{__make} check-ctypes-python
484 %{__make} check-swig-py
485 %endif
486 %if %{with perl}
487 %{__make} check-swig-pl
488 %endif
489 %if %{with ruby}
490 %{__make} check-swig-rb
491 %endif
492 %endif
493
494 %install
495 rm -rf $RPM_BUILD_ROOT
496 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
497         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
498         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
499         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
500
501 %{__make} install -j1 \
502 %if %{with javahl}
503         install-javahl \
504         javahl_javadir="%{_javadir}" \
505 %endif
506 %if !%{with net_client_only}
507 %if %{with python}
508         install-swig-py \
509         install-ctypes-python \
510 %endif
511 %if %{with ruby}
512         install-swig-rb install-swig-rb-doc \
513 %endif
514 %endif
515         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
516         DESTDIR=$RPM_BUILD_ROOT \
517         swig_pydir=%{py_sitedir}/libsvn \
518         swig_pydir_extra=%{py_sitedir}/svn
519
520 %if !%{with net_client_only} && %{with perl}
521 %{__make} install-swig-pl-lib \
522         DESTDIR=$RPM_BUILD_ROOT
523 %{__make} -C subversion/bindings/swig/perl/native install \
524         DESTDIR=$RPM_BUILD_ROOT \
525         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
526         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
527 %endif
528
529 %if %{with apache}
530 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
531 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
532 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
533 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
534 %endif
535
536 %if !%{with net_client_only}
537 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
538 %if %{with python}
539 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
540 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
541 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
542 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
543 %endif
544 %endif
545
546 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
547 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
548
549 %find_lang %{name}
550
551 %{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
552 rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
553 rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
554
555 %clean
556 rm -rf $RPM_BUILD_ROOT
557
558 %pre svnserve
559 %groupadd -g 86 svn
560 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
561
562 %post   libs -p /sbin/ldconfig
563 %postun libs -p /sbin/ldconfig
564
565 %post   devel -p /sbin/postshell
566 -/usr/sbin/fix-info-dir -c %{_infodir}
567
568 %postun devel -p /sbin/postshell
569 -/usr/sbin/fix-info-dir -c %{_infodir}
570
571 %post   -n perl-subversion -p /sbin/ldconfig
572 %postun -n perl-subversion -p /sbin/ldconfig
573
574 %post   -n python-subversion -p /sbin/ldconfig
575 %postun -n python-subversion -p /sbin/ldconfig
576
577 %post svnserve
578 /sbin/chkconfig --add svnserve
579 %service svnserve restart "svnserve daemon"
580
581 %preun svnserve
582 if [ "$1" = "0" ]; then
583         %service svnserve stop
584         /sbin/chkconfig --del svnserve
585 fi
586
587 %postun svnserve
588 if [ "$1" = "0" ]; then
589         %userremove svn
590         %groupremove svn
591 fi
592
593 %post -n apache-mod_dav_svn
594 %service -q httpd restart
595
596 %preun -n apache-mod_dav_svn
597 if [ "$1" = "0" ]; then
598         %service -q httpd restart
599 fi
600
601 %files
602 %defattr(644,root,root,755)
603 %doc BUGS CHANGES COPYING INSTALL README
604 %doc doc/*/*.html
605 %doc tools/hook-scripts/*.{pl,py,example}
606 %doc tools/hook-scripts/mailer/*.{py,example}
607 %doc tools/xslt/*
608 %attr(755,root,root) %{_bindir}/svn
609 %attr(755,root,root) %{_bindir}/svnadmin
610 %attr(755,root,root) %{_bindir}/svndumpfilter
611 %attr(755,root,root) %{_bindir}/svnlook
612 %attr(755,root,root) %{_bindir}/svnsync
613 %attr(755,root,root) %{_bindir}/svnversion
614 %{_mandir}/man1/svn.1*
615 %{_mandir}/man1/svnadmin.1*
616 %{_mandir}/man1/svndumpfilter.1*
617 %{_mandir}/man1/svnlook.1*
618 %{_mandir}/man1/svnsync.1*
619 %{_mandir}/man1/svnversion.1*
620
621 %files libs -f %{name}.lang
622 %defattr(644,root,root,755)
623 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
624 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
625 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
626 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
627 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
628 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
629 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
630 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
631 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
632 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
633 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
634 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
635 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
636 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
637 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
638 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
639 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
640 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
641 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
642 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
643 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
644 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
645 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
646 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
647 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
648 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
649 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
650 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
651
652 %files devel
653 %defattr(644,root,root,755)
654 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
655 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
656 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
657 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
658 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
659 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
660 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
661 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
662 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
663 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
664 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
665 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
666 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
667 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
668 %{_libdir}/libsvn_client-1.la
669 %{_libdir}/libsvn_delta-1.la
670 %{_libdir}/libsvn_diff-1.la
671 %{_libdir}/libsvn_fs-1.la
672 %{_libdir}/libsvn_fs_base-1.la
673 %{_libdir}/libsvn_fs_fs-1.la
674 %{_libdir}/libsvn_fs_util-1.la
675 %{_libdir}/libsvn_ra-1.la
676 %{_libdir}/libsvn_ra_local-1.la
677 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
678 %{_libdir}/libsvn_ra_svn-1.la
679 %{_libdir}/libsvn_repos-1.la
680 %{_libdir}/libsvn_subr-1.la
681 %{_libdir}/libsvn_wc-1.la
682 %{_includedir}/%{name}-1
683 %{_examplesdir}/%{name}-%{version}
684
685 %files static
686 %defattr(644,root,root,755)
687 %{_libdir}/libsvn_client-1.a
688 %{_libdir}/libsvn_delta-1.a
689 %{_libdir}/libsvn_diff-1.a
690 %{_libdir}/libsvn_fs-1.a
691 %{_libdir}/libsvn_fs_base-1.a
692 %{_libdir}/libsvn_fs_fs-1.a
693 %{_libdir}/libsvn_fs_util-1.a
694 %{_libdir}/libsvn_ra-1.a
695 %{_libdir}/libsvn_ra_local-1.a
696 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
697 %{_libdir}/libsvn_ra_svn-1.a
698 %{_libdir}/libsvn_repos-1.a
699 %{_libdir}/libsvn_subr-1.a
700 %{_libdir}/libsvn_wc-1.a
701
702 %files -n gnome-keyring-subversion
703 %defattr(644,root,root,755)
704 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
705 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
706
707 %if %{with kwallet}
708 %files -n kde4-kwallet-subversion
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
711 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
712 %endif
713
714 %if !%{with net_client_only}
715 %files svnserve
716 %defattr(644,root,root,755)
717 %attr(755,root,root) %{_bindir}/svnserve
718 %{_mandir}/man5/svnserve.conf.5*
719 %{_mandir}/man8/svnserve.8*
720 %dir %attr(750,svn,svn) /home/services/subversion
721 %dir %attr(750,svn,svn) /home/services/subversion/repos
722 %if %{with apache}
723 %attr(754,root,root) /etc/rc.d/init.d/svnserve
724 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
725 %endif
726
727 %files tools
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{_bindir}/svn-hot-backup
730
731 %files -n bash-completion-subversion
732 %defattr(644,root,root,755)
733 /etc/bash_completion.d/%{name}
734
735 %if %{with javahl}
736 %files -n java-subversion
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
739 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
740 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
741 %{_javadir}/svn-javahl.jar
742 %endif
743
744 %if %{with python}
745 %files -n python-subversion
746 %defattr(644,root,root,755)
747 %doc tools/backup/*.py tools/examples/*.py
748 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
749 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
750 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
751 %dir %{py_sitedir}/libsvn
752 %{py_sitedir}/libsvn/*.py[co]
753 %dir %{py_sitedir}/svn
754 %{py_sitedir}/svn/*.py[co]
755 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
756 %{_examplesdir}/python-%{name}-%{version}
757
758 %files -n python-csvn
759 %defattr(644,root,root,755)
760 %doc subversion/bindings/ctypes-python/{README,TODO}
761 %doc subversion/bindings/ctypes-python/examples/*.py
762 %dir %{py_sitescriptdir}/csvn
763 %{py_sitescriptdir}/csvn/*.py[co]
764 %dir %{py_sitescriptdir}/csvn/core
765 %{py_sitescriptdir}/csvn/core/*.py[co]
766 %dir %{py_sitescriptdir}/csvn/ext
767 %{py_sitescriptdir}/csvn/ext/*.py[co]
768 %{py_sitescriptdir}/*.egg-info
769 %endif
770
771 %if %{with perl}
772 %files -n perl-subversion
773 %defattr(644,root,root,755)
774 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
775 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
776 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
777 %{perl_vendorarch}/SVN
778 %dir %{perl_vendorarch}/auto/SVN
779 %dir %{perl_vendorarch}/auto/SVN/*
780 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
781 %{perl_vendorarch}/auto/SVN/*/*.bs
782 %{_mandir}/man3/*.3pm*
783 %endif
784
785 %if %{with ruby}
786 %files -n ruby-subversion
787 %defattr(644,root,root,755)
788 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
789 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
790 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
791 %dir %{_libdir}/ruby/site_ruby/[0-9].[0-9]
792 %dir %{_libdir}/ruby/site_ruby/*/svn
793 %{_libdir}/ruby/site_ruby/*/svn/*.rb
794 %dir %{_libdir}/ruby/site_ruby/*/*-*
795 %dir %{_libdir}/ruby/site_ruby/*/*-*/svn
796 %dir %{_libdir}/ruby/site_ruby/*/*-*/svn/ext
797 %attr(755,root,root) %{_libdir}/ruby/site_ruby/*/*-*/svn/ext/*.so
798 %{_datadir}/ri/*.*/system/OptionParser
799 %{_datadir}/ri/*.*/system/Svn
800 %{_datadir}/ri/*.*/system/Time
801 %{_datadir}/ri/*.*/system/Uconv
802 %{_datadir}/ri/*.*/system/*.rid
803 %{_datadir}/ri/*.*/system/Kernel/*
804 %endif
805
806 %if %{with apache}
807 %files -n apache-mod_dav_svn
808 %defattr(644,root,root,755)
809 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
810 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
811
812 %files -n apache-mod_authz_svn
813 %defattr(644,root,root,755)
814 %doc subversion/mod_authz_svn/INSTALL
815 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
816 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
817 %endif
818
819 %endif # net_client_only
This page took 0.084094 seconds and 4 git commands to generate.