]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- initial pld release
[packages/subversion.git] / subversion.spec
1 Summary:        A Concurrent Versioning system similar to but better than CVS.
2 Summary(pl):    System Concurrent Versioning System ale lepszy ni¿ CVS
3 Name:           subversion
4 Version:        1587
5 Release:        1
6 License:        Apache/BSD Style
7 Group:          Development/Version Control
8 Source0:        http://subversion.tigris.org/%{name}-r%{version}.tar.gz
9 Source1:        %{name}-dav_svn.conf
10 Patch0:         %{name}-lib.patch
11 Patch1:         %{name}-apache2.patch
12 URL:            http://subversion.tigris.org/
13 BuildRequires:  db4-devel >= 4.0.14
14 BuildRequires:  apache-devel >= 2.0.35
15 BuildRequires:  neon-devel >= 0.19.2
16 BuildRequires:  expat-devel
17 BuildRequires:  python >= 2.0
18 BuildRequires:  bison
19 BuildRequires:  texinfo
20 BuildRequires:  autoconf >= 2.53
21 BuildRequires:  libtool >= 1.4
22 Requires(post): /usr/sbin/fix-info-dir
23 Requires(post): /sbin/ldconfig
24 Requires(postun): /sbin/ldconfig 
25 Requires(postun): /usr/sbin/fix-info-dir 
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _libexecdir     /usr/lib/apache
29
30 %description
31 The goal of the Subversion project is to build a version control
32 system that is a compelling replacement for CVS in the open source
33 community.
34
35 Our goals are:
36 - All current CVS features.
37 - Directories, renames, and file meta-data are versioned.
38 - Symbolic links, etc, are supported
39 - Commits are truly atomic.
40 - Branching and tagging are cheap (constant time) operations
41 - Repeated merges are handled gracefully
42 - Support for plug-in client side diff programs
43 - Natively client/server
44 - Client/server protocol sends diffs in both directions
45 - Costs are proportional to change size, not project size
46 - Internationalization
47 - Progressive multi-lingual support
48
49 %description -l pl
50 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
51 zamiennika dla CVS.
52
53 Cele projektu to:
54 - Wszystkie aktualne mo¿liwo¶ci CVS.
55 - Katalogi, zmiany nazw oraz meta-dane plików s± wersjonowane.
56 - Wsparcie dla linków symbolicznych itp.
57 - Commity s± w pe³ni atomowe.
58 - Branchowanie oraz tagowanie s± tanimi (sta³ymi w czasie) operacjami.
59 - Powtarzaj±ce merge.
60 - Wsparcie dla pluginów diff'a po stronie klienta.
61 - Natywny klient/serwer.
62 - Klient/Serwer przesy³aj± diffy w obu kierunkach.
63 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
64 - Internacjonalizacja.
65 - Postêpuj±ce wsparcie dla wielu jêzyków.
66
67 %package devel
68 Summary:        Header files and develpment documentation for subversion
69 Summary(pl):    Pliki nag³ówkowe i dokumetacja do subversion
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}
72
73 %description devel
74 Header files and develpment documentation for subversion.
75
76 %description devel -l pl
77 Pliki nag³ówkowe i dokumetacja do subversion.
78
79 %package static
80 Summary:        Static subversion library
81 Summary(pl):    Biblioteka statyczna subversion
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}
84
85 %description static
86 Static subversion library.
87
88 %description static -l pl
89 Biblioteka statyczna subversion.
90
91 %package -n apache-mod_dav_svn
92 Summary:        Apache module: Subversion Server
93 Summary(pl):    Modu³ apache: Serwer Subversion
94 Group:          Networking/Daemons
95 Requires:       apache(EAPI) >= 2.0.35
96 Requires:       apache-mod_dav >= 2.0.35
97 Requires(post): %{_sbindir}/apxs
98 Requires(preun):%{_sbindir}/apxs
99
100 %description -n apache-mod_dav_svn
101 Apache module: Subversion Server.
102
103 %description -n apache-mod_dav_svn
104 Modu³ apache: Serwer Subversion.
105
106 %prep
107 %setup -q -n %{name}-r%{version}
108 %patch0 -p1
109 %patch1 -p1
110
111 %build
112 ./autogen.sh
113 # EXPAT is external so get rid of all except (patched) xmlparse.h
114 rm -rf expat-lite/[a-w]*.[ch] expat-lite/xmldef.h expat-lite/xmlparse.c
115 rm -rf expat-lite/xmlrole* expat-lite/xmltok* neon apr
116 %configure \
117         --enable-dso \
118         --with-neon \
119         --with-apr=%{_sbindir}/apr-config \
120         --with-apxs=%{_sbindir}/apxs \
121         --with-berkeley-db=%{_includedir}/db4:%{_libdir}
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd,%{_libexecdir}}
127
128 # relinking sux
129 for i in 1 2; do
130 [ "$i" = "2" ] && find . -name "*.la" -exec rm -f "{}" ";"
131 %{__make} install \
132         INSTALL_MOD_SHARED=echo \
133         DESTDIR=$RPM_BUILD_ROOT \
134         libdir=$RPM_BUILD_ROOT%{_libdir} \
135         fs_libdir=$RPM_BUILD_ROOT%{_libdir} \
136         base_libdir=$RPM_BUILD_ROOT%{_libdir} \
137         bindir=$RPM_BUILD_ROOT%{_bindir} \
138         fs_bindir=$RPM_BUILD_ROOT%{_bindir} \
139         includedir=$RPM_BUILD_ROOT%{_includedir}/svn
140 done
141
142 install subversion/mod_dav_svn/.libs/*.so $RPM_BUILD_ROOT%{_libexecdir}
143 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/mod_dav_svn.conf
144
145 gzip -9nf BUGS CHANGES IDEAS INSTALL README
146
147 %post
148 /sbin/ldconfig
149 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
150
151 %postun
152 /sbin/ldconfig
153 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
154
155 %post -n apache-mod_dav_svn
156 %{_sbindir}/apxs -e -a -n dav_svn %{_libexecdir}/libmod_dav_svn.so 1>&2
157 if [ -f /etc/httpd/httpd.conf ] && ! grep -q "^Include.*mod_dav_svn.conf" /etc/httpd/httpd.conf; then
158         echo "Include /etc/httpd/mod_dav_svn.conf" >> /etc/httpd/httpd.conf
159 fi
160 if [ -f /var/lock/subsys/httpd ]; then
161         /etc/rc.d/init.d/httpd restart 1>&2
162 else
163         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
164 fi
165
166 %preun -n apache-mod_dav_svn
167 if [ "$1" = "0" ]; then
168         %{_sbindir}/apxs -e -A -n dav_svn %{_libexecdir}/libmod_dav_svn.so 1>&2
169         grep -v "^Include.*mod_dav_svn.conf" /etc/httpd/httpd.conf > \
170                 /etc/httpd/httpd.conf.tmp
171         mv -f /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
172         if [ -f /var/lock/subsys/httpd ]; then
173                 /etc/rc.d/init.d/httpd restart 1>&2
174         fi
175 fi
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %files
181 %defattr(644,root,root,755)
182 %doc *.gz
183 %attr(755,root,root) %{_bindir}/*
184 %attr(755,root,root) %{_libdir}/lib*.so.*
185 %{_mandir}/man1/*
186 %{_infodir}/svn*
187
188 %files devel
189 %defattr(644,root,root,755)
190 %{_includedir}/svn
191 %attr(755,root,root) %{_libdir}/lib*.so
192 %attr(755,root,root) %{_libdir}/lib*.la
193
194 %files static
195 %defattr(644,root,root,755)
196 %{_libdir}/lib*.a
197
198 %files -n apache-mod_dav_svn
199 %defattr(644,root,root,755)
200 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/httpd/mod_dav_svn.conf
201 %attr(755,root,root) %{_libexecdir}/*.so
This page took 0.043998 seconds and 4 git commands to generate.