]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- updated to 0.34.0 (fs schema changed so DUMP/LOAD cycle REQUIRED)
[packages/subversion.git] / subversion.spec
1 #
2 # TODO:
3 # - separate subpackage with svnserve + init.d script + sysconfig file
4 #
5 # Conditional build:
6 %bcond_with     internal_neon           # build with internal neon
7 %bcond_with     net_client_only         # build only net client
8 #       
9 %include        /usr/lib/rpm/macros.python
10 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
11 Summary:        A Concurrent Versioning system similar to but better than CVS
12 Summary(pl):    System kontroli wersji podobny, ale lepszy, ni¿ CVS
13 Summary(pt_BR): Sistema de versionamento concorrente
14 Name:           subversion
15 Version:        0.34.0
16 Release:        1
17 License:        Apache/BSD Style
18 Group:          Development/Version Control
19 Source0:        http://svn.collab.net/tarballs/%{name}-%{version}.tar.gz
20 # Source0-md5:  52f3a73858566d4d7045e449d94390e3
21 Source1:        %{name}-dav_svn.conf
22 Source2:        %{name}-authz_svn.conf
23 Source3:        %{name}-svnserve.init
24 Source4:        %{name}-svnserve.sysconfig
25 Patch0:         %{name}-perl.patch
26 Patch1:         %{name}-svnlook.patch
27 URL:            http://subversion.tigris.org/
28 %if %{with net_client_only}
29 %global apache_modules_api 0
30 %else
31 BuildRequires:  apache-devel >= 2.0.47-0.6
32 BuildRequires:  db-devel >= 4.1.25
33 BuildRequires:  rpmbuild(macros) >= 1.120
34 BuildRequires:  swig >= 1.3.17
35 BuildRequires:  swig-python >= 1.3.17
36 BuildRequires:  perl-devel >= 5.8.0
37 BuildRequires:  rpm-perlprov
38 %endif
39 BuildRequires:  apr-devel >= 1:0.9.5
40 BuildRequires:  apr-util-devel >= 1:0.9.5
41 BuildRequires:  autoconf >= 2.53
42 BuildRequires:  bison
43 BuildRequires:  docbook-style-xsl >= 1.56
44 BuildRequires:  expat-devel
45 BuildRequires:  libtool >= 1.4-9
46 BuildRequires:  libxslt-progs
47 %{!?with_internal_neon:BuildRequires:   neon-devel >= 0.24.1}
48 BuildRequires:  python >= 2.2
49 BuildRequires:  rpm-pythonprov >= 4.0.2-50
50 BuildRequires:  texinfo
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         _apachelibdir   /usr/lib/apache
54 %define         _libexecdir     %{_libdir}/svn
55
56 %description
57 The goal of the Subversion project is to build a version control
58 system that is a compelling replacement for CVS in the open source
59 community.
60
61 Our goals are:
62 - All current CVS features.
63 - Directories, renames, and file meta-data are versioned.
64 - Symbolic links, etc, are supported
65 - Commits are truly atomic.
66 - Branching and tagging are cheap (constant time) operations
67 - Repeated merges are handled gracefully
68 - Support for plug-in client side diff programs
69 - Natively client/server
70 - Client/server protocol sends diffs in both directions
71 - Costs are proportional to change size, not project size
72 - Internationalization
73 - Progressive multi-lingual support
74
75 %description -l pl
76 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
77 zamiennika dla CVS.
78
79 Cele projektu to:
80 - Wszystkie aktualne mo¿liwo¶ci CVS.
81 - Katalogi, zmiany nazw oraz meta-dane plików s± wersjonowane.
82 - Wsparcie dla linków symbolicznych itp.
83 - Commity s± w pe³ni atomowe.
84 - Branchowanie oraz tagowanie s± tanimi (sta³ymi w czasie) operacjami.
85 - Powtarzaj±ce merge.
86 - Wsparcie dla pluginów diff'a po stronie klienta.
87 - Natywny klient/serwer.
88 - Klient/Serwer przesy³aj± diffy w obu kierunkach.
89 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
90 - Internacjonalizacja.
91 - Postêpuj±ce wsparcie dla wielu jêzyków.
92
93 %description -l pt_BR
94 O objetivo do projeto Subversion é construir um sistema de controle de
95 versões que seja um substituto para o CVS (Concurrent Versioning
96 System) na comunidade opensource, fornecendo grandes melhorias.
97
98 %package libs
99 Summary:        Subversion libraries and modules
100 Summary(pl):    Biblioteka subversion oraz ³adowalne modu³y
101 Group:          Libraries
102 Obsoletes:      libsubversion0
103
104 %description libs
105 Subversion libraries and modules.
106
107 %description libs -l pl
108 Biblioteka subversion oraz ³adowalne modu³y.
109
110 %package devel
111 Summary:        Header files and develpment documentation for subversion
112 Summary(pl):    Pliki nag³ówkowe i dokumetacja do subversion
113 Summary(pt_BR): Arquivos de desenvolvimento para o Subversion
114 Group:          Development/Libraries
115 Requires:       %{name}-libs = %{version}
116 Obsoletes:      libsubversion0-devel
117
118 %description devel
119 Header files and develpment documentation for subversion.
120
121 %description devel -l pl
122 Pliki nag³ówkowe i dokumetacja do subversion.
123
124 %description devel -l pt_BR
125 Este pacote provê os arquivos necessários para desenvolvedores
126 interagirem com o Subversion.
127
128 %package static
129 Summary:        Static subversion library
130 Summary(pl):    Biblioteka statyczna subversion
131 Summary(pt_BR): Sistema de versionamento concorrente
132 Group:          Development/Libraries
133 Requires:       %{name}-devel = %{version}
134 Obsoletes:      libsubversion0-static-devel
135
136 %description static
137 Static subversion library.
138
139 %description static -l pl
140 Biblioteka statyczna subversion.
141
142 %description static -l pt_BR
143 Este pacote provê um cliente estático do subversion.
144
145 %package svnserve
146 Summary:        Subversion svnserve
147 Summary(pl):    Subversion svnserve
148 Group:          Networking/Daemons
149 PreReq:         rc-scripts
150 Requires(post,preun):   /sbin/chkconfig
151
152 %description svnserve
153 Subversion svnserve server.
154
155 %description svnserve -l pl
156 Serwer subversion svnserve.
157
158 %package tools
159 Summary:        Subversion tools and scripts
160 Summary(pl):    Narzêdzia oraz skrypty dla subversion
161 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
162 Group:          Applications
163 %pyrequires_eq  python
164 Requires:       python-rcsparse >= 0.1-0.20031026.0
165 Requires:       python-subversion = %{version}
166
167 %description tools
168 Subversion tools and scripts.
169
170 %description tools -l pl
171 Narzêdzia oraz skrypty dla subversion.
172
173 %package -n python-subversion
174 Summary:        Subversion python bindings
175 Summary(pl):    Dowi±zania do subversion dla pythona
176 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
177 Group:          Development/Languages/Python
178 %pyrequires_eq  python
179 Obsoletes:      subversion-python
180
181 %description -n python-subversion
182 Subversion python bindings.
183
184 %description -n python-subversion -l pl
185 Dowi±zania do subversion dla pythona.
186
187 %description -n python-subversion -l pt_BR
188 Módulos python para acessar os recursos do Subversion.
189
190 %package -n perl-subversion
191 Summary:        Subversion perl bindings
192 Summary(pl):    Dowi±zania do subversion dla perla
193 Summary(pt_BR): Módulos perl para acessar os recursos do Subversion
194 Group:          Development/Languages/Perl
195 Obsoletes:      subversion-perl
196
197 %description -n perl-subversion
198 Subversion perl bindings.
199
200 %description -n perl-subversion -l pl
201 Dowi±zania do subversion dla perl.
202
203 %description -n perl-subversion -l pt_BR
204 Módulos perl para acessar os recursos do Subversion.
205
206 %package -n apache-mod_dav_svn
207 Summary:        Apache module: Subversion Server
208 Summary(pl):    Modu³ apache: Serwer Subversion
209 Group:          Networking/Daemons
210 Requires:       apache >= 2.0.47
211 Requires:       apache(modules-api) = %{apache_modules_api}
212 Requires:       apache-mod_dav
213
214 %description -n apache-mod_dav_svn
215 Apache module: Subversion Server.
216
217 %description -n apache-mod_dav_svn -l pl
218 Modu³ apache: Serwer Subversion.
219
220 %package -n apache-mod_authz_svn
221 Summary:        Apache module: Subversion Server - path-based authorization
222 Summary(pl):    Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion
223 Group:          Networking/Daemons
224 Requires:       apache-mod_dav_svn = %{version}
225 Requires:       apache >= 2.0.47
226 Requires:       apache(modules-api) = %{apache_modules_api}
227
228 %description -n apache-mod_authz_svn
229 Apache module: Subversion Server - path-based authorization.
230
231 %description -n apache-mod_authz_svn -l pl
232 Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion.
233
234 %prep
235 %setup -q
236 %patch0 -p1
237 %patch1 -p0
238
239 %build
240 chmod +x ./autogen.sh && ./autogen.sh
241
242 # don't enable dso - currently it's broken
243 %configure \
244 %if %{with net_client_only}
245         --without-apache \
246         --without-swig \
247         --without-apxs \
248         --without-berkeley-db \
249 %else
250         --disable-dso \
251         --disable-mod-activation \
252         --with-apxs=%{_sbindir}/apxs \
253         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
254 %endif
255         %{!?with_internal_neon:--with-neon=%{_prefix}} \
256         --with-apr=%{_bindir}/apr-config \
257         --with-apr-util=%{_bindir}/apu-config
258
259 %{__make}
260
261 %if ! %{with net_client_only}
262 # python
263 %{__make} swig-py \
264         swig_pydir=%{py_sitedir}/libsvn \
265         swig_pydir_extra=%{py_sitedir}/svn
266 # perl
267 bdir=$(pwd)
268 %{__make} install-swig-pl-lib \
269         LC_ALL=C \
270         DESTDIR=${bdir}/swig-pl-lib-buildroot
271 %{__make}
272 cd subversion/bindings/swig/perl
273 env APR_CONFIG=%{_bindir}/apr-config \
274         %{__perl} Makefile.PL \
275         INSTALLDIRS=vendor
276 env LIBRARY_PATH=${bdir}/swig-pl-lib-buildroot%{_libdir} %{__make}
277 cd ../../../../
278 %endif
279
280 # build documentation; build process for documentation is severely
281 # braindamaged -- authors suggests to untar docbook distribution in
282 # build directory, hence the hack here
283 ln -s /usr/share/sgml/docbook/xsl-stylesheets doc/book/tools/xsl
284 %{__make} -C doc/book all-html
285
286 # prepare for %%doc below
287 mv -f doc/book/book/html-chunk svn-handbook
288 mkdir svn-handbook/images/
289 cp -f doc/book/book/images/*.png svn-handbook/images/
290
291 %install
292 rm -rf $RPM_BUILD_ROOT
293 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
294 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}}
295
296 %{__make} install \
297         LC_ALL=C \
298         %{!?with_net_client_only:install-swig-py} \
299         DESTDIR=$RPM_BUILD_ROOT \
300         swig_pydir=%{py_sitedir}/libsvn \
301         swig_pydir_extra=%{py_sitedir}/svn
302
303 %if ! %{with net_client_only}
304 %{__make} install-swig-pl-lib \
305         LC_ALL=C \
306         DESTDIR=$RPM_BUILD_ROOT
307 %{__make} -C subversion/bindings/swig/perl install \
308         DESTDIR=$RPM_BUILD_ROOT
309 %endif
310
311 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
312 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
313 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
314 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
315 install doc/programmer/design/*.info* $RPM_BUILD_ROOT%{_infodir}/
316
317 %if ! %{with net_client_only}
318 install tools/cvs2svn/cvs2svn.py        $RPM_BUILD_ROOT%{_bindir}/cvs2svn
319 install tools/cvs2svn/cvs2svn.1         $RPM_BUILD_ROOT%{_mandir}/man1
320 cp tools/cvs2svn/README tools/cvs2svn/README.cvs2svn
321
322 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
323 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
324 %endif
325
326 %clean
327 rm -rf $RPM_BUILD_ROOT
328
329 %post devel
330 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
331
332 %postun devel
333 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
334
335 %post   libs -p /sbin/ldconfig
336 %postun libs -p /sbin/ldconfig
337
338 %post svnserve
339 if [ -f /var/lock/subsys/svnserve ]; then
340         /etc/rc.d/init.d/svnserve restart 1>&2
341 else
342         echo "Run \"/etc/rc.d/init.d/svnserve start\" to start subversion svnserve daemon."
343 fi
344
345 %preun svnserve
346 if [ "$1" = "0" ]; then
347         if [ -f /var/lock/subsys/svnserve ]; then
348                 /etc/rc.d/init.d/svnserve restart 1>&2
349         fi
350 fi
351
352 %post -n apache-mod_dav_svn
353 if [ -f /var/lock/subsys/httpd ]; then
354         /etc/rc.d/init.d/httpd restart 1>&2
355 else
356         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
357 fi
358
359 %preun -n apache-mod_dav_svn
360 if [ "$1" = "0" ]; then
361         if [ -f /var/lock/subsys/httpd ]; then
362                 /etc/rc.d/init.d/httpd restart 1>&2
363         fi
364 fi
365
366 %files
367 %defattr(644,root,root,755)
368 %doc BUGS CHANGES COPYING INSTALL README
369 %doc svn-handbook doc/book/misc-docs/misc-docs.html
370 %doc tools/hook-scripts/*.{pl,py,example}
371 %doc tools/hook-scripts/mailer/*.{py,example}
372 %attr(755,root,root) %{_bindir}/svn*
373 %exclude %{_bindir}/svnserve
374 %{_mandir}/man1/*
375 %{_mandir}/man5/*
376 %{_mandir}/man8/*
377 %exclude %{_mandir}/man?/svnserve*
378 %{?with_internal_neon:%exclude %{_mandir}/man1/neon*}
379
380 %files libs
381 %defattr(644,root,root,755)
382 %attr(755,root,root) %{_libdir}/lib*.so.*
383
384 %files devel
385 %defattr(644,root,root,755)
386 %{_includedir}/%{name}*
387 %attr(755,root,root) %{_libdir}/lib*.so
388 %{_libdir}/lib*.la
389 %{_infodir}/svn*
390
391 %files static
392 %defattr(644,root,root,755)
393 %{_libdir}/lib*.a
394
395 %if ! %{with net_client_only}
396 %files svnserve
397 %defattr(644,root,root,755)
398 %attr(755,root,root) %{_bindir}/svnserve
399 %{_mandir}/man?/svnserve*
400 %attr(754,root,root) /etc/rc.d/init.d/svnserve
401 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/svnserve
402
403 %files tools
404 %defattr(644,root,root,755)
405 %doc tools/cvs2svn/README*
406 %attr(755,root,root) %{_bindir}/cvs*
407 %{_mandir}/man1/cvs*
408
409 %files -n python-subversion
410 %defattr(644,root,root,755)
411 %doc tools/backup/*.py tools/examples/*.py
412 %dir %{py_sitedir}/svn
413 %dir %{py_sitedir}/libsvn
414 %{py_sitedir}/svn/*.py[co]
415 %{py_sitedir}/libsvn/*.py[co]
416 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
417
418 %files -n perl-subversion
419 %defattr(644,root,root,755)
420 %{perl_vendorarch}/SVN
421 %dir %{perl_vendorarch}/auto/SVN
422 %dir %{perl_vendorarch}/auto/SVN/*
423 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
424 %{perl_vendorarch}/auto/SVN/*/*.bs
425 %{_mandir}/man3/*.3pm*
426
427 %files -n apache-mod_dav_svn
428 %defattr(644,root,root,755)
429 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
430 %attr(755,root,root) %{_apachelibdir}/mod_dav_svn.so
431
432 %files -n apache-mod_authz_svn
433 %defattr(644,root,root,755)
434 %doc subversion/mod_authz_svn/INSTALL
435 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
436 %attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
437 %endif
This page took 0.104829 seconds and 4 git commands to generate.