]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- do not pull java-sun via BR - icedtea6 should be enough in all (most) cases
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - remove net_client_only and add db bcond (then without apache and
3 #   without db => net_client_only - spec will be more simpler, I think)
4 # - finish ruby
5 # - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
6 #
7 # Conditional build:
8 %bcond_with     net_client_only         # build only net client
9 %bcond_without  neon                    # use serf instead of neon
10 %bcond_without  python                  # build without python bindings (broken)
11 %bcond_without  perl                    # build without perl bindings
12 %bcond_without  ruby                    # build without ruby bindings
13 %bcond_without  apache                  # build without apache support (webdav, etc)
14 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
15 %bcond_without  tests                   # don't perform "make check"
16 %bcond_without  kwallet                 # build without kde4 wallet support
17 %bcond_without  gnome                   # build without gnome keyring support
18 #
19 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
20 %define apxs    /usr/sbin/apxs
21 %define pdir    SVN
22 %define pnam    _Core
23 #
24 %if %{with neon}
25 %define webdavlib       neon
26 %else
27 %define webdavlib       serf
28 %endif
29 #
30 Summary:        A Concurrent Versioning system similar to but better than CVS
31 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
32 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
33 Name:           subversion
34 Version:        1.6.9
35 Release:        5
36 License:        Apache/BSD-like
37 Group:          Development/Version Control
38 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
39 # Source0-md5:  9c30a47b1d48664e7afef68bb4834c53
40 Source1:        %{name}-dav_svn.conf
41 Source2:        %{name}-authz_svn.conf
42 Source3:        %{name}-svnserve.init
43 Source4:        %{name}-svnserve.sysconfig
44 # current subversion tarball has correct *.swg files
45 # but after regeneration these are broken again, so
46 # we still need this script
47 Source5:        %{name}-convert-typemaps-to-ifdef.py
48 Patch0:         %{name}-home_etc.patch
49 Patch1:         %{name}-DESTDIR.patch
50 Patch2:         %{name}-ruby-datadir-path.patch
51 URL:            http://subversion.apache.org/
52 %if %{with net_client_only}
53 %global apache_modules_api 0
54 %else
55 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
56 BuildRequires:  automake
57 BuildRequires:  db-devel >= 4.1.25
58 BuildRequires:  rpmbuild(macros) >= 1.268
59 %if %{with perl}
60 BuildRequires:  perl-devel >= 1:5.8.0
61 BuildRequires:  rpm-perlprov >= 4.1-13
62 BuildRequires:  swig-perl >= 1.3.24
63 %endif
64 %if %{with python}
65 BuildRequires:  python-ctypesgen
66 BuildRequires:  python-devel >= 2.2
67 BuildRequires:  swig-python >= 1.3.24
68 %endif
69 %if %{with ruby}
70 BuildRequires:  ruby-devel
71 BuildRequires:  swig-ruby >= 1.3.24
72 %endif
73 %if %{with javahl}
74 BuildRequires:  jdk
75 %endif
76 BuildRequires:  cyrus-sasl-devel
77 %endif
78 BuildRequires:  apr-devel >= 1:1.0.0
79 BuildRequires:  apr-util-devel >= 1:1.2.8-3
80 BuildRequires:  autoconf >= 2.59
81 BuildRequires:  bison
82 BuildRequires:  expat-devel
83 BuildRequires:  gettext-devel
84 %{?with_gnome:BuildRequires:    gnome-keyring-devel}
85 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
86 BuildRequires:  libtool >= 1.4-9
87 BuildRequires:  pkgconfig
88 BuildRequires:  sed >= 4.0
89 BuildRequires:  sqlite3-devel >= 3.6.11
90 BuildRequires:  texinfo
91 BuildRequires:  which
92 %if %{with neon}
93 BuildRequires:  neon-devel >= 0.26.0
94 %else
95 BuildRequires:  serf-devel
96 %endif
97 BuildRequires:  python >= 2.2
98 BuildRequires:  python-modules >= 2.2
99 Requires:       %{name}-libs = %{version}-%{release}
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %define         _libexecdir             %{_libdir}/svn
103 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
104 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
105
106 %description
107 The goal of the Subversion project is to build a version control
108 system that is a compelling replacement for CVS in the open source
109 community.
110
111 Our goals are:
112 - All current CVS features.
113 - Directories, renames, and file meta-data are versioned.
114 - Symbolic links, etc, are supported
115 - Commits are truly atomic.
116 - Branching and tagging are cheap (constant time) operations
117 - Repeated merges are handled gracefully
118 - Support for plug-in client side diff programs
119 - Natively client/server
120 - Client/server protocol sends diffs in both directions
121 - Costs are proportional to change size, not project size
122 - Internationalization
123 - Progressive multi-lingual support
124
125 %description -l pl.UTF-8
126 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
127 zamiennika dla CVS.
128
129 Cele projektu to:
130 - Wszystkie aktualne możliwości CVS.
131 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
132 - Obsługa dowiązań symbolicznych itp.
133 - Commity są w pełni atomowe.
134 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
135 - Dobra obsługa powtarzanego łączenia (merge).
136 - Obsługa wtyczek diff po stronie klienta.
137 - Natywny klient/serwer.
138 - Klient/Serwer przesyłają diffy w obu kierunkach.
139 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
140 - Internacjonalizacja.
141 - Postępujące wsparcie dla wielu języków.
142
143 %description -l pt_BR.UTF-8
144 O objetivo do projeto Subversion é construir um sistema de controle de
145 versões que seja um substituto para o CVS (Concurrent Versioning
146 System) na comunidade opensource, fornecendo grandes melhorias.
147
148 %package libs
149 Summary:        Subversion libraries and modules
150 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
151 Group:          Libraries
152 %{?with_neon:Requires:  neon >= 0.26.0}
153 Obsoletes:      libsubversion0
154
155 %description libs
156 Subversion libraries and modules.
157
158 %description libs -l pl.UTF-8
159 Biblioteka subversion oraz ładowalne moduły.
160
161 %package devel
162 Summary:        Header files and develpment documentation for subversion
163 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
164 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
165 Group:          Development/Libraries
166 Requires:       %{name}-libs = %{version}-%{release}
167 Requires:       apr-util-devel >= 1:1.0.0
168 %{?with_neon:Requires:  neon-devel >= 0.26.0}
169 Obsoletes:      libsubversion0-devel
170
171 %description devel
172 Header files and develpment documentation for subversion.
173
174 %description devel -l pl.UTF-8
175 Pliki nagłówkowe i dokumetacja do subversion.
176
177 %description devel -l pt_BR.UTF-8
178 Este pacote provê os arquivos necessários para desenvolvedores
179 interagirem com o Subversion.
180
181 %package static
182 Summary:        Static subversion library
183 Summary(pl.UTF-8):      Biblioteka statyczna subversion
184 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
185 Group:          Development/Libraries
186 Requires:       %{name}-devel = %{version}
187 Obsoletes:      libsubversion0-static-devel
188
189 %description static
190 Static subversion library.
191
192 %description static -l pl.UTF-8
193 Biblioteka statyczna subversion.
194
195 %description static -l pt_BR.UTF-8
196 Este pacote provê um cliente estático do subversion.
197
198 %package svnserve
199 Summary:        Subversion svnserve
200 Summary(pl.UTF-8):      Subversion svnserve
201 Group:          Networking/Daemons
202 Requires(post,preun):   /sbin/chkconfig
203 Requires(postun):       /usr/sbin/groupdel
204 Requires(postun):       /usr/sbin/userdel
205 Requires(pre):  /bin/id
206 Requires(pre):  /usr/bin/getgid
207 Requires(pre):  /usr/lib/rpm/user_group.sh
208 Requires(pre):  /usr/sbin/groupadd
209 Requires(pre):  /usr/sbin/useradd
210 Requires(pre):  /usr/sbin/usermod
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       rc-scripts
213 Provides:       group(svn)
214 Provides:       user(svn)
215
216 %description svnserve
217 Subversion svnserve server.
218
219 %description svnserve -l pl.UTF-8
220 Serwer subversion svnserve.
221
222 %package tools
223 Summary:        Subversion tools and scripts
224 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
225 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
226 Group:          Applications
227 %pyrequires_eq  python
228 Requires:       %{name} = %{version}-%{release}
229 Requires:       python-subversion = %{version}
230
231 %description tools
232 Subversion tools and scripts.
233
234 %description tools -l pl.UTF-8
235 Narzędzia oraz skrypty dla subversion.
236
237 %package -n bash-completion-subversion
238 Summary:        bash completion for subversion
239 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
240 Group:          Applications/Shells
241 Requires:       %{name} = %{version}-%{release}
242 Requires:       bash-completion
243 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
244
245 %description -n bash-completion-subversion
246 Bash completion for subversion.
247
248 %description -n bash-completion-subversion -l pl.UTF-8
249 Dopełnienia basha dla subversion.
250
251 %package -n java-subversion
252 Summary:        Subversion Java bindings
253 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
254 Group:          Development/Languages/Java
255 Requires:       %{name}-libs = %{version}-%{release}
256
257 %description -n java-subversion
258 This is a set of Java classes which provide the functionality of
259 subversion-libs, the Subversion libraries. It is useful if you want
260 to, for example, write a Java class that manipulates a Subversion
261 repository or working copy. See the 'subversion' package for more
262 information.
263
264 %description -n java-subversion -l pl.UTF-8
265 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
266 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
267 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
268 roboczą. Więcej informacji w pakiecie subversion.
269
270 %package -n python-subversion
271 Summary:        Subversion Python bindings
272 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
273 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
274 Group:          Development/Languages/Python
275 %pyrequires_eq  python
276 Requires:       %{name}-libs = %{version}-%{release}
277 Obsoletes:      subversion-python
278
279 %description -n python-subversion
280 Subversion Python bindings.
281
282 %description -n python-subversion -l pl.UTF-8
283 Dowiązania do Subversion dla Pythona.
284
285 %description -n python-subversion -l pt_BR.UTF-8
286 Módulos Python para acessar os recursos do Subversion.
287
288 %package -n python-csvn
289 Summary:        CTypes Subversion Python bindings
290 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
291 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
292 Group:          Development/Languages/Python
293 %pyrequires_eq  python
294 Requires:       %{name}-libs = %{version}-%{release}
295
296 %description -n python-csvn
297 Subversion CTypes Python bindings.
298
299 %description -n python-csvn -l pl.UTF-8
300 Dowiązania do Subversion dla Pythona używające CTypes.
301
302 %description -n python-csvn -l pt_BR.UTF-8
303 Módulos Python para acessar os recursos do Subversion.
304
305 %package -n perl-subversion
306 Summary:        Subversion Perl bindings
307 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
308 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
309 Group:          Development/Languages/Perl
310 Requires:       %{name}-libs = %{version}-%{release}
311 Obsoletes:      subversion-perl
312
313 %description -n perl-subversion
314 Subversion Perl bindings.
315
316 %description -n perl-subversion -l pl.UTF-8
317 Dowiązania do Subversion dla Perla.
318
319 %description -n perl-subversion -l pt_BR.UTF-8
320 Módulos Perl para acessar os recursos do Subversion.
321
322 %package -n ruby-subversion
323 Summary:        Subversion Ruby bindings
324 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
325 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
326 Group:          Development/Languages
327 Requires:       %{name}-libs = %{version}-%{release}
328 Obsoletes:      subversion-ruby
329
330 %description -n ruby-subversion
331 Subversion Ruby bindings.
332
333 %description -n ruby-subversion -l pl.UTF-8
334 Dowiązania do Subversion dla języka Ruby.
335
336 %description -n ruby-subversion -l pt_BR.UTF-8
337 Módulos Ruby para acessar os recursos do Subversion.
338
339 %package -n apache-mod_dav_svn
340 Summary:        Apache module: Subversion Server
341 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
342 Group:          Networking/Daemons
343 Requires:       %{name} = %{version}-%{release}
344 Requires:       apache(modules-api) = %apache_modules_api
345 Requires:       apache-mod_dav
346
347 %description -n apache-mod_dav_svn
348 Apache module: Subversion Server.
349
350 %description -n apache-mod_dav_svn -l pl.UTF-8
351 Moduł apache: Serwer Subversion.
352
353 %package -n apache-mod_authz_svn
354 Summary:        Apache module: Subversion Server - path-based authorization
355 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
356 Group:          Networking/Daemons
357 Requires:       apache(modules-api) = %apache_modules_api
358 Requires:       apache-mod_dav_svn = %{version}-%{release}
359
360 %description -n apache-mod_authz_svn
361 Apache module: Subversion Server - path-based authorization.
362
363 %description -n apache-mod_authz_svn -l pl.UTF-8
364 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
365
366 %package -n gnome-keyring-subversion
367 Summary:        Subversion module for Gnome Keyring
368 Summary(pl.UTF-8):      Moduł subversion dla zarządcy kluczy Gnome
369 Group:          X11/Applications
370
371 %description -n gnome-keyring-subversion
372 Subversion module for Gnome Keyring.
373
374 %description -n gnome-keyring-subversion -l pl.UTF-8
375 Moduł subversion dla zarządcy kluczy Gnome.
376
377 %package -n kde4-kwallet-subversion
378 Summary:        Subversion module for KDE Wallet
379 Summary(pl.UTF-8):      Moduł subversion dla Portfela KDE
380 Group:          X11/Applications
381
382 %description -n kde4-kwallet-subversion
383 Subversion module for KDE Wallet.
384
385 %description -n kde4-kwallet-subversion -l pl.UTF-8
386 Moduł subversion dla Portfela KDE.
387
388 %prep
389 %setup -q
390 rm -rf apr apr-util neon
391 %patch0 -p0
392 %patch1 -p1
393 %patch2 -p0
394
395 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
396
397 # serf.m4 macro is broken and ignores --without serf
398 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
399
400 %build
401 rm subversion/bindings/swig/proxy/*.swg
402 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
403 cp -f /usr/share/automake/config.sub ac-helpers
404 chmod +x ./autogen.sh && ./autogen.sh
405
406 %configure \
407         --with-editor=vi \
408         --with-zlib=%{_libdir} \
409 %if %{with net_client_only}
410         --without-apache \
411         --without-swig \
412         --without-apxs \
413         --without-berkeley-db \
414 %else
415         --disable-runtime-module-search \
416         --disable-mod-activation \
417         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
418 %if %{with apache}
419         --with-apxs=%{_sbindir}/apxs \
420 %else
421         --without-apache \
422         --without-apxs \
423 %endif
424 %if !%{with python} && !%{with perl} && !%{with ruby}
425         --without-swig \
426 %endif
427         %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
428         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
429 %endif
430         --with-jdk="%{java_home}" \
431 %if %{with neon}
432         --without-serf \
433         --with-neon=%{_prefix} \
434         --disable-neon-version-check \
435 %else
436         --with-serf=%{_prefix} \
437         --without-neon \
438 %endif
439         --with-apr=%{_bindir}/apr-1-config \
440         --with-apr-util=%{_bindir}/apu-1-config \
441 %if %{with kwallet}
442         --with-kwallet \
443 %endif
444 %if %{with gnome}
445         --with-gnome-keyring
446 %endif
447
448 %{__make} -j1
449
450 %if !%{with net_client_only}
451 # python
452 %if %{with python}
453 # ctypes bindings
454 %{__make} ctypes-python
455 # swig bindings
456 %{__make} swig-py \
457         swig_pydir=%{py_sitedir}/libsvn \
458         swig_pydir_extra=%{py_sitedir}/svn
459 %endif
460 # perl
461 %if %{with perl}
462 %{__make} -j1 swig-pl-lib
463 odir=$(pwd)
464 cd subversion/bindings/swig/perl/native
465 %{__perl} Makefile.PL INSTALLDIRS=vendor
466 %{__make} -j1
467 cd $odir
468 %endif
469 %if %{with javahl}
470 %{__make} -j1 javahl \
471         javahl_javadir="%{_javadir}"
472 %endif
473 # ruby
474 %if %{with ruby}
475 %{__make} swig-rb
476 %endif
477 %endif
478
479 %if %{with tests}
480 %{__make} check
481 %if %{with python}
482 %{__make} check-ctypes-python
483 %{__make} check-swig-py
484 %endif
485 %if %{with perl}
486 %{__make} check-swig-pl
487 %endif
488 %if %{with ruby}
489 %{__make} check-swig-rb
490 %endif
491 %endif
492
493 %install
494 rm -rf $RPM_BUILD_ROOT
495 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
496         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
497         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
498         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
499
500 %{__make} install -j1 \
501 %if %{with javahl}
502         install-javahl \
503         javahl_javadir="%{_javadir}" \
504 %endif
505 %if !%{with net_client_only}
506 %if %{with python}
507         install-swig-py \
508         install-ctypes-python \
509 %endif
510 %if %{with ruby}
511         install-swig-rb install-swig-rb-doc \
512 %endif
513 %endif
514         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
515         DESTDIR=$RPM_BUILD_ROOT \
516         swig_pydir=%{py_sitedir}/libsvn \
517         swig_pydir_extra=%{py_sitedir}/svn
518
519 %if !%{with net_client_only} && %{with perl}
520 %{__make} install-swig-pl-lib \
521         DESTDIR=$RPM_BUILD_ROOT
522 %{__make} -C subversion/bindings/swig/perl/native install \
523         DESTDIR=$RPM_BUILD_ROOT \
524         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
525         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
526 %endif
527
528 %if %{with apache}
529 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
530 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
531 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
532 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
533 %endif
534
535 %if !%{with net_client_only}
536 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
537 %if %{with python}
538 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
539 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
540 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
541 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
542 %endif
543 %endif
544
545 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
546 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
547
548 %find_lang %{name}
549
550 %{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
551 rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
552 rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
553
554 %clean
555 rm -rf $RPM_BUILD_ROOT
556
557 %pre svnserve
558 %groupadd -g 86 svn
559 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
560
561 %post   libs -p /sbin/ldconfig
562 %postun libs -p /sbin/ldconfig
563
564 %post   devel -p /sbin/postshell
565 -/usr/sbin/fix-info-dir -c %{_infodir}
566
567 %postun devel -p /sbin/postshell
568 -/usr/sbin/fix-info-dir -c %{_infodir}
569
570 %post   -n perl-subversion -p /sbin/ldconfig
571 %postun -n perl-subversion -p /sbin/ldconfig
572
573 %post   -n python-subversion -p /sbin/ldconfig
574 %postun -n python-subversion -p /sbin/ldconfig
575
576 %post svnserve
577 /sbin/chkconfig --add svnserve
578 %service svnserve restart "svnserve daemon"
579
580 %preun svnserve
581 if [ "$1" = "0" ]; then
582         %service svnserve stop
583         /sbin/chkconfig --del svnserve
584 fi
585
586 %postun svnserve
587 if [ "$1" = "0" ]; then
588         %userremove svn
589         %groupremove svn
590 fi
591
592 %post -n apache-mod_dav_svn
593 %service -q httpd restart
594
595 %postun -n apache-mod_dav_svn
596 if [ "$1" = "0" ]; then
597         %service -q httpd restart
598 fi
599
600 %post -n apache-mod_authz_svn
601 %service -q httpd restart
602
603 %postun -n apache-mod_authz_svn
604 if [ "$1" = "0" ]; then
605         %service -q httpd restart
606 fi
607
608 %files
609 %defattr(644,root,root,755)
610 %doc BUGS CHANGES COPYING INSTALL README
611 %doc doc/*/*.html
612 %doc tools/hook-scripts/*.{pl,py,example}
613 %doc tools/hook-scripts/mailer/*.{py,example}
614 %doc tools/xslt/*
615 %attr(755,root,root) %{_bindir}/svn
616 %attr(755,root,root) %{_bindir}/svnadmin
617 %attr(755,root,root) %{_bindir}/svndumpfilter
618 %attr(755,root,root) %{_bindir}/svnlook
619 %attr(755,root,root) %{_bindir}/svnsync
620 %attr(755,root,root) %{_bindir}/svnversion
621 %{_mandir}/man1/svn.1*
622 %{_mandir}/man1/svnadmin.1*
623 %{_mandir}/man1/svndumpfilter.1*
624 %{_mandir}/man1/svnlook.1*
625 %{_mandir}/man1/svnsync.1*
626 %{_mandir}/man1/svnversion.1*
627
628 %files libs -f %{name}.lang
629 %defattr(644,root,root,755)
630 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
631 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
632 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
633 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
634 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
635 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
636 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
637 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
638 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
639 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
640 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
641 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
642 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
643 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
644 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
645 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
646 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
647 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
648 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
649 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
650 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
651 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
652 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
653 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
654 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
655 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
656 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
657 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
658
659 %files devel
660 %defattr(644,root,root,755)
661 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
662 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
663 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
664 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
665 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
666 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
667 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
668 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
669 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
670 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
671 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
672 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
673 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
674 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
675 %{_libdir}/libsvn_client-1.la
676 %{_libdir}/libsvn_delta-1.la
677 %{_libdir}/libsvn_diff-1.la
678 %{_libdir}/libsvn_fs-1.la
679 %{_libdir}/libsvn_fs_base-1.la
680 %{_libdir}/libsvn_fs_fs-1.la
681 %{_libdir}/libsvn_fs_util-1.la
682 %{_libdir}/libsvn_ra-1.la
683 %{_libdir}/libsvn_ra_local-1.la
684 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
685 %{_libdir}/libsvn_ra_svn-1.la
686 %{_libdir}/libsvn_repos-1.la
687 %{_libdir}/libsvn_subr-1.la
688 %{_libdir}/libsvn_wc-1.la
689 %{_includedir}/%{name}-1
690 %{_examplesdir}/%{name}-%{version}
691
692 %files static
693 %defattr(644,root,root,755)
694 %{_libdir}/libsvn_client-1.a
695 %{_libdir}/libsvn_delta-1.a
696 %{_libdir}/libsvn_diff-1.a
697 %{_libdir}/libsvn_fs-1.a
698 %{_libdir}/libsvn_fs_base-1.a
699 %{_libdir}/libsvn_fs_fs-1.a
700 %{_libdir}/libsvn_fs_util-1.a
701 %{_libdir}/libsvn_ra-1.a
702 %{_libdir}/libsvn_ra_local-1.a
703 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
704 %{_libdir}/libsvn_ra_svn-1.a
705 %{_libdir}/libsvn_repos-1.a
706 %{_libdir}/libsvn_subr-1.a
707 %{_libdir}/libsvn_wc-1.a
708
709 %if %{with gnome}
710 %files -n gnome-keyring-subversion
711 %defattr(644,root,root,755)
712 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
713 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
714 %endif
715
716 %if %{with kwallet}
717 %files -n kde4-kwallet-subversion
718 %defattr(644,root,root,755)
719 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
720 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
721 %endif
722
723 %if !%{with net_client_only}
724 %files svnserve
725 %defattr(644,root,root,755)
726 %attr(755,root,root) %{_bindir}/svnserve
727 %{_mandir}/man5/svnserve.conf.5*
728 %{_mandir}/man8/svnserve.8*
729 %dir %attr(750,svn,svn) /home/services/subversion
730 %dir %attr(750,svn,svn) /home/services/subversion/repos
731 %if %{with apache}
732 %attr(754,root,root) /etc/rc.d/init.d/svnserve
733 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
734 %endif
735
736 %files tools
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{_bindir}/svn-hot-backup
739
740 %files -n bash-completion-subversion
741 %defattr(644,root,root,755)
742 /etc/bash_completion.d/%{name}
743
744 %if %{with javahl}
745 %files -n java-subversion
746 %defattr(644,root,root,755)
747 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
748 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
749 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
750 %{_javadir}/svn-javahl.jar
751 %endif
752
753 %if %{with python}
754 %files -n python-subversion
755 %defattr(644,root,root,755)
756 %doc tools/backup/*.py tools/examples/*.py
757 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
758 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
759 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
760 %dir %{py_sitedir}/libsvn
761 %{py_sitedir}/libsvn/*.py[co]
762 %dir %{py_sitedir}/svn
763 %{py_sitedir}/svn/*.py[co]
764 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
765 %{_examplesdir}/python-%{name}-%{version}
766
767 %files -n python-csvn
768 %defattr(644,root,root,755)
769 %doc subversion/bindings/ctypes-python/{README,TODO}
770 %doc subversion/bindings/ctypes-python/examples/*.py
771 %dir %{py_sitescriptdir}/csvn
772 %{py_sitescriptdir}/csvn/*.py[co]
773 %dir %{py_sitescriptdir}/csvn/core
774 %{py_sitescriptdir}/csvn/core/*.py[co]
775 %dir %{py_sitescriptdir}/csvn/ext
776 %{py_sitescriptdir}/csvn/ext/*.py[co]
777 %{py_sitescriptdir}/*.egg-info
778 %endif
779
780 %if %{with perl}
781 %files -n perl-subversion
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
784 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
785 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
786 %{perl_vendorarch}/SVN
787 %dir %{perl_vendorarch}/auto/SVN
788 %dir %{perl_vendorarch}/auto/SVN/*
789 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
790 %{perl_vendorarch}/auto/SVN/*/*.bs
791 %{_mandir}/man3/*.3pm*
792 %endif
793
794 %if %{with ruby}
795 %files -n ruby-subversion
796 %defattr(644,root,root,755)
797 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
798 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
799 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
800 %dir %{ruby_sitelibdir}/svn
801 %{ruby_sitelibdir}/svn/*.rb
802 %dir %{ruby_sitearchdir}/svn
803 %dir %{ruby_sitearchdir}/svn/ext
804 %attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
805 %{ruby_ridir}/Svn
806 %endif
807
808 %if %{with apache}
809 %files -n apache-mod_dav_svn
810 %defattr(644,root,root,755)
811 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
812 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
813
814 %files -n apache-mod_authz_svn
815 %defattr(644,root,root,755)
816 %doc subversion/mod_authz_svn/INSTALL
817 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
818 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
819 %endif
820
821 %endif # net_client_only
This page took 0.080546 seconds and 4 git commands to generate.