]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- added tests patch (disables auth test, which fails when subversion cannot load...
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - remove net_client_only and add db bcond (then without apache and
3 #   without db => net_client_only - spec will be more simpler, I think)
4 # - finish ruby
5 # - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
6 #
7 # Conditional build:
8 %bcond_with     net_client_only         # build only net client
9 %bcond_without  neon                    # use serf instead of neon
10 %bcond_without  python                  # build without python bindings (broken)
11 %bcond_without  perl                    # build without perl bindings
12 %bcond_without  ruby                    # build without ruby bindings
13 %bcond_without  apache                  # build without apache support (webdav, etc)
14 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
15 %bcond_without  tests                   # don't perform "make check"
16 %bcond_without  kwallet                 # build without kde4 wallet support
17 %bcond_without  gnome                   # build without gnome keyring support
18
19 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
20 %define apxs    /usr/sbin/apxs
21 %define pdir    SVN
22 %define pnam    _Core
23
24 %if %{with neon}
25 %define webdavlib       neon
26 %else
27 %define webdavlib       serf
28 %endif
29 Summary:        A Concurrent Versioning system similar to but better than CVS
30 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
31 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
32 Name:           subversion
33 Version:        1.6.13
34 Release:        4
35 License:        Apache/BSD-like
36 Group:          Development/Version Control
37 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
38 # Source0-md5:  7ae1c827689f21cf975804005be30aeb
39 Source1:        %{name}-dav_svn.conf
40 Source2:        %{name}-authz_svn.conf
41 Source3:        %{name}-svnserve.init
42 Source4:        %{name}-svnserve.sysconfig
43 # current subversion tarball has correct *.swg files
44 # but after regeneration these are broken again, so
45 # we still need this script
46 Source5:        %{name}-convert-typemaps-to-ifdef.py
47 Patch0:         %{name}-home_etc.patch
48 Patch1:         %{name}-DESTDIR.patch
49 Patch2:         %{name}-ruby-datadir-path.patch
50 Patch3:         %{name}-tests.patch
51 URL:            http://subversion.apache.org/
52 %if %{with net_client_only}
53 %global apache_modules_api 0
54 %else
55 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
56 BuildRequires:  autoconf
57 BuildRequires:  automake
58 BuildRequires:  db-devel >= 4.1.25
59 BuildRequires:  libtool
60 BuildRequires:  rpmbuild(macros) >= 1.583
61 %if %{with perl}
62 BuildRequires:  perl-devel >= 1:5.8.0
63 BuildRequires:  rpm-perlprov >= 4.1-13
64 BuildRequires:  swig-perl >= 1.3.24
65 %endif
66 %if %{with python}
67 BuildRequires:  python-ctypesgen
68 BuildRequires:  python-devel >= 2.2
69 BuildRequires:  swig-python >= 1.3.24
70 %endif
71 %if %{with ruby}
72 BuildRequires:  ruby-devel
73 BuildRequires:  swig-ruby >= 1.3.24
74 %endif
75 %if %{with javahl}
76 BuildRequires:  jdk
77 %endif
78 BuildRequires:  cyrus-sasl-devel
79 %endif
80 BuildRequires:  apr-devel >= 1:1.0.0
81 BuildRequires:  apr-util-devel >= 1:1.2.8-3
82 BuildRequires:  autoconf >= 2.59
83 BuildRequires:  bison
84 BuildRequires:  expat-devel
85 BuildRequires:  gettext-devel
86 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
87 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
88 BuildRequires:  libtool >= 1.4-9
89 BuildRequires:  pkgconfig
90 BuildRequires:  sed >= 4.0
91 BuildRequires:  sqlite3-devel >= 3.6.11
92 BuildRequires:  texinfo
93 BuildRequires:  which
94 %if %{with neon}
95 BuildRequires:  neon-devel >= 0.26.0
96 %else
97 BuildRequires:  serf-devel
98 %endif
99 BuildRequires:  python >= 2.2
100 BuildRequires:  python-modules >= 2.2
101 Requires:       %{name}-libs = %{version}-%{release}
102 %requires_ge    sqlite3
103 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
104
105 %define         _libexecdir             %{_libdir}/svn
106 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
107 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
108
109 %define         skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
110
111 %description
112 The goal of the Subversion project is to build a version control
113 system that is a compelling replacement for CVS in the open source
114 community.
115
116 Our goals are:
117 - All current CVS features.
118 - Directories, renames, and file meta-data are versioned.
119 - Symbolic links, etc, are supported
120 - Commits are truly atomic.
121 - Branching and tagging are cheap (constant time) operations
122 - Repeated merges are handled gracefully
123 - Support for plug-in client side diff programs
124 - Natively client/server
125 - Client/server protocol sends diffs in both directions
126 - Costs are proportional to change size, not project size
127 - Internationalization
128 - Progressive multi-lingual support
129
130 %description -l pl.UTF-8
131 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
132 zamiennika dla CVS.
133
134 Cele projektu to:
135 - Wszystkie aktualne możliwości CVS.
136 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
137 - Obsługa dowiązań symbolicznych itp.
138 - Commity są w pełni atomowe.
139 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
140 - Dobra obsługa powtarzanego łączenia (merge).
141 - Obsługa wtyczek diff po stronie klienta.
142 - Natywny klient/serwer.
143 - Klient/Serwer przesyłają diffy w obu kierunkach.
144 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
145 - Internacjonalizacja.
146 - Postępujące wsparcie dla wielu języków.
147
148 %description -l pt_BR.UTF-8
149 O objetivo do projeto Subversion é construir um sistema de controle de
150 versões que seja um substituto para o CVS (Concurrent Versioning
151 System) na comunidade opensource, fornecendo grandes melhorias.
152
153 %package libs
154 Summary:        Subversion libraries and modules
155 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
156 Group:          Libraries
157 %{?with_neon:Requires:  neon >= 0.26.0}
158 Obsoletes:      libsubversion0
159
160 %description libs
161 Subversion libraries and modules.
162
163 %description libs -l pl.UTF-8
164 Biblioteka subversion oraz ładowalne moduły.
165
166 %package devel
167 Summary:        Header files and develpment documentation for subversion
168 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
169 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
170 Group:          Development/Libraries
171 Requires:       %{name}-libs = %{version}-%{release}
172 Requires:       apr-util-devel >= 1:1.0.0
173 %{?with_neon:Requires:  neon-devel >= 0.26.0}
174 Obsoletes:      libsubversion0-devel
175
176 %description devel
177 Header files and develpment documentation for subversion.
178
179 %description devel -l pl.UTF-8
180 Pliki nagłówkowe i dokumetacja do subversion.
181
182 %description devel -l pt_BR.UTF-8
183 Este pacote provê os arquivos necessários para desenvolvedores
184 interagirem com o Subversion.
185
186 %package static
187 Summary:        Static subversion library
188 Summary(pl.UTF-8):      Biblioteka statyczna subversion
189 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
190 Group:          Development/Libraries
191 Requires:       %{name}-devel = %{version}
192 Obsoletes:      libsubversion0-static-devel
193
194 %description static
195 Static subversion library.
196
197 %description static -l pl.UTF-8
198 Biblioteka statyczna subversion.
199
200 %description static -l pt_BR.UTF-8
201 Este pacote provê um cliente estático do subversion.
202
203 %package svnserve
204 Summary:        Subversion svnserve
205 Summary(pl.UTF-8):      Subversion svnserve
206 Group:          Networking/Daemons
207 Requires(post,preun):   /sbin/chkconfig
208 Requires(postun):       /usr/sbin/groupdel
209 Requires(postun):       /usr/sbin/userdel
210 Requires(pre):  /bin/id
211 Requires(pre):  /usr/bin/getgid
212 Requires(pre):  /usr/lib/rpm/user_group.sh
213 Requires(pre):  /usr/sbin/groupadd
214 Requires(pre):  /usr/sbin/useradd
215 Requires(pre):  /usr/sbin/usermod
216 Requires:       %{name} = %{version}-%{release}
217 Requires:       rc-scripts
218 Provides:       group(svn)
219 Provides:       user(svn)
220
221 %description svnserve
222 Subversion svnserve server.
223
224 %description svnserve -l pl.UTF-8
225 Serwer subversion svnserve.
226
227 %package tools
228 Summary:        Subversion tools and scripts
229 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
230 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
231 Group:          Applications
232 %pyrequires_eq  python
233 Requires:       %{name} = %{version}-%{release}
234 Requires:       python-subversion = %{version}
235
236 %description tools
237 Subversion tools and scripts.
238
239 %description tools -l pl.UTF-8
240 Narzędzia oraz skrypty dla subversion.
241
242 %package -n bash-completion-subversion
243 Summary:        bash completion for subversion
244 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
245 Group:          Applications/Shells
246 Requires:       %{name} = %{version}-%{release}
247 Requires:       bash-completion
248 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
249
250 %description -n bash-completion-subversion
251 Bash completion for subversion.
252
253 %description -n bash-completion-subversion -l pl.UTF-8
254 Dopełnienia basha dla subversion.
255
256 %package -n java-subversion
257 Summary:        Subversion Java bindings
258 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
259 Group:          Development/Languages/Java
260 Requires:       %{name}-libs = %{version}-%{release}
261
262 %description -n java-subversion
263 This is a set of Java classes which provide the functionality of
264 subversion-libs, the Subversion libraries. It is useful if you want
265 to, for example, write a Java class that manipulates a Subversion
266 repository or working copy. See the 'subversion' package for more
267 information.
268
269 %description -n java-subversion -l pl.UTF-8
270 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
271 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
272 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
273 roboczą. Więcej informacji w pakiecie subversion.
274
275 %package -n python-subversion
276 Summary:        Subversion Python bindings
277 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
278 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
279 Group:          Development/Languages/Python
280 %pyrequires_eq  python
281 Requires:       %{name}-libs = %{version}-%{release}
282 Obsoletes:      subversion-python
283
284 %description -n python-subversion
285 Subversion Python bindings.
286
287 %description -n python-subversion -l pl.UTF-8
288 Dowiązania do Subversion dla Pythona.
289
290 %description -n python-subversion -l pt_BR.UTF-8
291 Módulos Python para acessar os recursos do Subversion.
292
293 %package -n python-csvn
294 Summary:        CTypes Subversion Python bindings
295 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
296 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
297 Group:          Development/Languages/Python
298 %pyrequires_eq  python
299 Requires:       %{name}-libs = %{version}-%{release}
300
301 %description -n python-csvn
302 Subversion CTypes Python bindings.
303
304 %description -n python-csvn -l pl.UTF-8
305 Dowiązania do Subversion dla Pythona używające CTypes.
306
307 %description -n python-csvn -l pt_BR.UTF-8
308 Módulos Python para acessar os recursos do Subversion.
309
310 %package -n perl-subversion
311 Summary:        Subversion Perl bindings
312 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
313 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
314 Group:          Development/Languages/Perl
315 Requires:       %{name}-libs = %{version}-%{release}
316 Obsoletes:      subversion-perl
317
318 %description -n perl-subversion
319 Subversion Perl bindings.
320
321 %description -n perl-subversion -l pl.UTF-8
322 Dowiązania do Subversion dla Perla.
323
324 %description -n perl-subversion -l pt_BR.UTF-8
325 Módulos Perl para acessar os recursos do Subversion.
326
327 %package -n ruby-subversion
328 Summary:        Subversion Ruby bindings
329 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
330 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
331 Group:          Development/Languages
332 Requires:       %{name}-libs = %{version}-%{release}
333 Obsoletes:      subversion-ruby
334
335 %description -n ruby-subversion
336 Subversion Ruby bindings.
337
338 %description -n ruby-subversion -l pl.UTF-8
339 Dowiązania do Subversion dla języka Ruby.
340
341 %description -n ruby-subversion -l pt_BR.UTF-8
342 Módulos Ruby para acessar os recursos do Subversion.
343
344 %package -n apache-mod_dav_svn
345 Summary:        Apache module: Subversion Server
346 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
347 Group:          Networking/Daemons
348 Requires:       %{name} = %{version}-%{release}
349 Requires:       apache(modules-api) = %apache_modules_api
350 Requires:       apache-mod_dav
351
352 %description -n apache-mod_dav_svn
353 Apache module: Subversion Server.
354
355 %description -n apache-mod_dav_svn -l pl.UTF-8
356 Moduł apache: Serwer Subversion.
357
358 %package -n apache-mod_authz_svn
359 Summary:        Apache module: Subversion Server - path-based authorization
360 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
361 Group:          Networking/Daemons
362 Requires:       apache(modules-api) = %apache_modules_api
363 Requires:       apache-mod_dav_svn = %{version}-%{release}
364
365 %description -n apache-mod_authz_svn
366 Apache module: Subversion Server - path-based authorization.
367
368 %description -n apache-mod_authz_svn -l pl.UTF-8
369 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
370
371 %package -n gnome-keyring-subversion
372 Summary:        Subversion module for Gnome Keyring
373 Summary(pl.UTF-8):      Moduł subversion dla zarządcy kluczy Gnome
374 Group:          X11/Applications
375
376 %description -n gnome-keyring-subversion
377 Subversion module for Gnome Keyring.
378
379 %description -n gnome-keyring-subversion -l pl.UTF-8
380 Moduł subversion dla zarządcy kluczy Gnome.
381
382 %package -n kde4-kwallet-subversion
383 Summary:        Subversion module for KDE Wallet
384 Summary(pl.UTF-8):      Moduł subversion dla Portfela KDE
385 Group:          X11/Applications
386
387 %description -n kde4-kwallet-subversion
388 Subversion module for KDE Wallet.
389
390 %description -n kde4-kwallet-subversion -l pl.UTF-8
391 Moduł subversion dla Portfela KDE.
392
393 %prep
394 %setup -q
395 rm -rf apr apr-util neon
396 %patch0 -p0
397 %patch1 -p1
398 %patch2 -p0
399 %patch3 -p1
400
401 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
402
403 # serf.m4 macro is broken and ignores --without serf
404 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
405
406 %build
407 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
408 #%{__rm} subversion/bindings/swig/proxy/*.swg
409 #cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
410 chmod +x ./autogen.sh && ./autogen.sh
411 %{__libtoolize}
412 %configure \
413         --with-editor=vi \
414         --with-zlib=%{_libdir} \
415 %if %{with net_client_only}
416         --without-apache \
417         --without-swig \
418         --without-apxs \
419         --without-berkeley-db \
420 %else
421         --disable-runtime-module-search \
422         --disable-mod-activation \
423         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
424 %if %{with apache}
425         --with-apxs=%{_sbindir}/apxs \
426 %else
427         --without-apache \
428         --without-apxs \
429 %endif
430 %if !%{with python} && !%{with perl} && !%{with ruby}
431         --without-swig \
432 %endif
433         %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
434         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
435 %endif
436         --with-jdk="%{java_home}" \
437         --without-jikes \
438 %if %{with neon}
439         --without-serf \
440         --with-neon=%{_prefix} \
441         --disable-neon-version-check \
442 %else
443         --with-serf=%{_prefix} \
444         --without-neon \
445 %endif
446         --with-apr=%{_bindir}/apr-1-config \
447         --with-apr-util=%{_bindir}/apu-1-config \
448 %if %{with kwallet}
449         --with-kwallet \
450 %endif
451 %if %{with gnome}
452         --with-gnome-keyring
453 %endif
454
455 %{__make} -j1
456
457 %if !%{with net_client_only}
458 # python
459 %if %{with python}
460 # ctypes bindings
461 %{__make} ctypes-python
462 # swig bindings
463 %{__make} swig-py \
464         swig_pydir=%{py_sitedir}/libsvn \
465         swig_pydir_extra=%{py_sitedir}/svn
466 %endif
467 # perl
468 %if %{with perl}
469 %{__make} -j1 swig-pl-lib
470 odir=$(pwd)
471 cd subversion/bindings/swig/perl/native
472 %{__perl} Makefile.PL INSTALLDIRS=vendor
473 %{__make} -j1
474 cd $odir
475 %endif
476 %if %{with javahl}
477 %{__make} -j1 javahl \
478         javahl_javadir="%{_javadir}"
479 %endif
480 # ruby
481 %if %{with ruby}
482 %{__make} swig-rb
483 %endif
484 %endif
485
486 %if %{with tests}
487 %{__make} check
488 %if %{with python}
489 %{__make} check-ctypes-python
490 %{__make} check-swig-py
491 %endif
492 %if %{with perl}
493 %{__make} check-swig-pl
494 %endif
495 %if %{with ruby}
496 %{__make} check-swig-rb
497 %endif
498 %endif
499
500 %install
501 rm -rf $RPM_BUILD_ROOT
502 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
503         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
504         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
505         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
506
507 %{__make} install -j1 \
508 %if %{with javahl}
509         install-javahl \
510         javahl_javadir="%{_javadir}" \
511 %endif
512 %if !%{with net_client_only}
513 %if %{with python}
514         install-swig-py \
515         install-ctypes-python \
516 %endif
517 %if %{with ruby}
518         install-swig-rb install-swig-rb-doc \
519 %endif
520 %endif
521         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
522         DESTDIR=$RPM_BUILD_ROOT \
523         swig_pydir=%{py_sitedir}/libsvn \
524         swig_pydir_extra=%{py_sitedir}/svn
525
526 %if !%{with net_client_only} && %{with perl}
527 %{__make} install-swig-pl-lib \
528         DESTDIR=$RPM_BUILD_ROOT
529 %{__make} -C subversion/bindings/swig/perl/native install \
530         DESTDIR=$RPM_BUILD_ROOT \
531         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
532         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
533 %endif
534
535 %if %{with apache}
536 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
537 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
538 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
539 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
540 %endif
541
542 %if !%{with net_client_only}
543 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
544 %if %{with python}
545 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
546 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
547 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
548 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
549 %endif
550 %endif
551
552 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
553 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
554
555 %find_lang %{name}
556
557 %{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
558 rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
559 rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
560
561 %clean
562 rm -rf $RPM_BUILD_ROOT
563
564 %pre svnserve
565 %groupadd -g 86 svn
566 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
567
568 %post   libs -p /sbin/ldconfig
569 %postun libs -p /sbin/ldconfig
570
571 %post   devel -p /sbin/postshell
572 -/usr/sbin/fix-info-dir -c %{_infodir}
573
574 %postun devel -p /sbin/postshell
575 -/usr/sbin/fix-info-dir -c %{_infodir}
576
577 %post   -n java-subversion -p /sbin/ldconfig
578 %postun -n java-subversion -p /sbin/ldconfig
579
580 %post   -n perl-subversion -p /sbin/ldconfig
581 %postun -n perl-subversion -p /sbin/ldconfig
582
583 %post   -n python-subversion -p /sbin/ldconfig
584 %postun -n python-subversion -p /sbin/ldconfig
585
586 %post   -n ruby-subversion -p /sbin/ldconfig
587 %postun -n ruby-subversion -p /sbin/ldconfig
588
589 %post   -n gnome-keyring-subversion -p /sbin/ldconfig
590 %postun -n gnome-keyring-subversion -p /sbin/ldconfig
591
592 %post   -n kde4-kwallet-subversion -p /sbin/ldconfig
593 %postun -n kde4-kwallet-subversion -p /sbin/ldconfig
594
595 %post svnserve
596 /sbin/chkconfig --add svnserve
597 %service svnserve restart "svnserve daemon"
598
599 %preun svnserve
600 if [ "$1" = "0" ]; then
601         %service svnserve stop
602         /sbin/chkconfig --del svnserve
603 fi
604
605 %postun svnserve
606 if [ "$1" = "0" ]; then
607         %userremove svn
608         %groupremove svn
609 fi
610
611 %post -n apache-mod_dav_svn
612 %service -q httpd restart
613
614 %postun -n apache-mod_dav_svn
615 if [ "$1" = "0" ]; then
616         %service -q httpd restart
617 fi
618
619 %post -n apache-mod_authz_svn
620 %service -q httpd restart
621
622 %postun -n apache-mod_authz_svn
623 if [ "$1" = "0" ]; then
624         %service -q httpd restart
625 fi
626
627 %files
628 %defattr(644,root,root,755)
629 %doc BUGS CHANGES COPYING INSTALL README
630 %doc doc/*/*.html
631 %doc tools/hook-scripts/*.{pl,py,example}
632 %doc tools/hook-scripts/mailer/*.{py,example}
633 %doc tools/xslt/*
634 %attr(755,root,root) %{_bindir}/svn
635 %attr(755,root,root) %{_bindir}/svnadmin
636 %attr(755,root,root) %{_bindir}/svndumpfilter
637 %attr(755,root,root) %{_bindir}/svnlook
638 %attr(755,root,root) %{_bindir}/svnsync
639 %attr(755,root,root) %{_bindir}/svnversion
640 %{_mandir}/man1/svn.1*
641 %{_mandir}/man1/svnadmin.1*
642 %{_mandir}/man1/svndumpfilter.1*
643 %{_mandir}/man1/svnlook.1*
644 %{_mandir}/man1/svnsync.1*
645 %{_mandir}/man1/svnversion.1*
646
647 %files libs -f %{name}.lang
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
650 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
651 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
652 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
653 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
654 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
655 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
656 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
657 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
658 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
659 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
660 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
661 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
662 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
663 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
664 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
665 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
666 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
667 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
668 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
669 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
670 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
671 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
672 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
673 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
674 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
675 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
676 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
677
678 %files devel
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
681 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
682 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
683 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
684 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
685 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
686 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
687 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
688 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
689 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
690 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
691 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
692 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
693 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
694 %{_libdir}/libsvn_client-1.la
695 %{_libdir}/libsvn_delta-1.la
696 %{_libdir}/libsvn_diff-1.la
697 %{_libdir}/libsvn_fs-1.la
698 %{_libdir}/libsvn_fs_base-1.la
699 %{_libdir}/libsvn_fs_fs-1.la
700 %{_libdir}/libsvn_fs_util-1.la
701 %{_libdir}/libsvn_ra-1.la
702 %{_libdir}/libsvn_ra_local-1.la
703 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
704 %{_libdir}/libsvn_ra_svn-1.la
705 %{_libdir}/libsvn_repos-1.la
706 %{_libdir}/libsvn_subr-1.la
707 %{_libdir}/libsvn_wc-1.la
708 %{_includedir}/%{name}-1
709 %{_examplesdir}/%{name}-%{version}
710
711 %files static
712 %defattr(644,root,root,755)
713 %{_libdir}/libsvn_client-1.a
714 %{_libdir}/libsvn_delta-1.a
715 %{_libdir}/libsvn_diff-1.a
716 %{_libdir}/libsvn_fs-1.a
717 %{_libdir}/libsvn_fs_base-1.a
718 %{_libdir}/libsvn_fs_fs-1.a
719 %{_libdir}/libsvn_fs_util-1.a
720 %{_libdir}/libsvn_ra-1.a
721 %{_libdir}/libsvn_ra_local-1.a
722 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
723 %{_libdir}/libsvn_ra_svn-1.a
724 %{_libdir}/libsvn_repos-1.a
725 %{_libdir}/libsvn_subr-1.a
726 %{_libdir}/libsvn_wc-1.a
727
728 %if %{with gnome}
729 %files -n gnome-keyring-subversion
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
732 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
733 %endif
734
735 %if %{with kwallet}
736 %files -n kde4-kwallet-subversion
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
739 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
740 %endif
741
742 %if %{without net_client_only}
743 %files svnserve
744 %defattr(644,root,root,755)
745 %attr(755,root,root) %{_bindir}/svnserve
746 %{_mandir}/man5/svnserve.conf.5*
747 %{_mandir}/man8/svnserve.8*
748 %dir %attr(750,svn,svn) /home/services/subversion
749 %dir %attr(750,svn,svn) /home/services/subversion/repos
750 %if %{with apache}
751 %attr(754,root,root) /etc/rc.d/init.d/svnserve
752 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
753 %endif
754
755 %files tools
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_bindir}/svn-hot-backup
758
759 %files -n bash-completion-subversion
760 %defattr(644,root,root,755)
761 /etc/bash_completion.d/%{name}
762
763 %if %{with javahl}
764 %files -n java-subversion
765 %defattr(644,root,root,755)
766 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
767 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
768 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
769 %{_javadir}/svn-javahl.jar
770 %endif
771
772 %if %{with python}
773 %files -n python-subversion
774 %defattr(644,root,root,755)
775 %doc tools/backup/*.py tools/examples/*.py
776 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
777 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
778 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
779 %dir %{py_sitedir}/libsvn
780 %{py_sitedir}/libsvn/*.py[co]
781 %dir %{py_sitedir}/svn
782 %{py_sitedir}/svn/*.py[co]
783 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
784 %{_examplesdir}/python-%{name}-%{version}
785
786 %files -n python-csvn
787 %defattr(644,root,root,755)
788 %doc subversion/bindings/ctypes-python/{README,TODO}
789 %doc subversion/bindings/ctypes-python/examples/*.py
790 %dir %{py_sitescriptdir}/csvn
791 %{py_sitescriptdir}/csvn/*.py[co]
792 %dir %{py_sitescriptdir}/csvn/core
793 %{py_sitescriptdir}/csvn/core/*.py[co]
794 %dir %{py_sitescriptdir}/csvn/ext
795 %{py_sitescriptdir}/csvn/ext/*.py[co]
796 %{py_sitescriptdir}/*.egg-info
797 %endif
798
799 %if %{with perl}
800 %files -n perl-subversion
801 %defattr(644,root,root,755)
802 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
803 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
804 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
805 %{perl_vendorarch}/SVN
806 %dir %{perl_vendorarch}/auto/SVN
807 %dir %{perl_vendorarch}/auto/SVN/*
808 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
809 %{perl_vendorarch}/auto/SVN/*/*.bs
810 %{_mandir}/man3/*.3pm*
811 %endif
812
813 %if %{with ruby}
814 %files -n ruby-subversion
815 %defattr(644,root,root,755)
816 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
817 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
818 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
819 %dir %{ruby_sitelibdir}/svn
820 %{ruby_sitelibdir}/svn/*.rb
821 %dir %{ruby_sitearchdir}/svn
822 %dir %{ruby_sitearchdir}/svn/ext
823 %attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
824 %{ruby_ridir}/Svn
825 %endif
826
827 %if %{with apache}
828 %files -n apache-mod_dav_svn
829 %defattr(644,root,root,755)
830 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
831 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
832
833 %files -n apache-mod_authz_svn
834 %defattr(644,root,root,755)
835 %doc subversion/mod_authz_svn/INSTALL
836 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
837 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
838 %endif
839
840 %endif # net_client_only
This page took 0.111922 seconds and 4 git commands to generate.