]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- comment on mod_dav_svn causing mod_rails breakage
[packages/subversion.git] / subversion.spec
1 #
2 # Conditional build:
3 %bcond_with     net_client_only         # build only net client
4 %bcond_without  neon                    # use serf instead of neon
5 %bcond_without  swig                    # disable bindings generation with Swig
6 %bcond_without  python                  # build without Python bindings (broken)
7 %bcond_without  csvn                    # build Python csvn bindings
8 %bcond_without  perl                    # build without Perl bindings
9 %bcond_with     ruby                    # build with Ruby bindings (only 1.8.x is supported)
10 %bcond_without  apache                  # build without Apache support (webdav, etc)
11 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
12 %bcond_without  tests                   # don't perform "make check"
13 %bcond_without  kwallet                 # build without kde4 wallet support
14 %bcond_without  kde                     # build without kde4 support (alias for kwallet)
15 %bcond_without  gnome                   # build without gnome keyring support
16 %bcond_without  db                      # disable Subversion Berkeley DB based filesystem library
17
18 %if %{with net_client_only}
19 %undefine       with_apache
20 %undefine       with_db
21 %undefine       with_swig
22 %undefine       with_javahl
23 %endif
24
25 %if %{without swig}
26 %undefine       with_perl
27 %undefine       with_python
28 %undefine       with_ruby
29 %endif
30
31 %if %{without kde}
32 %undefine       with_kwallet
33 %endif
34
35 %if %{without python} && %{without perl} && %{without ruby}
36 %undefine       with_swig
37 %endif
38
39 %define apxs    /usr/sbin/apxs
40 %define pdir    SVN
41 %define pnam    _Core
42
43 %if %{with neon}
44 %define webdavlib       neon
45 %else
46 %define webdavlib       serf
47 %endif
48 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
49 Summary:        A Concurrent Versioning system similar to but better than CVS
50 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
51 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
52 Name:           subversion
53 Version:        1.7.0
54 Release:        3
55 License:        Apache/BSD-like
56 Group:          Development/Version Control
57 Source0:        http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
58 # Source0-md5:  930e6644a1b6094efd268fde6a318f04
59 Source1:        %{name}-dav_svn.conf
60 Source2:        %{name}-authz_svn.conf
61 Source3:        %{name}-svnserve.init
62 Source4:        %{name}-svnserve.sysconfig
63 # current subversion tarball has correct *.swg files
64 # but after regeneration these are broken again, so
65 # we still need this script
66 Source5:        %{name}-convert-typemaps-to-ifdef.py
67 Patch0:         %{name}-home_etc.patch
68 Patch1:         %{name}-DESTDIR.patch
69 Patch2:         %{name}-ruby-datadir-path.patch
70 Patch3:         %{name}-tests.patch
71 # running this hook for every post breaks mod_rails
72 Patch4:         %{name}-mod_dav_svn-fix-hook.patch
73 URL:            http://subversion.apache.org/
74 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
75 BuildRequires:  apr-devel >= 1:1.0.0
76 BuildRequires:  apr-util-devel >= 1:1.2.8-3
77 BuildRequires:  autoconf >= 2.59
78 BuildRequires:  automake
79 BuildRequires:  bison
80 BuildRequires:  cyrus-sasl-devel
81 %if %{with kwallet} || %{with gnome}
82 BuildRequires:  dbus-devel
83 %endif
84 BuildRequires:  db-devel >= 4.1.25
85 BuildRequires:  expat-devel
86 BuildRequires:  gettext-devel
87 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
88 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
89 BuildRequires:  libmagic-devel
90 BuildRequires:  libtool >= 1.4-9
91 BuildRequires:  pkgconfig
92 %{?with_csvn:BuildRequires:     python-ctypesgen}
93 BuildRequires:  rpm-pythonprov
94 BuildRequires:  rpmbuild(macros) >= 1.583
95 BuildRequires:  sed >= 4.0
96 BuildRequires:  sqlite3-devel >= 3.6.18
97 BuildRequires:  texinfo
98 BuildRequires:  which
99 %if %{with neon}
100 BuildRequires:  neon-devel >= 0.26.0
101 %else
102 BuildRequires:  serf-devel >= 0.7.1
103 %endif
104 %if %{with javahl}
105 BuildRequires:  jdk >= 1.5
106 BuildRequires:  libstdc++-devel
107 %endif
108 %if %{with perl}
109 BuildRequires:  perl-devel >= 1:5.8.0
110 BuildRequires:  rpm-perlprov >= 4.1-13
111 BuildRequires:  swig-perl >= 1.3.24
112 %endif
113 %if %{with python}
114 BuildRequires:  python-devel >= 1:2.4
115 BuildRequires:  swig-python >= 1.3.24
116 %endif
117 %if %{with ruby}
118 BuildRequires:  ruby-devel >= 1:1.8.2
119 BuildRequires:  ruby-devel < 1:1.9
120 BuildRequires:  ruby-rubygems
121 BuildRequires:  swig-ruby >= 1.3.24
122 %endif
123 Requires:       %{name}-libs = %{version}-%{release}
124 %requires_ge    sqlite3
125 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
126
127 %define         _libexecdir             %{_libdir}/svn
128 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
129 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
130
131 %define         skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
132
133 %description
134 The goal of the Subversion project is to build a version control
135 system that is a compelling replacement for CVS in the open source
136 community.
137
138 Our goals are:
139 - All current CVS features.
140 - Directories, renames, and file meta-data are versioned.
141 - Symbolic links, etc, are supported
142 - Commits are truly atomic.
143 - Branching and tagging are cheap (constant time) operations
144 - Repeated merges are handled gracefully
145 - Support for plug-in client side diff programs
146 - Natively client/server
147 - Client/server protocol sends diffs in both directions
148 - Costs are proportional to change size, not project size
149 - Internationalization
150 - Progressive multi-lingual support
151
152 %description -l pl.UTF-8
153 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
154 zamiennika dla CVS.
155
156 Cele projektu to:
157 - Wszystkie aktualne możliwości CVS.
158 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
159 - Obsługa dowiązań symbolicznych itp.
160 - Commity są w pełni atomowe.
161 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
162 - Dobra obsługa powtarzanego łączenia (merge).
163 - Obsługa wtyczek diff po stronie klienta.
164 - Natywny klient/serwer.
165 - Klient/Serwer przesyłają diffy w obu kierunkach.
166 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
167 - Internacjonalizacja.
168 - Postępujące wsparcie dla wielu języków.
169
170 %description -l pt_BR.UTF-8
171 O objetivo do projeto Subversion é construir um sistema de controle de
172 versões que seja um substituto para o CVS (Concurrent Versioning
173 System) na comunidade opensource, fornecendo grandes melhorias.
174
175 %package libs
176 Summary:        Subversion libraries and modules
177 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
178 Group:          Libraries
179 %if %{with neon}
180 Requires:       neon >= 0.26.0
181 %else
182 Requires:       serf >= 0.7.1
183 %endif
184 Obsoletes:      libsubversion0
185
186 %description libs
187 Subversion libraries and modules.
188
189 %description libs -l pl.UTF-8
190 Biblioteka subversion oraz ładowalne moduły.
191
192 %package devel
193 Summary:        Header files and develpment documentation for subversion
194 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
195 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
196 Group:          Development/Libraries
197 Requires:       %{name}-libs = %{version}-%{release}
198 Requires:       apr-util-devel >= 1:1.0.0
199 %{?with_neon:Requires:  neon-devel >= 0.26.0}
200 Obsoletes:      libsubversion0-devel
201
202 %description devel
203 Header files and develpment documentation for subversion.
204
205 %description devel -l pl.UTF-8
206 Pliki nagłówkowe i dokumetacja do subversion.
207
208 %description devel -l pt_BR.UTF-8
209 Este pacote provê os arquivos necessários para desenvolvedores
210 interagirem com o Subversion.
211
212 %package static
213 Summary:        Static subversion library
214 Summary(pl.UTF-8):      Biblioteka statyczna subversion
215 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
216 Group:          Development/Libraries
217 Requires:       %{name}-devel = %{version}
218 Obsoletes:      libsubversion0-static-devel
219
220 %description static
221 Static subversion library.
222
223 %description static -l pl.UTF-8
224 Biblioteka statyczna subversion.
225
226 %description static -l pt_BR.UTF-8
227 Este pacote provê um cliente estático do subversion.
228
229 %package svnserve
230 Summary:        Subversion svnserve
231 Summary(pl.UTF-8):      Subversion svnserve
232 Group:          Networking/Daemons
233 Requires(post,preun):   /sbin/chkconfig
234 Requires(postun):       /usr/sbin/groupdel
235 Requires(postun):       /usr/sbin/userdel
236 Requires(pre):  /bin/id
237 Requires(pre):  /usr/bin/getgid
238 Requires(pre):  /usr/lib/rpm/user_group.sh
239 Requires(pre):  /usr/sbin/groupadd
240 Requires(pre):  /usr/sbin/useradd
241 Requires(pre):  /usr/sbin/usermod
242 Requires:       %{name} = %{version}-%{release}
243 Requires:       rc-scripts
244 Provides:       group(svn)
245 Provides:       user(svn)
246
247 %description svnserve
248 Subversion svnserve server.
249
250 %description svnserve -l pl.UTF-8
251 Serwer subversion svnserve.
252
253 %package tools
254 Summary:        Subversion tools and scripts
255 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
256 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
257 Group:          Applications
258 %pyrequires_eq  python
259 Requires:       %{name} = %{version}-%{release}
260 Requires:       python-subversion = %{version}
261
262 %description tools
263 Subversion tools and scripts.
264
265 %description tools -l pl.UTF-8
266 Narzędzia oraz skrypty dla subversion.
267
268 %package -n bash-completion-subversion
269 Summary:        bash completion for subversion
270 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
271 Group:          Applications/Shells
272 Requires:       %{name} = %{version}-%{release}
273 Requires:       bash-completion
274 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
275
276 %description -n bash-completion-subversion
277 Bash completion for subversion.
278
279 %description -n bash-completion-subversion -l pl.UTF-8
280 Dopełnienia basha dla subversion.
281
282 %package -n java-subversion
283 Summary:        Subversion Java bindings
284 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
285 Group:          Development/Languages/Java
286 Requires:       %{name}-libs = %{version}-%{release}
287
288 %description -n java-subversion
289 This is a set of Java classes which provide the functionality of
290 subversion-libs, the Subversion libraries. It is useful if you want
291 to, for example, write a Java class that manipulates a Subversion
292 repository or working copy. See the 'subversion' package for more
293 information.
294
295 %description -n java-subversion -l pl.UTF-8
296 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
297 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
298 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
299 roboczą. Więcej informacji w pakiecie subversion.
300
301 %package -n python-subversion
302 Summary:        Subversion Python bindings
303 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
304 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
305 Group:          Development/Languages/Python
306 %pyrequires_eq  python
307 Requires:       %{name}-libs = %{version}-%{release}
308 Obsoletes:      subversion-python
309
310 %description -n python-subversion
311 Subversion Python bindings.
312
313 %description -n python-subversion -l pl.UTF-8
314 Dowiązania do Subversion dla Pythona.
315
316 %description -n python-subversion -l pt_BR.UTF-8
317 Módulos Python para acessar os recursos do Subversion.
318
319 %package -n python-csvn
320 Summary:        CTypes Subversion Python bindings
321 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
322 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
323 Group:          Development/Languages/Python
324 %pyrequires_eq  python
325 Requires:       %{name}-libs = %{version}-%{release}
326
327 %description -n python-csvn
328 Subversion CTypes Python bindings.
329
330 %description -n python-csvn -l pl.UTF-8
331 Dowiązania do Subversion dla Pythona używające CTypes.
332
333 %description -n python-csvn -l pt_BR.UTF-8
334 Módulos Python para acessar os recursos do Subversion.
335
336 %package -n perl-subversion
337 Summary:        Subversion Perl bindings
338 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
339 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
340 Group:          Development/Languages/Perl
341 Requires:       %{name}-libs = %{version}-%{release}
342 Obsoletes:      subversion-perl
343
344 %description -n perl-subversion
345 Subversion Perl bindings.
346
347 %description -n perl-subversion -l pl.UTF-8
348 Dowiązania do Subversion dla Perla.
349
350 %description -n perl-subversion -l pt_BR.UTF-8
351 Módulos Perl para acessar os recursos do Subversion.
352
353 %package -n ruby-subversion
354 Summary:        Subversion Ruby bindings
355 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
356 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
357 Group:          Development/Languages
358 Requires:       %{name}-libs = %{version}-%{release}
359 Obsoletes:      subversion-ruby
360
361 %description -n ruby-subversion
362 Subversion Ruby bindings.
363
364 %description -n ruby-subversion -l pl.UTF-8
365 Dowiązania do Subversion dla języka Ruby.
366
367 %description -n ruby-subversion -l pt_BR.UTF-8
368 Módulos Ruby para acessar os recursos do Subversion.
369
370 %package -n apache-mod_dav_svn
371 Summary:        Apache module: Subversion Server
372 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
373 Group:          Networking/Daemons
374 Requires:       %{name} = %{version}-%{release}
375 Requires:       apache(modules-api) = %apache_modules_api
376 Requires:       apache-mod_dav
377
378 %description -n apache-mod_dav_svn
379 Apache module: Subversion Server.
380
381 %description -n apache-mod_dav_svn -l pl.UTF-8
382 Moduł apache: Serwer Subversion.
383
384 %package -n apache-mod_authz_svn
385 Summary:        Apache module: Subversion Server - path-based authorization
386 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
387 Group:          Networking/Daemons
388 Requires:       apache(modules-api) = %apache_modules_api
389 Requires:       apache-mod_dav_svn = %{version}-%{release}
390
391 %description -n apache-mod_authz_svn
392 Apache module: Subversion Server - path-based authorization.
393
394 %description -n apache-mod_authz_svn -l pl.UTF-8
395 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
396
397 %package -n gnome-keyring-subversion
398 Summary:        GNOME Keyring authentication provider for Subversion
399 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Subversion
400 Group:          X11/Applications
401
402 %description -n gnome-keyring-subversion
403 Authentication provider module for Subversion which allows SVN client
404 to authenticate using GNOME Keyring.
405
406 %description -n gnome-keyring-subversion -l pl.UTF-8
407 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
408 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
409
410 %package -n kde4-kwallet-subversion
411 Summary:        KDE Wallet authentication provider for Subversion
412 Summary(pl.UTF-8):      Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
413 Group:          X11/Applications
414
415 %description -n kde4-kwallet-subversion
416 Authentication provider module for Subversion which allows SVN client
417 to authenticate using KDE Wallet.
418
419 %description -n kde4-kwallet-subversion -l pl.UTF-8
420 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
421 uwierzytelniać się przy użyciu Portfela KDE.
422
423 %prep
424 %setup -q
425 %patch0 -p0
426 %patch1 -p1
427 %patch2 -p0
428 %patch3 -p1
429 %patch4 -p1
430
431 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
432
433 # serf.m4 macro is broken and ignores --without serf
434 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
435
436 %build
437 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
438 #%{__rm} subversion/bindings/swig/proxy/*.swg
439 #cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
440 chmod +x ./autogen.sh && ./autogen.sh
441 %{__libtoolize}
442 %configure \
443         --with-editor=vi \
444         --with-zlib=%{_libdir} \
445         --disable-runtime-module-search \
446         --disable-mod-activation \
447 %if %{with db}
448         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
449 %else
450         --without-berkeley-db \
451 %endif
452 %if %{with apache}
453         --with-apxs=%{_sbindir}/apxs \
454 %else
455         --without-apxs \
456 %endif
457 %if %{without swig}
458         --without-swig \
459 %endif
460 %if %{without ruby}
461         ac_cv_path_RUBY=none \
462 %endif
463 %if %{with csvn}
464         --with-ctypesgen=%{_bindir}/ctypesgen.py \
465 %endif
466 %if %{with javahl}
467         --enable-javahl \
468         --with-jdk="%{java_home}" \
469         --without-jikes \
470 %else
471         --disable-javahl \
472 %endif
473 %if %{with neon}
474         --without-serf \
475         --with-neon=%{_prefix} \
476         --disable-neon-version-check \
477 %else
478         --with-serf=%{_prefix} \
479         --without-neon \
480 %endif
481         --with-apr=%{_bindir}/apr-1-config \
482         --with-apr-util=%{_bindir}/apu-1-config \
483 %if %{with kwallet}
484         --with-kwallet \
485 %endif
486 %if %{with gnome}
487         --with-gnome-keyring
488 %endif
489
490 %{__make} -j1
491
492 %if %{with csvn}
493 # Python ctypes bindings
494 %{__make} ctypes-python
495 %endif
496 %if %{with python}
497 # Python swig bindings
498 %{__make} swig-py \
499         swig_pydir=%{py_sitedir}/libsvn \
500         swig_pydir_extra=%{py_sitedir}/svn
501 %endif
502 %if %{with perl}
503 # Perl swig bindings
504 %{__make} -j1 swig-pl-lib
505 cd subversion/bindings/swig/perl/native
506 %{__perl} Makefile.PL INSTALLDIRS=vendor
507 %{__make} -j1
508 cd -
509 %endif
510 %if %{with javahl}
511 %{__make} -j1 javahl \
512         javahl_javadir="%{_javadir}"
513 %endif
514 # ruby
515 %if %{with ruby}
516 %{__make} swig-rb
517 %endif
518
519 %if %{with tests}
520 %{__make} -j1 check
521 %if %{with csvn}
522 %{__make} -j1 check-ctypes-python
523 %endif
524 %if %{with python}
525 %{__make} -j1 check-swig-py
526 %endif
527 %if %{with perl}
528 %{__make} -j1 check-swig-pl
529 %endif
530 %if %{with ruby}
531 # disabled, see https://bugs.launchpad.net/pld-linux/+bug/734340
532 #%{__make} check-swig-rb
533 %endif
534 %endif
535
536 %install
537 rm -rf $RPM_BUILD_ROOT
538 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
539         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
540         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
541         $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
542         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
543
544 %{__make} install -j1 \
545         DESTDIR=$RPM_BUILD_ROOT \
546         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
547 %if %{with javahl}
548         install-javahl \
549         javahl_javadir="%{_javadir}" \
550 %endif
551 %if %{with python}
552         install-swig-py \
553         swig_pydir=%{py_sitedir}/libsvn \
554         swig_pydir_extra=%{py_sitedir}/svn \
555 %endif
556 %if %{with csvn}
557         install-ctypes-python \
558 %endif
559
560 %if %{with ruby}
561 %{__make} install -j1 \
562         DESTDIR=$RPM_BUILD_ROOT \
563         install-swig-rb install-swig-rb-doc \
564
565 # not our package
566 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Kernel
567 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
568 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
569 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Uconv
570 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
571 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
572 %endif
573
574 %if %{with perl}
575 %{__make} install-swig-pl-lib \
576         DESTDIR=$RPM_BUILD_ROOT
577 %{__make} -C subversion/bindings/swig/perl/native install \
578         DESTDIR=$RPM_BUILD_ROOT \
579         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
580         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
581 %endif
582
583 %if %{with apache}
584 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
585 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
586 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
587 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
588 %endif
589
590 %if %{without net_client_only}
591 install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
592 %endif
593 %if %{with python} || %{with csvn}
594 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
595 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
596 %py_postclean
597 %endif
598 %if %{with python}
599 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
600 # .a created on ac only
601 %{__rm} -f $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.a
602 cp -p tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
603 %endif
604
605 cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
606 cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
607
608 %if %{with javahl}
609 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}
610 %endif
611 %if %{with swig}
612 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
613 %if %{with ruby}
614 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
615 %endif
616 %endif
617 %if %{with gnome} || %{with kwallet}
618 # dlopened by soname (libsvn_auth_*-1.so.0)
619 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
620 %endif
621
622 %find_lang %{name}
623
624 %clean
625 rm -rf $RPM_BUILD_ROOT
626
627 %pre svnserve
628 %groupadd -g 86 svn
629 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
630
631 %post   libs -p /sbin/ldconfig
632 %postun libs -p /sbin/ldconfig
633
634 %post   devel -p /sbin/postshell
635 -/usr/sbin/fix-info-dir -c %{_infodir}
636
637 %postun devel -p /sbin/postshell
638 -/usr/sbin/fix-info-dir -c %{_infodir}
639
640 %post   -n java-subversion -p /sbin/ldconfig
641 %postun -n java-subversion -p /sbin/ldconfig
642
643 %post   -n perl-subversion -p /sbin/ldconfig
644 %postun -n perl-subversion -p /sbin/ldconfig
645
646 %post   -n python-subversion -p /sbin/ldconfig
647 %postun -n python-subversion -p /sbin/ldconfig
648
649 %post   -n ruby-subversion -p /sbin/ldconfig
650 %postun -n ruby-subversion -p /sbin/ldconfig
651
652 %post   -n gnome-keyring-subversion -p /sbin/ldconfig
653 %postun -n gnome-keyring-subversion -p /sbin/ldconfig
654
655 %post   -n kde4-kwallet-subversion -p /sbin/ldconfig
656 %postun -n kde4-kwallet-subversion -p /sbin/ldconfig
657
658 %post svnserve
659 /sbin/chkconfig --add svnserve
660 %service svnserve restart "svnserve daemon"
661
662 %preun svnserve
663 if [ "$1" = "0" ]; then
664         %service svnserve stop
665         /sbin/chkconfig --del svnserve
666 fi
667
668 %postun svnserve
669 if [ "$1" = "0" ]; then
670         %userremove svn
671         %groupremove svn
672 fi
673
674 %post -n apache-mod_dav_svn
675 %service -q httpd restart
676
677 %postun -n apache-mod_dav_svn
678 if [ "$1" = "0" ]; then
679         %service -q httpd restart
680 fi
681
682 %post -n apache-mod_authz_svn
683 %service -q httpd restart
684
685 %postun -n apache-mod_authz_svn
686 if [ "$1" = "0" ]; then
687         %service -q httpd restart
688 fi
689
690 %files
691 %defattr(644,root,root,755)
692 %doc BUGS CHANGES INSTALL README
693 %doc doc/*/*.html
694 %doc tools/hook-scripts/*.{pl,py,example}
695 %doc tools/hook-scripts/mailer/*.{py,example}
696 %doc tools/xslt/*
697 %attr(755,root,root) %{_bindir}/svn
698 %attr(755,root,root) %{_bindir}/svnadmin
699 %attr(755,root,root) %{_bindir}/svndumpfilter
700 %attr(755,root,root) %{_bindir}/svnrdump
701 %attr(755,root,root) %{_bindir}/svnlook
702 %attr(755,root,root) %{_bindir}/svnsync
703 %attr(755,root,root) %{_bindir}/svnversion
704 %{_mandir}/man1/svn.1*
705 %{_mandir}/man1/svnadmin.1*
706 %{_mandir}/man1/svndumpfilter.1*
707 %{_mandir}/man1/svnrdump.1*
708 %{_mandir}/man1/svnlook.1*
709 %{_mandir}/man1/svnsync.1*
710 %{_mandir}/man1/svnversion.1*
711
712 %files libs -f %{name}.lang
713 %defattr(644,root,root,755)
714 %dir %{_sysconfdir}/%{name}
715 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
716 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
717 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
718 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
719 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
720 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
721 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
722 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
723 %if %{without net_client_only}
724 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
725 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
726 %endif
727 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
728 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
729 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
730 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
731 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
732 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
733 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
734 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
735 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
736 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
737 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
738 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
739 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
740 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
741 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
742 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
743 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
744 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
745
746 %files devel
747 %defattr(644,root,root,755)
748 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
749 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
750 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
751 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
752 %if %{without net_client_only}
753 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
754 %endif
755 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
756 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
757 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
758 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
759 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
760 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
761 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
762 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
763 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
764 %{_libdir}/libsvn_client-1.la
765 %{_libdir}/libsvn_delta-1.la
766 %{_libdir}/libsvn_diff-1.la
767 %{_libdir}/libsvn_fs-1.la
768 %if %{without net_client_only}
769 %{_libdir}/libsvn_fs_base-1.la
770 %endif
771 %{_libdir}/libsvn_fs_fs-1.la
772 %{_libdir}/libsvn_fs_util-1.la
773 %{_libdir}/libsvn_ra-1.la
774 %{_libdir}/libsvn_ra_local-1.la
775 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
776 %{_libdir}/libsvn_ra_svn-1.la
777 %{_libdir}/libsvn_repos-1.la
778 %{_libdir}/libsvn_subr-1.la
779 %{_libdir}/libsvn_wc-1.la
780 %{_includedir}/%{name}-1
781 %{_examplesdir}/%{name}-%{version}
782
783 %files static
784 %defattr(644,root,root,755)
785 %{_libdir}/libsvn_client-1.a
786 %{_libdir}/libsvn_delta-1.a
787 %{_libdir}/libsvn_diff-1.a
788 %{_libdir}/libsvn_fs-1.a
789 %if %{without net_client_only}
790 %{_libdir}/libsvn_fs_base-1.a
791 %endif
792 %{_libdir}/libsvn_fs_fs-1.a
793 %{_libdir}/libsvn_fs_util-1.a
794 %{_libdir}/libsvn_ra-1.a
795 %{_libdir}/libsvn_ra_local-1.a
796 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
797 %{_libdir}/libsvn_ra_svn-1.a
798 %{_libdir}/libsvn_repos-1.a
799 %{_libdir}/libsvn_subr-1.a
800 %{_libdir}/libsvn_wc-1.a
801
802 %if %{with gnome}
803 %files -n gnome-keyring-subversion
804 %defattr(644,root,root,755)
805 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
806 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
807 %endif
808
809 %if %{with kwallet}
810 %files -n kde4-kwallet-subversion
811 %defattr(644,root,root,755)
812 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
813 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
814 %endif
815
816 %if %{without net_client_only}
817 %files svnserve
818 %defattr(644,root,root,755)
819 %attr(755,root,root) %{_bindir}/svnserve
820 %{_mandir}/man5/svnserve.conf.5*
821 %{_mandir}/man8/svnserve.8*
822 %dir %attr(750,svn,svn) /home/services/subversion
823 %dir %attr(750,svn,svn) /home/services/subversion/repos
824 %if %{with apache}
825 %attr(754,root,root) /etc/rc.d/init.d/svnserve
826 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
827 %endif
828
829 %files tools
830 %defattr(644,root,root,755)
831 %attr(755,root,root) %{_bindir}/svn-hot-backup
832
833 %files -n bash-completion-subversion
834 %defattr(644,root,root,755)
835 /etc/bash_completion.d/%{name}
836
837 %endif # net_client_only
838
839 %if %{with javahl}
840 %files -n java-subversion
841 %defattr(644,root,root,755)
842 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
843 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
844 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
845 %{_javadir}/svn-javahl.jar
846 %endif
847
848 %if %{with python}
849 %files -n python-subversion
850 %defattr(644,root,root,755)
851 %doc tools/backup/*.py
852 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
853 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
854 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
855 %dir %{py_sitedir}/libsvn
856 %attr(755,root,root) %{py_sitedir}/libsvn/_*.so
857 %{py_sitedir}/libsvn/*.py[co]
858 %dir %{py_sitedir}/svn
859 %{py_sitedir}/svn/*.py[co]
860 %{_examplesdir}/python-%{name}-%{version}
861 %endif
862
863 %if %{with csvn}
864 %files -n python-csvn
865 %defattr(644,root,root,755)
866 %doc subversion/bindings/ctypes-python/{README,TODO}
867 %doc subversion/bindings/ctypes-python/examples/*.py
868 %dir %{py_sitescriptdir}/csvn
869 %{py_sitescriptdir}/csvn/*.py[co]
870 %dir %{py_sitescriptdir}/csvn/core
871 %{py_sitescriptdir}/csvn/core/*.py[co]
872 %dir %{py_sitescriptdir}/csvn/ext
873 %{py_sitescriptdir}/csvn/ext/*.py[co]
874 %{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
875 %endif
876
877 %if %{with perl}
878 %files -n perl-subversion
879 %defattr(644,root,root,755)
880 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
881 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
882 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
883 %{perl_vendorarch}/SVN
884 %dir %{perl_vendorarch}/auto/SVN
885 %dir %{perl_vendorarch}/auto/SVN/*
886 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
887 %{perl_vendorarch}/auto/SVN/*/*.bs
888 %{_mandir}/man3/*.3pm*
889 %endif
890
891 %if %{with ruby}
892 %files -n ruby-subversion
893 %defattr(644,root,root,755)
894 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
895 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
896 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
897 %dir %{ruby_sitelibdir}/svn
898 %{ruby_sitelibdir}/svn/*.rb
899 %dir %{ruby_sitearchdir}/svn
900 %dir %{ruby_sitearchdir}/svn/ext
901 %attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
902 %{ruby_ridir}/Svn
903 %endif
904
905 %if %{with apache}
906 %files -n apache-mod_dav_svn
907 %defattr(644,root,root,755)
908 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
909 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
910
911 %files -n apache-mod_authz_svn
912 %defattr(644,root,root,755)
913 %doc subversion/mod_authz_svn/INSTALL
914 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
915 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
916 %endif
This page took 0.12014 seconds and 4 git commands to generate.