]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- fix ruby-subversion-1.5.0-2: req /usr/share/ri/1.8/system/OptionParser not found
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - remove net_client_only and add db bcond (then without apache and
3 #   without db => net_client_only - spec will be more simpler, I think)
4 # - finish ruby
5 #
6 # Conditional build:
7 %bcond_with     net_client_only         # build only net client
8 %bcond_without  python                  # build without python bindings (broken)
9 %bcond_without  perl                    # build without perl bindings
10 %bcond_without  ruby                    # build without ruby bindings
11 %bcond_without  apache                  # build without apache support (webdav, etc)
12 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
13 %bcond_without  tests                   # don't perform "make check"
14 #
15 %ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
16 %undefine       with_javahl
17 %endif
18 #
19 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
20 %define apxs    /usr/sbin/apxs
21 %define pdir    SVN
22 %define pnam    _Core
23 #
24 Summary:        A Concurrent Versioning system similar to but better than CVS
25 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
26 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
27 Name:           subversion
28 Version:        1.5.0
29 Release:        3
30 License:        Apache/BSD-like
31 Group:          Development/Version Control
32 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
33 # Source0-md5:  004b57643406dd10957ec87955702189
34 Source1:        %{name}-dav_svn.conf
35 Source2:        %{name}-authz_svn.conf
36 Source3:        %{name}-svnserve.init
37 Source4:        %{name}-svnserve.sysconfig
38 Source5:        %{name}-convert-typemaps-to-ifdef.py
39 Patch0:         %{name}-home_etc.patch
40 Patch1:         %{name}-DESTDIR.patch
41 Patch2:         %{name}-ruby-datadir-path.patch
42 URL:            http://subversion.tigris.org/
43 %if %{with net_client_only}
44 %global apache_modules_api 0
45 %else
46 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
47 BuildRequires:  automake
48 BuildRequires:  db-devel >= 4.1.25
49 BuildRequires:  rpmbuild(macros) >= 1.268
50 %if %{with perl}
51 BuildRequires:  perl-devel >= 1:5.8.0
52 BuildRequires:  rpm-perlprov >= 4.1-13
53 BuildRequires:  swig-perl >= 1.3.24
54 %endif
55 %{?with_javahl:BuildRequires:   jdk}
56 %endif
57 BuildRequires:  apr-devel >= 1:1.0.0
58 BuildRequires:  apr-util-devel >= 1:1.2.8-3
59 BuildRequires:  autoconf >= 2.59
60 BuildRequires:  bison
61 BuildRequires:  cyrus-sasl-devel
62 BuildRequires:  expat-devel
63 BuildRequires:  gettext-devel
64 BuildRequires:  libtool >= 1.4-9
65 BuildRequires:  neon-devel >= 0.26.0
66 BuildRequires:  python >= 2.2
67 BuildRequires:  python-modules >= 2.2
68 %if %{with python}
69 BuildRequires:  python-devel >= 2.2
70 BuildRequires:  sed >= 4.0
71 BuildRequires:  swig-python >= 1.3.24
72 %endif
73 %{?with_ruby:BuildRequires:     swig-ruby >= 1.3.24}
74 BuildRequires:  texinfo
75 BuildRequires:  which
76 Requires:       %{name}-libs = %{version}-%{release}
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %define         _libexecdir             %{_libdir}/svn
80 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
81 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
82
83 %description
84 The goal of the Subversion project is to build a version control
85 system that is a compelling replacement for CVS in the open source
86 community.
87
88 Our goals are:
89 - All current CVS features.
90 - Directories, renames, and file meta-data are versioned.
91 - Symbolic links, etc, are supported
92 - Commits are truly atomic.
93 - Branching and tagging are cheap (constant time) operations
94 - Repeated merges are handled gracefully
95 - Support for plug-in client side diff programs
96 - Natively client/server
97 - Client/server protocol sends diffs in both directions
98 - Costs are proportional to change size, not project size
99 - Internationalization
100 - Progressive multi-lingual support
101
102 %description -l pl.UTF-8
103 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
104 zamiennika dla CVS.
105
106 Cele projektu to:
107 - Wszystkie aktualne możliwości CVS.
108 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
109 - Obsługa dowiązań symbolicznych itp.
110 - Commity są w pełni atomowe.
111 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
112 - Dobra obsługa powtarzanego łączenia (merge).
113 - Obsługa wtyczek diff po stronie klienta.
114 - Natywny klient/serwer.
115 - Klient/Serwer przesyłają diffy w obu kierunkach.
116 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
117 - Internacjonalizacja.
118 - Postępujące wsparcie dla wielu języków.
119
120 %description -l pt_BR.UTF-8
121 O objetivo do projeto Subversion é construir um sistema de controle de
122 versões que seja um substituto para o CVS (Concurrent Versioning
123 System) na comunidade opensource, fornecendo grandes melhorias.
124
125 %package libs
126 Summary:        Subversion libraries and modules
127 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
128 Group:          Libraries
129 Requires:       neon >= 0.26.0
130 Obsoletes:      libsubversion0
131
132 %description libs
133 Subversion libraries and modules.
134
135 %description libs -l pl.UTF-8
136 Biblioteka subversion oraz ładowalne moduły.
137
138 %package devel
139 Summary:        Header files and develpment documentation for subversion
140 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
141 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
142 Group:          Development/Libraries
143 Requires:       %{name}-libs = %{version}-%{release}
144 Requires:       apr-util-devel >= 1:1.0.0
145 Requires:       neon-devel >= 0.26.0
146 Obsoletes:      libsubversion0-devel
147
148 %description devel
149 Header files and develpment documentation for subversion.
150
151 %description devel -l pl.UTF-8
152 Pliki nagłówkowe i dokumetacja do subversion.
153
154 %description devel -l pt_BR.UTF-8
155 Este pacote provê os arquivos necessários para desenvolvedores
156 interagirem com o Subversion.
157
158 %package static
159 Summary:        Static subversion library
160 Summary(pl.UTF-8):      Biblioteka statyczna subversion
161 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
162 Group:          Development/Libraries
163 Requires:       %{name}-devel = %{version}
164 Obsoletes:      libsubversion0-static-devel
165
166 %description static
167 Static subversion library.
168
169 %description static -l pl.UTF-8
170 Biblioteka statyczna subversion.
171
172 %description static -l pt_BR.UTF-8
173 Este pacote provê um cliente estático do subversion.
174
175 %package svnserve
176 Summary:        Subversion svnserve
177 Summary(pl.UTF-8):      Subversion svnserve
178 Group:          Networking/Daemons
179 Requires(post,preun):   /sbin/chkconfig
180 Requires(postun):       /usr/sbin/groupdel
181 Requires(postun):       /usr/sbin/userdel
182 Requires(pre):  /bin/id
183 Requires(pre):  /usr/bin/getgid
184 Requires(pre):  /usr/lib/rpm/user_group.sh
185 Requires(pre):  /usr/sbin/groupadd
186 Requires(pre):  /usr/sbin/useradd
187 Requires(pre):  /usr/sbin/usermod
188 Requires:       %{name} = %{version}-%{release}
189 Requires:       rc-scripts
190 Provides:       group(svn)
191 Provides:       user(svn)
192
193 %description svnserve
194 Subversion svnserve server.
195
196 %description svnserve -l pl.UTF-8
197 Serwer subversion svnserve.
198
199 %package tools
200 Summary:        Subversion tools and scripts
201 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
202 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
203 Group:          Applications
204 %pyrequires_eq  python
205 Requires:       %{name} = %{version}-%{release}
206 Requires:       python-rcsparse >= 0.1-0.20031026.0
207 Requires:       python-subversion = %{version}
208
209 %description tools
210 Subversion tools and scripts.
211
212 %description tools -l pl.UTF-8
213 Narzędzia oraz skrypty dla subversion.
214
215 %package -n bash-completion-subversion
216 Summary:        bash completion for subversion
217 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
218 Group:          Applications/Shells
219 Requires:       %{name} = %{version}-%{release}
220 Requires:       bash-completion
221 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
222
223 %description -n bash-completion-subversion
224 Bash completion for subversion.
225
226 %description -n bash-completion-subversion -l pl.UTF-8
227 Dopełnienia basha dla subversion.
228
229 %package -n java-subversion
230 Summary:        Subversion Java bindings
231 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
232 Group:          Development/Languages/Java
233 Requires:       %{name}-libs = %{version}-%{release}
234
235 %description -n java-subversion
236 This is a set of Java classes which provide the functionality of
237 subversion-libs, the Subversion libraries. It is useful if you want
238 to, for example, write a Java class that manipulates a Subversion
239 repository or working copy. See the 'subversion' package for more
240 information.
241
242 %description -n java-subversion -l pl.UTF-8
243 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
244 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
245 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
246 roboczą. Więcej informacji w pakiecie subversion.
247
248 %package -n python-subversion
249 Summary:        Subversion Python bindings
250 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
251 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
252 Group:          Development/Languages/Python
253 %pyrequires_eq  python
254 Requires:       %{name}-libs = %{version}-%{release}
255 Obsoletes:      subversion-python
256
257 %description -n python-subversion
258 Subversion Python bindings.
259
260 %description -n python-subversion -l pl.UTF-8
261 Dowiązania do Subversion dla Pythona.
262
263 %description -n python-subversion -l pt_BR.UTF-8
264 Módulos Python para acessar os recursos do Subversion.
265
266 %package -n perl-subversion
267 Summary:        Subversion Perl bindings
268 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
269 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
270 Group:          Development/Languages/Perl
271 Requires:       %{name}-libs = %{version}-%{release}
272 Obsoletes:      subversion-perl
273
274 %description -n perl-subversion
275 Subversion Perl bindings.
276
277 %description -n perl-subversion -l pl.UTF-8
278 Dowiązania do Subversion dla Perla.
279
280 %description -n perl-subversion -l pt_BR.UTF-8
281 Módulos Perl para acessar os recursos do Subversion.
282
283 %package -n ruby-subversion
284 Summary:        Subversion Ruby bindings
285 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
286 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
287 Group:          Development/Languages
288 Requires:       %{name}-libs = %{version}-%{release}
289 Obsoletes:      subversion-ruby
290
291 %description -n ruby-subversion
292 Subversion Ruby bindings.
293
294 %description -n ruby-subversion -l pl.UTF-8
295 Dowiązania do Subversion dla języka Ruby.
296
297 %description -n ruby-subversion -l pt_BR.UTF-8
298 Módulos Ruby para acessar os recursos do Subversion.
299
300 %package -n apache-mod_dav_svn
301 Summary:        Apache module: Subversion Server
302 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
303 Group:          Networking/Daemons
304 Requires:       %{name} = %{version}-%{release}
305 Requires:       apache(modules-api) = %apache_modules_api
306 Requires:       apache-mod_dav
307
308 %description -n apache-mod_dav_svn
309 Apache module: Subversion Server.
310
311 %description -n apache-mod_dav_svn -l pl.UTF-8
312 Moduł apache: Serwer Subversion.
313
314 %package -n apache-mod_authz_svn
315 Summary:        Apache module: Subversion Server - path-based authorization
316 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
317 Group:          Networking/Daemons
318 Requires:       apache(modules-api) = %apache_modules_api
319 Requires:       apache-mod_dav_svn = %{version}-%{release}
320
321 %description -n apache-mod_authz_svn
322 Apache module: Subversion Server - path-based authorization.
323
324 %description -n apache-mod_authz_svn -l pl.UTF-8
325 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
326
327 %prep
328 %setup -q
329 rm -rf apr apr-util neon
330 %patch0 -p0
331 %patch1 -p1
332 %patch2 -p0
333
334 %build
335 rm subversion/bindings/swig/proxy/*.swg
336 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
337 cp -f /usr/share/automake/config.sub ac-helpers
338 chmod +x ./autogen.sh && ./autogen.sh
339
340 %configure \
341         --with-editor=vi \
342         --with-zlib=%{_libdir} \
343 %if %{with net_client_only}
344         --without-apache \
345         --without-swig \
346         --without-apxs \
347         --without-berkeley-db \
348 %else
349         --disable-runtime-module-search \
350         --disable-mod-activation \
351 %if %{with apache}
352         --with-apxs=%{_sbindir}/apxs \
353 %else
354         --without-apache \
355         --without-apxs \
356         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
357 %endif
358 %if !%{with python} && !%{with perl} && !%{with ruby}
359         --without-swig \
360 %endif
361         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
362 %endif
363         --with-jdk="%{java_home}" \
364         --with-neon=%{_prefix} \
365         --disable-neon-version-check \
366         --with-apr=%{_bindir}/apr-1-config \
367         --with-apr-util=%{_bindir}/apu-1-config
368
369 %{__make} -j1
370
371 %if !%{with net_client_only}
372 # python
373 %if %{with python}
374 %{__make} swig-py \
375         swig_pydir=%{py_sitedir}/libsvn \
376         swig_pydir_extra=%{py_sitedir}/svn
377 %endif
378 # perl
379 %if %{with perl}
380 %{__make} swig-pl-lib
381 odir=$(pwd)
382 cd subversion/bindings/swig/perl/native
383 %{__perl} Makefile.PL INSTALLDIRS=vendor
384 %{__make} -j1
385 cd $odir
386 %endif
387 %if %{with javahl}
388 %{__make} -j1 javahl \
389         javahl_javadir="%{_javadir}"
390 %endif
391 # ruby
392 %if %{with ruby}
393 %{__make} swig-rb
394 %endif
395 %endif
396
397 %if %{with tests}
398 %{__make} check
399 %if %{with python}
400 %{__make} check-swig-py
401 %endif
402 %if %{with perl}
403 %{__make} check-swig-pl
404 %endif
405 %if %{with ruby}
406 %{__make} check-swig-rb
407 %endif
408 %endif
409
410 %install
411 rm -rf $RPM_BUILD_ROOT
412 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
413         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
414         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
415         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
416
417 %{__make} install -j1 \
418 %if %{with javahl}
419         install-javahl \
420         javahl_javadir="%{_javadir}" \
421 %endif
422 %if !%{with net_client_only}
423 %if %{with python}
424         install-swig-py \
425 %endif
426 %if %{with ruby}
427         install-swig-rb install-swig-rb-doc \
428 %endif
429 %endif
430         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
431         DESTDIR=$RPM_BUILD_ROOT \
432         swig_pydir=%{py_sitedir}/libsvn \
433         swig_pydir_extra=%{py_sitedir}/svn
434
435 %if !%{with net_client_only} && %{with perl}
436 %{__make} install-swig-pl-lib \
437         DESTDIR=$RPM_BUILD_ROOT
438 %{__make} -C subversion/bindings/swig/perl/native install \
439         DESTDIR=$RPM_BUILD_ROOT \
440         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
441         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
442 %endif
443
444 %if %{with apache}
445 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
446 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
447 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
448 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
449 %endif
450
451 %if !%{with net_client_only}
452 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
453 %if %{with python}
454 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
455 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
456 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
457 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
458 %endif
459 %endif
460
461 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
462 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
463
464 %find_lang %{name}
465
466 rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn{javahl,_swig}*.{la,a}
467 rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/svn/ext/*.la
468
469 %clean
470 rm -rf $RPM_BUILD_ROOT
471
472 %pre svnserve
473 %groupadd -g 86 svn
474 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
475
476 %post   libs -p /sbin/ldconfig
477 %postun libs -p /sbin/ldconfig
478
479 %post   devel -p /sbin/postshell
480 -/usr/sbin/fix-info-dir -c %{_infodir}
481
482 %postun devel -p /sbin/postshell
483 -/usr/sbin/fix-info-dir -c %{_infodir}
484
485 %post   -n perl-subversion -p /sbin/ldconfig
486 %postun -n perl-subversion -p /sbin/ldconfig
487
488 %post   -n python-subversion -p /sbin/ldconfig
489 %postun -n python-subversion -p /sbin/ldconfig
490
491 %post svnserve
492 /sbin/chkconfig --add svnserve
493 %service svnserve restart "svnserve daemon"
494
495 %preun svnserve
496 if [ "$1" = "0" ]; then
497         %service svnserve stop
498         /sbin/chkconfig --del svnserve
499 fi
500
501 %postun svnserve
502 if [ "$1" = "0" ]; then
503         %userremove svn
504         %groupremove svn
505 fi
506
507 %post -n apache-mod_dav_svn
508 %service -q httpd restart
509
510 %preun -n apache-mod_dav_svn
511 if [ "$1" = "0" ]; then
512         %service -q httpd restart
513 fi
514
515 %files
516 %defattr(644,root,root,755)
517 %doc BUGS CHANGES COPYING INSTALL README
518 %doc doc/*/*.html
519 %doc tools/hook-scripts/*.{pl,py,example}
520 %doc tools/hook-scripts/mailer/*.{py,example}
521 %doc tools/xslt/*
522 %attr(755,root,root) %{_bindir}/svn
523 %attr(755,root,root) %{_bindir}/svnadmin
524 %attr(755,root,root) %{_bindir}/svndumpfilter
525 %attr(755,root,root) %{_bindir}/svnlook
526 %attr(755,root,root) %{_bindir}/svnsync
527 %attr(755,root,root) %{_bindir}/svnversion
528 %{_mandir}/man1/svn.1*
529 %{_mandir}/man1/svnadmin.1*
530 %{_mandir}/man1/svndumpfilter.1*
531 %{_mandir}/man1/svnlook.1*
532 %{_mandir}/man1/svnsync.1*
533 %{_mandir}/man1/svnversion.1*
534
535 %files libs -f %{name}.lang
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
538 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
539 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
540 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
541 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
542 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
543 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
544 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
545 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
546 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
547 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
548 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
549 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
550 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
551 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
552 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
553 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
554 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
555 %attr(755,root,root) %{_libdir}/libsvn_ra_neon-1.so.*.*.*
556 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_neon-1.so.0
557 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
558 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
559 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
560 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
561 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
562 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
563 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
564 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
565
566 %files devel
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
569 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
570 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
571 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
572 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
573 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
574 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
575 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
576 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
577 %attr(755,root,root) %{_libdir}/libsvn_ra_neon-1.so
578 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
579 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
580 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
581 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
582 %{_libdir}/libsvn_client-1.la
583 %{_libdir}/libsvn_delta-1.la
584 %{_libdir}/libsvn_diff-1.la
585 %{_libdir}/libsvn_fs-1.la
586 %{_libdir}/libsvn_fs_base-1.la
587 %{_libdir}/libsvn_fs_fs-1.la
588 %{_libdir}/libsvn_fs_util-1.la
589 %{_libdir}/libsvn_ra-1.la
590 %{_libdir}/libsvn_ra_local-1.la
591 %{_libdir}/libsvn_ra_neon-1.la
592 %{_libdir}/libsvn_ra_svn-1.la
593 %{_libdir}/libsvn_repos-1.la
594 %{_libdir}/libsvn_subr-1.la
595 %{_libdir}/libsvn_wc-1.la
596 %{_includedir}/%{name}-1
597 %{_examplesdir}/%{name}-%{version}
598
599 %files static
600 %defattr(644,root,root,755)
601 %{_libdir}/libsvn_client-1.a
602 %{_libdir}/libsvn_delta-1.a
603 %{_libdir}/libsvn_diff-1.a
604 %{_libdir}/libsvn_fs-1.a
605 %{_libdir}/libsvn_fs_base-1.a
606 %{_libdir}/libsvn_fs_fs-1.a
607 %{_libdir}/libsvn_fs_util-1.a
608 %{_libdir}/libsvn_ra-1.a
609 %{_libdir}/libsvn_ra_local-1.a
610 %{_libdir}/libsvn_ra_neon-1.a
611 %{_libdir}/libsvn_ra_svn-1.a
612 %{_libdir}/libsvn_repos-1.a
613 %{_libdir}/libsvn_subr-1.a
614 %{_libdir}/libsvn_wc-1.a
615
616 %if !%{with net_client_only}
617 %files svnserve
618 %defattr(644,root,root,755)
619 %attr(755,root,root) %{_bindir}/svnserve
620 %{_mandir}/man5/svnserve.conf.5*
621 %{_mandir}/man8/svnserve.8*
622 %dir %attr(750,svn,svn) /home/services/subversion
623 %dir %attr(750,svn,svn) /home/services/subversion/repos
624 %if %{with apache}
625 %attr(754,root,root) /etc/rc.d/init.d/svnserve
626 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
627 %endif
628
629 %files tools
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{_bindir}/svn-hot-backup
632
633 %files -n bash-completion-subversion
634 %defattr(644,root,root,755)
635 /etc/bash_completion.d/%{name}
636
637 %if %{with javahl}
638 %files -n java-subversion
639 %defattr(644,root,root,755)
640 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
641 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
642 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
643 %{_javadir}/svn-javahl.jar
644 %endif
645
646 %if %{with python}
647 %files -n python-subversion
648 %defattr(644,root,root,755)
649 %doc tools/backup/*.py tools/examples/*.py
650 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
651 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
652 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
653 %dir %{py_sitedir}/libsvn
654 %{py_sitedir}/libsvn/*.py[co]
655 %dir %{py_sitedir}/svn
656 %{py_sitedir}/svn/*.py[co]
657 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
658 %{_examplesdir}/python-%{name}-%{version}
659 %endif
660
661 %if %{with perl}
662 %files -n perl-subversion
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
665 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
666 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
667 %{perl_vendorarch}/SVN
668 %dir %{perl_vendorarch}/auto/SVN
669 %dir %{perl_vendorarch}/auto/SVN/*
670 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
671 %{perl_vendorarch}/auto/SVN/*/*.bs
672 %{_mandir}/man3/*.3pm*
673 %endif
674
675 %if %{with ruby}
676 %files -n ruby-subversion
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
679 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
680 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
681 %dir %{_libdir}/ruby/site_ruby/svn
682 %{_libdir}/ruby/site_ruby/svn/*.rb
683 %dir %{_libdir}/ruby/site_ruby/svn/ext
684 %attr(755,root,root) %{_libdir}/ruby/site_ruby/svn/ext/*.so
685 %{_datadir}/ri/*.*/system/OptionParser
686 %{_datadir}/ri/*.*/system/Svn
687 %{_datadir}/ri/*.*/system/Time
688 %{_datadir}/ri/*.*/system/Uconv
689 %{_datadir}/ri/*.*/system/*.rid
690 %{_datadir}/ri/*.*/system/Kernel/*
691 %endif
692
693 %if %{with apache}
694 %files -n apache-mod_dav_svn
695 %defattr(644,root,root,755)
696 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
697 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
698
699 %files -n apache-mod_authz_svn
700 %defattr(644,root,root,755)
701 %doc subversion/mod_authz_svn/INSTALL
702 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
703 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
704 %endif
705
706 %endif # net_client_only
This page took 0.147209 seconds and 3 git commands to generate.