]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
94541a2c188952e615280005d9964fe29e8c923d
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - remove net_client_only and add db bcond (then without apache and
3 #   without db => net_client_only - spec will be more simpler, I think)
4 # - finish ruby
5 #
6 # Conditional build:
7 %bcond_with     net_client_only         # build only net client
8 %bcond_without  python                  # build without python bindings (broken)
9 %bcond_without  perl                    # build without perl bindings
10 %bcond_without  ruby                    # build without ruby bindings
11 %bcond_without  apache                  # build without apache support (webdav, etc)
12 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
13 %bcond_without  tests                   # don't perform "make check"
14 #
15 %ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
16 %undefine       with_javahl
17 %endif
18 #
19 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
20 %define apxs    /usr/sbin/apxs
21 %define pdir    SVN
22 %define pnam    _Core
23 #
24 Summary:        A Concurrent Versioning system similar to but better than CVS
25 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
26 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
27 Name:           subversion
28 Version:        1.5.1
29 Release:        1
30 License:        Apache/BSD-like
31 Group:          Development/Version Control
32 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
33 # Source0-md5:  8dbdaa625d6b18887702885df07fc87e
34 Source1:        %{name}-dav_svn.conf
35 Source2:        %{name}-authz_svn.conf
36 Source3:        %{name}-svnserve.init
37 Source4:        %{name}-svnserve.sysconfig
38 Source5:        %{name}-convert-typemaps-to-ifdef.py
39 Patch0:         %{name}-home_etc.patch
40 Patch1:         %{name}-DESTDIR.patch
41 Patch2:         %{name}-ruby-datadir-path.patch
42 URL:            http://subversion.tigris.org/
43 %if %{with net_client_only}
44 %global apache_modules_api 0
45 %else
46 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
47 BuildRequires:  automake
48 BuildRequires:  db-devel >= 4.1.25
49 BuildRequires:  rpmbuild(macros) >= 1.268
50 %if %{with perl}
51 BuildRequires:  perl-devel >= 1:5.8.0
52 BuildRequires:  rpm-perlprov >= 4.1-13
53 BuildRequires:  swig-perl >= 1.3.24
54 %endif
55 %{?with_javahl:BuildRequires:   jdk}
56 %endif
57 BuildRequires:  apr-devel >= 1:1.0.0
58 BuildRequires:  apr-util-devel >= 1:1.2.8-3
59 BuildRequires:  autoconf >= 2.59
60 BuildRequires:  bison
61 BuildRequires:  cyrus-sasl-devel
62 BuildRequires:  expat-devel
63 BuildRequires:  gettext-devel
64 BuildRequires:  libtool >= 1.4-9
65 BuildRequires:  neon-devel >= 0.26.0
66 BuildRequires:  python >= 2.2
67 BuildRequires:  python-modules >= 2.2
68 %if %{with python}
69 BuildRequires:  python-devel >= 2.2
70 BuildRequires:  sed >= 4.0
71 BuildRequires:  swig-python >= 1.3.24
72 %endif
73 %{?with_ruby:BuildRequires:     ruby-devel}
74 %{?with_ruby:BuildRequires:     swig-ruby >= 1.3.24}
75 BuildRequires:  texinfo
76 BuildRequires:  which
77 Requires:       %{name}-libs = %{version}-%{release}
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %define         _libexecdir             %{_libdir}/svn
81 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
82 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
83
84 %description
85 The goal of the Subversion project is to build a version control
86 system that is a compelling replacement for CVS in the open source
87 community.
88
89 Our goals are:
90 - All current CVS features.
91 - Directories, renames, and file meta-data are versioned.
92 - Symbolic links, etc, are supported
93 - Commits are truly atomic.
94 - Branching and tagging are cheap (constant time) operations
95 - Repeated merges are handled gracefully
96 - Support for plug-in client side diff programs
97 - Natively client/server
98 - Client/server protocol sends diffs in both directions
99 - Costs are proportional to change size, not project size
100 - Internationalization
101 - Progressive multi-lingual support
102
103 %description -l pl.UTF-8
104 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
105 zamiennika dla CVS.
106
107 Cele projektu to:
108 - Wszystkie aktualne możliwości CVS.
109 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
110 - Obsługa dowiązań symbolicznych itp.
111 - Commity są w pełni atomowe.
112 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
113 - Dobra obsługa powtarzanego łączenia (merge).
114 - Obsługa wtyczek diff po stronie klienta.
115 - Natywny klient/serwer.
116 - Klient/Serwer przesyłają diffy w obu kierunkach.
117 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
118 - Internacjonalizacja.
119 - Postępujące wsparcie dla wielu języków.
120
121 %description -l pt_BR.UTF-8
122 O objetivo do projeto Subversion é construir um sistema de controle de
123 versões que seja um substituto para o CVS (Concurrent Versioning
124 System) na comunidade opensource, fornecendo grandes melhorias.
125
126 %package libs
127 Summary:        Subversion libraries and modules
128 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
129 Group:          Libraries
130 Requires:       neon >= 0.26.0
131 Obsoletes:      libsubversion0
132
133 %description libs
134 Subversion libraries and modules.
135
136 %description libs -l pl.UTF-8
137 Biblioteka subversion oraz ładowalne moduły.
138
139 %package devel
140 Summary:        Header files and develpment documentation for subversion
141 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
142 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
143 Group:          Development/Libraries
144 Requires:       %{name}-libs = %{version}-%{release}
145 Requires:       apr-util-devel >= 1:1.0.0
146 Requires:       neon-devel >= 0.26.0
147 Obsoletes:      libsubversion0-devel
148
149 %description devel
150 Header files and develpment documentation for subversion.
151
152 %description devel -l pl.UTF-8
153 Pliki nagłówkowe i dokumetacja do subversion.
154
155 %description devel -l pt_BR.UTF-8
156 Este pacote provê os arquivos necessários para desenvolvedores
157 interagirem com o Subversion.
158
159 %package static
160 Summary:        Static subversion library
161 Summary(pl.UTF-8):      Biblioteka statyczna subversion
162 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
163 Group:          Development/Libraries
164 Requires:       %{name}-devel = %{version}
165 Obsoletes:      libsubversion0-static-devel
166
167 %description static
168 Static subversion library.
169
170 %description static -l pl.UTF-8
171 Biblioteka statyczna subversion.
172
173 %description static -l pt_BR.UTF-8
174 Este pacote provê um cliente estático do subversion.
175
176 %package svnserve
177 Summary:        Subversion svnserve
178 Summary(pl.UTF-8):      Subversion svnserve
179 Group:          Networking/Daemons
180 Requires(post,preun):   /sbin/chkconfig
181 Requires(postun):       /usr/sbin/groupdel
182 Requires(postun):       /usr/sbin/userdel
183 Requires(pre):  /bin/id
184 Requires(pre):  /usr/bin/getgid
185 Requires(pre):  /usr/lib/rpm/user_group.sh
186 Requires(pre):  /usr/sbin/groupadd
187 Requires(pre):  /usr/sbin/useradd
188 Requires(pre):  /usr/sbin/usermod
189 Requires:       %{name} = %{version}-%{release}
190 Requires:       rc-scripts
191 Provides:       group(svn)
192 Provides:       user(svn)
193
194 %description svnserve
195 Subversion svnserve server.
196
197 %description svnserve -l pl.UTF-8
198 Serwer subversion svnserve.
199
200 %package tools
201 Summary:        Subversion tools and scripts
202 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
203 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
204 Group:          Applications
205 %pyrequires_eq  python
206 Requires:       %{name} = %{version}-%{release}
207 Requires:       python-rcsparse >= 0.1-0.20031026.0
208 Requires:       python-subversion = %{version}
209
210 %description tools
211 Subversion tools and scripts.
212
213 %description tools -l pl.UTF-8
214 Narzędzia oraz skrypty dla subversion.
215
216 %package -n bash-completion-subversion
217 Summary:        bash completion for subversion
218 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
219 Group:          Applications/Shells
220 Requires:       %{name} = %{version}-%{release}
221 Requires:       bash-completion
222 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
223
224 %description -n bash-completion-subversion
225 Bash completion for subversion.
226
227 %description -n bash-completion-subversion -l pl.UTF-8
228 Dopełnienia basha dla subversion.
229
230 %package -n java-subversion
231 Summary:        Subversion Java bindings
232 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
233 Group:          Development/Languages/Java
234 Requires:       %{name}-libs = %{version}-%{release}
235
236 %description -n java-subversion
237 This is a set of Java classes which provide the functionality of
238 subversion-libs, the Subversion libraries. It is useful if you want
239 to, for example, write a Java class that manipulates a Subversion
240 repository or working copy. See the 'subversion' package for more
241 information.
242
243 %description -n java-subversion -l pl.UTF-8
244 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
245 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
246 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
247 roboczą. Więcej informacji w pakiecie subversion.
248
249 %package -n python-subversion
250 Summary:        Subversion Python bindings
251 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
252 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
253 Group:          Development/Languages/Python
254 %pyrequires_eq  python
255 Requires:       %{name}-libs = %{version}-%{release}
256 Obsoletes:      subversion-python
257
258 %description -n python-subversion
259 Subversion Python bindings.
260
261 %description -n python-subversion -l pl.UTF-8
262 Dowiązania do Subversion dla Pythona.
263
264 %description -n python-subversion -l pt_BR.UTF-8
265 Módulos Python para acessar os recursos do Subversion.
266
267 %package -n perl-subversion
268 Summary:        Subversion Perl bindings
269 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
270 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
271 Group:          Development/Languages/Perl
272 Requires:       %{name}-libs = %{version}-%{release}
273 Obsoletes:      subversion-perl
274
275 %description -n perl-subversion
276 Subversion Perl bindings.
277
278 %description -n perl-subversion -l pl.UTF-8
279 Dowiązania do Subversion dla Perla.
280
281 %description -n perl-subversion -l pt_BR.UTF-8
282 Módulos Perl para acessar os recursos do Subversion.
283
284 %package -n ruby-subversion
285 Summary:        Subversion Ruby bindings
286 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
287 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
288 Group:          Development/Languages
289 Requires:       %{name}-libs = %{version}-%{release}
290 Obsoletes:      subversion-ruby
291
292 %description -n ruby-subversion
293 Subversion Ruby bindings.
294
295 %description -n ruby-subversion -l pl.UTF-8
296 Dowiązania do Subversion dla języka Ruby.
297
298 %description -n ruby-subversion -l pt_BR.UTF-8
299 Módulos Ruby para acessar os recursos do Subversion.
300
301 %package -n apache-mod_dav_svn
302 Summary:        Apache module: Subversion Server
303 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
304 Group:          Networking/Daemons
305 Requires:       %{name} = %{version}-%{release}
306 Requires:       apache(modules-api) = %apache_modules_api
307 Requires:       apache-mod_dav
308
309 %description -n apache-mod_dav_svn
310 Apache module: Subversion Server.
311
312 %description -n apache-mod_dav_svn -l pl.UTF-8
313 Moduł apache: Serwer Subversion.
314
315 %package -n apache-mod_authz_svn
316 Summary:        Apache module: Subversion Server - path-based authorization
317 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
318 Group:          Networking/Daemons
319 Requires:       apache(modules-api) = %apache_modules_api
320 Requires:       apache-mod_dav_svn = %{version}-%{release}
321
322 %description -n apache-mod_authz_svn
323 Apache module: Subversion Server - path-based authorization.
324
325 %description -n apache-mod_authz_svn -l pl.UTF-8
326 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
327
328 %prep
329 %setup -q
330 rm -rf apr apr-util neon
331 %patch0 -p0
332 %patch1 -p1
333 %patch2 -p0
334
335 %build
336 rm subversion/bindings/swig/proxy/*.swg
337 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
338 cp -f /usr/share/automake/config.sub ac-helpers
339 chmod +x ./autogen.sh && ./autogen.sh
340
341 %configure \
342         --with-editor=vi \
343         --with-zlib=%{_libdir} \
344 %if %{with net_client_only}
345         --without-apache \
346         --without-swig \
347         --without-apxs \
348         --without-berkeley-db \
349 %else
350         --disable-runtime-module-search \
351         --disable-mod-activation \
352 %if %{with apache}
353         --with-apxs=%{_sbindir}/apxs \
354 %else
355         --without-apache \
356         --without-apxs \
357         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
358 %endif
359 %if !%{with python} && !%{with perl} && !%{with ruby}
360         --without-swig \
361 %endif
362         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
363 %endif
364         --with-jdk="%{java_home}" \
365         --with-neon=%{_prefix} \
366         --disable-neon-version-check \
367         --with-apr=%{_bindir}/apr-1-config \
368         --with-apr-util=%{_bindir}/apu-1-config
369
370 %{__make} -j1
371
372 %if !%{with net_client_only}
373 # python
374 %if %{with python}
375 %{__make} swig-py \
376         swig_pydir=%{py_sitedir}/libsvn \
377         swig_pydir_extra=%{py_sitedir}/svn
378 %endif
379 # perl
380 %if %{with perl}
381 %{__make} swig-pl-lib
382 odir=$(pwd)
383 cd subversion/bindings/swig/perl/native
384 %{__perl} Makefile.PL INSTALLDIRS=vendor
385 %{__make} -j1
386 cd $odir
387 %endif
388 %if %{with javahl}
389 %{__make} -j1 javahl \
390         javahl_javadir="%{_javadir}"
391 %endif
392 # ruby
393 %if %{with ruby}
394 %{__make} swig-rb
395 %endif
396 %endif
397
398 %if %{with tests}
399 %{__make} check
400 %if %{with python}
401 %{__make} check-swig-py
402 %endif
403 %if %{with perl}
404 %{__make} check-swig-pl
405 %endif
406 %if %{with ruby}
407 %{__make} check-swig-rb
408 %endif
409 %endif
410
411 %install
412 rm -rf $RPM_BUILD_ROOT
413 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
414         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
415         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
416         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
417
418 %{__make} install -j1 \
419 %if %{with javahl}
420         install-javahl \
421         javahl_javadir="%{_javadir}" \
422 %endif
423 %if !%{with net_client_only}
424 %if %{with python}
425         install-swig-py \
426 %endif
427 %if %{with ruby}
428         install-swig-rb install-swig-rb-doc \
429 %endif
430 %endif
431         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
432         DESTDIR=$RPM_BUILD_ROOT \
433         swig_pydir=%{py_sitedir}/libsvn \
434         swig_pydir_extra=%{py_sitedir}/svn
435
436 %if !%{with net_client_only} && %{with perl}
437 %{__make} install-swig-pl-lib \
438         DESTDIR=$RPM_BUILD_ROOT
439 %{__make} -C subversion/bindings/swig/perl/native install \
440         DESTDIR=$RPM_BUILD_ROOT \
441         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
442         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
443 %endif
444
445 %if %{with apache}
446 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
447 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
448 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
449 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
450 %endif
451
452 %if !%{with net_client_only}
453 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
454 %if %{with python}
455 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
456 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
457 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
458 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
459 %endif
460 %endif
461
462 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
463 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
464
465 %find_lang %{name}
466
467 rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn{javahl,_swig}*.{la,a}
468 rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/svn/ext/*.la
469
470 %clean
471 rm -rf $RPM_BUILD_ROOT
472
473 %pre svnserve
474 %groupadd -g 86 svn
475 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
476
477 %post   libs -p /sbin/ldconfig
478 %postun libs -p /sbin/ldconfig
479
480 %post   devel -p /sbin/postshell
481 -/usr/sbin/fix-info-dir -c %{_infodir}
482
483 %postun devel -p /sbin/postshell
484 -/usr/sbin/fix-info-dir -c %{_infodir}
485
486 %post   -n perl-subversion -p /sbin/ldconfig
487 %postun -n perl-subversion -p /sbin/ldconfig
488
489 %post   -n python-subversion -p /sbin/ldconfig
490 %postun -n python-subversion -p /sbin/ldconfig
491
492 %post svnserve
493 /sbin/chkconfig --add svnserve
494 %service svnserve restart "svnserve daemon"
495
496 %preun svnserve
497 if [ "$1" = "0" ]; then
498         %service svnserve stop
499         /sbin/chkconfig --del svnserve
500 fi
501
502 %postun svnserve
503 if [ "$1" = "0" ]; then
504         %userremove svn
505         %groupremove svn
506 fi
507
508 %post -n apache-mod_dav_svn
509 %service -q httpd restart
510
511 %preun -n apache-mod_dav_svn
512 if [ "$1" = "0" ]; then
513         %service -q httpd restart
514 fi
515
516 %files
517 %defattr(644,root,root,755)
518 %doc BUGS CHANGES COPYING INSTALL README
519 %doc doc/*/*.html
520 %doc tools/hook-scripts/*.{pl,py,example}
521 %doc tools/hook-scripts/mailer/*.{py,example}
522 %doc tools/xslt/*
523 %attr(755,root,root) %{_bindir}/svn
524 %attr(755,root,root) %{_bindir}/svnadmin
525 %attr(755,root,root) %{_bindir}/svndumpfilter
526 %attr(755,root,root) %{_bindir}/svnlook
527 %attr(755,root,root) %{_bindir}/svnsync
528 %attr(755,root,root) %{_bindir}/svnversion
529 %{_mandir}/man1/svn.1*
530 %{_mandir}/man1/svnadmin.1*
531 %{_mandir}/man1/svndumpfilter.1*
532 %{_mandir}/man1/svnlook.1*
533 %{_mandir}/man1/svnsync.1*
534 %{_mandir}/man1/svnversion.1*
535
536 %files libs -f %{name}.lang
537 %defattr(644,root,root,755)
538 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
539 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
540 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
541 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
542 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
543 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
544 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
545 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
546 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
547 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
548 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
549 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
550 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
551 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
552 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
553 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
554 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
555 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
556 %attr(755,root,root) %{_libdir}/libsvn_ra_neon-1.so.*.*.*
557 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_neon-1.so.0
558 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
559 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
560 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
561 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
562 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
563 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
564 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
565 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
566
567 %files devel
568 %defattr(644,root,root,755)
569 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
570 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
571 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
572 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
573 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
574 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
575 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
576 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
577 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
578 %attr(755,root,root) %{_libdir}/libsvn_ra_neon-1.so
579 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
580 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
581 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
582 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
583 %{_libdir}/libsvn_client-1.la
584 %{_libdir}/libsvn_delta-1.la
585 %{_libdir}/libsvn_diff-1.la
586 %{_libdir}/libsvn_fs-1.la
587 %{_libdir}/libsvn_fs_base-1.la
588 %{_libdir}/libsvn_fs_fs-1.la
589 %{_libdir}/libsvn_fs_util-1.la
590 %{_libdir}/libsvn_ra-1.la
591 %{_libdir}/libsvn_ra_local-1.la
592 %{_libdir}/libsvn_ra_neon-1.la
593 %{_libdir}/libsvn_ra_svn-1.la
594 %{_libdir}/libsvn_repos-1.la
595 %{_libdir}/libsvn_subr-1.la
596 %{_libdir}/libsvn_wc-1.la
597 %{_includedir}/%{name}-1
598 %{_examplesdir}/%{name}-%{version}
599
600 %files static
601 %defattr(644,root,root,755)
602 %{_libdir}/libsvn_client-1.a
603 %{_libdir}/libsvn_delta-1.a
604 %{_libdir}/libsvn_diff-1.a
605 %{_libdir}/libsvn_fs-1.a
606 %{_libdir}/libsvn_fs_base-1.a
607 %{_libdir}/libsvn_fs_fs-1.a
608 %{_libdir}/libsvn_fs_util-1.a
609 %{_libdir}/libsvn_ra-1.a
610 %{_libdir}/libsvn_ra_local-1.a
611 %{_libdir}/libsvn_ra_neon-1.a
612 %{_libdir}/libsvn_ra_svn-1.a
613 %{_libdir}/libsvn_repos-1.a
614 %{_libdir}/libsvn_subr-1.a
615 %{_libdir}/libsvn_wc-1.a
616
617 %if !%{with net_client_only}
618 %files svnserve
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{_bindir}/svnserve
621 %{_mandir}/man5/svnserve.conf.5*
622 %{_mandir}/man8/svnserve.8*
623 %dir %attr(750,svn,svn) /home/services/subversion
624 %dir %attr(750,svn,svn) /home/services/subversion/repos
625 %if %{with apache}
626 %attr(754,root,root) /etc/rc.d/init.d/svnserve
627 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
628 %endif
629
630 %files tools
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_bindir}/svn-hot-backup
633
634 %files -n bash-completion-subversion
635 %defattr(644,root,root,755)
636 /etc/bash_completion.d/%{name}
637
638 %if %{with javahl}
639 %files -n java-subversion
640 %defattr(644,root,root,755)
641 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
642 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
643 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
644 %{_javadir}/svn-javahl.jar
645 %endif
646
647 %if %{with python}
648 %files -n python-subversion
649 %defattr(644,root,root,755)
650 %doc tools/backup/*.py tools/examples/*.py
651 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
652 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
653 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
654 %dir %{py_sitedir}/libsvn
655 %{py_sitedir}/libsvn/*.py[co]
656 %dir %{py_sitedir}/svn
657 %{py_sitedir}/svn/*.py[co]
658 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
659 %{_examplesdir}/python-%{name}-%{version}
660 %endif
661
662 %if %{with perl}
663 %files -n perl-subversion
664 %defattr(644,root,root,755)
665 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
666 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
667 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
668 %{perl_vendorarch}/SVN
669 %dir %{perl_vendorarch}/auto/SVN
670 %dir %{perl_vendorarch}/auto/SVN/*
671 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
672 %{perl_vendorarch}/auto/SVN/*/*.bs
673 %{_mandir}/man3/*.3pm*
674 %endif
675
676 %if %{with ruby}
677 %files -n ruby-subversion
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
680 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
681 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
682 %dir %{_libdir}/ruby/site_ruby/svn
683 %{_libdir}/ruby/site_ruby/svn/*.rb
684 %dir %{_libdir}/ruby/site_ruby/svn/ext
685 %attr(755,root,root) %{_libdir}/ruby/site_ruby/svn/ext/*.so
686 %{_datadir}/ri/*.*/system/OptionParser
687 %{_datadir}/ri/*.*/system/Svn
688 %{_datadir}/ri/*.*/system/Time
689 %{_datadir}/ri/*.*/system/Uconv
690 %{_datadir}/ri/*.*/system/*.rid
691 %{_datadir}/ri/*.*/system/Kernel/*
692 %endif
693
694 %if %{with apache}
695 %files -n apache-mod_dav_svn
696 %defattr(644,root,root,755)
697 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
698 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
699
700 %files -n apache-mod_authz_svn
701 %defattr(644,root,root,755)
702 %doc subversion/mod_authz_svn/INSTALL
703 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
704 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
705 %endif
706
707 %endif # net_client_only
This page took 0.06622 seconds and 2 git commands to generate.