]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- some *.so are needed in main packages (todo: move them somewhere)
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - move modules to some directory (+ link with rpath)
3 Summary:        A Concurrent Versioning system similar to but better than CVS.
4 Summary(pl):    System Concurrent Versioning System ale lepszy ni¿ CVS
5 Name:           subversion
6 Version:        1587
7 Release:        1
8 License:        Apache/BSD Style
9 Group:          Development/Version Control
10 Source0:        http://subversion.tigris.org/%{name}-r%{version}.tar.gz
11 Source1:        %{name}-dav_svn.conf
12 Patch0:         %{name}-lib.patch
13 Patch1:         %{name}-apache2.patch
14 URL:            http://subversion.tigris.org/
15 BuildRequires:  apache-devel >= 2.0.35
16 BuildRequires:  autoconf >= 2.53
17 BuildRequires:  bison
18 BuildRequires:  db4-devel >= 4.0.14
19 BuildRequires:  expat-devel
20 BuildRequires:  libtool >= 1.4
21 BuildRequires:  neon-devel >= 0.19.2
22 BuildRequires:  python >= 2.0
23 BuildRequires:  texinfo
24 Requires(post): /usr/sbin/fix-info-dir
25 Requires(post): /sbin/ldconfig
26 Requires(postun): /sbin/ldconfig 
27 Requires(postun): /usr/sbin/fix-info-dir 
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _libexecdir     /usr/lib/apache
31
32 %description
33 The goal of the Subversion project is to build a version control
34 system that is a compelling replacement for CVS in the open source
35 community.
36
37 Our goals are:
38 - All current CVS features.
39 - Directories, renames, and file meta-data are versioned.
40 - Symbolic links, etc, are supported
41 - Commits are truly atomic.
42 - Branching and tagging are cheap (constant time) operations
43 - Repeated merges are handled gracefully
44 - Support for plug-in client side diff programs
45 - Natively client/server
46 - Client/server protocol sends diffs in both directions
47 - Costs are proportional to change size, not project size
48 - Internationalization
49 - Progressive multi-lingual support
50
51 %description -l pl
52 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
53 zamiennika dla CVS.
54
55 Cele projektu to:
56 - Wszystkie aktualne mo¿liwo¶ci CVS.
57 - Katalogi, zmiany nazw oraz meta-dane plików s± wersjonowane.
58 - Wsparcie dla linków symbolicznych itp.
59 - Commity s± w pe³ni atomowe.
60 - Branchowanie oraz tagowanie s± tanimi (sta³ymi w czasie) operacjami.
61 - Powtarzaj±ce merge.
62 - Wsparcie dla pluginów diff'a po stronie klienta.
63 - Natywny klient/serwer.
64 - Klient/Serwer przesy³aj± diffy w obu kierunkach.
65 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
66 - Internacjonalizacja.
67 - Postêpuj±ce wsparcie dla wielu jêzyków.
68
69 %package devel
70 Summary:        Header files and develpment documentation for subversion
71 Summary(pl):    Pliki nag³ówkowe i dokumetacja do subversion
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}
74
75 %description devel
76 Header files and develpment documentation for subversion.
77
78 %description devel -l pl
79 Pliki nag³ówkowe i dokumetacja do subversion.
80
81 %package static
82 Summary:        Static subversion library
83 Summary(pl):    Biblioteka statyczna subversion
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}
86
87 %description static
88 Static subversion library.
89
90 %description static -l pl
91 Biblioteka statyczna subversion.
92
93 %package -n apache-mod_dav_svn
94 Summary:        Apache module: Subversion Server
95 Summary(pl):    Modu³ apache: Serwer Subversion
96 Group:          Networking/Daemons
97 Requires:       apache(EAPI) >= 2.0.35
98 Requires:       apache-mod_dav >= 2.0.35
99 Requires(post): %{_sbindir}/apxs
100 Requires(preun):%{_sbindir}/apxs
101
102 %description -n apache-mod_dav_svn
103 Apache module: Subversion Server.
104
105 %description -n apache-mod_dav_svn
106 Modu³ apache: Serwer Subversion.
107
108 %prep
109 %setup -q -n %{name}-r%{version}
110 %patch0 -p1
111 %patch1 -p1
112
113 %build
114 ./autogen.sh
115 # EXPAT is external so get rid of all except (patched) xmlparse.h
116 rm -rf expat-lite/[a-w]*.[ch] expat-lite/xmldef.h expat-lite/xmlparse.c
117 rm -rf expat-lite/xmlrole* expat-lite/xmltok* neon apr
118 %configure \
119         --enable-dso \
120         --with-neon \
121         --with-apr=%{_sbindir}/apr-config \
122         --with-apxs=%{_sbindir}/apxs \
123         --with-berkeley-db=%{_includedir}/db4:%{_libdir}
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd,%{_libexecdir}}
129
130 # relinking sux
131 for i in 1 2; do
132 [ "$i" = "2" ] && find . -name "*.la" -exec rm -f "{}" ";"
133 %{__make} install \
134         INSTALL_MOD_SHARED=echo \
135         DESTDIR=$RPM_BUILD_ROOT \
136         libdir=$RPM_BUILD_ROOT%{_libdir} \
137         fs_libdir=$RPM_BUILD_ROOT%{_libdir} \
138         base_libdir=$RPM_BUILD_ROOT%{_libdir} \
139         bindir=$RPM_BUILD_ROOT%{_bindir} \
140         fs_bindir=$RPM_BUILD_ROOT%{_bindir} \
141         includedir=$RPM_BUILD_ROOT%{_includedir}/%{name}
142 done
143
144 install subversion/mod_dav_svn/.libs/*.so $RPM_BUILD_ROOT%{_libexecdir}
145 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/mod_dav_svn.conf
146
147 gzip -9nf BUGS CHANGES IDEAS INSTALL README
148
149 %post
150 /sbin/ldconfig
151 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
152
153 %postun
154 /sbin/ldconfig
155 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
156
157 %post -n apache-mod_dav_svn
158 %{_sbindir}/apxs -e -a -n dav_svn %{_libexecdir}/libmod_dav_svn.so 1>&2
159 if [ -f /etc/httpd/httpd.conf ] && ! grep -q "^Include.*mod_dav_svn.conf" /etc/httpd/httpd.conf; then
160         echo "Include /etc/httpd/mod_dav_svn.conf" >> /etc/httpd/httpd.conf
161 fi
162 if [ -f /var/lock/subsys/httpd ]; then
163         /etc/rc.d/init.d/httpd restart 1>&2
164 else
165         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
166 fi
167
168 %preun -n apache-mod_dav_svn
169 if [ "$1" = "0" ]; then
170         %{_sbindir}/apxs -e -A -n dav_svn %{_libexecdir}/libmod_dav_svn.so 1>&2
171         grep -v "^Include.*mod_dav_svn.conf" /etc/httpd/httpd.conf > \
172                 /etc/httpd/httpd.conf.tmp
173         mv -f /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
174         if [ -f /var/lock/subsys/httpd ]; then
175                 /etc/rc.d/init.d/httpd restart 1>&2
176         fi
177 fi
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %files
183 %defattr(644,root,root,755)
184 %doc *.gz
185 %attr(755,root,root) %{_bindir}/*
186 %attr(755,root,root) %{_libdir}/libsvn_[cdsw]*.so.*
187 %attr(755,root,root) %{_libdir}/libsvn_ra.so.*
188 %attr(755,root,root) %{_libdir}/libsvn_fs*.so*
189 %attr(755,root,root) %{_libdir}/libsvn_ra_*.so*
190 %attr(755,root,root) %{_libdir}/libsvn_repos.so*
191 %{_mandir}/man1/*
192 %{_infodir}/svn*
193
194 %files devel
195 %defattr(644,root,root,755)
196 %{_includedir}/%{name}
197 %attr(755,root,root) %{_libdir}/libsvn_[cdsw]*.so
198 %attr(755,root,root) %{_libdir}/libsvn_ra.so
199 %attr(755,root,root) %{_libdir}/lib*.la
200
201 %files static
202 %defattr(644,root,root,755)
203 %{_libdir}/lib*.a
204
205 %files -n apache-mod_dav_svn
206 %defattr(644,root,root,755)
207 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/httpd/mod_dav_svn.conf
208 %attr(755,root,root) %{_libexecdir}/*.so
This page took 0.039254 seconds and 3 git commands to generate.