]> git.pld-linux.org Git - packages/stunnel.git/blob - stunnel.spec
- updated to 4.56 (fixes CVE-2013-1762)
[packages/stunnel.git] / stunnel.spec
1 Summary:        Universal SSL tunnel
2 Summary(pl.UTF-8):      Uniwersalne narzędzie do bezpiecznego tunelowania
3 Name:           stunnel
4 Version:        4.56
5 Release:        1
6 License:        GPL v2+ with OpenSSL exception
7 Group:          Networking/Daemons
8 Source0:        ftp://ftp.stunnel.org/stunnel/%{name}-%{version}.tar.gz
9 # Source0-md5:  ac4c4a30bd7a55b6687cbd62d864054c
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Source3:        %{name}.inet
13 Source4:        %{name}.tmpfiles
14 Patch0:         %{name}-authpriv.patch
15 Patch1:         %{name}-ac_fixes.patch
16 Patch2:         %{name}-am.patch
17 Patch3:         %{name}-libwrap_srv_name_log.patch
18 Patch4:         %{name}-config.patch
19 URL:            http://www.stunnel.org/
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  libtool >= 2:2.0
23 BuildRequires:  libwrap-devel
24 BuildRequires:  openssl-devel >= 0.9.7d
25 BuildRequires:  openssl-tools >= 0.9.7d
26 BuildRequires:  rpmbuild(macros) >= 1.268
27 Requires(postun):       /sbin/ldconfig
28 Requires(postun):       /usr/sbin/groupdel
29 Requires(postun):       /usr/sbin/userdel
30 Requires(pre):  /bin/id
31 Requires(pre):  /usr/bin/getgid
32 Requires(pre):  /usr/sbin/groupadd
33 Requires(pre):  /usr/sbin/useradd
34 Provides:       group(stunnel)
35 Provides:       user(stunnel)
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 The stunnel program is designed to work as SSL encryption wrapper
40 between remote client and local (inetd-startable) or remote server.
41 The concept is that having non-SSL aware daemons running on your
42 system you can easily setup them to communicate with clients over
43 secure SSL channel. stunnel can be used to add SSL functionality to
44 commonly used inetd daemons like POP-2, POP-3 and IMAP servers without
45 any changes in the programs' code.
46
47 %description -l pl.UTF-8
48 Stunnel umożliwia stawianie silnie kodowanych tuneli pomiędzy serwerem
49 a komputerem klienta. Przy jego użyciu można łatwo zrealizować usługi
50 pop3s lub HTTPS.
51
52 %package standalone
53 Summary:        stunnel acts as standalone server
54 Summary(pl.UTF-8):      stunnel działający jako samodzielny serwer
55 Group:          Networking/Daemons
56 Requires(post,preun):   /sbin/chkconfig
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       rc-scripts
59 Obsoletes:      stunnel-inetd
60
61 %description standalone
62 stunnel acts as standalone server.
63
64 %description standalone -l pl.UTF-8
65 stunnel działający jako samodzielny serwer.
66
67 %package inetd
68 Summary:        stunnel acts as inetd service
69 Summary(pl.UTF-8):      stunnel działający jako usługa inetd
70 Group:          Networking/Daemons
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       rc-inetd
73 Obsoletes:      stunnel-standalone
74
75 %description inetd
76 stunnel acts as inetd service.
77
78 %description inetd -l pl.UTF-8
79 stunnel działający jako usługa inetd.
80
81 %prep
82 %setup -q
83 %patch0 -p1
84 %patch1 -p1
85 %patch2 -p1
86 %patch3 -p1
87 %patch4 -p1
88
89 %build
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoconf}
93 %{__automake}
94 %configure
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig/rc-inetd},%{_mandir}/{pl,fr}/man8,%{_var}/run/stunnel} \
100         $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 mv -f $RPM_BUILD_ROOT%{_mandir}/man8/stunnel.fr.8 $RPM_BUILD_ROOT%{_mandir}/fr/man8/stunnel.8
106 mv -f $RPM_BUILD_ROOT%{_mandir}/man8/stunnel.pl.8 $RPM_BUILD_ROOT%{_mandir}/pl/man8/stunnel.8
107 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.conf-sample $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.conf
108
109 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/stunnel
110 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/stunnel
111 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/stunnel
112 install %{SOURCE4} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
113
114 rm -rf $RPM_BUILD_ROOT%{_libdir}/stunnel
115 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.pem
116 rm -rf $RPM_BUILD_ROOT%{_docdir}/stunnel
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %pre
122 %groupadd -g 130 stunnel
123 %useradd -u 130 -d /var/run/stunnel -s /bin/false -c "stunnel User" -g stunnel stunnel
124
125 %post   -p /sbin/ldconfig
126
127 %postun
128 /sbin/ldconfig
129 if [ "$1" = "0" ]; then
130         %userremove stunnel
131         %groupremove stunnel
132 fi
133
134 %post standalone
135 /sbin/chkconfig --add stunnel
136 %service stunnel restart "stunnel daemon"
137
138 %preun standalone
139 if [ "$1" = "0" ]; then
140         %service stunnel stop
141         /sbin/chkconfig --del stunnel
142 fi
143
144 %post inetd
145 %service -q rc-inetd reload
146
147 %postun inetd
148 if [ "$1" = "0" ]; then
149         %service -q rc-inetd reload
150 fi
151
152 %files
153 %defattr(644,root,root,755)
154 # note: this COPYING contains general information not GPL text
155 %doc AUTHORS BUGS COPYING CREDITS ChangeLog NEWS PORTS README TODO doc/en/* doc/stunnel.html tools/{ca.*,importCA.*}
156 %doc %lang(fr) doc/stunnel.fr.html
157 %doc %lang(pl) doc/pl/* doc/stunnel.pl.html
158 %attr(755,root,root) %{_bindir}/stunnel
159 %attr(755,root,root) %{_bindir}/stunnel3
160 %dir %{_sysconfdir}/stunnel
161 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/stunnel/stunnel.conf
162 %attr(750,stunnel,stunnel) %{_var}/run/stunnel
163 /usr/lib/tmpfiles.d/%{name}.conf
164 %{_mandir}/man8/stunnel.8*
165 %lang(fr) %{_mandir}/fr/man8/stunnel.8*
166 %lang(pl) %{_mandir}/pl/man8/stunnel.8*
167
168 %files standalone
169 %defattr(644,root,root,755)
170 %attr(754,root,root) /etc/rc.d/init.d/stunnel
171 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/stunnel
172
173 %files inetd
174 %defattr(644,root,root,755)
175 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/stunnel
This page took 0.079228 seconds and 4 git commands to generate.