]> git.pld-linux.org Git - packages/stunnel.git/blob - stunnel.spec
5cf6392f23db0800e2e420962a76cc488b20616a
[packages/stunnel.git] / stunnel.spec
1 Summary:        Universal SSL tunnel
2 Summary(pl):    Uniwersalne narzêdzie do bezpiecznego tunelowania
3 Name:           stunnel
4 Version:        4.05
5 Release:        4
6 License:        GPL v2
7 Group:          Networking/Daemons
8 Source0:        ftp://stunnel.mirt.net/stunnel/%{name}-%{version}.tar.gz
9 # Source0-md5:  e28a03cf694a43a7f144ec3d5c064456
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Source3:        %{name}.inet
13 Patch0:         %{name}-gethostbyname_is_in_libc_aka_no_libnsl.patch
14 Patch1:         %{name}-authpriv.patch
15 Patch2:         %{name}-ac_fixes.patch
16 Patch3:         %{name}-am.patch
17 Patch4:         %{name}-getgrnam.patch
18 Patch5:         %{name}-libwrap_srv_name_log.patch
19 Patch6:         %{name}-config.patch
20 URL:            http://www.stunnel.org/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  libtool
24 BuildRequires:  openssl-devel >= 0.9.7d
25 BuildRequires:  openssl-tools >= 0.9.7d
26 BuildRequires:  libwrap-devel
27 PreReq:         rc-scripts
28 Requires(pre):  /bin/id
29 Requires(pre):  /usr/bin/getgid
30 Requires(pre):  /usr/sbin/groupadd
31 Requires(pre):  /usr/sbin/useradd
32 Requires(postun):       /usr/sbin/userdel
33 Requires(postun):       /usr/sbin/groupdel
34 Requires(post,preun):   /sbin/chkconfig
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 The stunnel program is designed to work as SSL encryption wrapper
39 between remote client and local (inetd-startable) or remote server.
40 The concept is that having non-SSL aware daemons running on your
41 system you can easily setup them to communicate with clients over
42 secure SSL channel. stunnel can be used to add SSL functionality to
43 commonly used inetd daemons like POP-2, POP-3 and IMAP servers without
44 any changes in the programs' code.
45
46 %description -l pl
47 Stunnel umo¿liwia stawianie silnie kodowanych tuneli pomiêdzy serwerem
48 a komputerem klienta. Przy jego u¿yciu mo¿na ³atwo zrealizowaæ us³ugi
49 pop3s lub https.
50
51 %package standalone
52 Summary:        stunnel acts as standalone server 
53 Summary(pl):    stunnel dzia³aj±cy jako samodzielny serwer
54 Group:          Networking/Daemons
55 Requires:       %{name} = %{epoch}:%{version}-%{release}
56 Obsoletes:      %{name}-inetd
57
58 %description standalone
59 stunnel acts as standalone server.
60
61 %description standalone -l pl
62 stunnel dzia³aj±cy jako samodzielny serwer.
63
64 %package inetd 
65 Summary:        stunnel acts as inetd service
66 Summary(pl):    stunnel dzia³aj±cy jako us³uga inetd
67 Group:          Networking/Daemons
68 Requires:       %{name} = %{epoch}:%{version}-%{release}
69 Obsoletes:      %{name}-standalone
70
71 %description inetd
72 stunnel acts as inetd service.
73
74 %description standalone -l pl
75 stunnel dzia³aj±cy jako us³uga inetd.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80 %patch1 -p1
81 %patch2 -p1
82 %patch3 -p1
83 %patch4 -p1
84 %patch5 -p1
85 %patch6 -p1
86
87 %build
88 %{__aclocal}
89 %{__autoconf}
90 %{__automake}
91 %configure
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig/rc-inetd},%{_mandir}/{pl,fr}/man8,%{_var}/run/stunnel}
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 mv -f $RPM_BUILD_ROOT%{_mandir}/man8/stunnel.fr.8 $RPM_BUILD_ROOT%{_mandir}/fr/man8/stunnel.8
102 mv -f $RPM_BUILD_ROOT%{_mandir}/man8/stunnel.pl.8 $RPM_BUILD_ROOT%{_mandir}/pl/man8/stunnel.8
103 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.conf-sample $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.conf
104
105 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/stunnel
106 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/stunnel
107 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/stunnel
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %pre
113 if [ -n "`getgid stunnel`" ]; then
114         if [ "`getgid stunnel`" != "130" ]; then
115                 echo "Error: group stunnel doesn't have gid=130. Correct this before installing stunnel." 1>&2
116                 exit 1
117         fi
118 else
119         /usr/sbin/groupadd -g 130 -r -f stunnel
120 fi
121 if [ -n "`id -u stunnel 2>/dev/null`" ]; then
122         if [ "`id -u stunnel`" != "130" ]; then
123                 echo "Error: user stunnel doesn't have uid=130. Correct this before installing stunnel." 1>&2
124                 exit 1
125         fi
126 else
127         /usr/sbin/useradd -u 130 -r -d /var/run/stunnel -s /bin/false -c "stunnel User" -g stunnel stunnel 1>&2
128 fi
129
130 %postun 
131 if [ "$1" = "0" ]; then
132         /usr/sbin/userdel stunnel
133         /usr/sbin/groupdel stunnel
134 fi
135
136 %post standalone
137 /sbin/chkconfig --add stunnel
138 if [ -f /var/lock/subsys/stunnel ]; then
139         /etc/rc.d/init.d/stunnel restart 1>&2
140 else
141         echo "Run \"/etc/rc.d/init.d/stunnel start\" to start stunnel daemon."
142 fi
143
144 %preun standalone
145 if [ "$1" = "0" ]; then
146         if [ -f /var/lock/subsys/stunnel ]; then
147                 /etc/rc.d/init.d/stunnel stop 1>&2
148         fi
149         /sbin/chkconfig --del stunnel
150 fi
151
152 %post inetd
153 if [ -f /var/lock/subsys/rc-inetd ]; then
154         /etc/rc.d/init.d/rc-inetd restart 1>&2
155 else
156         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
157 fi
158
159 %postun inetd
160 if [ "$1" = "0" -a -f /var/lock/subsys/rc-inetd ]; then
161         /etc/rc.d/init.d/rc-inetd reload 1>&2
162 fi
163
164 %files
165 %defattr(644,root,root,755)
166 # note: this COPYING contains general information not GPL text
167 %doc AUTHORS BUGS COPYING CREDITS ChangeLog NEWS PORTS README TODO doc/en/* doc/stunnel.html
168 %doc src/stunnel.exe  tools/{ca.*,importCA.*}
169 %doc %lang(fr) doc/stunnel.fr.html
170 %doc %lang(pl) doc/pl/* doc/stunnel.pl.html
171 %attr(750,stunnel,stunnel) %{_var}/run/stunnel
172 %dir %{_sysconfdir}/stunnel
173 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/stunnel/stunnel.conf
174 %attr(600,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/stunnel/stunnel.pem
175 %attr(755,root,root) %{_sbindir}/*
176 %{_mandir}/man8/*
177 %lang(fr) %{_mandir}/fr/man8/*
178 %lang(pl) %{_mandir}/pl/man8/*
179
180 %files standalone
181 %defattr(644,root,root,755)
182 %attr(754,root,root) /etc/rc.d/init.d/stunnel
183 %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/stunnel
184
185 %files inetd
186 %defattr(644,root,root,755)
187 %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/rc-inetd/stunnel
This page took 0.055834 seconds and 3 git commands to generate.