]> git.pld-linux.org Git - packages/sqlite3.git/blob - sqlite3.spec
- release 3 to rebuild w/o sqlite Provides
[packages/sqlite3.git] / sqlite3.spec
1 #
2 # Conditional build:
3 %bcond_without  tests # don't run tests
4 #
5 Summary:        SQLite library
6 Summary(pl):    Biblioteka SQLite
7 Name:           sqlite3
8 Version:        3.0.8
9 Release:        3
10 License:        LGPL
11 Group:          Libraries
12 # Source0Download: http://sqlite.org/download.html
13 Source0:        http://sqlite.org/sqlite-%{version}.tar.gz
14 # Source0-md5:  b7dff1ec9bf4d08928c039b278630ba7
15 URL:            http://sqlite.org/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  libtool
19 BuildRequires:  readline-devel
20 BuildRequires:  tcl-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 SQLite is a C library that implements an SQL database engine. A large
25 subset of SQL92 is supported. A complete database is stored in a
26 single disk file. The API is designed for convenience and ease of use.
27 Applications that link against SQLite can enjoy the power and
28 flexiblity of an SQL database without the administrative hassles of
29 supporting a separate database server. Because it omits the
30 client-server interaction overhead and writes directly to disk, SQLite
31 is also faster than the big database servers for most operations. In
32 addition to the C library, the SQLite distribution includes a
33 command-line tool for interacting with SQLite databases and SQLite
34 bindings for Tcl/Tk.
35
36 %description -l pl
37 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
38 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
39 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
40 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
41 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
42 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
43 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
44 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
45 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
46 bazami danych.
47
48 %package devel
49 Summary:        Header files for SQLite development
50 Summary(pl):    Pliki nag³ówkowe SQLite
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53
54 %description devel
55 SQLite is a C library that implements an SQL database engine. A large
56 subset of SQL92 is supported. A complete database is stored in a
57 single disk file. The API is designed for convenience and ease of use.
58 Applications that link against SQLite can enjoy the power and
59 flexiblity of an SQL database without the administrative hassles of
60 supporting a separate database server. Because it omits the
61 client-server interaction overhead and writes directly to disk, SQLite
62 is also faster than the big database servers for most operations. In
63 addition to the C library, the SQLite distribution includes a
64 command-line tool for interacting with SQLite databases and SQLite
65 bindings for Tcl/Tk.
66
67 This package contains the header files needed to develop programs that
68 use these SQLite.
69
70 %description devel -l pl
71 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
72 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
73 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
74 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
75 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
76 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
77 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
78 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
79 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
80 bazami danych.
81
82 Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
83 u¿ywaj±cych biblioteki SQLite.
84
85 %package static
86 Summary:        Static libraries for SQLite development
87 Summary(pl):    Statyczne biblioteki SQLite
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 SQLite is a C library that implements an SQL database engine. A large
93 subset of SQL92 is supported. A complete database is stored in a
94 single disk file. The API is designed for convenience and ease of use.
95 Applications that link against SQLite can enjoy the power and
96 flexiblity of an SQL database without the administrative hassles of
97 supporting a separate database server. Because it omits the
98 client-server interaction overhead and writes directly to disk, SQLite
99 is also faster than the big database servers for most operations. In
100 addition to the C library, the SQLite distribution includes a
101 command-line tool for interacting with SQLite databases and SQLite
102 bindings for Tcl/Tk.
103
104 This package contains the static SQLite libraries.
105
106 %description static -l pl
107 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
108 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
109 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
110 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
111 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
112 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
113 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
114 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
115 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
116 bazami danych.
117
118 Pakiet zawiera statyczne biblioteki SQLite.
119
120 %prep
121 %setup -q -n sqlite
122 sed -i 's/mkdir doc/#mkdir doc/' Makefile*
123
124 %build
125 %{__libtoolize}
126 cp -f /usr/share/automake/config.sub .
127 %{__aclocal}
128 %{__autoconf}
129 %configure \
130         --enable-threadsafe
131 %{__make}
132 %{__make} doc
133
134 %{?with_tests:%{__make} test}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 install sqlite.1 $RPM_BUILD_ROOT%{_mandir}/man1
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post   -p /sbin/ldconfig
149 %postun -p /sbin/ldconfig
150
151 %files
152 %defattr(644,root,root,755)
153 %doc README
154 %attr(755,root,root) %{_bindir}/sqlite3
155 %attr(755,root,root) %{_libdir}/lib*.so.*.*
156 %{_mandir}/man1/sqlite.1*
157
158 %files devel
159 %defattr(644,root,root,755)
160 %doc doc/*
161 %attr(755,root,root) %{_libdir}/lib*.so
162 %{_libdir}/lib*.la
163 %{_includedir}/sqlite3.h
164 %{_pkgconfigdir}/*.pc
165
166 %files static
167 %defattr(644,root,root,755)
168 %{_libdir}/lib*.a
This page took 0.068312 seconds and 4 git commands to generate.