]> git.pld-linux.org Git - packages/sqlite3.git/blob - sqlite3.spec
- readline 5.0; disable tests on amd64
[packages/sqlite3.git] / sqlite3.spec
1 # TODO:
2 # - fix lib64 in tcl module
3 #
4 # Conditional build:
5 %bcond_without  tests # don't run tests
6 #
7 Summary:        SQLite library
8 Summary(pl):    Biblioteka SQLite
9 Name:           sqlite3
10 Version:        3.2.5
11 Release:        2
12 License:        LGPL
13 Group:          Libraries
14 # Source0Download: http://sqlite.org/download.html
15 Source0:        http://sqlite.org/sqlite-%{version}.tar.gz
16 # Source0-md5:  0f07cfd8591c3fcae159f0c69bf2436f
17 URL:            http://sqlite.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  libtool
21 BuildRequires:  readline-devel
22 BuildRequires:  tcl-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %ifarch alpha %{x8664}
26 %undefine       with_tests
27 %endif
28
29 %define         _ulibdir        /usr/lib
30
31 %description
32 SQLite is a C library that implements an SQL database engine. A large
33 subset of SQL92 is supported. A complete database is stored in a
34 single disk file. The API is designed for convenience and ease of use.
35 Applications that link against SQLite can enjoy the power and
36 flexiblity of an SQL database without the administrative hassles of
37 supporting a separate database server. Because it omits the
38 client-server interaction overhead and writes directly to disk, SQLite
39 is also faster than the big database servers for most operations. In
40 addition to the C library, the SQLite distribution includes a
41 command-line tool for interacting with SQLite databases and SQLite
42 bindings for Tcl/Tk.
43
44 %description -l pl
45 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
46 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
47 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
48 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
49 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
50 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
51 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
52 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
53 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
54 bazami danych.
55
56 %package devel
57 Summary:        Header files for SQLite development
58 Summary(pl):    Pliki nag³ówkowe SQLite
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61
62 %description devel
63 SQLite is a C library that implements an SQL database engine. A large
64 subset of SQL92 is supported. A complete database is stored in a
65 single disk file. The API is designed for convenience and ease of use.
66 Applications that link against SQLite can enjoy the power and
67 flexiblity of an SQL database without the administrative hassles of
68 supporting a separate database server. Because it omits the
69 client-server interaction overhead and writes directly to disk, SQLite
70 is also faster than the big database servers for most operations. In
71 addition to the C library, the SQLite distribution includes a
72 command-line tool for interacting with SQLite databases and SQLite
73 bindings for Tcl/Tk.
74
75 This package contains the header files needed to develop programs that
76 use these SQLite.
77
78 %description devel -l pl
79 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
80 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
81 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
82 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
83 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
84 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
85 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
86 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
87 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
88 bazami danych.
89
90 Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
91 u¿ywaj±cych biblioteki SQLite.
92
93 %package static
94 Summary:        Static libraries for SQLite development
95 Summary(pl):    Statyczne biblioteki SQLite
96 Group:          Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98
99 %description static
100 SQLite is a C library that implements an SQL database engine. A large
101 subset of SQL92 is supported. A complete database is stored in a
102 single disk file. The API is designed for convenience and ease of use.
103 Applications that link against SQLite can enjoy the power and
104 flexiblity of an SQL database without the administrative hassles of
105 supporting a separate database server. Because it omits the
106 client-server interaction overhead and writes directly to disk, SQLite
107 is also faster than the big database servers for most operations. In
108 addition to the C library, the SQLite distribution includes a
109 command-line tool for interacting with SQLite databases and SQLite
110 bindings for Tcl/Tk.
111
112 This package contains the static SQLite libraries.
113
114 %description static -l pl
115 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
116 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
117 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
118 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
119 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
120 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
121 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
122 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
123 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
124 bazami danych.
125
126 Pakiet zawiera statyczne biblioteki SQLite.
127
128 %package -n tcl-%{name}
129 Summary:        sqlite3 tcl extension
130 Summary(pl):    Rozszerzenie sqlite3 dla Tcl
131 Group:          Development/Languages/Tcl
132
133 %description -n tcl-%{name}
134 sqlite3 tcl extension.
135
136 %description -l pl -n tcl-%{name}
137 Rozszerzenie sqlite3 dla Tcl.
138
139 %prep
140 %setup -q -n sqlite-%{version}
141 sed -i 's/mkdir doc/#mkdir doc/' Makefile*
142
143 %build
144 %{__libtoolize}
145 cp -f /usr/share/automake/config.sub .
146 %{__aclocal}
147 %{__autoconf}
148 %configure \
149         --with-tcl=%{_ulibdir} \
150         --enable-threadsafe
151 %{__make}
152 %{__make} doc
153
154 %{?with_tests:LC_ALL=C %{__make} test}
155
156 %install
157 rm -rf $RPM_BUILD_ROOT
158 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
159
160 %{__make} install \
161         DESTDIR=$RPM_BUILD_ROOT
162
163 install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %post   -p /sbin/ldconfig
169 %postun -p /sbin/ldconfig
170
171 %files
172 %defattr(644,root,root,755)
173 %doc README
174 %attr(755,root,root) %{_bindir}/sqlite3
175 %attr(755,root,root) %{_libdir}/lib*.so.*.*
176 %{_mandir}/man1/sqlite3.1*
177
178 %files devel
179 %defattr(644,root,root,755)
180 %doc doc/*
181 %attr(755,root,root) %{_libdir}/lib*.so
182 %{_libdir}/lib*.la
183 %{_includedir}/sqlite3.h
184 %{_pkgconfigdir}/*.pc
185
186 %files static
187 %defattr(644,root,root,755)
188 %{_libdir}/lib*.a
189
190 %files -n tcl-%{name}
191 %defattr(644,root,root,755)
192 %dir %{_ulibdir}/tcl*/sqlite3
193 %attr(755,root,root) %{_ulibdir}/tcl*/sqlite3/*.so
194 %{_ulibdir}/tcl*/sqlite3/*.tcl
This page took 0.043242 seconds and 4 git commands to generate.