]> git.pld-linux.org Git - packages/sqlite3.git/blob - sqlite3.spec
- rel 2 STBR for Ac
[packages/sqlite3.git] / sqlite3.spec
1 #
2 # Conditional build:
3 %bcond_without  tests # don't run tests
4 #
5 Summary:        SQLite library
6 Summary(pl):    Biblioteka SQLite
7 Name:           sqlite3
8 Version:        3.0.8
9 Release:        2
10 License:        LGPL
11 Group:          Libraries
12 # Source0Download: http://sqlite.org/download.html
13 Source0:        http://sqlite.org/sqlite-%{version}.tar.gz
14 # Source0-md5:  b7dff1ec9bf4d08928c039b278630ba7
15 URL:            http://sqlite.org/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  libtool
19 BuildRequires:  readline-devel
20 BuildRequires:  tcl-devel
21 Provides:       sqlite = %{version}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 SQLite is a C library that implements an SQL database engine. A large
26 subset of SQL92 is supported. A complete database is stored in a
27 single disk file. The API is designed for convenience and ease of use.
28 Applications that link against SQLite can enjoy the power and
29 flexiblity of an SQL database without the administrative hassles of
30 supporting a separate database server. Because it omits the
31 client-server interaction overhead and writes directly to disk, SQLite
32 is also faster than the big database servers for most operations. In
33 addition to the C library, the SQLite distribution includes a
34 command-line tool for interacting with SQLite databases and SQLite
35 bindings for Tcl/Tk.
36
37 %description -l pl
38 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
39 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
40 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
41 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
42 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
43 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
44 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
45 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
46 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
47 bazami danych.
48
49 %package devel
50 Summary:        Header files for SQLite development
51 Summary(pl):    Pliki nag³ówkowe SQLite
52 Group:          Development/Libraries
53 Provides:       sqlite-devel = %{version}
54 Requires:       %{name} = %{version}-%{release}
55
56 %description devel
57 SQLite is a C library that implements an SQL database engine. A large
58 subset of SQL92 is supported. A complete database is stored in a
59 single disk file. The API is designed for convenience and ease of use.
60 Applications that link against SQLite can enjoy the power and
61 flexiblity of an SQL database without the administrative hassles of
62 supporting a separate database server. Because it omits the
63 client-server interaction overhead and writes directly to disk, SQLite
64 is also faster than the big database servers for most operations. In
65 addition to the C library, the SQLite distribution includes a
66 command-line tool for interacting with SQLite databases and SQLite
67 bindings for Tcl/Tk.
68
69 This package contains the header files needed to develop programs that
70 use these SQLite.
71
72 %description devel -l pl
73 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
74 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
75 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
76 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
77 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
78 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
79 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
80 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
81 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
82 bazami danych.
83
84 Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
85 u¿ywaj±cych biblioteki SQLite.
86
87 %package static
88 Summary:        Static libraries for SQLite development
89 Summary(pl):    Statyczne biblioteki SQLite
90 Group:          Development/Libraries
91 Provides:       sqlite-static = %{version}
92 Requires:       %{name}-devel = %{version}-%{release}
93
94 %description static
95 SQLite is a C library that implements an SQL database engine. A large
96 subset of SQL92 is supported. A complete database is stored in a
97 single disk file. The API is designed for convenience and ease of use.
98 Applications that link against SQLite can enjoy the power and
99 flexiblity of an SQL database without the administrative hassles of
100 supporting a separate database server. Because it omits the
101 client-server interaction overhead and writes directly to disk, SQLite
102 is also faster than the big database servers for most operations. In
103 addition to the C library, the SQLite distribution includes a
104 command-line tool for interacting with SQLite databases and SQLite
105 bindings for Tcl/Tk.
106
107 This package contains the static SQLite libraries.
108
109 %description static -l pl
110 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
111 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
112 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
113 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
114 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
115 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
116 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
117 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
118 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
119 bazami danych.
120
121 Pakiet zawiera statyczne biblioteki SQLite.
122
123 %prep
124 %setup -q -n sqlite
125 sed -i 's/mkdir doc/#mkdir doc/' Makefile*
126
127 %build
128 %{__libtoolize}
129 cp -f /usr/share/automake/config.sub .
130 %{__aclocal}
131 %{__autoconf}
132 %configure \
133         --enable-threadsafe
134 %{__make}
135 %{__make} doc
136
137 %{?with_tests:%{__make} test}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 install sqlite.1 $RPM_BUILD_ROOT%{_mandir}/man1
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post   -p /sbin/ldconfig
152 %postun -p /sbin/ldconfig
153
154 %files
155 %defattr(644,root,root,755)
156 %doc README
157 %attr(755,root,root) %{_bindir}/sqlite3
158 %attr(755,root,root) %{_libdir}/lib*.so.*.*
159 %{_mandir}/man1/sqlite.1*
160
161 %files devel
162 %defattr(644,root,root,755)
163 %doc doc/*
164 %attr(755,root,root) %{_libdir}/lib*.so
165 %{_libdir}/lib*.la
166 %{_includedir}/sqlite3.h
167 %{_pkgconfigdir}/*.pc
168
169 %files static
170 %defattr(644,root,root,755)
171 %{_libdir}/lib*.a
This page took 0.124641 seconds and 4 git commands to generate.