]> git.pld-linux.org Git - packages/sqlite3.git/blob - sqlite3.spec
- enable support for dbstat virtual table (required by firefox / iceweasel)
[packages/sqlite3.git] / sqlite3.spec
1 # TODO:
2 # - some tests fail with tcl8.5, it's tcl fault,
3 #       if someone REALLY cares (s)he can look into it
4 #
5 # Conditional build:
6 %bcond_with     tests           # run tests
7 %bcond_without  tcl             # Tcl extension
8 %bcond_without  doc             # disable documentation building
9 %bcond_without  unlock_notify   # disable unlock notify API
10 %bcond_without  load_extension  # enable load extension API
11 %bcond_with     icu             # ICU tokenizer support
12
13 %ifarch alpha sparc %{x8664}
14 %undefine       with_tests
15 %endif
16
17 # disabling tcl currently breaks making test target,
18 # some hack in Makefile needs to be done
19 %if %{without tcl}
20 %undefine       with_tests
21 %endif
22
23 # sqlite3 version with zero padded without any dots (3 08 10 01 is 3.8.10.1)
24 %define         vnum    3081101
25 %define         ver             %{lua:vn=rpm.expand("%vnum");v="";for i in string.gmatch(string.format("%08d", vn), "..") do; v=v.."."..i:gsub("^0", "");end;v=v:gsub("^.","");print(v)}
26
27 %define         tclver          8.6
28 Summary:        SQLite library
29 Summary(pl.UTF-8):      Biblioteka SQLite
30 Name:           sqlite3
31 Version:        %{ver}
32 Release:        3
33 License:        Public Domain
34 Group:          Libraries
35 # Source0Download: http://www.sqlite.org/download.html
36 Source0:        http://www.sqlite.org/2015/sqlite-src-%{vnum}.zip
37 # Source0-md5:  4550012d85ffdc607d0c86aef2d47974
38 Patch0:         %{name}-sign-function.patch
39 URL:            http://www.sqlite.org/
40 %{?with_load_extension:Provides:        %{name}(load_extension)}
41 %{?with_unlock_notify:Provides: %{name}(unlock_notify)}
42 %{?with_icu:Provides:   %{name}(icu)}
43 BuildRequires:  autoconf >= 2.50
44 BuildRequires:  automake
45 BuildRequires:  libtool
46 BuildRequires:  readline-devel
47 %{?with_load_extension:BuildRequires:   sed >= 4.0}
48 BuildRequires:  tcl
49 %{?with_tcl:BuildRequires:      tcl-devel >= %{tclver}}
50 BuildRequires:  unzip
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         _ulibdir        /usr/lib
54
55 %description
56 SQLite is a C library that implements an SQL database engine. A large
57 subset of SQL92 is supported. A complete database is stored in a
58 single disk file. The API is designed for convenience and ease of use.
59 Applications that link against SQLite can enjoy the power and
60 flexiblity of an SQL database without the administrative hassles of
61 supporting a separate database server. Because it omits the
62 client-server interaction overhead and writes directly to disk, SQLite
63 is also faster than the big database servers for most operations. In
64 addition to the C library, the SQLite distribution includes a
65 command-line tool for interacting with SQLite databases and SQLite
66 bindings for Tcl/Tk.
67
68 %description -l pl.UTF-8
69 SQLite jest biblioteką języka C, która implementuje silnik baz danych
70 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
71 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
72 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
73 danych bez konieczności utrzymywania osobnego serwera baz danych.
74 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
75 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
76 bazodanowych przy większości operacji na bazie danych. Dodatkowo
77 oprócz biblioteki języka C, dostarczany jest program do zarządzania
78 bazami danych.
79
80 %package devel
81 Summary:        Header files for SQLite development
82 Summary(pl.UTF-8):      Pliki nagłówkowe SQLite
83 Group:          Development/Libraries
84 Requires:       %{name} = %{version}-%{release}
85 %if %{with unlock_notify}
86 Provides:       %{name}-devel(unlock_notify)
87 %endif
88 %if %{with load_extension}
89 Provides:       %{name}-devel(load_extension)
90 %endif
91 %if %{with icu}
92 Provides:       %{name}-devel(icu)
93 %endif
94
95 %description devel
96 SQLite is a C library that implements an SQL database engine. A large
97 subset of SQL92 is supported. A complete database is stored in a
98 single disk file. The API is designed for convenience and ease of use.
99 Applications that link against SQLite can enjoy the power and
100 flexiblity of an SQL database without the administrative hassles of
101 supporting a separate database server. Because it omits the
102 client-server interaction overhead and writes directly to disk, SQLite
103 is also faster than the big database servers for most operations. In
104 addition to the C library, the SQLite distribution includes a
105 command-line tool for interacting with SQLite databases and SQLite
106 bindings for Tcl/Tk.
107
108 This package contains the header files needed to develop programs that
109 use these SQLite.
110
111 %description devel -l pl.UTF-8
112 SQLite jest biblioteką języka C, która implementuje silnik baz danych
113 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
114 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
115 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
116 danych bez konieczności utrzymywania osobnego serwera baz danych.
117 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
118 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
119 bazodanowych przy większości operacji na bazie danych. Dodatkowo
120 oprócz biblioteki języka C, dostarczany jest program do zarządzania
121 bazami danych.
122
123 Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
124 używających biblioteki SQLite.
125
126 %package static
127 Summary:        Static libraries for SQLite development
128 Summary(pl.UTF-8):      Statyczne biblioteki SQLite
129 Group:          Development/Libraries
130 Requires:       %{name}-devel = %{version}-%{release}
131 %if %{with unclock_notify}
132 Provides:       %{name}-static(unlock_notify)
133 %endif
134 %if %{with load_extension}
135 Provides:       %{name}-static(load_extension)
136 %endif
137
138 %description static
139 SQLite is a C library that implements an SQL database engine. A large
140 subset of SQL92 is supported. A complete database is stored in a
141 single disk file. The API is designed for convenience and ease of use.
142 Applications that link against SQLite can enjoy the power and
143 flexiblity of an SQL database without the administrative hassles of
144 supporting a separate database server. Because it omits the
145 client-server interaction overhead and writes directly to disk, SQLite
146 is also faster than the big database servers for most operations. In
147 addition to the C library, the SQLite distribution includes a
148 command-line tool for interacting with SQLite databases and SQLite
149 bindings for Tcl/Tk.
150
151 This package contains the static SQLite libraries.
152
153 %description static -l pl.UTF-8
154 SQLite jest biblioteką języka C, która implementuje silnik baz danych
155 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
156 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
157 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
158 danych bez konieczności utrzymywania osobnego serwera baz danych.
159 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
160 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
161 bazodanowych przy większości operacji na bazie danych. Dodatkowo
162 oprócz biblioteki języka C, dostarczany jest program do zarządzania
163 bazami danych.
164
165 Pakiet zawiera statyczne biblioteki SQLite.
166
167 %package -n tcl-%{name}
168 Summary:        sqlite3 tcl extension
169 Summary(pl.UTF-8):      Rozszerzenie sqlite3 dla Tcl
170 Group:          Development/Languages/Tcl
171
172 %description -n tcl-%{name}
173 sqlite3 tcl extension.
174
175 %description -n tcl-%{name} -l pl.UTF-8
176 Rozszerzenie sqlite3 dla Tcl.
177
178 %prep
179 %setup -q -n sqlite-src-%{vnum}
180 %patch0 -p1
181
182 %{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile.in
183
184 if [ "$(cat VERSION)" != "%{version}" ]; then
185         echo "Tarball content doesn't match version %{version}." >&2
186         exit 1
187 fi
188
189 %build
190 %{__libtoolize}
191 cp -f /usr/share/automake/config.sub .
192 %{__aclocal}
193 %{__autoconf}
194 append-cppflags() {
195         CPPFLAGS="$CPPFLAGS $*"
196 }
197 append-libs() {
198         LIBS="$LIBS $*"
199 }
200 export CPPFLAGS="%{rpmcflags}"
201 export LIBS
202 %if %{with tcl}
203 export TCLLIBDIR="%{tcl_sitearch}/sqlite3"
204 %endif
205
206 append-cppflags -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_SECURE_DELETE
207
208 # Support column metadata functions.
209 # http://sqlite.org/c3ref/column_database_name.html
210 # http://sqlite.org/c3ref/table_column_metadata.html
211 append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
212
213 # Support Full-Text Search versions 3 and 4.
214 # http://sqlite.org/fts3.html
215 #append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_ENABLE_FTS4 -DSQLITE_ENABLE_FTS4_UNICODE61
216 append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS
217
218 # Support R*Trees.
219 # http://sqlite.org/rtree.html
220 append-cppflags -DSQLITE_ENABLE_RTREE
221
222 # Support soundex() function.
223 # http://sqlite.org/lang_corefunc.html#soundex
224 #append-cppflags -DSQLITE_SOUNDEX
225
226 # Support dbstat virtual table.
227 # https://www.sqlite.org/dbstat.html
228 append-cppflags -DSQLITE_ENABLE_DBSTAT_VTAB
229
230 %if %{with unlock_notify}
231 # Support unlock notification.
232 # http://sqlite.org/unlock_notify.html
233 append-cppflags -DSQLITE_ENABLE_UNLOCK_NOTIFY
234 %endif
235
236 %if %{with icu}
237 append-cppflags -DSQLITE_ENABLE_ICU
238 append-libs "-licui18n -licuuc"
239 %endif
240
241 %if %{with load_extension}
242 append-libs "-ldl"
243 %endif
244
245 %configure \
246         %{!?with_tcl:--disable-tcl}%{?with_tcl:--with-tcl=%{_ulibdir}} \
247         %{__enable_disable load_extension load-extension} \
248         --enable-threadsafe
249
250 %{__make}
251
252 %if %{with doc}
253 %{__make} doc
254 %endif
255
256 %{?with_tests:LC_ALL=C %{__make} test}
257
258 %install
259 rm -rf $RPM_BUILD_ROOT
260 install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
261 %{__make} install \
262         DESTDIR=$RPM_BUILD_ROOT
263
264 mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
265 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.so
266 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo lib*.so.*.*) \
267         $RPM_BUILD_ROOT%{_libdir}/libsqlite3.so
268
269 cp -p sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
270
271 %clean
272 rm -rf $RPM_BUILD_ROOT
273
274 %post   -p /sbin/ldconfig
275 %postun -p /sbin/ldconfig
276
277 %files
278 %defattr(644,root,root,755)
279 %doc README.md
280 %attr(755,root,root) %{_bindir}/sqlite3
281 %attr(755,root,root) /%{_lib}/libsqlite3.so.*.*.*
282 %attr(755,root,root) %ghost /%{_lib}/libsqlite3.so.0
283 %{_mandir}/man1/sqlite3.1*
284
285 %files devel
286 %defattr(644,root,root,755)
287 %attr(755,root,root) %{_libdir}/libsqlite3.so
288 %{_libdir}/libsqlite3.la
289 %{_includedir}/sqlite3.h
290 %{_includedir}/sqlite3ext.h
291 %{_pkgconfigdir}/sqlite3.pc
292
293 %files static
294 %defattr(644,root,root,755)
295 %{_libdir}/libsqlite3.a
296
297 %if %{with tcl}
298 %files -n tcl-%{name}
299 %defattr(644,root,root,755)
300 %dir %{_libdir}/tcl*/sqlite3
301 %attr(755,root,root) %{_libdir}/tcl%{tclver}/sqlite3/libtclsqlite3.so
302 %{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
303 %endif
This page took 0.049316 seconds and 4 git commands to generate.