]> git.pld-linux.org Git - packages/spread-sheet-widget.git/blob - spread-sheet-widget.spec
427859d6ee6ef35cb151021bc5b141fd662bdf1f
[packages/spread-sheet-widget.git] / spread-sheet-widget.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Library for Gtk+ which provides a widget for viewing and manipulating 2 dimensional tabular data
6 Summary(pl.UTF-8):      Biblioteka Gtk+ zapewniająca widget do przeglądania i manipulowania dwuwymiarowymi danymi tabelarycznymi
7 Name:           spread-sheet-widget
8 Version:        0.8
9 Release:        1
10 License:        GPL v3+
11 Group:          Libraries
12 Source0:        http://alpha.gnu.org/gnu/ssw/%{name}-%{version}.tar.gz
13 # Source0-md5:  429ab7326a95f237c680d770c226a7c0
14 Patch0:         %{name}-info.patch
15 URL:            https://www.gnu.org/software/ssw/
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake >= 1:1.10.1
18 BuildRequires:  glib2-devel >= 1:2.44
19 BuildRequires:  gtk+3-devel >= 3.18.0
20 BuildRequires:  libtool >= 2:2
21 BuildRequires:  pkgconfig
22 BuildRequires:  texinfo
23 Requires:       glib2 >= 1:2.44
24 Requires:       gtk+3 >= 3.18.0
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 GNU Spread Sheet Widget is a library for Gtk+ which provides a widget
29 for viewing and manipulating 2 dimensional tabular data in a manner
30 similar to many popular spread sheet programs.
31
32 The design follows the model-view-controller paradigm and is of
33 complexity O(1) in both time and space. This means that it is
34 efficient and fast even for very large data.
35
36 Features commonly found in graphical user interfaces such as cut and
37 paste, drag and drop and row/column labelling are also included.
38
39 %description -l pl.UTF-8
40 GNU Spread Sheet Widget to biblioteka Gtk+, która udostępnia widget do
41 przeglądania i manipulowania dwuwymiarowymi danymi tabelarycznymi w
42 sposób zbliżony do wielu popularnych programów do obsługi arkuszy
43 kalkulacyjnych.
44
45 Projekt jest zgodny z paradygmatem model-widok-kontroler i ma
46 złożoność O(1) w czasie i przestrzeni. Oznacza to, że jest wydajny
47 nawet dla bardzo dużych zestawów danych.
48
49 Funkcje często spotykane w graficznych interfejsach użytkownika, takie
50 jak wycinanie, wklejanie, przeciąganie i upuszczanie oraz
51 etykietowanie wiersz / kolumna są również uwzględniane.
52
53 %package devel
54 Summary:        Header files for %{name} library
55 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       glib2-devel >= 1:2.44
59 Requires:       gtk+3-devel >= 3.18.0
60
61 %description devel
62 Header files for %{name} library.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe biblioteki %{name}.
66
67 %package static
68 Summary:        Static %{name} library
69 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 Static %{name} library.
75
76 %description static -l pl.UTF-8
77 Statyczna biblioteka %{name}.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82
83 %build
84 %{__libtoolize}
85 %{__aclocal}
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         %{!?with_static_libs:--disable-static}
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 # obsoleted by pkg-config
100 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libspread-sheet-widget.la
101
102 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %post   devel -p /sbin/postshell
111 -/usr/sbin/fix-info-dir -c %{_infodir}
112
113 %postun devel -p /sbin/postshell
114 -/usr/sbin/fix-info-dir -c %{_infodir}
115
116 %files
117 %defattr(644,root,root,755)
118 %doc AUTHORS ChangeLog NEWS README TODO
119 %attr(755,root,root) %{_libdir}/libspread-sheet-widget.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libspread-sheet-widget.so.0
121
122 %files devel
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_libdir}/libspread-sheet-widget.so
125 %{_includedir}/ssw-axis-model.h
126 %{_includedir}/ssw-sheet-axis.h
127 %{_includedir}/ssw-sheet.h
128 %{_includedir}/ssw-virtual-model.h
129 %{_pkgconfigdir}/spread-sheet-widget.pc
130 %{_infodir}/spread-sheet-widget.info*
131
132 %if %{with static_libs}
133 %files static
134 %defattr(644,root,root,755)
135 %{_libdir}/libspread-sheet-widget.a
136 %endif
This page took 0.063449 seconds and 3 git commands to generate.