]> git.pld-linux.org Git - packages/spl.git/blob - spl.spec
- release 2 (by relup.sh)
[packages/spl.git] / spl.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # allow non-distribution kernel
4 %bcond_without  kernel          # don't build kernel modules
5 %bcond_without  userspace       # don't build userspace programs
6 %bcond_with     verbose         # verbose build (V=1)
7 #
8 %if %{without kernel}
9 %undefine       with_dist_kernel
10 %endif
11 %if "%{_alt_kernel}" != "%{nil}"
12 %undefine       with_userspace
13 %endif
14 %if %{without userspace}
15 # nothing to be placed to debuginfo package
16 %define         _enable_debug_packages  0
17 %endif
18 Summary:        Solaris Porting Layer
19 Summary(pl.UTF-8):      Solaris Porting Layer - warstwa do portowania kodu z Solarisa
20 %define pname   spl
21 Name:           %{pname}%{_alt_kernel}
22 Version:        0.6.2
23 %define rel     2
24 Release:        %{rel}
25 License:        GPL v2+
26 Group:          Applications/System
27 Source0:        http://archive.zfsonlinux.org/downloads/zfsonlinux/spl/%{pname}-%{version}.tar.gz
28 # Source0-md5:  f00535bf89a7fde0e08f44a14a1f1e03
29 URL:            http://zfsonlinux.org/
30 %if %{with kernel}
31 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
32 BuildRequires:  rpmbuild(macros) >= 1.379
33 %endif
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Solaris Porting Layer.
38
39 %description -l pl.UTF-8
40 Solaris Porting Layer - warstwa do portowania kodu z Solarisa.
41
42 %package -n kernel%{_alt_kernel}-spl
43 Summary:        Solaris Porting Layer - Linux kernel modules
44 Summary(pl.UTF-8):      Solaris Porting Layer - moduły jądra Linuksa
45 Release:        %{rel}@%{_kernel_ver_str}
46 Group:          Base/Kernel
47 Requires(post,postun):  /sbin/depmod
48 %if %{with dist_kernel}
49 %requires_releq_kernel
50 Requires(postun):       %releq_kernel
51 %endif
52
53 %description -n kernel%{_alt_kernel}-spl
54 Solaris Porting Layer - Linux kernel modules.
55
56 %description -n kernel%{_alt_kernel}-spl -l pl.UTF-8
57 Solaris Porting Layer - moduły jądra Linuksa.
58
59 %package -n kernel%{_alt_kernel}-spl-devel
60 Summary:        Solaris Porting Layer - Linux kernel headers
61 Summary(pl.UTF-8):      Solaris Porting Layer - pliki nagłówkowe jądra Linuksa
62 Release:        %{rel}@%{_kernel_ver_str}
63 Group:          Development/Building
64 %{?with_dist_kernel:Requires:   kernel%{_alt_kernel}-headers}
65
66 %description -n kernel%{_alt_kernel}-spl-devel
67 Solaris Porting Layer - Linux kernel headers configured for PLD
68 kernel%{_alt_kernel}, version %{_kernel_ver}.
69
70 %description -n kernel%{_alt_kernel}-spl-devel -l pl.UTF-8
71 Solaris Porting Layer - pliki nagłówkowe jądra Linuksa skonfigurowane
72 dla jądra PLD z pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.
73
74 %prep
75 %setup -q
76
77 %build
78 %configure \
79         --disable-silent-rules \
80         --with-config="%{?with_kernel:%{?with_userspace:all}}%{!?with_kernel:user}%{!?with_userspace:kernel}" \
81         --with-linux=%{_kernelsrcdir}
82
83 %{__make} \
84         %{?with_verbose:V=1}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT \
91         INSTALL_MOD_DIR=misc
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %if %{with userspace}
97 %files
98 %defattr(644,root,root,755)
99 %doc AUTHORS DISCLAIMER
100 %attr(755,root,root) %{_sbindir}/splat
101 %{_mandir}/man1/splat.1*
102 %endif
103
104 %if %{with kernel}
105 %files -n kernel%{_alt_kernel}-spl
106 %defattr(644,root,root,755)
107 %dir /lib/modules/%{_kernel_ver}/misc/spl
108 /lib/modules/%{_kernel_ver}/misc/spl/spl.ko*
109 %dir /lib/modules/%{_kernel_ver}/misc/splat
110 /lib/modules/%{_kernel_ver}/misc/splat/splat.ko*
111
112 %files -n kernel%{_alt_kernel}-spl-devel
113 %defattr(644,root,root,755)
114 /usr/src/spl-%{version}
115 %endif
This page took 0.085571 seconds and 4 git commands to generate.