]> git.pld-linux.org Git - packages/spl.git/blob - spl.spec
- new
[packages/spl.git] / spl.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # allow non-distribution kernel
4 %bcond_without  kernel          # don't build kernel modules
5 %bcond_without  userspace       # don't build userspace programs
6 %bcond_with     verbose         # verbose build (V=1)
7 #
8 %if %{without kernel}
9 %undefine       with_dist_kernel
10 %endif
11 %if "%{_alt_kernel}" != "%{nil}"
12 %undefine       with_userspace
13 %endif
14 %if %{without userspace}
15 # nothing to be placed to debuginfo package
16 %define         _enable_debug_packages  0
17 %endif
18 Summary:        Solaris Porting Layer
19 Summary(pl.UTF-8):      Solaris Porting Layer - warstwa do portowania kodu z Solarisa
20 %define pname   spl
21 Name:           %{pname}%{_alt_kernel}
22 Version:        0.6.2
23 %define rel     1
24 Release:        %{rel}
25 License:        GPL v2+
26 Group:          Applications/System
27 Source0:        http://archive.zfsonlinux.org/downloads/zfsonlinux/spl/%{name}-%{version}.tar.gz
28 # Source0-md5:  f00535bf89a7fde0e08f44a14a1f1e03
29 URL:            http://zfsonlinux.org/
30 %if %{with kernel}
31 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
32 BuildRequires:  rpmbuild(macros) >= 1.379
33 %endif
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Solaris Porting Layer.
38
39 %description -l pl.UTF-8
40 Solaris Porting Layer - warstwa do portowania kodu z Solarisa.
41
42 %package -n kernel%{_alt_kernel}-spl
43 Summary:        Solaris Porting Layer - Linux kernel modules
44 Summary(pl.UTF-8):      Solaris Porting Layer - moduły jądra Linuksa
45 Release:        %{rel}@%{_kernel_ver_str}
46 Group:          Base/Kernel
47 Requires(post,postun):  /sbin/depmod
48 %if %{with dist_kernel}
49 %requires_releq_kernel
50 Requires(postun):       %releq_kernel
51 %endif
52
53 %description -n kernel%{_alt_kernel}-spl
54 Solaris Porting Layer - Linux kernel modules.
55
56 %description -n kernel%{_alt_kernel}-spl -l pl.UTF-8
57 Solaris Porting Layer - moduły jądra Linuksa.
58
59 %package -n kernel%{_alt_kernel}-spl-devel
60 Summary:        Solaris Porting Layer - Linux kernel headers
61 Summary(pl.UTF-8):      Solaris Porting Layer - pliki nagłówkowe jądra Linuksa
62 Group:          Development/Building
63 %{?with_dist_kernel:Requires:   kernel%{_alt_kernel}-headers}
64
65 %description -n kernel%{_alt_kernel}-spl-devel
66 Solaris Porting Layer - Linux kernel headers configured for PLD
67 kernel%{_alt_kernel}, version %{_kernel_ver}.
68
69 %description -n kernel%{_alt_kernel}-spl-devel -l pl.UTF-8
70 Solaris Porting Layer - pliki nagłówkowe jądra Linuksa skonfigurowane
71 dla jądra PLD z pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.
72
73 %prep
74 %setup -q
75
76 %build
77 %configure \
78         --disable-silent-rules \
79         --with-config="%{?with_kernel:%{?with_userspace:all}}%{!?with_kernel:user}%{!?with_userspace:kernel}" \
80         --with-linux=%{_kernelsrcdir}
81
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT \
89         INSTALL_MOD_DIR=misc
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %if %{with userspace}
95 %files
96 %defattr(644,root,root,755)
97 %doc AUTHORS DISCLAIMER 
98 %attr(755,root,root) %{_sbindir}/splat
99 %{_mandir}/man1/splat.1*
100 %endif
101
102 %if %{with kernel}
103 %files -n kernel%{_alt_kernel}-spl
104 %defattr(644,root,root,755)
105 %dir /lib/modules/%{_kernel_ver}/misc/spl
106 /lib/modules/%{_kernel_ver}/misc/spl/spl.ko*
107 %dir /lib/modules/%{_kernel_ver}/misc/splat
108 /lib/modules/%{_kernel_ver}/misc/splat/splat.ko*
109
110 %files -n kernel%{_alt_kernel}-spl-devel
111 %defattr(644,root,root,755)
112 /usr/src/spl-%{version}
113 %endif
This page took 0.065767 seconds and 4 git commands to generate.