]> git.pld-linux.org Git - packages/spice-space.git/blob - spice-space.spec
ac14b24365a3523fa05f080bf7c0650c1f1ce95f
[packages/spice-space.git] / spice-space.spec
1 # TODO: verify slirp comment validity with current qemu/spice versions [how to?]
2 #
3 # Conditional build:
4 %bcond_with     slirp           # build with tunneling support (breaks qemu)
5 #
6 Summary:        SPICE virtualization solution
7 Summary(pl.UTF-8):      System wirtualizacji SPICE
8 # real package name (spice) is already occupied
9 Name:           spice-space
10 Version:        0.12.4
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          Applications/Emulators
14 Source0:        http://spice-space.org/download/releases/spice-%{version}.tar.bz2
15 # Source0-md5:  325b1c42ce24e75de45a75876b73a8bd
16 Patch0:         spice-sh.patch
17 Patch1:         spice-link.patch
18 Patch2:         spice-am.patch
19 URL:            http://spice-space.org/
20 BuildRequires:  OpenGL-GLU-devel
21 BuildRequires:  alsa-lib-devel
22 BuildRequires:  autoconf >= 2.57
23 BuildRequires:  automake
24 BuildRequires:  celt051-devel >= 0.5.1.1
25 BuildRequires:  cyrus-sasl-devel >= 2
26 BuildRequires:  glib2-devel >= 1:2.22
27 BuildRequires:  libcacard-devel >= 0.1.2
28 BuildRequires:  libjpeg-devel
29 %{?with_slirp:BuildRequires:    libslirp-devel}
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libtool
32 BuildRequires:  openssl-devel
33 BuildRequires:  pixman-devel >= 0.17.7
34 BuildRequires:  pkgconfig
35 BuildRequires:  python >= 2
36 BuildRequires:  python-pyparsing
37 BuildRequires:  rpmbuild(macros) >= 1.527
38 BuildRequires:  spice-protocol >= 0.10.1
39 BuildRequires:  xorg-lib-libX11-devel
40 BuildRequires:  xorg-lib-libXext-devel
41 BuildRequires:  xorg-lib-libXfixes-devel
42 BuildRequires:  xorg-lib-libXinerama-devel >= 1.0
43 BuildRequires:  xorg-lib-libXrandr-devel >= 1.2
44 BuildRequires:  xorg-lib-libXrender-devel
45 BuildRequires:  zlib-devel
46 ExclusiveArch:  %{ix86} %{x8664} arm
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Spice is an open remote computing solution, providing client access to
51 remote machine display and devices (e.g., keyboard, mouse, audio).
52 Spice achieves a user experience similar to an interaction with a
53 local machine, while trying to offload most of the intensive CPU and
54 GPU tasks to the client. Spice is suitable for both LAN and WAN usage,
55 without compromising on the user experience.
56
57 %description -l pl.UTF-8
58 Spice to rozwiązanie do zdalnych obliczeń, zapewniające dostęp
59 kliencki ekranu i urządzeń zdalnej maszyny (klawiatury, myszy,
60 dźwięku). Daje użytkownikowi wrażenie podobne do pracy lokalnej, ale
61 próbuje większość zadań wykorzystujących intensywnie CPU i GPU zrzucić
62 na klienta. Nadaje się do pracy w sieciach LAN i WAN, bez większych
63 poświęceń ze strony doznań użytkownika.
64
65 %package -n spice-server-libs
66 Summary:        SPICE server library
67 Summary(pl.UTF-8):      Biblioteka serwera SPICE
68 Group:          Libraries
69 Requires:       celt051 >= 0.5.1.1
70 Requires:       glib2 >= 1:2.22
71 Requires:       pixman >= 0.17.7
72
73 %description -n spice-server-libs
74 SPICE server library.
75
76 %description -n spice-server-libs -l pl.UTF-8
77 Biblioteka serwera SPICE.
78
79 %package -n spice-server-devel
80 Summary:        Header files for SPICE server library
81 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki serwera SPICE
82 Group:          Development/Libraries
83 Requires:       celt051-devel >= 0.5.1.1
84 Requires:       glib2-devel >= 1:2.22
85 %{?with_slirp:Requires: libslirp-devel}
86 Requires:       openssl-devel
87 Requires:       pixman-devel >= 0.17.7
88 Requires:       spice-server-libs = %{version}-%{release}
89
90 %description -n spice-server-devel
91 Header files for SPICE server library.
92
93 %description -n spice-server-devel -l pl.UTF-8
94 Pliki nagłówkowe biblioteki serwera SPICE.
95
96 %package -n spice-server-static
97 Summary:        Static SPICE server library
98 Summary(pl.UTF-8):      Statyczna biblioteka serwera SPICE
99 Group:          Development/Libraries
100 Requires:       spice-server-devel = %{version}-%{release}
101
102 %description -n spice-server-static
103 Static SPICE server library.
104
105 %description -n spice-server-static -l pl.UTF-8
106 Statyczna biblioteka serwera SPICE.
107
108 %package -n spice-client
109 Summary:        SPICE client for X11
110 Summary(pl.UTF-8):      Klient SPICE dla X11
111 Group:          X11/Applications
112 Requires:       celt051 >= 0.5.1.1
113 Requires:       libcacard >= 0.1.2
114 Requires:       pixman >= 0.17.7
115 Requires:       xorg-lib-libXrandr >= 1.2
116 Requires:       xorg-lib-libXinerama >= 1.0
117
118 %description -n spice-client
119 SPICE client for X11.
120
121 %description -n spice-client -l pl.UTF-8
122 Klient SPICE dla X11.
123
124 %prep
125 %setup -q -n spice-%{version}
126 %patch0 -p1
127 %patch1 -p1
128 %patch2 -p1
129
130 %build
131 %{__libtoolize}
132 %{__aclocal}
133 %{__autoconf}
134 %{__autoheader}
135 %{__automake}
136 %configure \
137         --disable-silent-rules \
138         --enable-client \
139         --enable-opengl \
140         --enable-smartcard \
141         --enable-tunnel%{!?with_slirp:=no}
142 # --enable-gui          BR: CEGUI-devel >= 0.6.0 < 0.7.0
143
144 %{__make}
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148
149 %{__make} install \
150         DESTDIR=$RPM_BUILD_ROOT
151
152 # obsoleted by pkg-config
153 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libspice-server.la
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post   -n spice-server-libs -p /sbin/ldconfig
159 %postun -n spice-server-libs -p /sbin/ldconfig
160
161 %files -n spice-server-libs
162 %defattr(644,root,root,755)
163 %doc NEWS README
164 %attr(755,root,root) %{_libdir}/libspice-server.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libspice-server.so.1
166
167 %files -n spice-server-devel
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_libdir}/libspice-server.so
170 %{_includedir}/spice-server
171 %{_pkgconfigdir}/spice-server.pc
172
173 %files -n spice-server-static
174 %defattr(644,root,root,755)
175 %{_libdir}/libspice-server.a
176
177 %files -n spice-client
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_bindir}/spicec
This page took 0.096945 seconds and 3 git commands to generate.