]> git.pld-linux.org Git - packages/spice-space.git/blob - spice-space.spec
- updated to 0.12.6
[packages/spice-space.git] / spice-space.spec
1 #
2 # Conditional build:
3 %bcond_without  opengl  # OpenGL support
4 #
5 Summary:        SPICE virtualization solution
6 Summary(pl.UTF-8):      System wirtualizacji SPICE
7 # real package name (spice) is already occupied
8 Name:           spice-space
9 Version:        0.12.6
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Applications/Emulators
13 Source0:        http://www.spice-space.org/download/releases/spice-%{version}.tar.bz2
14 # Source0-md5:  605a8c8ea80bc95076c4b3539c6dd026
15 Patch0:         spice-link.patch
16 Patch1:         spice-am.patch
17 Patch2:         spice-codegen.patch
18 URL:            http://www.spice-space.org/
19 %{?with_opengl:BuildRequires:   OpenGL-devel}
20 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
21 BuildRequires:  alsa-lib-devel
22 BuildRequires:  asciidoc
23 BuildRequires:  autoconf >= 2.63
24 BuildRequires:  automake >= 1:1.11
25 BuildRequires:  celt051-devel >= 0.5.1.1
26 BuildRequires:  cyrus-sasl-devel >= 2
27 BuildRequires:  gcc >= 5:3.2
28 BuildRequires:  glib2-devel >= 1:2.22
29 BuildRequires:  libcacard-devel >= 0.1.2
30 BuildRequires:  libjpeg-devel
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtool >= 2:2
33 BuildRequires:  lz4-devel
34 BuildRequires:  openssl-devel
35 BuildRequires:  opus-devel >= 0.9.14
36 BuildRequires:  pixman-devel >= 0.17.7
37 BuildRequires:  pkgconfig
38 BuildRequires:  python >= 2
39 BuildRequires:  python-pyparsing
40 BuildRequires:  python-six
41 BuildRequires:  rpmbuild(macros) >= 1.527
42 BuildRequires:  spice-protocol >= 0.12.10
43 BuildRequires:  spice-protocol-codegen >= 0.12.10
44 BuildRequires:  xorg-lib-libX11-devel
45 BuildRequires:  xorg-lib-libXext-devel
46 BuildRequires:  xorg-lib-libXfixes-devel
47 BuildRequires:  xorg-lib-libXinerama-devel >= 1.0
48 BuildRequires:  xorg-lib-libXrandr-devel >= 1.2
49 BuildRequires:  xorg-lib-libXrender-devel
50 BuildRequires:  zlib-devel
51 ExclusiveArch:  %{ix86} %{x8664} x32 arm
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 Spice is an open remote computing solution, providing client access to
56 remote machine display and devices (e.g., keyboard, mouse, audio).
57 Spice achieves a user experience similar to an interaction with a
58 local machine, while trying to offload most of the intensive CPU and
59 GPU tasks to the client. Spice is suitable for both LAN and WAN usage,
60 without compromising on the user experience.
61
62 %description -l pl.UTF-8
63 Spice to rozwiązanie do zdalnych obliczeń, zapewniające dostęp
64 kliencki ekranu i urządzeń zdalnej maszyny (klawiatury, myszy,
65 dźwięku). Daje użytkownikowi wrażenie podobne do pracy lokalnej, ale
66 próbuje większość zadań wykorzystujących intensywnie CPU i GPU zrzucić
67 na klienta. Nadaje się do pracy w sieciach LAN i WAN, bez większych
68 poświęceń ze strony doznań użytkownika.
69
70 %package -n spice-server-libs
71 Summary:        SPICE server library
72 Summary(pl.UTF-8):      Biblioteka serwera SPICE
73 Group:          Libraries
74 Requires:       celt051 >= 0.5.1.1
75 Requires:       opus >= 0.9.14
76 Requires:       glib2 >= 1:2.22
77 Requires:       pixman >= 0.17.7
78 Obsoletes:      spice-client
79
80 %description -n spice-server-libs
81 SPICE server library.
82
83 %description -n spice-server-libs -l pl.UTF-8
84 Biblioteka serwera SPICE.
85
86 %package -n spice-server-devel
87 Summary:        Header files for SPICE server library
88 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki serwera SPICE
89 Group:          Development/Libraries
90 Requires:       celt051-devel >= 0.5.1.1
91 Requires:       glib2-devel >= 1:2.22
92 Requires:       openssl-devel
93 Requires:       pixman-devel >= 0.17.7
94 Requires:       spice-server-libs = %{version}-%{release}
95
96 %description -n spice-server-devel
97 Header files for SPICE server library.
98
99 %description -n spice-server-devel -l pl.UTF-8
100 Pliki nagłówkowe biblioteki serwera SPICE.
101
102 %package -n spice-server-static
103 Summary:        Static SPICE server library
104 Summary(pl.UTF-8):      Statyczna biblioteka serwera SPICE
105 Group:          Development/Libraries
106 Requires:       spice-server-devel = %{version}-%{release}
107
108 %description -n spice-server-static
109 Static SPICE server library.
110
111 %description -n spice-server-static -l pl.UTF-8
112 Statyczna biblioteka serwera SPICE.
113
114 %package -n spice-client
115 Summary:        SPICE client for X11
116 Summary(pl.UTF-8):      Klient SPICE dla X11
117 Group:          X11/Applications
118 Requires:       celt051 >= 0.5.1.1
119 Requires:       libcacard >= 0.1.2
120 Requires:       opus >= 0.9.14
121 Requires:       pixman >= 0.17.7
122 Requires:       xorg-lib-libXrandr >= 1.2
123 Requires:       xorg-lib-libXinerama >= 1.0
124
125 %description -n spice-client
126 SPICE client for X11.
127
128 %description -n spice-client -l pl.UTF-8
129 Klient SPICE dla X11.
130
131 %prep
132 %setup -q -n spice-%{version}
133 %patch0 -p1
134 %patch1 -p1
135 %patch2 -p1
136
137 %build
138 %{__libtoolize}
139 %{__aclocal} -I m4
140 %{__autoconf}
141 %{__autoheader}
142 %{__automake}
143 cd spice-common
144 %{__libtoolize}
145 %{__aclocal} -I m4
146 %{__autoconf}
147 %{__autoheader}
148 %{__automake}
149 cd ..
150 %configure \
151         --disable-silent-rules \
152         --enable-client \
153         --enable-lz4 \
154         %{?with_opengl:--enable-opengl} \
155         --enable-smartcard
156
157 %{__make}
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161
162 %{__make} install \
163         DESTDIR=$RPM_BUILD_ROOT
164
165 # obsoleted by pkg-config
166 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libspice-server.la
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %post   -n spice-server-libs -p /sbin/ldconfig
172 %postun -n spice-server-libs -p /sbin/ldconfig
173
174 %files -n spice-server-libs
175 %defattr(644,root,root,755)
176 %doc NEWS README
177 %attr(755,root,root) %{_libdir}/libspice-server.so.*.*.*
178 %attr(755,root,root) %ghost %{_libdir}/libspice-server.so.1
179
180 %files -n spice-server-devel
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_libdir}/libspice-server.so
183 %{_includedir}/spice-server
184 %{_pkgconfigdir}/spice-server.pc
185
186 %files -n spice-server-static
187 %defattr(644,root,root,755)
188 %{_libdir}/libspice-server.a
This page took 0.040912 seconds and 3 git commands to generate.