]> git.pld-linux.org Git - packages/sphinx.git/blob - sphinx.spec
- created php-sphinx
[packages/sphinx.git] / sphinx.spec
1 #  TODO
2 # - packages for Python/Ruby API
3 #
4 # Conditional build:
5 %bcond_without  pgsql           # without pgsql support
6 #
7 Summary:        Free open-source SQL full-text search engine
8 Summary(pl.UTF-8):      Silnik przeszukiwania pełnotekstowego SQL open-source
9 Name:           sphinx
10 Version:        0.9.7
11 Release:        0.4
12 License:        GPL v2
13 Group:          Applications/Databases
14 Source0:        http://www.sphinxsearch.com/downloads/%{name}-%{version}.tar.gz
15 # Source0-md5:  32f2b7e98d8485c86108851d52c5cef4
16 Patch0:         %{name}-DESTDIR.patch
17 Source1:        sphinx.init
18 URL:            http://www.sphinxsearch.com/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  mysql-devel
22 %{?with_pgsql:BuildRequires:    postgresql-devel}
23 Requires:       mysql-libs
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Sphinx is a a standalone search engine, meant to provide fast,
28 size-efficient and relevant fulltext search functions to other
29 applications. Sphinx was specially designed to integrate well with SQL
30 databases and scripting languages. Currently built-in data sources
31 support fetching data either via direct connection to MySQL, or from
32 an XML pipe.
33
34 %description -l pl.UTF-8
35 Sphinx jest samodzielnym silnikiem przeszukującym, dostarczającym
36 innym aplikacjom szybkie, zoptymalizowane rozmiarowo funkcje
37 przeszukiwania pełnotekstowego. Sphinx został specjalnie
38 zaprojektowany z myślą o dobrej integracji z bazami danych SQL oraz
39 językami skryptowymi. Obecnie wbudowane źródła danych wspierają
40 pobieranie danych poprzez bezpośrednie połączenie z MySQL lub z potoku
41 XML.
42
43 %package -n php-sphinx
44 Summary:        PHP API for Sphinx
45 Group:          Libraries
46 Requires:       php-common >= 4:5.0.4
47
48 %description -n php-sphinx
49 PHP API for Sphinx.
50
51 %prep
52 %setup -q
53 %patch0 -p1
54
55 %build
56 %{__aclocal}
57 %{__autoconf}
58 %{__autoheader}
59 %{__automake}
60 CPPFLAGS=-D_FILE_OFFSET_BITS=64
61 %configure \
62         %{?with_pgsql:--with-pgsql} \
63         --with-mysql
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT{%{_sbindir},/etc/rc.d/init.d,%{_datadir}/php}
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/example.sql
74 mv $RPM_BUILD_ROOT%{_sysconfdir}/sphinx.conf{.dist,}
75 mv $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/searchd
76 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
77
78 cp -a api/sphinxapi.php $RPM_BUILD_ROOT%{_datadir}/php
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc doc/sphinx.txt example.sql
86 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sphinx.conf
87 %attr(755,root,root) %{_bindir}/indexer
88 %attr(755,root,root) %{_bindir}/search
89 %attr(755,root,root) %{_sbindir}/searchd
90 %attr(754,root,root) /etc/rc.d/init.d/%{name}
91
92 %files -n php-sphinx
93 %{_datadir}/php/sphinxapi.php
This page took 0.02829 seconds and 3 git commands to generate.