]> git.pld-linux.org Git - packages/spamassassin.git/blob - spamassassin.spec
- maruderzy nie czytają TODO!
[packages/spamassassin.git] / spamassassin.spec
1 #
2 # Conditional build:
3 %bcond_with  tests      # perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Mail
7 %define pnam    SpamAssassin
8 Summary:        A spam filter for email which can be invoked from mail delivery agents
9 Summary(pl):    Filtr antyspamowy, przeznaczony dla programów dostarczaj±cych pocztê (MDA)
10 Name:           spamassassin
11 Version:        2.64
12 Release:        0.3
13 License:        GPL v1+ or Artistic
14 Group:          Applications/Mail
15 Source0:        http://old.spamassassin.org/released/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a82a9dab95462d102e253edb99091fdd
17 Source1:        %{name}.sysconfig
18 Patch0:         %{name}-rc-script.patch
19 URL:            http://spamassassin.org/
20 BuildRequires:  openssl-devel >= 0.9.6m
21 BuildRequires:  perl-devel >= 5.6
22 %if %{with tests}
23 BuildRequires:  perl-HTML-Parser >= 3
24 # are these really needed?
25 BuildRequires:  perl-MailTools
26 BuildRequires:  perl-Mail-Audit
27 BuildRequires:  perl-MIME-Base64
28 BuildRequires:  perl-MIME-tools
29 %endif
30 BuildRequires:  rpm-perlprov >= 4.0.2-104
31 PreReq:         rc-scripts
32 Requires(post,preun):   /sbin/chkconfig
33 Requires:       perl-Mail-SpamAssassin >= %{version}
34 Obsoletes:      SpamAssassin
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _noautoreq      'perl(Razor2::Client::Agent)' 'perl(Razor::Agent)' 'perl(Razor::Client)' 'perl(DBI)'
38
39 %description
40 SpamAssassin provides you with a way to reduce if not completely
41 eliminate Unsolicited Commercial Email (SPAM) from your incoming
42 email. It can be invoked by a MDA such as sendmail or postfix, or can
43 be called from a procmail script, .forward file, etc. It uses a
44 genetic-algorithm evolved scoring system to identify messages which
45 look spammy, then adds headers to the message so they can be filtered
46 by the user's mail reading software. This distribution includes the
47 spamd/spamc components which create a server that considerably speeds
48 processing of mail.
49
50 %description -l pl
51 SpamAssassin udostêpnia Ci mo¿liwo¶æ zredukowania, je¶li nie
52 kompletnego wyeliminowania Niezamawianej Komercyjnej Poczty
53 (Unsolicited Commercial Email, spamu) z Twojej poczty. Mo¿e byæ
54 wywo³ywany z MDA, np. Sendmaila czy Postfixa, lub z pliku ~/.forward
55 itp. U¿ywa ogólnego algorytmu oceniania w celu identyfikacji
56 wiadomo¶ci, które wygl±daj± na SPAM, po czym dodaje nag³ówki do
57 wiadomo¶ci, umo¿liwiaj±c filtrowanie przez oprogramowanie u¿ytkownika.
58 Ta dystrybucja zawiera programy spamd/spamc, umo¿liwiaj±ce
59 uruchomienie serwera, co znacznie przyspieszy proces przetwarzania
60 poczty.
61
62 %package tools
63 Summary:        Miscleanous tools for SpamAssassin
64 Summary(pl):    Przeró¿ne narzêdzia zwi±zane z SpamAssassin
65 Group:          Applications/Mail
66 Obsoletes:      SpamAssassin-tools
67
68 %description tools
69 Miscleanous tools from various authors, distributed with SpamAssassin.
70 See /usr/share/doc/spamassassin-tools-*/.
71
72 %description tools -l pl
73 Przeró¿ne narzêdzia, dystrybuowane razem z SpamAssassin. Zobacz
74 /usr/share/doc/spamassassin-tools-*/.
75
76 %package spamd
77 Summary:        spamd - daemonized version of spamassassin
78 Summary(pl):    spamd - spamassassin w postaci demona
79 Group:          Applications/Mail
80
81 %description spamd
82 The purpose of this program is to provide a daemonized version of the
83 spamassassin executable. The goal is improving throughput performance
84 for automated mail checking.
85
86 This is intended to be used alongside "spamc", a fast, low-overhead C
87 client program.
88
89 %description spamd -l pl
90 Spamd jest "demoniczn±" wersj± spamassassina. Jego zadaniem jest
91 poprawa wydajno¶ci automatycznego sprawdzania poczty.
92
93 Spamd powinien byæ u¿ywany wespó³ ze "spamc", który jest szybkim i
94 wydajnym programem klienckim.
95
96 %package spamc
97 Summary:        spamc - client for spamd
98 Summary(pl):    spamc - klient dla spamd
99 Group:          Applications/Mail
100
101 %description spamc
102 Spamc is the client half of the spamc/spamd pair. It should be used in
103 place of "spamassassin" in scripts to process mail. It will read the
104 mail from STDIN, and spool it to its connection to spamd, then read
105 the result back and print it to STDOUT. Spamc has extremely low
106 overhead in loading, so it should be much faster to load than the
107 whole spamassassin program.
108
109 %description spamc -l pl
110 Spamc powinien byæ u¿ywany zamiast "spamassassina" w skryptach
111 przetwarzaj±cych pocztê. Zczytuje pocztê ze STDIN, kolejkuje j± a
112 nastêpnie przekazuje spamd'owi, odczytuje wynik i podaje go na STDOUT.
113 Spamc stara siê nie obci±¿aæ zbytnio procesora podczas ³adowania,
114 dziêki czemu powinien dzia³aæ szybciej ni¿ sam spamassassin.
115
116 %package -n perl-Mail-SpamAssassin
117 Summary:        Mail::SpamAssassin - SpamAssassin e-mail filter libraries
118 Summary(pl):    Mail::SpamAssassin - biblioteki filtra poczty SpamAssassin
119 Group:          Development/Languages/Perl
120 Requires:       perl-HTML-Parser >= 3
121 Requires:       perl-Cache-DB_File >= 0.2
122
123 %description -n perl-Mail-SpamAssassin
124 Mail::SpamAssassin is a Mail::Audit plugin to identify spam using text
125 analysis and several internet-based realtime blacklists. Using its
126 rule base, it uses a wide range of heuristic tests on mail headers and
127 body text to identify ``spam'', also known as unsolicited commercial
128 email. Once identified, the mail can then be optionally tagged as spam
129 for later filtering using the user's own mail user-agent application.
130
131 %description -n perl-Mail-SpamAssassin -l pl
132 Mail::SpamAssassin jest pluginem dla Mail::Audit, s³u¿±cym do
133 identyfikacji spamu przy u¿yciu analizy zawarto¶ci i/lub internetowych
134 czarnych list. Do zidentyfikowania jako ,,spam'' stosuje szeroki
135 zakres testów heurystycznych na nag³ówkach i tre¶ci, posi³kuj±c siê
136 stworzon± wcze¶niej baz± regu³. Po zidentyfikowaniu, poczta mo¿e byæ
137 oznaczona jako spam w celu pó¼niejszego wyfiltrowania, np. przy u¿yciu
138 aplikacji do czytania poczty.
139
140 %prep
141 %setup -q -n %{pdir}-%{pnam}-%{version}
142 %patch0 -p0
143
144 %build
145 echo "postmaster@localhost" | \
146 %{__perl} Makefile.PL \
147         PREFIX=%{_prefix} \
148         SYSCONFDIR=%{_sysconfdir} \
149         RUN_RAZOR1_TESTS=0 \
150         RUN_RAZOR2_TESTS=0
151 %{__make} OPTIMIZE="%{rpmcflags}"
152
153 %{?with_tests:%{__make} test}
154
155 %install
156 rm -rf $RPM_BUILD_ROOT
157 install -d $RPM_BUILD_ROOT{/etc/{sysconfig,rc.d/init.d},%{_sysconfdir}/mail/spamassassin}
158
159 %{__make} install \
160         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
161         INSTALLMAN1DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
162         INSTALLMAN3DIR=$RPM_BUILD_ROOT%{_mandir}/man3
163
164 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/spamassassin
165
166 install rules/local.cf $RPM_BUILD_ROOT%{_sysconfdir}/mail/spamassassin
167
168 # shouldn't this script be called `spamd' instead?
169 install spamd/pld-rc-script.sh $RPM_BUILD_ROOT/etc/rc.d/init.d/spamassassin
170
171 rm -f spamd/{*.sh,*.conf,spam*} contrib/snp.tar.gz
172
173 %post spamd
174 /sbin/chkconfig --add spamassassin
175 if [ -f /var/lock/subsys/spamd ]; then
176         /etc/rc.d/init.d/spamassassin restart 1>&2
177 else
178         echo 'Run "/etc/rc.d/init.d/spamassassin start" to start the spamd daemon.'
179 fi
180
181 %preun spamd
182 if [ "$1" = "0" ]; then
183         if [ -f /var/lock/subsys/spamd ]; then
184                 /etc/rc.d/init.d/spamassassin stop 1>&2
185         fi
186         /sbin/chkconfig --del spamassassin
187 fi
188
189 %clean
190 rm -rf $RPM_BUILD_ROOT
191
192 %files
193 %defattr(644,root,root,755)
194 %doc BUGS Changes COPYRIGHT INSTALL README TRADEMARK USAGE
195 %doc procmailrc.example
196 %attr(755,root,root) %{_bindir}/sa-learn
197 %attr(755,root,root) %{_bindir}/spamassassin
198 %{_mandir}/man1/sa-learn*
199 %{_mandir}/man1/spamassassin*
200
201 %files tools
202 %defattr(644,root,root,755)
203 %doc sql tools masses contrib
204
205 %files spamd
206 %defattr(644,root,root,755)
207 %doc spamd/*
208 %attr(754,root,root) /etc/rc.d/init.d/spamassassin
209 %attr(600,root,root) %config(noreplace) /etc/sysconfig/spamassassin
210 %attr(755,root,root) %{_bindir}/spamd
211 %{_mandir}/man1/spamd*
212
213 %files spamc
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_bindir}/spamc
216 %{_mandir}/man1/spamc*
217
218 %files -n perl-Mail-SpamAssassin
219 %defattr(644,root,root,755)
220 %doc sample-nonspam.txt sample-spam.txt
221 %dir %{_sysconfdir}/mail/spamassassin
222 %config(noreplace) %{_sysconfdir}/mail/spamassassin/*
223 %dir %{_datadir}/spamassassin
224 %config(noreplace) %{_datadir}/spamassassin/*
225 %{perl_sitelib}/Mail/*
226 %{_mandir}/man3/*
This page took 0.801938 seconds and 4 git commands to generate.