]> git.pld-linux.org Git - packages/spamassassin.git/blob - spamassassin.spec
- ahh, what the hell: openssl 0.9.7c
[packages/spamassassin.git] / spamassassin.spec
1 #
2 # Conditional build:
3 # _with_tests - perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Mail
7 %define pnam    SpamAssassin
8 Summary:        A spam filter for email which can be invoked from mail delivery agents
9 Summary(pl):    Filtr antyspamowy, przeznaczony dla programów dostarczaj±cych pocztê (MDA)
10 Name:           spamassassin
11 Version:        2.60
12 Release:        1
13 License:        GPL v1+ or Artistic
14 Group:          Applications/Mail
15 Source0:        http://spamassassin.org/released/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  5d23aa5ddb1c5381281cd88bf734341f
17 Source1:        %{name}.sysconfig
18 Patch0:         %{name}-rc-script.patch
19 URL:            http://spamassassin.org/
20 BuildRequires:  openssl-devel >= 0.9.7ca
21 BuildRequires:  perl-devel >= 5.8
22 %if %{?_with_tests:1}0
23 BuildRequires:  perl-HTML-Parser >= 3
24 # are these really needed?
25 BuildRequires:  perl-MailTools
26 BuildRequires:  perl-MIME-Base64
27 BuildRequires:  perl-MIME-tools
28 %endif
29 BuildRequires:  rpm-perlprov >= 4.1-13
30 Requires:       perl-Mail-SpamAssassin >= %{version}
31 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32 Obsoletes:      SpamAssassin
33
34 %define         _noautoreq      'perl(Razor2::Client::Agent)' 'perl(Razor::Agent)' 'perl(Razor::Client)' 'perl(DBI)'
35
36 %description
37 SpamAssassin provides you with a way to reduce if not completely
38 eliminate Unsolicited Commercial Email (SPAM) from your incoming
39 email. It can be invoked by a MDA such as sendmail or postfix, or can
40 be called from a procmail script, .forward file, etc. It uses a
41 genetic-algorithm evolved scoring system to identify messages which
42 look spammy, then adds headers to the message so they can be filtered
43 by the user's mail reading software. This distribution includes the
44 spamd/spamc components which create a server that considerably speeds
45 processing of mail.
46
47 %description -l pl
48 SpamAssassin udostêpnia Ci mo¿liwo¶æ zredukowania, je¶li nie
49 kompletnego wyeliminowania Niezamawianej Komercyjnej Poczty
50 (Unsolicited Commercial Email, spamu) z Twojej poczty. Mo¿e byæ
51 wywo³ywany z MDA, np. Sendmaila czy Postfixa, lub z pliku ~/.forward
52 itp. U¿ywa ogólnego algorytmu oceniania w celu identyfikacji
53 wiadomo¶ci, które wygl±daj± na SPAM, po czym dodaje nag³ówki do
54 wiadomo¶ci, umo¿liwiaj±c filtrowanie przez oprogramowanie u¿ytkownika.
55 Ta dystrybucja zawiera programy spamd/spamc, umo¿liwiaj±ce
56 uruchomienie serwera, co znacznie przyspieszy proces przetwarzania
57 poczty.
58
59 %package tools
60 Summary:        Miscleanous tools for SpamAssassin
61 Summary(pl):    Przeró¿ne narzêdzia zwi±zane z SpamAssassin
62 Group:          Applications/Mail
63 Obsoletes:      SpamAssassin-tools
64
65 %description tools
66 Miscleanous tools from various authors, distributed with SpamAssassin.
67 See /usr/share/doc/spamassassin-tools-*/.
68
69 %description tools -l pl
70 Przeró¿ne narzêdzia, dystrybuowane razem z SpamAssassin. Zobacz
71 /usr/share/doc/spamassassin-tools-*/.
72
73 %package spamd
74 Summary:        spamd - daemonized version of spamassassin
75 Summary(pl):    spamd - spamassassin w postaci demona
76 Group:          Applications/Mail
77 PreReq:         rc-scripts
78 Requires(post,preun):   /sbin/chkconfig
79
80 %description spamd
81 The purpose of this program is to provide a daemonized version of the
82 spamassassin executable. The goal is improving throughput performance
83 for automated mail checking.
84
85 This is intended to be used alongside "spamc", a fast, low-overhead C
86 client program.
87
88 %description spamd -l pl
89 Spamd jest "demoniczn±" wersj± spamassassina. Jego zadaniem jest
90 poprawa wydajno¶ci automatycznego sprawdzania poczty.
91
92 Spamd powinien byæ u¿ywany wespó³ ze "spamc", który jest szybkim i
93 wydajnym programem klienckim.
94
95 %package spamc
96 Summary:        spamc - client for spamd
97 Summary(pl):    spamc - klient dla spamd
98 Group:          Applications/Mail
99
100 %description spamc
101 Spamc is the client half of the spamc/spamd pair. It should be used in
102 place of "spamassassin" in scripts to process mail. It will read the
103 mail from STDIN, and spool it to its connection to spamd, then read
104 the result back and print it to STDOUT. Spamc has extremely low
105 overhead in loading, so it should be much faster to load than the
106 whole spamassassin program.
107
108 %description spamc -l pl
109 Spamc powinien byæ u¿ywany zamiast "spamassassina" w skryptach
110 przetwarzaj±cych pocztê. Zczytuje pocztê ze STDIN, kolejkuje j± a
111 nastêpnie przekazuje spamd'owi, odczytuje wynik i podaje go na STDOUT.
112 Spamc stara siê nie obci±¿aæ zbytnio procesora podczas ³adowania,
113 dziêki czemu powinien dzia³aæ szybciej ni¿ sam spamassassin.
114
115 %package -n perl-Mail-SpamAssassin
116 Summary:        Mail::SpamAssassin - SpamAssassin e-mail filter libraries
117 Summary(pl):    Mail::SpamAssassin - biblioteki filtru poczty SpamAssassin
118 Group:          Development/Languages/Perl
119 Requires:       perl-HTML-Parser >= 3
120
121 %description -n perl-Mail-SpamAssassin
122 Mail::SpamAssassin is a Mail::Audit plugin to identify spam using text
123 analysis and several internet-based realtime blacklists. Using its
124 rule base, it uses a wide range of heuristic tests on mail headers and
125 body text to identify ``spam'', also known as unsolicited commercial
126 email. Once identified, the mail can then be optionally tagged as spam
127 for later filtering using the user's own mail user-agent application.
128
129 %description -n perl-Mail-SpamAssassin -l pl
130 Mail::SpamAssassin jest pluginem dla Mail::Audit, s³u¿±cym do
131 identyfikacji spamu przy u¿yciu analizy zawarto¶ci i/lub internetowych
132 czarnych list. Do zidentyfikowania jako ,,spam'' stosuje szeroki
133 zakres testów heurystycznych na nag³ówkach i tre¶ci, posi³kuj±c siê
134 stworzon± wcze¶niej baz± regu³. Po zidentyfikowaniu, poczta mo¿e byæ
135 oznaczona jako spam w celu pó¼niejszego wyfiltrowania, np. przy u¿yciu
136 aplikacji do czytania poczty.
137
138 %prep
139 %setup -q -n %{pdir}-%{pnam}-%{version}
140 %patch0 -p0
141
142 %build
143 echo "postmaster@localhost" | \
144 %{__perl} Makefile.PL \
145         INSTALLDIRS=vendor \
146         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
147         SYSCONFDIR=$RPM_BUILD_ROOT%{_sysconfdir} \
148         INST_PREFIX=%{_prefix} \
149         INST_SYSCONFDIR=%{_sysconfdir} \
150         RUN_RAZOR1_TESTS=0 \
151         RUN_RAZOR2_TESTS=0
152 %{__make} \
153         OPTIMIZE="%{rpmcflags}"
154
155 %{?_with_tests:%{__make} test}
156
157 %install
158 rm -rf $RPM_BUILD_ROOT
159 install -d $RPM_BUILD_ROOT{/etc/{sysconfig,rc.d/init.d},%{_sysconfdir}/mail/spamassassin}
160
161 %{__make} install \
162         INSTALLMAN1DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
163         INSTALLMAN3DIR=$RPM_BUILD_ROOT%{_mandir}/man3
164
165 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/spamassassin
166 install rules/local.cf $RPM_BUILD_ROOT%{_sysconfdir}/mail/spamassassin
167 install rules/languages $RPM_BUILD_ROOT%{_sysconfdir}/mail/spamassassin
168
169 # shouldn't this script be called `spamd' instead?
170 install spamd/pld-rc-script.sh $RPM_BUILD_ROOT/etc/rc.d/init.d/spamassassin
171
172 rm -f spamd/{*.sh,*.conf,spam*} contrib/snp.tar.gz
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %post spamd
178 /sbin/chkconfig --add spamassassin
179 if [ -f /var/lock/subsys/spamd ]; then
180         /etc/rc.d/init.d/spamassassin restart 1>&2
181 else
182         echo 'Run "/etc/rc.d/init.d/spamassassin start" to start the spamd daemon.'
183 fi
184
185 %preun spamd
186 if [ "$1" = "0" ]; then
187         if [ -f /var/lock/subsys/spamd ]; then
188                 /etc/rc.d/init.d/spamassassin stop 1>&2
189         fi
190         /sbin/chkconfig --del spamassassin
191 fi
192
193 %files
194 %defattr(644,root,root,755)
195 %doc BUGS Changes COPYRIGHT INSTALL README TRADEMARK USAGE
196 %doc procmailrc.example
197 %attr(755,root,root) %{_bindir}/sa-learn
198 %attr(755,root,root) %{_bindir}/spamassassin
199 %{_mandir}/man1/sa-learn*
200 %{_mandir}/man1/spamassassin*
201
202 %files tools
203 %defattr(644,root,root,755)
204 %doc sql tools masses contrib
205
206 %files spamd
207 %defattr(644,root,root,755)
208 %doc spamd/*
209 %attr(754,root,root) /etc/rc.d/init.d/spamassassin
210 %attr(600,root,root) %config(noreplace) /etc/sysconfig/spamassassin
211 %attr(755,root,root) %{_bindir}/spamd
212 %{_mandir}/man1/spamd*
213
214 %files spamc
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_bindir}/spamc
217 %{_mandir}/man1/spamc*
218
219 %files -n perl-Mail-SpamAssassin
220 %defattr(644,root,root,755)
221 %doc sample-nonspam.txt sample-spam.txt
222 %dir %{_sysconfdir}/mail/spamassassin
223 %config(noreplace) %{_sysconfdir}/mail/spamassassin/*
224 %dir %{_datadir}/spamassassin
225 %config(noreplace) %{_datadir}/spamassassin/*
226 %{perl_vendorlib}/Mail/*
227 %{_mandir}/man3/*
This page took 0.052321 seconds and 4 git commands to generate.