]> git.pld-linux.org Git - packages/sox.git/blob - sox.spec
d00671abfff3cd47184f87880381a540cad33c29
[packages/sox.git] / sox.spec
1 #
2 # Conditional build:    
3 # bcond_off_alsa - without ALSA support
4 #
5 Summary:        A general purpose sound file conversion tool
6 Summary(de):    Mehrzweck-Sounddatei-Konvertierungs-Tool
7 Summary(fr):    outil général de conversion de fichiers son
8 Summary(tr):    Genel amaçlý ses dosyasý çevirme aracý
9 Name:           sox
10 Version:        12.17.1
11 Release:        3
12 LIcense:        Distributable
13 Group:          Applications/Sound
14 Group(de):      Applikationen/Laut
15 Group(pl):      Aplikacje/D¼wiêk
16 Source0:        http://home.sprynet.com/sprynet/cbagwell/%{name}-%{version}.tar.gz
17 Patch0:         %{name}-paths.patch
18 Patch1:         %{name}-makefile.patch
19 Patch2:         %{name}-play.patch
20 URL:            http://home.sprynet.com/~cbagwell/sox.html
21 BuildRequires:  libgsm-devel
22 %ifnarch sparc sparc64
23 %{!?bcond_off_alsa:BuildRequires:       alsa-driver-devel}
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 SoX (Sound eXchange) is a sound file format converter for Linux, UNIX
29 and DOS PCs. The self-described 'Swiss Army knife of sound tools,' SoX
30 can convert between many different digitized sound formats and perform
31 simple sound manipulation functions, including sound effects.
32
33 Install the sox package if you'd like to convert sound file formats or
34 manipulate some sounds.
35
36 %package devel
37 Summary:        The SoX sound file format converter libraries.
38 Group:          Development/Libraries
39 Group(de):      Entwicklung/Libraries
40 Group(fr):      Development/Librairies
41 Group(pl):      Programowanie/Biblioteki
42
43 %description devel 
44 This package contains the library needed for compiling applications
45 which will use the SoX sound file format converter.
46
47 Install sox-devel if you want to develop applications which will use
48 SoX.
49
50 %prep
51 %setup -q 
52 %patch0 -p1
53 %patch1 -p1
54 %patch2 -p1
55
56 %build
57 %configure \
58         --with-oss-dsp \
59 %ifnarch sparc sparc64
60         %{!?bcond_off_alsa:--with-alsa-dsp}
61 %endif
62
63 %{__make} PREFIX=%{_prefix}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_mandir}/man{1,3}}
68
69 %{__make} install install-lib \
70         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
71         MANDIR=$RPM_BUILD_ROOT%{_mandir} \
72         BINDIR=$RPM_BUILD_ROOT%{_bindir} \
73         LIBDIR=$RPM_BUILD_ROOT%{_libdir} \
74         INCDIR=$RPM_BUILD_ROOT%{_includedir} \
75         INSTALL_DIR=$RPM_BUILD_ROOT 
76
77 echo "#!/bin/sh" > $RPM_BUILD_ROOT%{_bindir}/soxplay
78 echo "" >> $RPM_BUILD_ROOT%{_bindir}/soxplay
79 echo '%{_bindir}/sox $1 -t .au - > /dev/audio' >> $RPM_BUILD_ROOT%{_bindir}/soxplay
80
81 echo .so play.1 >$RPM_BUILD_ROOT%{_mandir}/man1/rec.1
82
83 gzip -9nf Changelog README TODO INSTALL
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc *.gz monkey.*
91 %attr(755,root,root) %{_bindir}/sox
92 %attr(755,root,root) %{_bindir}/play   
93 %attr(755,root,root) %{_bindir}/rec  
94 %attr(755,root,root) %{_bindir}/soxplay
95 %{_mandir}/man1/*
96
97 %files devel
98 %defattr(644,root,root,755)
99 %{_libdir}/libst.a
100 %{_includedir}/st.h
101 %{_mandir}/man3/*
This page took 0.056164 seconds and 3 git commands to generate.