]> git.pld-linux.org Git - packages/solaar.git/blob - solaar.spec
- use macros to install this in the proper place, rel 2
[packages/solaar.git] / solaar.spec
1 Summary:        Linux devices manager for the Logitech Unifying Receiver
2 Name:           solaar
3 Version:        1.0.6
4 Release:        2
5 License:        GPL v2
6 Group:          Applications/System
7 Source0:        https://github.com/pwr/Solaar/archive/%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  0b8ba34ae8968a6f4f17d9311f5e54b6
9 URL:            http://pwr.github.io/Solaar/
10 BuildRequires:  python3-dbus
11 BuildRequires:  python3-distribute
12 BuildRequires:  python3-modules
13 BuildRequires:  python3-pygobject3
14 BuildRequires:  python3-pyudev
15 BuildRequires:  python3-setuptools
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 2.000
18 Requires:       python3-dbus
19 Requires:       python3-modules
20 Requires:       python3-pygobject3
21 Requires:       python3-pyudev
22 Requires(post,postun):  gtk-update-icon-cache
23 Requires(post,postun):  hicolor-icon-theme
24 Provides:       %{name}-gui = %{version}
25 Obsoletes:      solaar-gui < %{version}
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Solaar is a Linux device manager for Logitech's Unifying Receiver
31 peripherals. It is able to pair/unpair devices to the receiver, and
32 for most devices read battery status.
33
34 It comes in two flavors, command-line and GUI. Both are able to list
35 the devices paired to a Unifying Receiver, show detailed info for each
36 device, and also pair/unpair supported devices with the receiver.
37
38 %prep
39 %setup -q -n Solaar-%{version}
40
41 %build
42 %py3_build
43
44 cd tools
45 sh po-compile.sh
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT/lib/udev/rules.d
50
51 %py3_install
52
53 ln -sr $RPM_BUILD_ROOT%{_bindir}/{%{name},%{name}-cli}
54
55 %{__mv} $RPM_BUILD_ROOT%{_datadir}/solaar/udev-rules.d/42-logitech-unify-permissions.rules $RPM_BUILD_ROOT/lib/udev/rules.d/
56 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/solaar/udev-rules.d
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post
62 %update_icon_cache hicolor
63
64 %posttrans
65 # This is needed to apply permissions to existing devices when the package is installed.
66 /bin/udevadm trigger --subsystem-match=hidraw --action=add
67
68 %postun
69 %update_icon_cache hicolor
70
71 %files
72 %defattr(644,root,root,755)
73 %doc ChangeLog docs/*
74 %attr(755,root,root) %{_bindir}/solaar
75 %attr(755,root,root) %{_bindir}/solaar-cli
76 %dir %{py3_sitescriptdir}/hidapi
77 %{py3_sitescriptdir}/hidapi/*.py
78 %dir %{py3_sitescriptdir}/hidapi/__pycache__
79 %{py3_sitescriptdir}/hidapi/__pycache__/*.pyc
80 %dir %{py3_sitescriptdir}/logitech_receiver
81 %{py3_sitescriptdir}/logitech_receiver/*.py
82 %dir %{py3_sitescriptdir}/logitech_receiver/__pycache__
83 %{py3_sitescriptdir}/logitech_receiver/__pycache__/*.pyc
84 %dir %{py3_sitescriptdir}/solaar
85 %{py3_sitescriptdir}/solaar/*.py
86 %dir %{py3_sitescriptdir}/solaar/__pycache__
87 %{py3_sitescriptdir}/solaar/__pycache__/*.pyc
88 %dir %{py3_sitescriptdir}/solaar/cli
89 %{py3_sitescriptdir}/solaar/cli/*.py
90 %dir %{py3_sitescriptdir}/solaar/cli/__pycache__
91 %{py3_sitescriptdir}/solaar/cli/__pycache__/*.pyc
92 %dir %{py3_sitescriptdir}/solaar/ui
93 %{py3_sitescriptdir}/solaar/ui/*.py
94 %dir %{py3_sitescriptdir}/solaar/ui/__pycache__
95 %{py3_sitescriptdir}/solaar/ui/__pycache__/*.pyc
96 %{py3_sitescriptdir}/solaar-%{version}-py%{py3_ver}.egg-info
97 %{_datadir}/%{name}
98 %{_desktopdir}/solaar.desktop
99 %{_iconsdir}/hicolor/scalable/apps/solaar.svg
100 %{_datadir}/metainfo/io.github.pwr_solaar.solaar.metainfo.xml
101 %{_localedir}/*/LC_MESSAGES/%{name}.mo
102 /lib/udev/rules.d/42-logitech-unify-permissions.rules
This page took 0.047851 seconds and 4 git commands to generate.