]> git.pld-linux.org Git - packages/snapmakerjs.git/blob - snapmakerjs.spec
- drop ix86, the tarball for 32-bit archs uses 64-bit binaries, so it does not make...
[packages/snapmakerjs.git] / snapmakerjs.spec
1 Summary:        Snapmaker 3-in-1 Software for 3D Printing, Laser Engraving and CNC Cutting
2 Name:           snapmakerjs
3 Version:        2.7.1
4 Release:        3
5 License:        MIT
6 Group:          Applications
7 Source0:        https://s3-us-west-2.amazonaws.com/snapmaker.com/download/snapmakerjs/%{name}-%{version}-linux-x64.tar.gz
8 # Source0-md5:  f4b1e550664f7f8e4da2e29ab1f0c4ff
9 Source2:        %{name}.desktop
10 Source3:        %{name}.png
11 URL:            https://snapmaker.com/
12 BuildRequires:  ImageMagick
13 ExclusiveArch:  %{x8664}
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         no_install_post_strip   1
17 %define         no_install_post_check_shebangs  1
18 %define         _enable_debug_packages  0
19
20 %description
21 Snapmaker 3-in-1 Software for 3D Printing, Laser Engraving and CNC
22 Cutting.
23
24 %prep
25 %setup -q -T -b0 -n %{name}-%{version}-linux-x64
26
27 %build
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 install -d $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir},%{_desktopdir}} \
32         $RPM_BUILD_ROOT%{_iconsdir}/hicolor/256x256/apps
33
34 cp -a * $RPM_BUILD_ROOT%{_libdir}/%{name}
35 ln -s %{_libdir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
36
37 for i in 16 24 32 48 64 96 128 ; do
38   install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps
39   convert -geometry ${i}x${i} %{SOURCE3} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps/%{name}.png
40 done
41
42 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
43 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/256x256/apps
44
45 # _install_post_check_shebangs can't cope with filenames with spaces
46 find $RPM_BUILD_ROOT -name "Apache License.txt" -print0 | xargs -0 %{__rm}
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %post
52 %update_icon_cache hicolor
53
54 %postun
55 %update_icon_cache hicolor
56
57 %triggerpostun -- snapmakerjs < 2.6.1-1
58 %groupremove snapmaker
59
60 %files
61 %defattr(644,root,root,755)
62 %doc LICENSE.electron.txt LICENSES.chromium.html
63 %attr(755,root,root) %{_bindir}/%{name}*
64 %dir %{_libdir}/%{name}
65 %{_libdir}/%{name}/locales
66 %dir %{_libdir}/snapmakerjs/resources
67 %{_libdir}/%{name}/resources/electron.asar
68 %dir %{_libdir}/snapmakerjs/resources/app
69 %{_libdir}/snapmakerjs/resources/app/app
70 %{_libdir}/snapmakerjs/resources/app/electron-app
71 %{_libdir}/snapmakerjs/resources/app/node_modules
72 %{_libdir}/snapmakerjs/resources/app/*.js
73 %{_libdir}/snapmakerjs/resources/app/*.json
74 %dir %{_libdir}/snapmakerjs/resources/app/resources
75 %{_libdir}/snapmakerjs/resources/app/resources/fonts
76 %dir %{_libdir}/snapmakerjs/resources/app/resources/CuraEngine
77 %{_libdir}/snapmakerjs/resources/app/resources/CuraEngine/Config
78 %dir %{_libdir}/snapmakerjs/resources/app/resources/CuraEngine/3.6
79 %dir %{_libdir}/snapmakerjs/resources/app/resources/CuraEngine/3.6/Linux
80 %attr(755,root,root) %{_libdir}/snapmakerjs/resources/app/resources/CuraEngine/3.6/Linux/CuraEngine
81 %dir %{_libdir}/snapmakerjs/resources/app/server
82 %{_libdir}/snapmakerjs/resources/app/server/index.js
83 %dir %{_libdir}/snapmakerjs/resources/app/server/i18n
84 %lang(cs) %{_libdir}/snapmakerjs/resources/app/server/i18n/cs
85 %lang(de) %{_libdir}/snapmakerjs/resources/app/server/i18n/de
86 %lang(en) %{_libdir}/snapmakerjs/resources/app/server/i18n/en
87 %lang(es) %{_libdir}/snapmakerjs/resources/app/server/i18n/es
88 %lang(fr) %{_libdir}/snapmakerjs/resources/app/server/i18n/fr
89 %lang(hu) %{_libdir}/snapmakerjs/resources/app/server/i18n/hu
90 %lang(it) %{_libdir}/snapmakerjs/resources/app/server/i18n/it
91 %lang(ja) %{_libdir}/snapmakerjs/resources/app/server/i18n/ja
92 %lang(pt_BR) %{_libdir}/snapmakerjs/resources/app/server/i18n/pt-br
93 %lang(ru) %{_libdir}/snapmakerjs/resources/app/server/i18n/ru
94 %lang(zh_CN) %{_libdir}/snapmakerjs/resources/app/server/i18n/zh-cn
95 %lang(zh_TW) %{_libdir}/snapmakerjs/resources/app/server/i18n/zh-tw
96 %{_libdir}/snapmakerjs/resources/app/server/views
97 %{_libdir}/%{name}/*.dat
98 %{_libdir}/%{name}/*.bin
99 %{_libdir}/%{name}/*.pak
100 %attr(755,root,root) %{_libdir}/%{name}/libffmpeg.so
101 %attr(755,root,root) %{_libdir}/%{name}/libnode.so
102 %attr(755,root,root) %{_libdir}/%{name}/snapmakerjs
103 %{_desktopdir}/%{name}.desktop
104 %{_iconsdir}/hicolor/*x*/apps/%{name}.png
This page took 0.064434 seconds and 3 git commands to generate.