]> git.pld-linux.org Git - packages/shfs.git/blob - shfs.spec
- %bcond_with new_bconds
[packages/shfs.git] / shfs.spec
1 #
2 # Conditional build:
3 %bcond_without dist_kernel      # without distribution kernel
4 #
5 Summary:        (Secure) SHell FileSystem utilities
6 Summary(pl):    Narzêdzia obs³uguj±ce system plików przez ssh
7 Name:           shfs
8 Version:        0.32
9 %define rel     1
10 Release:        %{rel}
11 License:        GPL
12 Group:          Applications/System
13 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
14 # Source0-md5:  477c4236f24c770238075f04de38fd71
15 Patch0:         %{name}-opt.patch
16 URL:            http://shfs.sourceforge.net/
17 %{?with_dist_kernel:BuildRequires:         kernel-headers}
18 BuildRequires:  %{kgcc_package}
19 BuildRequires:  rpmbuild(macros) >= 1.118
20 Obsoletes:      shfsmount
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 SHFS is a simple and easy to use Linux kernel (2.4) module which
25 allows you to mount remote filesystems using plain shell (ssh/rsh)
26 connection. It supports some nice features like number of different
27 caches for access speedup, target system optimisations, etc.
28
29 This package contains utilities for SHFS.
30
31 %description -l pl
32 SHFS to prosty i ³atwy w u¿yciu modu³ j±dra Linuksa (2.4) pozwalaj±cy
33 montowaæ zdalne systemy plików przy u¿yciu zwyk³ego po³±czenia ze
34 zdaln± pow³ok± (ssh lub rsh). Obs³uguje pewne mi³e cechy, takie jak
35 ró¿ne sposoby buforowania dla przyspieszenia dostêpu, optymalizacje
36 pod k±tem zdalnego systemu itp.
37
38 Ten pakiet zawiera programy narzêdziowe dla SHFS.
39
40 %package -n kernel-fs-shfs
41 Summary:        SHell File System Linux kernel module
42 Summary(pl):    Modu³ j±dra Linuksa obs³uguj±cy pow³okowy system plików
43 Release:        %{rel}@%{_kernel_ver_str}
44 Group:          Base/Kernel
45 %{?with_dist_kernel:%requires_releq_kernel_up}
46 Requires(post,postun):  /sbin/depmod
47 Obsoletes:      kernel-misc-shfs
48
49 %description -n kernel-fs-shfs
50 SHell File System Linux kernel module.
51
52 %description -n kernel-fs-shfs -l pl
53 Modu³ j±dra Linuksa obs³uguj±cy pow³okowy system plików.
54
55 %package -n kernel-smp-fs-shfs
56 Summary:        SHell File System Linux SMP kernel module
57 Summary(pl):    Modu³ j±dra Linuksa SMP obs³uguj±cy pow³okowy system plików
58 Release:        %{rel}@%{_kernel_ver_str}
59 Group:          Base/Kernel
60 %{?with_dist_kernel:%requires_releq_kernel_smp}
61 Requires(post,postun):  /sbin/depmod
62 Obsoletes:      kernel-smp-misc-shfs
63
64 %description -n kernel-fs-shfs
65 SHell File System Linux kernel module.
66
67 %description -n kernel-smp-fs-shfs -l pl
68 Modu³ j±dra Linuksa obs³uguj±cy pow³okowy system plików.
69
70 %prep
71 %setup -q
72 %patch -p1
73
74 %build
75 %{__make} -C shfs \
76         CC="%{kgcc} -D__SMP__" \
77         OPT="%{rpmcflags}"
78
79 mv -f shfs/Linux-2.4/shfs.o shfs.smp.o
80
81 %{__make} clean -C shfs
82 %{__make} -C shfs \
83         CC="%{kgcc}" \
84         OPT="%{rpmcflags}"
85
86 %{__make} -C shfsmount \
87         CC="%{__cc}" \
88         OPT="%{rpmcflags}"
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/kernel/fs/shfs
93
94 %{__make} install \
95         ROOT=$RPM_BUILD_ROOT \
96         MODULESDIR=$RPM_BUILD_ROOT/lib/modules/%{_kernel_ver} \
97         MAN_PAGE_DIR=%{_mandir}
98
99 install shfs.smp.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/kernel/fs/shfs/shfs.o
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -n kernel-fs-shfs
105 %depmod %{_kernel_ver}
106
107 %postun -n kernel-fs-shfs
108 %depmod %{_kernel_ver}
109
110 %post   -n kernel-smp-fs-shfs
111 %depmod %{_kernel_ver}smp
112
113 %postun -n kernel-smp-fs-shfs
114 %depmod %{_kernel_ver}smp
115
116 %files
117 %defattr(644,root,root,755)
118 %doc COPYRIGHT Changelog TODO docs/html
119 %attr(755,root,root) %{_bindir}/*
120 /sbin/*
121 %{_mandir}/man8/*
122
123 %files -n kernel-fs-shfs
124 %defattr(644,root,root,755)
125 /lib/modules/%{_kernel_ver}/kernel/fs/shfs/*.o*
126
127 %files -n kernel-smp-fs-shfs
128 %defattr(644,root,root,755)
129 /lib/modules/%{_kernel_ver}smp/kernel/fs/shfs/*.o*
This page took 0.085623 seconds and 4 git commands to generate.