]> git.pld-linux.org Git - packages/shfs.git/blob - shfs.spec
- added opt patch, merged modules building from kernel-misc-shfs.spec
[packages/shfs.git] / shfs.spec
1 #
2 # Conditional build:
3 # _without_dist_kernel          without distribution kernel
4 #
5 Summary:        (Secure) SHell FileSystem utilities
6 Summary(pl):    Narzêdzia obs³uguj±ce system plików przez ssh
7 Name:           shfs
8 Version:        0.32pre1
9 %define rel     3
10 Release:        %{rel}
11 License:        GPL
12 Group:          Applications/System
13 # Source0-md5:  eb4840e893da72f6169796b020a77769
14 Source0:        http://atrey.karlin.mff.cuni.cz/~qiq/src/shfs/%{name}-%{version}.tar.gz
15 Patch0:         %{name}-opt.patch
16 URL:            http://shfs.sourceforge.net/
17 %{!?_without_dist_kernel:BuildRequires:         kernel-headers}
18 BuildRequires:  %{kgcc_package}
19 BuildRequires:  rpmbuild(macros) >= 1.118
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 SHFS is a simple and easy to use Linux kernel (2.4) module which
24 allows you to mount remote filesystems using plain shell (ssh/rsh)
25 connection. It supports some nice features like number of different
26 caches for access speedup, target system optimisations, etc.
27
28 This package contains utilities for SHFS.
29
30 %description -l pl
31 SHFS to prosty i ³atwy w u¿yciu modu³ j±dra Linuksa (2.4) pozwalaj±cy
32 montowaæ zdalne systemy plików przy u¿yciu zwyk³ego po³±czenia ze
33 zdaln± pow³ok± (ssh lub rsh). Obs³uguje pewne mi³e cechy, takie jak
34 ró¿ne sposoby buforowania dla przyspieszenia dostêpu, optymalizacje
35 pod k±tem zdalnego systemu itp.
36
37 Ten pakiet zawiera programy narzêdziowe dla SHFS.
38
39 %package -n kernel-fs-shfs
40 Summary:        SHell File System Linux kernel module
41 Summary(pl):    Modu³ j±dra Linuksa obs³uguj±cy pow³okowy system plików
42 Release:        %{rel}@%{_kernel_ver_str}
43 Group:          Base/Kernel
44 %{!?_without_dist_kernel:%requires_releq_kernel_up}
45 Requires(post,postun):  /sbin/depmod
46 Obsoletes:      kernel-misc-shfs
47
48 %description -n kernel-fs-shfs
49 SHell File System Linux kernel module.
50
51 %description -n kernel-fs-shfs -l pl
52 Modu³ j±dra Linuksa obs³uguj±cy pow³okowy system plików.
53
54 %package -n kernel-smp-fs-shfs
55 Summary:        SHell File System Linux SMP kernel module
56 Summary(pl):    Modu³ j±dra Linuksa SMP obs³uguj±cy pow³okowy system plików
57 Release:        %{rel}@%{_kernel_ver_str}
58 Group:          Base/Kernel
59 %{!?_without_dist_kernel:%requires_releq_kernel_smp}
60 Requires(post,postun):  /sbin/depmod
61 Obsoletes:      kernel-smp-misc-shfs
62
63 %description -n kernel-fs-shfs
64 SHell File System Linux kernel module.
65
66 %description -n kernel-smp-fs-shfs -l pl
67 Modu³ j±dra Linuksa obs³uguj±cy pow³okowy system plików.
68
69 %prep
70 %setup -q
71 %patch -p1
72
73 %build
74 %{__make} -C shfs \
75         CC="%{kgcc} -D__SMP__" \
76         OPT="%{rpmcflags}"
77
78 mv -f shfs/shfs.o shfs.smp.o
79
80 %{__make} clean -C shfs
81 %{__make} -C shfs \
82         CC="%{kgcc}" \
83         OPT="%{rpmcflags}"
84
85 %{__make} -C shfsmount \
86         CC="%{__cc}" \
87         OPT="%{rpmcflags}"
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/kernel/fs/shfs
92
93 %{__make} install \
94         ROOT=$RPM_BUILD_ROOT \
95         MODULESDIR=$RPM_BUILD_ROOT/lib/modules/%{_kernel_ver} \
96         MAN_PAGE_DIR=%{_mandir}
97
98 install shfs.smp.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/kernel/fs/shfs/shfs.o
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -n kernel-fs-shfs
104 %depmod %{_kernel_ver}
105
106 %postun -n kernel-fs-shfs
107 %depmod %{_kernel_ver}
108
109 %post   -n kernel-smp-fs-shfs
110 %depmod %{_kernel_ver}smp
111
112 %postun -n kernel-smp-fs-shfs
113 %depmod %{_kernel_ver}smp
114
115 %files
116 %defattr(644,root,root,755)
117 %doc COPYRIGHT Changelog TODO docs/html
118 %attr(755,root,root) %{_bindir}/*
119 /sbin/*
120 %{_mandir}/man8/*
121
122 %files -n kernel-fs-shfs
123 %defattr(644,root,root,755)
124 %attr(755,root,root) /lib/modules/%{_kernel_ver}/kernel/fs/shfs/*.o*
125
126 %files -n kernel-smp-fs-shfs
127 %defattr(644,root,root,755)
128 %attr(755,root,root) /lib/modules/%{_kernel_ver}smp/kernel/fs/shfs/*.o*
This page took 0.060517 seconds and 4 git commands to generate.